[PATCH gnome-team 0/2] Fix todoman test failure

  • Done
  • quality assurance status badge
Details
2 participants
  • Liliana Marie Prikler
  • Vivien Kraus
Owner
unassigned
Submitted by
Vivien Kraus
Severity
normal

Debbugs page

Vivien Kraus wrote 12 months ago
(address . guix-patches@gnu.org)
cover.1711189473.git.vivien@planete-kraus.eu
Dear Guix,

The todoman test suite should be run with the "ci" hypothesis profile, so as
to disable deadlines and other nice improvements.

What do you think?

Best regards,

Vivien

Vivien Kraus (2):
gnu: todoman: Update style.
gnu: todoman: Fix tests.

gnu/packages/task-management.scm | 32 +++++++++++++++++---------------
1 file changed, 17 insertions(+), 15 deletions(-)


base-commit: a9951a74a591a9b22ee2d93d8efe0523c6c42c97
--
2.41.0
Vivien Kraus wrote 12 months ago
[PATCH gnome-team 2/2] gnu: todoman: Fix tests.
(address . 69960@debbugs.gnu.org)
ea51946638b9941b04cef8f0ee7763e0bf5ff1a9.1711189473.git.vivien@planete-kraus.eu
* gnu/packages/task-management.scm (todoman) [#:phase 'check]: Load the `ci'
hypothesis profile provided by upstream.

Change-Id: I2ea01f8c424a50cd617303f8338f92563e7b0204
---
gnu/packages/task-management.scm | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/task-management.scm b/gnu/packages/task-management.scm
index aac643799f..96df50d747 100644
--- a/gnu/packages/task-management.scm
+++ b/gnu/packages/task-management.scm
@@ -453,7 +453,8 @@ (define-public todoman
(replace 'check
(lambda* (#:key inputs outputs tests? #:allow-other-keys)
(when tests?
- (invoke "pytest" "-vv" "tests" "-k"
+ (invoke "pytest" "--hypothesis-profile=ci"
+ "-vv" "tests" "-k"
(string-append
;; Test expects wrong output string.
"not test_bad_start_date "
--
2.41.0
Vivien Kraus wrote 12 months ago
[PATCH gnome-team 1/2] gnu: todoman: Update style.
(address . 69960@debbugs.gnu.org)
30c8f3427a3eed2a69e34cf62a886e2d1baae1f6.1711189473.git.vivien@planete-kraus.eu
* gnu/packages/task-management.scm (todoman) [arguments]: Convert to list of G-Expressions.

Change-Id: I63faadabb27fa2053e3e01c3e285176bc040c634
---
gnu/packages/task-management.scm | 31 ++++++++++++++++---------------
1 file changed, 16 insertions(+), 15 deletions(-)

Toggle diff (44 lines)
diff --git a/gnu/packages/task-management.scm b/gnu/packages/task-management.scm
index f9221f8483..aac643799f 100644
--- a/gnu/packages/task-management.scm
+++ b/gnu/packages/task-management.scm
@@ -443,21 +443,22 @@ (define-public todoman
(base32 "1j2h5cv8wnmw41fpz1ggsgi599qhk184cas9kgd92glj3m4alg6f"))))
(build-system python-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch-tests
- (lambda _
- (substitute* '("tests/test_cli.py" "tests/test_formatter.py")
- (("tests\\.helpers") "helpers"))))
- (replace 'check
- (lambda* (#:key inputs outputs tests? #:allow-other-keys)
- (when tests?
- (invoke "pytest" "-vv" "tests" "-k"
- (string-append
- ;; Test expects wrong output string.
- "not test_bad_start_date "
- ;; Unknown failure
- "and not test_default_command_args"))))))))
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-tests
+ (lambda _
+ (substitute* '("tests/test_cli.py" "tests/test_formatter.py")
+ (("tests\\.helpers") "helpers"))))
+ (replace 'check
+ (lambda* (#:key inputs outputs tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest" "-vv" "tests" "-k"
+ (string-append
+ ;; Test expects wrong output string.
+ "not test_bad_start_date "
+ ;; Unknown failure
+ "and not test_default_command_args"))))))))
(native-inputs
(list python-setuptools-scm
python-pytest
--
2.41.0
Liliana Marie Prikler wrote 12 months ago
14563d278128cbee10c13e02f19cde41b052b718.camel@gmail.com
Am Samstag, dem 23.03.2024 um 11:20 +0100 schrieb Vivien Kraus:
Toggle quote (4 lines)
> * gnu/packages/task-management.scm (todoman) [arguments]: Convert to
> list of G-Expressions.
>
> Change-Id: I63faadabb27fa2053e3e01c3e285176bc040c634
LGTM
Liliana Marie Prikler wrote 12 months ago
Re: [PATCH gnome-team 2/2] gnu: todoman: Fix tests.
808e81dfe2658dd9e48d9cf9b777e1c00852a072.camel@gmail.com
Am Samstag, dem 23.03.2024 um 11:21 +0100 schrieb Vivien Kraus:
Toggle quote (5 lines)
> * gnu/packages/task-management.scm (todoman) [#:phase 'check]: Load
> the `ci'
> hypothesis profile provided by upstream.
>
> Change-Id: I2ea01f8c424a50cd617303f8338f92563e7b0204
SGTM. If you're okay with it, I'd locally rephrase this to [#:phases]
<check> and push it with that change once it's confirmed by the rest,
WDTY?
Vivien Kraus wrote 12 months ago
b887d2f61f307bf3a7c72cb2ede2de45baa58b68.camel@planete-kraus.eu
Le samedi 23 mars 2024 à 11:50 +0100, Liliana Marie Prikler a écrit :
Toggle quote (11 lines)
> Am Samstag, dem 23.03.2024 um 11:21 +0100 schrieb Vivien Kraus:
> > * gnu/packages/task-management.scm (todoman) [#:phase 'check]: Load
> > the `ci'
> > hypothesis profile provided by upstream.
> >
> > Change-Id: I2ea01f8c424a50cd617303f8338f92563e7b0204
> SGTM.  If you're okay with it, I'd locally rephrase this to
> [#:phases]
> <check> and push it with that change once it's confirmed by the rest,
> WDTY?

Sorry, I always hesitate with this. I will try my best to do the
correct thing in the future, but in the mean time, please go ahead.

Vivien
Liliana Marie Prikler wrote 12 months ago
9d9aeb94ccf58ac11ba5e9fe3f3973155049f2d1.camel@gmail.com
Am Samstag, dem 23.03.2024 um 11:52 +0100 schrieb Vivien Kraus:
Toggle quote (12 lines)
> Le samedi 23 mars 2024 à 11:50 +0100, Liliana Marie Prikler a écrit :
> > Am Samstag, dem 23.03.2024 um 11:21 +0100 schrieb Vivien Kraus:
> > > * gnu/packages/task-management.scm (todoman) [#:phase 'check]:
> > > Load the `ci' hypothesis profile provided by upstream.
> > >
> > > Change-Id: I2ea01f8c424a50cd617303f8338f92563e7b0204
> > SGTM.  If you're okay with it, I'd locally rephrase this to
> > [#:phases] <check> and push it with that change once it's confirmed
> > by the rest,WDTY?
>
> Sorry, I always hesitate with this. I will try my best to do the
> correct thing in the future, but in the mean time, please go ahead.
It's fine – I do fall back to my own writing style a lot, and the
guidelines aren't super close on the details as of yet, so I sometimes
go ahead with edits and hesitate at other times.

Anyway, pushed.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 69960@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 69960
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help