[PATCH] gnu: shellutils: Add process-compose 0.88.0.

  • Done
  • quality assurance status badge
Details
4 participants
  • Daniel Ziltener
  • Dale Mellor
  • Leo Famulari
  • Suhail Singh
Owner
unassigned
Submitted by
Daniel Ziltener
Severity
normal

Debbugs page

Daniel Ziltener wrote 12 months ago
(address . guix-patches@gnu.org)(address . dziltener@lyrion.ch)
c07818ffd76f6717d7d80ad4ad2cc5bb@lyrion.ch
---
gnu/packages/shellutils.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/shellutils.scm b/gnu/packages/shellutils.scm
index e58e9e61fc..fc8c1bc0f1 100644
--- a/gnu/packages/shellutils.scm
+++ b/gnu/packages/shellutils.scm
@@ -539,6 +539,34 @@ (define-public direnv
environment variables of the current shell.")
(license license:expat)))
+(define-public process-compose
+ (package
+ (name "process-compose")
+ (version "0.88.0")
+ (source
+ (origin
+ (method url-fetch/tarbomb)
+ (uri (string-append
+ "https://github.com/F1bonacc1/process-compose/releases/download/v"
+ version "/process-compose_linux_amd64.tar.gz"))
+ (sha256
+ (base32
+ "1qhfrbd5ybb0sinl9pad64rscr08qvlfzrzmi4p4hk61xn6phlmz"))))
+ (build-system trivial-build-system)
+ (arguments
+ (list
+ #:modules '((guix build utils))
+ #:builder #~(let ((source (assoc-ref %build-inputs "source"))
+ (output (assoc-ref %outputs "out")))
+ (use-modules (guix build utils))
+ (install-file
+ (string-append source "/process-compose") output))))
+ (home-page "https://f1bonacc1.github.io/process-compose")
+ (synopsis "Scheduler and orchestrator for processes")
+ (description "Process Compose is a simple and flexible scheduler and orchestrator
+to manage non-containerized applications.")
+ (license license:expat)))
+
(define-public fzy
(package
(name "fzy")
--
2.41.0
Daniel Ziltener wrote 12 months ago
(address . 69932@debbugs.gnu.org)(address . dziltener@lyrion.ch)
fe63794336d29e14d8d9f57f9e0f760b@lyrion.ch
Sorry for the commit above; this one here is the corrected, working one.

---
gnu/packages/shellutils.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/shellutils.scm b/gnu/packages/shellutils.scm
index e58e9e61fc..fc8c1bc0f1 100644
--- a/gnu/packages/shellutils.scm
+++ b/gnu/packages/shellutils.scm
@@ -539,6 +539,34 @@ (define-public direnv
environment variables of the current shell.")
(license license:expat)))
+(define-public process-compose
+ (package
+ (name "process-compose")
+ (version "0.88.0")
+ (source
+ (origin
+ (method url-fetch/tarbomb)
+ (uri (string-append
+ "https://github.com/F1bonacc1/process-compose/releases/download/v"
+ version "/process-compose_linux_amd64.tar.gz"))
+ (sha256
+ (base32
+ "1qhfrbd5ybb0sinl9pad64rscr08qvlfzrzmi4p4hk61xn6phlmz"))))
+ (build-system trivial-build-system)
+ (arguments
+ (list
+ #:modules '((guix build utils))
+ #:builder #~(let ((source (assoc-ref %build-inputs "source"))
+ (output (assoc-ref %outputs "out")))
+ (use-modules (guix build utils))
+ (install-file
+ (string-append source "/process-compose") output))))
+ (home-page "https://f1bonacc1.github.io/process-compose")
+ (synopsis "Scheduler and orchestrator for processes")
+ (description "Process Compose is a simple and flexible scheduler and orchestrator
+to manage non-containerized applications.")
+ (license license:expat)))
+
(define-public fzy
(package
(name "fzy")
--
2.41.0
Dale Mellor wrote 11 months ago
(address . 69932@debbugs.gnu.org)
ad9a201cb390277ace9f8ad420c3bd81c789a585.camel@rdmp.org
Hello,

you need to understand that Guix can only take scrutable source as its
inputs, so that it can build binaries with a known specific build
infrastructure; all of this information needs to be available so that hashes can
be computed for the package which are tamper-evident and anyone must be able to
reproduce the exact hash under the same conditions, if they wish it, for their
own peace of mind.

Thus this trivial-build dump-from-tarbomb approach cannot be accepted; the
package should be pulled directly from its GIT repository, and full build
instructions need to be provided to the Guix package management system.

Please look at how other Go-sourced packages are done for some inspiration.

Thank you.
Leo Famulari wrote 11 months ago
(name . Dale Mellor)(address . guix-devel-0brg6a@rdmp.org)(address . 69932@debbugs.gnu.org)
ZhKp_UHrB3YXMPrS@jasmine.lan
On Sat, Apr 06, 2024 at 08:00:42PM +0100, Dale Mellor wrote:
Toggle quote (11 lines)
> you need to understand that Guix can only take scrutable source as its
> inputs, so that it can build binaries with a known specific build
> infrastructure; all of this information needs to be available so that hashes can
> be computed for the package which are tamper-evident and anyone must be able to
> reproduce the exact hash under the same conditions, if they wish it, for their
> own peace of mind.
>
> Thus this trivial-build dump-from-tarbomb approach cannot be accepted; the
> package should be pulled directly from its GIT repository, and full build
> instructions need to be provided to the Guix package management system.

To summarize, the package needs to build process-compose from source.
Please feel free to ask for help if necessary.
Daniel Ziltener wrote 11 months ago
Re: [PATCH] gnu: shellutils: Add process-compose 0.88.0.
(address . control@debbugs.gnu.org)(address . 69932@debbugs.gnu.org)
b66a69af-d5cf-2f9a-8159-4e098dd8654e@lyrion.ch
close 69932

thanks
Suhail Singh wrote 3 months ago
control message to remove spurious waiting-on-contributor tag
(address . control@debbugs.gnu.org)
877c8c20qa.fsf@gmail.com
user guix
unarchive 74174
usertag 74174 - waiting-on-contributor
archive 74174
unarchive 69932
usertag 69932 - waiting-on-contributor
archive 69932
unarchive 69633
usertag 69633 - waiting-on-contributor
archive 69633
quit
?
Your comment

This issue is archived.

To comment on this conversation send an email to 69932@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 69932
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help