[PATCH] gnu: arcan-sdl: Add missing inputs.

  • Done
  • quality assurance status badge
Details
4 participants
  • Ahmad Draidi
  • David Elsing
  • Ludovic Courtès
  • Skyler Ferris
Owner
unassigned
Submitted by
David Elsing
Severity
normal

Debbugs page

David Elsing wrote 12 months ago
(name . David Elsing)(address . david.elsing@posteo.net)
20240320213619.11777-1-david.elsing@posteo.net
* gnu/packages/arcan.scm (arcan-sdl)[inputs]: Add glu, libglvnd and mesa.
---
Hello,

I found the problem: The glu, libglvnd and mesa packages are
additionally required, now the build succeeds.

Cheers,
David
gnu/packages/arcan.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/packages/arcan.scm b/gnu/packages/arcan.scm
index 4ca76edbec..dfc211ae9c 100644
--- a/gnu/packages/arcan.scm
+++ b/gnu/packages/arcan.scm
@@ -171,7 +171,7 @@ (define-public arcan-sdl
(inputs
(modify-inputs (package-inputs arcan)
(delete "libdrm")
- (prepend sdl)))
+ (prepend glu libglvnd mesa sdl)))
(arguments
`(,@(ensure-keyword-arguments
(package-arguments arcan)
--
2.41.0
Skyler Ferris wrote 12 months ago
13526d18-3721-46cf-8195-ee634f8e812e@protonmail.com
Awesome! I just checked on my machine with the patch from 69866 and it
still builds with that patch applied. It'll be great to have another
package working!

Also, just to clarify, I believe you mentioned on the call that you
noticed that there was bundled source in this package which needs to be
addressed. Is that something that you were planning on working on?

Regards,
Skyler
Ahmad Draidi wrote 12 months ago
arcan-sdl
(address . 69923@debbugs.gnu.org)
7EDE3556-4F94-467C-8064-886ABBF6D717@redscript.org
Hello,

I believe arcan-sdl is built as part of the arcan package. I think I was planning to deprecate and remove it later as part of my arcan rework patches, but never got around to it.

Is there a reason to keep it around and not use arcan? Perhaps it should be converted to an output for the main package instead, if there's a good reason?

What do you think?

Thanks,
Ahmad Draidi
Attachment: file
Ludovic Courtès wrote 12 months ago
Re: [bug#69923] [PATCH] gnu: arcan-sdl: Add missing inputs.
(name . David Elsing)(address . david.elsing@posteo.net)
87bk76tuzw.fsf@gnu.org
Hi,

David Elsing <david.elsing@posteo.net> skribis:

Toggle quote (2 lines)
> * gnu/packages/arcan.scm (arcan-sdl)[inputs]: Add glu, libglvnd and mesa.

Applied, thanks!

Ludo’.
Closed
David Elsing wrote 12 months ago
Re: arcan-sdl
(name . Ahmad Draidi)(address . a.r.draidi@redscript.org)(address . 69923@debbugs.gnu.org)
86il1eyq08.fsf@posteo.net
Hello,

Ahmad Draidi <a.r.draidi@redscript.org> writes:

Toggle quote (3 lines)
> Is there a reason to keep it around and not use arcan? Perhaps it should be converted to an output for the main package instead, if
> there's a good reason?

I don't know what the motivation was to make a separate package with
SDL1 and just looked why the build failed. The main package is built
with SDL2, maybe that's the reason? Here is the original issue where
arcan was added, you should probably ask them:

Best,
David
?
Your comment

This issue is archived.

To comment on this conversation send an email to 69923@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 69923
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help