Sharlatan Hellseher wrote 12 months ago
(address . guix-patches@gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
Hi Guix,
It's been a long time since I packed some Common Lisp! Here we go - welcome
CIEL as stated on the project's README - an Extended Lisp. Scripting with
batteries included.
This series includes just CL library and does not provide ready-to-use image or
binary as it's mentioned in Makefile, which may be prepared as dedicated
package if we may need it (see pgloader):
Toggle snippet (17 lines)
image:
$(LISP) --load build-image.lisp
build:
$(LISP) --non-interactive \
--eval '(ql:quickload :deploy)' \
--eval '(ql:quickload "cl+ssl")' \
--load ciel.asd \
--load build-config.lisp \
--eval '(ql:quickload :swank)' \
--eval '(push :deploy-console *features*)' \
--eval '(ql:quickload :ciel)' \
--eval '(ql:quickload :ciel/repl)' \
--eval '(asdf:make :ciel/repl)' \
--eval '(quit)'
Build and lint are passed locally, but I've got issue to fix ecl-boost-json
(check comments for details) leaving it for Guillaume ;-) or for the next
update cycle to check.
Thanks,
Oleg
Sharlatan Hellseher (10):
gnu: Add cl-arrow-macros.
gnu: Add cl-trivial-utilities.
gnu: Add cl-trivial-monitored-thread.
gnu: Add cl-boost-json.
gnu: Add cl-st-json.
gnu: Add cl-json-pointer.
gnu: Add cl-easy-routes.
gnu: Add cl-vgplot.
gnu: Add cl-punch.
gnu: Add cl-ciel.
gnu/packages/lisp-xyz.scm | 396 ++++++++++++++++++++++++++++++++++++++
1 file changed, 396 insertions(+)
base-commit: b7eb1a8116b2caee7acf26fb963ae998fbdb4253
--
2.41.0