[PATCH 00/10] gnu: Add cl-ciel.

  • Done
  • quality assurance status badge
Details
2 participants
  • Guillaume Le Vaillant
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal

Debbugs page

Sharlatan Hellseher wrote 12 months ago
(address . guix-patches@gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
cover.1710883390.git.sharlatanus@gmail.com
Hi Guix,

It's been a long time since I packed some Common Lisp! Here we go - welcome
CIEL as stated on the project's README - an Extended Lisp. Scripting with
batteries included.

This series includes just CL library and does not provide ready-to-use image or
binary as it's mentioned in Makefile, which may be prepared as dedicated
package if we may need it (see pgloader):

Toggle snippet (17 lines)
image:
$(LISP) --load build-image.lisp

build:
$(LISP) --non-interactive \
--eval '(ql:quickload :deploy)' \
--eval '(ql:quickload "cl+ssl")' \
--load ciel.asd \
--load build-config.lisp \
--eval '(ql:quickload :swank)' \
--eval '(push :deploy-console *features*)' \
--eval '(ql:quickload :ciel)' \
--eval '(ql:quickload :ciel/repl)' \
--eval '(asdf:make :ciel/repl)' \
--eval '(quit)'

Build and lint are passed locally, but I've got issue to fix ecl-boost-json
(check comments for details) leaving it for Guillaume ;-) or for the next
update cycle to check.

Thanks,
Oleg

Sharlatan Hellseher (10):
gnu: Add cl-arrow-macros.
gnu: Add cl-trivial-utilities.
gnu: Add cl-trivial-monitored-thread.
gnu: Add cl-boost-json.
gnu: Add cl-st-json.
gnu: Add cl-json-pointer.
gnu: Add cl-easy-routes.
gnu: Add cl-vgplot.
gnu: Add cl-punch.
gnu: Add cl-ciel.

gnu/packages/lisp-xyz.scm | 396 ++++++++++++++++++++++++++++++++++++++
1 file changed, 396 insertions(+)


base-commit: b7eb1a8116b2caee7acf26fb963ae998fbdb4253
--
2.41.0
Sharlatan Hellseher wrote 12 months ago
[PATCH 02/10] gnu: Add cl-trivial-utilities.
(address . 69904@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
a9ebe831e1fb73019632a5285f84d07ec39ff6c2.1710883390.git.sharlatanus@gmail.com
* gnu/packages/lisp-xyz.scm (cl-trivial-utilities,
ecl-trivial-utilities, sbcl-trivial-utilities): New variables.

Change-Id: I1fde88484add5b77cf93ccacafb17ac548929481
---
gnu/packages/lisp-xyz.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (45 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index cd8dd6bf14..c3d199a890 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -8092,6 +8092,38 @@ (define-public cl-trivial-utf-8
(define-public ecl-trivial-utf-8
(sbcl-package->ecl-package sbcl-trivial-utf-8))
+(define-public sbcl-trivial-utilities
+ (let ((commit "279ff255562628196942632c543d91c357067221")
+ (revision "0"))
+ (package
+ (name "sbcl-trivial-utilities")
+ (version (git-version "0.4.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/ediethelm/trivial-utilities")
+ (commit commit)))
+ (file-name (git-file-name "trivial-utilities" version))
+ (sha256
+ (base32 "0k1xmn5f5dik7scadw0vyy67mik4ypnfqbhlv2vsg9afxzbpx2dz"))))
+ (build-system asdf-build-system/sbcl)
+ (inputs
+ (list sbcl-alexandria sbcl-iterate sbcl-closer-mop))
+ (home-page "https://gitlab.com/ediethelm/trivial-utilities")
+ (synopsis "Collection of useful types, functions and macros for Common Lisp")
+ (description
+ "This package provides a collection of types, functions and macros. Some
+ of the functionality is implemented from Grham's On Lisp and Seibel's Practical
+ Common Lisp.")
+ (license license:expat))))
+
+(define-public cl-trivial-utilities
+ (sbcl-package->cl-source-package sbcl-trivial-utilities))
+
+(define-public ecl-trivial-utilities
+ (sbcl-package->ecl-package sbcl-trivial-utilities))
+
(define-public sbcl-idna
(package
(name "sbcl-idna")
--
2.41.0
Sharlatan Hellseher wrote 12 months ago
[PATCH 03/10] gnu: Add cl-trivial-monitored-thread.
(address . 69904@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
978884fc78562459be498542255a7003ded5f25c.1710883390.git.sharlatanus@gmail.com
* gnu/packages/lisp-xyz.scm (cl-trivial-monitored-thread,
ecl-trivial-monitored-thread, sbcl-trivial-monitored-thread): New
variables.

Change-Id: I5da3c72e8437d368057aa7a7305e724141dfe09c
---
gnu/packages/lisp-xyz.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)

Toggle diff (46 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index c3d199a890..b92f2a7fb3 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -21312,6 +21312,39 @@ (define-public ecl-trivial-main-thread
(define-public cl-trivial-main-thread
(sbcl-package->cl-source-package sbcl-trivial-main-thread))
+(define-public sbcl-trivial-monitored-thread
+ (let ((commit "b0bab23f9a9bd06f0f33809635c7ba4e6a3d5a21")
+ (revision "0"))
+ (package
+ (name "sbcl-trivial-monitored-thread")
+ (version (git-version "0.3.11" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/ediethelm/trivial-monitored-thread")
+ (commit commit)))
+ (file-name (git-file-name "trivial-monitored-thread" version))
+ (sha256
+ (base32 "1ipnp2l944hc587bifxsnmiymw468imar0v8bqvgxv8pc5sym4ib"))))
+ (build-system asdf-build-system/sbcl)
+ (native-inputs
+ (list sbcl-fiveam))
+ (inputs
+ (list sbcl-iterate sbcl-log4cl sbcl-trivial-utilities))
+ (home-page "https://gitlab.com/ediethelm/trivial-monitored-thread")
+ (synopsis "Thread monitoring library for Common Lisp")
+ (description
+ "Trivial Monitored Thread offers a very simple (aka trivial) way of
+spawning threads and being informed when one any of them crash and die.")
+ (license license:expat))))
+
+(define-public cl-trivial-monitored-thread
+ (sbcl-package->cl-source-package sbcl-trivial-monitored-thread))
+
+(define-public ecl-trivial-monitored-thread
+ (sbcl-package->ecl-package sbcl-trivial-monitored-thread))
+
(define-public sbcl-moira
(let ((commit "21f1cfd5942fcaea2ed2e4f6055b2a5a39ac4c6e")
(revision "0"))
--
2.41.0
Sharlatan Hellseher wrote 12 months ago
[PATCH 04/10] gnu: Add cl-boost-json.
(address . 69904@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
5bef1b7e35d027a76a5890dc3898941879771abf.1710883390.git.sharlatanus@gmail.com
* gnu/packages/lisp-xyz.scm (cl-boost-json, sbcl-boost-json): New
variables.

Change-Id: I9b00905645f220c512c245e9cf02c74c4c1efcbc
---
gnu/packages/lisp-xyz.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index b92f2a7fb3..1378fe7353 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -1692,6 +1692,37 @@ (define-public ecl-re
(define-public cl-re
(sbcl-package->cl-source-package sbcl-re))
+(define-public sbcl-boost-json
+ (let ((commit "eca166f5ff1f10bad14e00b9fd5bf9fcf3691a47")
+ (revision "0"))
+ (package
+ (name "sbcl-boost-json")
+ (version (git-version "1.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/cl-boost/json")
+ (commit commit)))
+ (file-name (git-file-name "cl-boost-json" version))
+ (sha256
+ (base32 "12k0470899qsll2qixksxf2vrhjmskk3nzp1di9k04n1b29nrakd"))))
+ (build-system asdf-build-system/sbcl)
+ (home-page "https://github.com/cl-boost/json")
+ (synopsis "JSON encoding and decoding for Common Lisp")
+ (description
+ "BOOST-JSON is a simple JSON parsing library for Common Lisp.")
+ (license license:asl2.0))))
+
+(define-public cl-boost-json
+ (sbcl-package->cl-source-package sbcl-boost-json))
+
+;; FIXME: Failed to build on ECL: "fORMFEED" is an illegal character name.An
+;; error occurred during initialization:
+;;
+;; (define-public ecl-boost-json
+;; (sbcl-package->ecl-package sbcl-boost-json))
+
(define-public sbcl-boost-parse
(let ((commit "c8f7e536b950752f3e35003e7ee0446e0fd51b50")
(revision "0"))
--
2.41.0
Sharlatan Hellseher wrote 12 months ago
[PATCH 05/10] gnu: Add cl-st-json.
(address . 69904@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
b27db2e4a0a8d8fbc6db87517c3a9de70c3de377.1710883390.git.sharlatanus@gmail.com
* gnu/packages/lisp-xyz.scm (cl-st-json, ecl-st-json, sbcl-st-json):
New variables.

Change-Id: Ib349cfb6fb7da17741f331215e9a4d46bc4866c0
---
gnu/packages/lisp-xyz.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)

Toggle diff (46 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 1378fe7353..9f25066e1c 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -251,6 +251,39 @@ (define-public ecl-reader
;; TODO: Tests fail on call to coreutils echo for ecl.
`(#:tests? #f))))
+(define-public sbcl-st-json
+ (let ((commit "4a0025bcc5b6921454822f1b9f38f697b4eeaf43")
+ (revision "0"))
+ (package
+ (name "sbcl-st-json")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/marijnh/ST-JSON")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "06qrhr5iw73k96lai2x9w52l6gnmlxy7fsr0r35gz6nz1f71x7gx"))))
+ (build-system asdf-build-system/sbcl)
+ (home-page "https://marijnhaverbeke.nl/st-json/")
+ (synopsis "JSON for Common Lisp")
+ (description
+ "ST-JSON (@code{ST} because it originated at Streamtech) is a Common Lisp
+ library for encoding and decoding JSON values (as specified on json.org).
+
+This library does mostly the same thing as CL-JSON, but is simpler and more
+precise about types (distinguishing boolean false, the empty array, and the
+empty object).")
+ (license license:zlib))))
+
+(define-public cl-st-json
+ (sbcl-package->cl-source-package sbcl-st-json))
+
+(define-public ecl-st-json
+ (sbcl-package->ecl-package sbcl-st-json))
+
(define-public sbcl-stdutils
(let ((commit "4a4e5a4036b815318282da5dee2a22825369137b")
(revision "0"))
--
2.41.0
Sharlatan Hellseher wrote 12 months ago
[PATCH 07/10] gnu: Add cl-easy-routes.
(address . 69904@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
08205512dd11fa2c19d91a7d9dcb9f09ff58e01f.1710883391.git.sharlatanus@gmail.com
* gnu/packages/lisp-xyz.scm (cl-easy-routes, ecl-easy-routes,
sbcl-easy-routes): New variables.

Change-Id: Ic8d7413faf4b7e23775cc9c10b1b3da6494433d0
---
gnu/packages/lisp-xyz.scm | 40 +++++++++++++++++++++++++++++++++++++++
1 file changed, 40 insertions(+)

Toggle diff (53 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index a22aef345f..6c59dd915e 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -2986,6 +2986,46 @@ (define-public cl-eager-future2
(define-public ecl-eager-future2
(sbcl-package->ecl-package sbcl-eager-future2))
+(define-public sbcl-easy-routes
+ (let ((commit "7832f8bf3d07825b5eb967a2ef04da7c40c18248")
+ (revision "0"))
+ (package
+ (name "sbcl-easy-routes")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mmontone/easy-routes")
+ (commit commit)))
+ (file-name (git-file-name "cl-easy-routes" version))
+ (sha256
+ (base32 "1banw54kz2llzb9h5sm47ckfc9l348m7qncm0npsy0w837rxkyzx"))))
+ (build-system asdf-build-system/sbcl)
+ (native-inputs (list sbcl-stefil))
+ (inputs
+ (list sbcl-djula sbcl-hunchentoot sbcl-routes))
+ (home-page "https://github.com/mmontone/easy-routes/")
+ (synopsis "Routes handling utility on top of Hunchentoot")
+ (description
+ "EASY-ROUTES is yet another routes handling system on top of Hunchentoot. It's
+just glue code for Restas routing subsystem (CL-ROUTES).
+
+It supports:
+@itemize
+@item dispatch based on HTTP method
+@item arguments extraction from the url path
+@item decorators
+@item URL generation from route names
+@end itemize")
+ (license license:expat ))))
+
+(define-public cl-easy-routes
+ (sbcl-package->cl-source-package sbcl-easy-routes))
+
+(define-public ecl-easy-routes
+ (sbcl-package->ecl-package sbcl-easy-routes))
+
(define-public sbcl-jpl-util
(let ((commit "0311ed374e19a49d43318064d729fe3abd9a3b62"))
(package
--
2.41.0
Sharlatan Hellseher wrote 12 months ago
[PATCH 08/10] gnu: Add cl-vgplot.
(address . 69904@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
82dddcd1462e1d46f9c727f4f2f6738f47c8de13.1710883391.git.sharlatanus@gmail.com
* gnu/packages/lisp-xyz.scm (cl-vgplot, ecl-vgplot, sbcl-vgplot): New
variables.

Change-Id: I0c5aa5f3a0bb5bf79f0750b957442533073e5e2c
---
gnu/packages/lisp-xyz.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)

Toggle diff (47 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 6c59dd915e..81a0a164ae 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -7711,6 +7711,40 @@ (define-public ecl-verbose
(define-public cl-verbose
(sbcl-package->cl-source-package sbcl-verbose))
+(define-public sbcl-vgplot
+ (let ((commit "76329928a3709387c0779175af56ec49d16bcd35")
+ (revision "0"))
+ (package
+ (name "sbcl-vgplot")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/volkers/vgplot")
+ (commit commit)))
+ (file-name (git-file-name "vgplot" version))
+ (sha256
+ (base32 "1vc5fd787xa8831wjbmwrpg17f9isi5k8dmb85fsysz47plbvi1y"))))
+ (build-system asdf-build-system/sbcl)
+ (native-inputs
+ (list sbcl-lisp-unit))
+ (inputs
+ (list sbcl-cl-fad sbcl-cl-ppcre sbcl-ltk))
+ (home-page "https://github.com/volkers/vgplot")
+ (synopsis "Common lisp library interfacing to the gnuplot utility")
+ (description
+ "This package provides an interface to the @code{gnuplot} plotting
+utility. The intention of the API is to resemble to some of the plot commands
+of octave or matlab.")
+ (license license:gpl3))))
+
+(define-public cl-vgplot
+ (sbcl-package->cl-source-package sbcl-vgplot))
+
+(define-public ecl-vgplot
+ (sbcl-package->ecl-package sbcl-vgplot))
+
(define-public sbcl-find-port
(let ((commit "811727f88d7f000623bf92fdb0e64678a7112a28")
(revision "2"))
--
2.41.0
Sharlatan Hellseher wrote 12 months ago
[PATCH 09/10] gnu: Add cl-punch.
(address . 69904@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
fd6d08a6b26c2b7f3b6f98e92f393f310fe7a9fe.1710883391.git.sharlatanus@gmail.com
* gnu/packages/lisp-xyz.scm (cl-punch, ecl-cl-punch,
sbcl-cl-punch): New variables.

Change-Id: If6f7937d02a8dec67a9594ff011c44719349fd22
---
gnu/packages/lisp-xyz.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 81a0a164ae..debcfd96f2 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -4383,6 +4383,36 @@ (define-public cl-string-match
(define-public ecl-cl-string-match
(sbcl-package->ecl-package sbcl-cl-string-match))
+(define-public sbcl-cl-punch
+ (package
+ (name "sbcl-cl-punch")
+ (version "0.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/windymelt/cl-punch")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name "cl-punch" version))
+ (sha256
+ (base32 "1vmbaz9y9lq4wvi8mfbyif8vc9yfk2i0qd3ysbzl152wx32dbzs3"))))
+ (build-system asdf-build-system/sbcl)
+ (native-inputs
+ (list sbcl-prove))
+ (inputs
+ (list sbcl-cl-syntax))
+ (home-page "https://github.com/windymelt/cl-punch")
+ (synopsis "Anonymous lambda literal in Common Lisp, respecting Scala")
+ (description
+ "CL-PUNCH is a Scala-like anonymous lambda literal.")
+ (license license:expat )))
+
+(define-public cl-punch
+ (sbcl-package->cl-source-package sbcl-cl-punch))
+
+(define-public ecl-cl-punch
+ (sbcl-package->ecl-package sbcl-cl-punch))
+
(define-public sbcl-puri
(let ((commit "4bbab89d9ccbb26346899d1f496c97604fec567b")
(revision "2"))
--
2.41.0
Sharlatan Hellseher wrote 12 months ago
[PATCH 10/10] gnu: Add cl-ciel.
(address . 69904@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
4955abe60afd3c03b829188bae3a20de9ac0b7bb.1710883391.git.sharlatanus@gmail.com
* gnu/packages/lisp-xyz.scm (cl-ciel, sbcl-ciel): New variables.

Change-Id: I2d8eb9039a7b4a59c17af65eb76b74638e1685b3
---
gnu/packages/lisp-xyz.scm | 91 +++++++++++++++++++++++++++++++++++++++
1 file changed, 91 insertions(+)

Toggle diff (104 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index debcfd96f2..06e98c8628 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -7086,6 +7086,97 @@ (define-public cl-http-body
(define-public ecl-http-body
(sbcl-package->ecl-package sbcl-http-body))
+(define-public sbcl-ciel
+ (let ((commit "6cc1cef5e37e9f495c8163271a5de48de99f348a")
+ (revision "0"))
+ (package
+ (name "sbcl-ciel")
+ (version (git-version "0.1.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ciel-lang/CIEL")
+ (commit commit)))
+ (file-name (git-file-name "ciel" version))
+ (sha256
+ (base32 "1bwafbbsppxqvijf43dii55mpzrklh6faj2m5dhajg2f2m8qckgi"))))
+ (build-system asdf-build-system/sbcl)
+ (native-inputs
+ (list sbcl-fiveam))
+ (inputs
+ (list sbcl-access
+ sbcl-alexandria
+ sbcl-arrow-macros
+ sbcl-bordeaux-threads
+ sbcl-cl-ansi-text
+ sbcl-cl-ansi-text
+ sbcl-cl-cron
+ sbcl-cl-csv
+ sbcl-cl-json-pointer
+ sbcl-cl-ppcre
+ sbcl-cl-punch
+ sbcl-cl-reexport
+ sbcl-cl-str
+ sbcl-clesh
+ sbcl-clingon
+ sbcl-closer-mop
+ sbcl-cmd
+ sbcl-dbi
+ sbcl-defstar
+ sbcl-deploy
+ sbcl-dexador
+ sbcl-dissect
+ sbcl-easy-routes
+ sbcl-file-notify
+ sbcl-fn
+ sbcl-for
+ sbcl-fset
+ sbcl-generic-cl
+ sbcl-hunchentoot
+ sbcl-local-time
+ sbcl-log4cl
+ sbcl-lparallel
+ sbcl-lquery
+ sbcl-metabang-bind
+ sbcl-modf
+ sbcl-named-readtables
+ sbcl-nodgui
+ sbcl-parse-float
+ sbcl-parse-number
+ sbcl-printv
+ sbcl-pythonic-string-reader
+ sbcl-quicksearch
+ sbcl-quri
+ sbcl-repl-utilities
+ sbcl-serapeum
+ sbcl-shasht
+ sbcl-shlex
+ sbcl-spinneret
+ sbcl-sxql
+ sbcl-trivia
+ sbcl-trivial-arguments
+ sbcl-trivial-do
+ sbcl-trivial-monitored-thread
+ sbcl-trivial-package-local-nicknames
+ sbcl-trivial-types
+ sbcl-vgplot
+ sbcl-which))
+ (home-page "http://ciel-lang.org/")
+ (synopsis "CIEL Is an Extended Lisp")
+ (description
+ "CIEL is a ready-to-use collection of libraries providing: a binary, to
+run CIEL scripts; a simple full-featured REPL for the terminal; a Lisp library
+and a core image .")
+ (license license:expat))))
+
+(define-public cl-ciel
+ (sbcl-package->cl-source-package sbcl-ciel))
+
+;; FIXME: Blocked by sbcl-boost-json.
+;; (define-public ecl-ciel
+;; (sbcl-package->ecl-package sbcl-ciel))
+
(define-public sbcl-circular-streams
(let ((commit "e770bade1919c5e8533dd2078c93c3d3bbeb38df")
(revision "1"))
--
2.41.0
Sharlatan Hellseher wrote 12 months ago
[PATCH 06/10] gnu: Add cl-json-pointer.
(address . 69904@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
69310aa3ae5c654bbd8bd1f6508cb4736e2ee20d.1710883390.git.sharlatanus@gmail.com
* gnu/packages/lisp-xyz.scm (cl-json-pointer, sbcl-cl-json-pointer): New
variables.

Change-Id: I9fb6a063595792995c4a5af05a03ab889660702e
---
gnu/packages/lisp-xyz.scm | 42 +++++++++++++++++++++++++++++++++++++++
1 file changed, 42 insertions(+)

Toggle diff (55 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 9f25066e1c..a22aef345f 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -4943,6 +4943,48 @@ (define-public cl-json
(define-public ecl-cl-json
(sbcl-package->ecl-package sbcl-cl-json))
+(define-public sbcl-cl-json-pointer
+ (let ((commit "f6760e2a02972783f96b92a15f801e14a6828e0c")
+ (revision "0"))
+ (package
+ (name "sbcl-cl-json-pointer")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/y2q-actionman/cl-json-pointer")
+ (commit commit)))
+ (file-name (git-file-name "cl-json-pointer" version))
+ (sha256
+ (base32 "0b7a755wc2ghsd1pv7d32877b21h4nssp41xs017anbmj55czb2h"))))
+ (build-system asdf-build-system/sbcl)
+ (arguments
+ ;; Component "cl-json-pointer/test" not found
+ `(#:tests? #f
+ #:asd-systems '("cl-json-pointer" "cl-json-pointer/synonyms")))
+ (inputs
+ (list sbcl-alexandria
+ sbcl-boost-json
+ sbcl-cl-json
+ sbcl-closer-mop
+ sbcl-st-json))
+ (home-page "https://github.com/y2q-actionman/cl-json-pointer")
+ (synopsis "JSON Pointer processor for Common Lisp")
+ (description "
+This package provides a JSON
+Pointer (@url{https://tools.ietf.org/html/rfc6901,RFC6901}) implementation for
+Common Lisp. This libary aims to be independent from any JSON libraries (as much
+as possible).")
+ (license license:expat))))
+
+(define-public cl-json-pointer
+ (sbcl-package->cl-source-package sbcl-cl-json-pointer))
+
+;; FIXME: Not availalbe due to issue with ecl-boost-json
+;; (define-public ecl-cl-json-poiniter
+;; (sbcl-package->ecl-package sbcl-cl-json-pointer))
+
(define-public sbcl-unix-opts
(let ((commit "0e61f34b2ecf62288437810d4abb31e572048b04")
(revision "1"))
--
2.41.0
Sharlatan Hellseher wrote 12 months ago
[PATCH 01/10] gnu: Add cl-arrow-macros.
(address . 69904@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
8017fb71dc489ddb7f856765166d6d295f1510a2.1710883390.git.sharlatanus@gmail.com
* gnu/packages/lisp-xyz.scm (cl-arrow-macros, ecl-arrow-macros,
sbcl-arrow-macros): New variables.

Change-Id: I1d92139871f456d7d6780f2e60bbfed951d0298e
---
gnu/packages/lisp-xyz.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index ec9bf3a9ca..cd8dd6bf14 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -10190,6 +10190,36 @@ (define-public cl-rutils
(define-public ecl-rutils
(sbcl-package->ecl-package sbcl-rutils))
+(define-public sbcl-arrow-macros
+ (let ((commit "16bdfd31298182099c7d70df4598104e5a38b05e")
+ (revision "0"))
+ (package
+ (name "sbcl-arrow-macros")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hipeta/arrow-macros")
+ (commit commit)))
+ (file-name (git-file-name "arrow-macros" version))
+ (sha256
+ (base32 "0q4vpysk4h9ghs5zmnzzilky9jyz7i8n0x0p98nq528crbrkh6c4"))))
+ (build-system asdf-build-system/sbcl)
+ (native-inputs (list sbcl-fiveam))
+ (home-page "https://github.com/hipeta/arrow-macros/")
+ (synopsis "Clojure-like arrow macros in Common Lisp")
+ (description
+ "Arrow-macros provides clojure-like arrow macros (ex. ->, ->>) and diamond wands
+in swiss-arrows.")
+ (license license:expat))))
+
+(define-public cl-arrow-macros
+ (sbcl-package->cl-source-package sbcl-arrow-macros))
+
+(define-public ecl-arrow-macros
+ (sbcl-package->ecl-package sbcl-arrow-macros))
+
(define-public sbcl-arrows
(let ((commit "df7cf0067e0132d9697ac8b1a4f1b9c88d4f5382")
(revision "0"))
--
2.41.0
Guillaume Le Vaillant wrote 12 months ago
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 69904@debbugs.gnu.org)
87jzlxt6rz.fsf@kitej
Sharlatan Hellseher <sharlatanus@gmail.com> skribis:

Toggle quote (7 lines)
> +(define-public sbcl-arrow-macros
> + (let ((commit "16bdfd31298182099c7d70df4598104e5a38b05e")
> + (revision "0"))
> + (package
> + (name "sbcl-arrow-macros")
> + (version (git-version "0.0.0" revision commit))

The repository has an old "0.2.7" tag, so I guess we should use
'(git-version "0.2.7" revision commit)' as version.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCZfrZcA8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j8efQD+M7kRn+5OUeGmuMrLa1384yD2IqYUPT21NFgN
nZESs84A/ij0U/lDYSQVJ6svua6ONxJKdgiriUGJ4U4sQpjJMPZy
=AMEX
-----END PGP SIGNATURE-----

Guillaume Le Vaillant wrote 12 months ago
Re: [bug#69904] [PATCH 02/10] gnu: Add cl-trivial-utilities.
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 69904@debbugs.gnu.org)
87frwlt6jh.fsf@kitej
Sharlatan Hellseher <sharlatanus@gmail.com> skribis:

Toggle quote (4 lines)
> + (description
> + "This package provides a collection of types, functions and macros. Some
> + of the functionality is implemented from Grham's On Lisp and Seibel's Practical

Typo: Grham -> Graham
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCZfraog8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j8GOQD+KgXwoL8A/Gu5083nTRv81e9jcHK6jbNbf4wl
PMMkXpoA/R/r+nESvt7Xee+hR9FvN6MkDxLUr6CTd2QycsNmCU7r
=OFxw
-----END PGP SIGNATURE-----

Guillaume Le Vaillant wrote 12 months ago
Re: [bug#69904] [PATCH 07/10] gnu: Add cl-easy-routes.
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 69904@debbugs.gnu.org)
877chxt56j.fsf@kitej
Sharlatan Hellseher <sharlatanus@gmail.com> skribis:

Toggle quote (3 lines)
> + (inputs
> + (list sbcl-djula sbcl-hunchentoot sbcl-routes))

To get the support for djula, I suppose it will be necessary add an
'asd-systems' argument with 'easy-routes' and 'easy-routes+djula'
(maybe also adding 'eeasy-routes+errors' could be useful).
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCZfrhhA8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j8yBAD8DV9BC8l46EuQ5bHMUYheN6oHsMQ2uMORNFjB
MtFI8k4A/RXyXBSIYdg3hb9zVDjyu6A3a8L/ElGhIa+8oO/8q+cG
=4PDe
-----END PGP SIGNATURE-----

Guillaume Le Vaillant wrote 12 months ago
Re: [bug#69904] [PATCH 04/10] gnu: Add cl-boost-json.
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 69904@debbugs.gnu.org)
87bk79t5va.fsf@kitej
Sharlatan Hellseher <sharlatanus@gmail.com> skribis:

Toggle quote (6 lines)
> +;; FIXME: Failed to build on ECL: "fORMFEED" is an illegal character name.An
> +;; error occurred during initialization:
> +;;
> +;; (define-public ecl-boost-json
> +;; (sbcl-package->ecl-package sbcl-boost-json))

Apparently '#\formfeed' in "decode.lisp" should be replaced by '#\page'.

Even in SBCL:

Toggle snippet (4 lines)
* #\formfeed
#\Page

You could also report this upstream.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCZfreCQ8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j+kywD9Eim7Y2z1MHI/z4t2b+UaXtZ5JeZw486fE2zK
mpS1wKUA/ii9a/5nZAtYTjjAFqVjTxn3g6Cbjx40eYYl2bYdNPZa
=AV4B
-----END PGP SIGNATURE-----

Guillaume Le Vaillant wrote 12 months ago
Re: [bug#69904] [PATCH 00/10] gnu: Add cl-ciel.
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 69904@debbugs.gnu.org)
87y1adrpn0.fsf@kitej
Hi Sharlatan.
I made a quick review of this patch series and replied to some of the
patch emails with some things to fix. The rest looked good to me (but
I have not tried to run everything).
If after the few fixes everything still works fine on your side, no need
to send a v2 for review, just push the updated patches.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCZfrmcw8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j/oMwEAn33XLm8OXtBxko0I9IEQFDZVrDWd2tkVodDi
8+CNOVcBAIk/uq+1gXMxb8gwLBzh7zatY9bx4AcN1Avum90303T7
=irbP
-----END PGP SIGNATURE-----

Guillaume Le Vaillant wrote 12 months ago
Re: [bug#69904] [PATCH 08/10] gnu: Add cl-vgplot.
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 69904@debbugs.gnu.org)
8734slt4yv.fsf@kitej
Sharlatan Hellseher <sharlatanus@gmail.com> skribis:

Toggle quote (2 lines)
> + (license license:gpl3))))

According to the headers in the lisp files, it should be
'license:gpl3+'.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCZfrimA8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j+M4AEApl/sQu6oZJG9Kr2MIu2Olov0t5lnpLvQ9V2G
H7w4rFIA/18RyVj5JZsLdnWBP6eC2C5NTVI62Q/6eZuJc8iiR5Jo
=0nar
-----END PGP SIGNATURE-----

Sharlatan Hellseher wrote 12 months ago
[PATCH 00/10] gnu: Add cl-ciel.
(address . 69904-done@debbugs.gnu.org)
87a5mrxn0o.fsf@gmail.com
Hi Guillaume,

Thanks for the review!

I've covered all of review comments and added 2 more trivial packages from
already know upstreams: CL-HUNCHENTOOT-ERRORS and CL-MIMEPARSE to have
all systems from CL-EASY-ROUTES availale.

Pushed as 14942e2abb..c75eb3b38a to master.

--
Oleg
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmX8rjcACgkQdtcnv/Ys
0rXScg/8CuiCIoFywGhX++vYYex5W5v4BNYw0TdCDiKc6ntr0I+56ihTme6TY/HY
L8/f7dX3fuIZAcCTUoRNeVXMG0Qn0C+5gIV4OTK4O9FIfmt7Q4vBhXwkqzl7MK7k
5CRj1t7aT7ZjnHWv0qs7RSktr23eDA2XOnKPLvwzInrvvjNtkAsiJA0H9R9K8YaF
qHlin4J9sZGDcgPvNM+jTmwizP0Nz1IMssMQfLxZVecaC1wR27v4RYhFkYKrMhNP
jpCuZDgrNCBlWiOe9+lBFTn8hDKjXoH9CSPY5b0+Ctvt8uXE2VoB72B4WG4OU1gW
FJqpH6EsqlfEsBHIH+bdzpO8ZO5uCTXb18KSmmzCJ3ttMViYNnn5HryFtKw4K9Kx
SpLqrvO8KVbcMmGKAwU6PgKVXGKF9QypJZdgP0+AKU2ESFQIFidNue3/tadfiJ5m
CuoIBnKseOWKYBaKJgKdDvFJN6gbmtcmVd/ys5/uQ6tvfAchgWhc3Qc0peNh/hqA
KFRXQSkpR65IYQSUvZLJwVWq7e/CcDz52u7e7wC99yNKwVeHvGlrm19w+BfNx1vd
nSmN20bACkm76PqwB7itvF2lVQQi2FmFGnjbWgcIgkIWT/zP8jG2galaKFY9o22c
iUzKtlLkOb0yl2VEnmZtmLb4vZMgRsRsgcU5SVXXe3gnDJL30Ds=
=EmD+
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 69904@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 69904
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help