[PATCH] gnu: gtk: Update cairo to 1.18.0.

  • Done
  • quality assurance status badge
Details
2 participants
  • Daniel Ziltener
  • John Kehayias
Owner
unassigned
Submitted by
Daniel Ziltener
Severity
normal

Debbugs page

Daniel Ziltener wrote 12 months ago
(address . guix-patches@gnu.org)(address . dziltener@lyrion.ch)
6b76c31e120fda491be8ee8126cc5ae5@lyrion.ch
---
gnu/packages/gtk.scm | 26 ++++++++++++--------------
1 file changed, 12 insertions(+), 14 deletions(-)

Toggle diff (72 lines)
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 2dcfa0edc1..9afc692e8d 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -157,12 +157,11 @@ (define-public appmenu-gtk-module
"This package provides a global menu applet for use with desktop panels
such as mate-panel and xfce4-panel.")
(home-page "https://gitlab.com/vala-panel-project/vala-panel-appmenu")
- (license (list license:lgpl3))))
(define-public cairo
(package
(name "cairo")
- (version "1.16.0")
+ (version "1.18.0")
(source
(origin
(method url-fetch)
@@ -170,17 +169,16 @@ (define-public cairo
(string-append "https://cairographics.org/releases/cairo-"
version ".tar.xz"))
(sha256
- (base32 "0c930mk5xr2bshbdljv005j3j8zr47gqmkry3q6qgvqky6rjjysy"))
- (patches (search-patches
- "cairo-CVE-2018-19876.patch"
- "cairo-CVE-2020-35492.patch"))))
- (build-system glib-or-gtk-build-system)
- (outputs '("out" "doc"))
+ (base32
+ "0r0by563s75xyzz0d0j1nmjqmdrk2x9agk7r57p3v8vqp4v0ffi4"))))
+ (build-system meson-build-system)
(arguments
`(#:tests? #f ; see http://lists.gnu.org/archive/html/bug-guix/2013-06/msg00085.html
#:configure-flags
(list
- "--disable-static"
+ "-Dgtk_doc=true"
+ "-Dsymbol-lookup=disabled"
+ "-Dspectre=disabled"
;; XXX: To be enabled.
;; "--enable-gallium=yes"
;; "--enable-gl=yes"
@@ -189,15 +187,14 @@ (define-public cairo
;; "--enable-cogl=yes"
;; "--enable-directfb=yes"
;; "--enable-vg=yes"
- "--enable-tee=yes" ;needed for GNU IceCat
- "--enable-xml=yes" ;for cairo-xml support
- (string-append "--with-html-dir="
- (assoc-ref %outputs "doc")
- "/share/gtk-doc/html"))))
+ )))
(native-inputs
`(,@(if (target-hurd?)
'()
`(("gobject-introspection" ,gobject-introspection)))
+ ("gcc-13" ,gcc-13)
+ ("gtk-doc" ,gtk-doc)
+ ("docbook-xsl" ,docbook-xsl)
("pkg-config" ,pkg-config)
("python" ,python-wrapper)))
(inputs
@@ -236,6 +233,7 @@ (define-public cairo
(list
license:lgpl2.1+
license:mpl1.1))))
+ (license (list license:lgpl3))))
(define-public cairo-sans-poppler
;; Variant used to break the dependency cycle between Poppler and Cairo.
--
2.41.0
John Kehayias wrote 12 months ago
(name . Daniel Ziltener)(address . dziltener@lyrion.ch)(address . 69886@debbugs.gnu.org)
87y1af0zx8.fsf@protonmail.com
Hello,

Thanks for the submission!

On Mon, Mar 18, 2024 at 11:38 PM, Daniel Ziltener wrote:

Toggle quote (7 lines)
> (native-inputs
> `(,@(if (target-hurd?)
> '()
> `(("gobject-introspection" ,gobject-introspection)))
> + ("gcc-13" ,gcc-13)
> + ("gtk-doc" ,gtk-doc)

Note that this is a circular dependency as, gtk-doc depends on cairo currently:

Toggle snippet (8 lines)
$ guix graph --path gtk-doc cairo
gtk-doc@1.33.2
dblatex@0.3.12
imagemagick@6.9.12-4
pango@1.50.10
cairo@1.16.0

Please see https://issues.guix.gnu.org/69495 for my submission as
well. Since it has been a couple of weeks, I'll likely push that version
on mesa-updates for testing soon, but comments welcome.

John
Daniel Ziltener wrote 12 months ago
(name . John Kehayias)(address . john.kehayias@protonmail.com)(address . 69886@debbugs.gnu.org)(address . control@debbugs.gnu.org)
565ea2ef-e9f4-164a-d60d-d76674c9591d@lyrion.ch
Oh, nice, I will close this here then.

close 69886
thanks
?
Your comment

This issue is archived.

To comment on this conversation send an email to 69886@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 69886
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help