[PATCH] gnu: Add python-x-wr-timezone.

  • Open
  • quality assurance status badge
Details
2 participants
  • Skyler Ferris
  • Benjamin Slade
Owner
unassigned
Submitted by
Benjamin Slade
Severity
normal
B
B
Benjamin Slade wrote on 18 Mar 23:49 +0100
(address . guix-patches@gnu.org)
877chzyx3t.fsf@lambda-y.net

From f93366cb785f4783efe3c5e4027ae2062f0f87a3 Mon Sep 17 00:00:00 2001
From: Benjamin Slade <slade@lambda-y.net>
Date: Mon, 18 Mar 2024 17:47:03 -0500
Subject: [PATCH] gnu: Add python-x-wr-timezone.

* gnu/packages/<module>.scm (python-x-wr-timezone): New variable
---
gnu/packages/python-xyz.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (48 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 7ed8c94..17ce6ef 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -149,6 +149,7 @@
;;; Copyright © 2024 Timothee Mathieu <timothee.mathieu@inria.fr>
;;; Copyright © 2024 Ian Eure <ian@retrospec.tv>
;;; Copyright © 2024 Adriel Dumas--Jondeau <leirda@disroot.org>
+;;; Copyright © 2024 Benjamin Slade <slade@lambda-y.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -17622,6 +17623,33 @@ (define-public python-execnet
(home-page "https://codespeak.net/execnet/")
(license license:expat))))
+(define-public python-x-wr-timezone
+ (package
+ (name "python-x-wr-timezone")
+ (version "0.0.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "x_wr_timezone" version))
+ (sha256
+ (base32 "0j5zjvrshn7smq6cgbh7l66dl64wqs18cfyfnq1np1y00g320pha"))))
+ (build-system python-build-system)
+ (arguments
+ ;; Broken tests or cyclic dependecies with other packages.
+ '(#:phases (modify-phases %standard-phases
+ (delete 'sanity-check))
+ #:tests? #f))
+ (propagated-inputs (list python-icalendar python-pytz))
+ (home-page "https://github.com/niccokunzmann/x-wr-timezone")
+ (synopsis "Handling of non-standard X-WR-TIMEZONE icalendar property")
+ (description
+ "Some calendar providers introduce the non-standard X-WR-TIMEZONE
+parameter to ICS calendar files. Strict interpretations according to RFC 5545 ignore
+ the X-WR-TIMEZONE parameter. This causes the times of the events to differ from those
+ which make use of X-WR-TIMEZONE. This module aims to bridge the gap by converting
+ calendars using X-WR-TIMEZONE to a strict RFC 5545 calendars.")
+ (license license:lgpl3+)))
+
(define-public python-icalendar
(package
(name "python-icalendar")
--
2.41.0
S
S
Skyler Ferris wrote on 20 Mar 20:20 +0100
12d7b39d-bbe2-493a-842a-10f8b9a71593@protonmail.com
Hi Benjamin,

Toggle quote (3 lines)
> +     '(#:phases (modify-phases %standard-phases
> +                  (delete 'sanity-check))

Could you elaborate on why it is necessary to remove this phase? I tried
adding it back in and the package still built.

Toggle quote (2 lines)
> +       #:tests? #f))

It looks like this is here because tests require
python-icalendar>=5.0.11, correct? Could you update the existing package
(note that it has 3 dependents which should be checked for compatibility
in this case), or add a second package with the correct version instead
of skipping the tests? I also tried the example from the x-wr-timezone
README, and the icalendar.from_ical function it uses doesn't seem to
exist on the 4.1.0 version of python-icalendar (or at least if it does,
it is not provided by the top-level icalendar package, so I expect that
this package would break). Note that the python-icalendar update should
be in a separate commit that this one is based on.

Also a note about submissions: if it would be possible for you to use
git send-email as described in the manual, this would make it easier for
more reviewer to look at and so make it more likely that your patches
are reviewed quickly. It is described in the section "Sending a Patch
Series", but the instructions apply to single patches as well.

Regards,
Skyler
?