Daniel Ziltener wrote 12 months ago
(address . guix-patches@gnu.org)(address . dziltener@lyrion.ch)
---
gnu/packages/cpp.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)
Toggle diff (35 lines)
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index d451eea2fd..8f8b528071 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -786,6 +786,28 @@ (define-public nlohmann-json
(define-public json-modern-cxx
(deprecated-package "json-modern-cxx" nlohmann-json))
+(define-public tomlplusplus
+ (package
+ (name "tomlplusplus")
+ (version "3.4.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/marzer/tomlplusplus")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32
+ "1hvbifzcc97r9jwjzpnq31ynqnj5y93cjz4frmgddnkg8hxmp6w7"))))
+ (build-system cmake-build-system)
+ (native-inputs
+ (list python))
+ (arguments
+ (list #:tests? #f))
+ (home-page "https://marzer.github.io/tomlplusplus/")
+ (synopsis "Header-only TOML config file parser and serializer for C++17")
+ (description "Header-only TOML config file parser and serializer for C++17.")
+ (license license:expat)))
+
(define-public xtl
(package
(name "xtl")
--
2.41.0