[PATCH] gnu: flint: Update to 3.1.0.

  • Open
  • quality assurance status badge
Details
One participant
  • Andreas Enge
Owner
unassigned
Submitted by
Andreas Enge
Severity
normal
A
A
Andreas Enge wrote on 18 Mar 15:47 +0100
(address . guix-patches@gnu.org)(name . Andreas Enge)(address . andreas@enge.fr)
0f4ffd1d8aa64cd1f6e08eaeb45c5f9a76583988.1710773239.git.andreas@enge.fr
* gnu/packages/algebra.scm (flint): Update to 3.1.0.
[arguments]: Add a configure flag. Add a phase.
[license]: Change to lgpl3+.

Change-Id: I57d6dc7e1ce90399d9e4c01b35e62793bfc07bee
---
gnu/packages/algebra.scm | 23 ++++++++++++++++++-----
1 file changed, 18 insertions(+), 5 deletions(-)

Toggle diff (63 lines)
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 3fb9362b91..13cd523d6a 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -446,20 +446,32 @@ (define-public giac
(define-public flint
(package
(name "flint")
- (version "3.0.1")
+ (version "3.1.0")
(source
(origin
(method url-fetch)
(uri (string-append "https://flintlib.org/flint-" version ".tar.gz"))
(sha256
- (base32 "1d4lawfvmjd4n7rp4z9xkwwjjbrjhkmxnxw1xf0ki1isa001lcbv"))))
+ (base32 "0h9k792w4lidlv3czpmjk5hi8fqf3b0vp7av28sc6f3pp18pw42b"))))
(build-system gnu-build-system)
(inputs
(list ntl))
(propagated-inputs
(list gmp mpfr)) ; header files from both are included by flint/arith.h
(arguments
- `(#:parallel-tests? #f)) ; seems to be necessary on arm
+ ;; Parallel tests failed in the past on ARM, this may need to be
+ ;; tested again.
+ `(#:parallel-tests? #f ;; seems to be necessary on arm,
+ ;;but maybe not any more...
+ ;; Prevent build machine specifics from ending up in the binary.
+ #:configure-flags '("--disable-assembly")
+ ;; Replace absolute path.
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'patch-makefile
+ (lambda _
+ (substitute* "Makefile"
+ (("/sbin/ldconfig") "ldconfig")))))))
(synopsis "Fast library for number theory")
(description
"FLINT is a C library for number theory. It supports arithmetic
@@ -472,7 +484,7 @@ (define-public flint
GCDs, factoring, solving linear systems, and evaluating special
functions. In addition, FLINT provides various low-level routines for
fast arithmetic.")
- (license license:lgpl2.1+)
+ (license license:lgpl3+)
(home-page "https://flintlib.org/")
(properties
'((release-monitoring-url . "http://flintlib.org/downloads.html")))))
@@ -996,7 +1008,8 @@ (define-public eigen
(guix build utils)
(guix build cmake-build-system))
- #:phases (modify-phases %standard-phases
+ #:phases
+ (modify-phases %standard-phases
(add-after 'unpack 'disable-some-tests
;; Not all platforms are well supported by the test suite.
(lambda _

base-commit: c8556379c3f2d3d095a178858915720f2eebc012
--
2.41.0
A
A
Andreas Enge wrote on 19 Mar 15:31 +0100
[PATCH v2] gnu: flint: Update to 3.1.2.
(address . 69871@debbugs.gnu.org)(name . Andreas Enge)(address . andreas@enge.fr)
37f33c5f293233a97a29c38c3535f92b679407b8.1710858705.git.andreas@enge.fr
* gnu/packages/algebra.scm (flint): Update to 3.1.2.
[arguments]: Add a configure flag.
[license]: Change to lgpl3+.

Change-Id: I57d6dc7e1ce90399d9e4c01b35e62793bfc07bee
---
gnu/packages/algebra.scm | 17 +++++++++++------
1 file changed, 11 insertions(+), 6 deletions(-)

Toggle diff (56 lines)
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 3fb9362b91..c8601e7f78 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -446,20 +446,24 @@ (define-public giac
(define-public flint
(package
(name "flint")
- (version "3.0.1")
+ (version "3.1.2")
(source
(origin
(method url-fetch)
(uri (string-append "https://flintlib.org/flint-" version ".tar.gz"))
(sha256
- (base32 "1d4lawfvmjd4n7rp4z9xkwwjjbrjhkmxnxw1xf0ki1isa001lcbv"))))
+ (base32 "0017bjncpx4kdx67qcnm3nahz3gyyi2w3ggkrx586r3llcqs9czx"))))
(build-system gnu-build-system)
(inputs
(list ntl))
(propagated-inputs
- (list gmp mpfr)) ; header files from both are included by flint/arith.h
+ (list gmp mpfr)) ; header files included by flint.h or mpfr_mat.h
(arguments
- `(#:parallel-tests? #f)) ; seems to be necessary on arm
+ ;; Parallel tests failed in the past on ARM, this may need to be
+ ;; tested again.
+ `(#:parallel-tests? #f
+ ;; Prevent build machine specifics from ending up in the binary.
+ #:configure-flags '("--disable-assembly")))
(synopsis "Fast library for number theory")
(description
"FLINT is a C library for number theory. It supports arithmetic
@@ -472,7 +476,7 @@ (define-public flint
GCDs, factoring, solving linear systems, and evaluating special
functions. In addition, FLINT provides various low-level routines for
fast arithmetic.")
- (license license:lgpl2.1+)
+ (license license:lgpl3+)
(home-page "https://flintlib.org/")
(properties
'((release-monitoring-url . "http://flintlib.org/downloads.html")))))
@@ -996,7 +1000,8 @@ (define-public eigen
(guix build utils)
(guix build cmake-build-system))
- #:phases (modify-phases %standard-phases
+ #:phases
+ (modify-phases %standard-phases
(add-after 'unpack 'disable-some-tests
;; Not all platforms are well supported by the test suite.
(lambda _

base-commit: 83c5e7169d3bfa23a51225a8d809a435c1f2dd6b
--
2.41.0
A
A
Andreas Enge wrote on 19 Mar 16:02 +0100
[PATCH v3 2/2] gnu: ntl: Correct license.
(address . 69871@debbugs.gnu.org)(name . Andreas Enge)(address . andreas@enge.fr)
387366f538695b222983f0e46c744c25e4955e23.1710860525.git.andreas@enge.fr
* gnu/packages/algebra.scm (ntl)[license]: Set to lgpl2.1+.
[source]: Remove trailing #t in snippet.

Change-Id: Ibfcb520aa7fe71087adf2352b4051185a0d6f11e
---
gnu/packages/algebra.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (26 lines)
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index c8601e7f78..d997bb9c70 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -528,8 +528,7 @@ (define-public ntl
(modules '((guix build utils)))
(snippet
'(begin
- (delete-file-recursively "src/libtool-origin")
- #t))))
+ (delete-file-recursively "src/libtool-origin")))))
(build-system gnu-build-system)
(native-inputs
(list libtool perl)) ; for configuration
@@ -557,7 +556,8 @@ (define-public ntl
"NTL is a C++ library providing data structures and algorithms
for manipulating signed, arbitrary length integers, and for vectors,
matrices, and polynomials over the integers and over finite fields.")
- (license license:gpl2+)
+ (license license:lgpl2.1+) ; Linking with gf2x makes the distributed
+ ; binary de facto gpl3+.
(home-page "https://shoup.net/ntl/")))
(define-public singular
--
2.41.0
A
A
Andreas Enge wrote on 19 Mar 16:02 +0100
[PATCH v3 1/2] gnu: flint: Update to 3.1.2.
(address . 69871@debbugs.gnu.org)(name . Andreas Enge)(address . andreas@enge.fr)
b92c3964a70bfe88a918e4e64f456615b899049e.1710860525.git.andreas@enge.fr
* gnu/packages/algebra.scm (flint): Update to 3.1.2.
[arguments]: Add a configure flag.
[license]: Change to lgpl3+.

Change-Id: I57d6dc7e1ce90399d9e4c01b35e62793bfc07bee
---
gnu/packages/algebra.scm | 17 +++++++++++------
1 file changed, 11 insertions(+), 6 deletions(-)

Toggle diff (56 lines)
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 3fb9362b91..c8601e7f78 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -446,20 +446,24 @@ (define-public giac
(define-public flint
(package
(name "flint")
- (version "3.0.1")
+ (version "3.1.2")
(source
(origin
(method url-fetch)
(uri (string-append "https://flintlib.org/flint-" version ".tar.gz"))
(sha256
- (base32 "1d4lawfvmjd4n7rp4z9xkwwjjbrjhkmxnxw1xf0ki1isa001lcbv"))))
+ (base32 "0017bjncpx4kdx67qcnm3nahz3gyyi2w3ggkrx586r3llcqs9czx"))))
(build-system gnu-build-system)
(inputs
(list ntl))
(propagated-inputs
- (list gmp mpfr)) ; header files from both are included by flint/arith.h
+ (list gmp mpfr)) ; header files included by flint.h or mpfr_mat.h
(arguments
- `(#:parallel-tests? #f)) ; seems to be necessary on arm
+ ;; Parallel tests failed in the past on ARM, this may need to be
+ ;; tested again.
+ `(#:parallel-tests? #f
+ ;; Prevent build machine specifics from ending up in the binary.
+ #:configure-flags '("--disable-assembly")))
(synopsis "Fast library for number theory")
(description
"FLINT is a C library for number theory. It supports arithmetic
@@ -472,7 +476,7 @@ (define-public flint
GCDs, factoring, solving linear systems, and evaluating special
functions. In addition, FLINT provides various low-level routines for
fast arithmetic.")
- (license license:lgpl2.1+)
+ (license license:lgpl3+)
(home-page "https://flintlib.org/")
(properties
'((release-monitoring-url . "http://flintlib.org/downloads.html")))))
@@ -996,7 +1000,8 @@ (define-public eigen
(guix build utils)
(guix build cmake-build-system))
- #:phases (modify-phases %standard-phases
+ #:phases
+ (modify-phases %standard-phases
(add-after 'unpack 'disable-some-tests
;; Not all platforms are well supported by the test suite.
(lambda _

base-commit: ee11b22fcc7d8b42847e9d940ce5be3bc0d4f880
--
2.41.0
?