(address . guix-patches@gnu.org)(name . Andreas Enge)(address . andreas@enge.fr)
* gnu/packages/algebra.scm (flint): Update to 3.1.0.
[arguments]: Add a configure flag. Add a phase.
[license]: Change to lgpl3+.
Change-Id: I57d6dc7e1ce90399d9e4c01b35e62793bfc07bee
---
gnu/packages/algebra.scm | 23 ++++++++++++++++++-----
1 file changed, 18 insertions(+), 5 deletions(-)
Toggle diff (63 lines)
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 3fb9362b91..13cd523d6a 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -446,20 +446,32 @@ (define-public giac
(define-public flint
(package
(name "flint")
- (version "3.0.1")
+ (version "3.1.0")
(source
(origin
(method url-fetch)
(uri (string-append "https://flintlib.org/flint-" version ".tar.gz"))
(sha256
- (base32 "1d4lawfvmjd4n7rp4z9xkwwjjbrjhkmxnxw1xf0ki1isa001lcbv"))))
+ (base32 "0h9k792w4lidlv3czpmjk5hi8fqf3b0vp7av28sc6f3pp18pw42b"))))
(build-system gnu-build-system)
(inputs
(list ntl))
(propagated-inputs
(list gmp mpfr)) ; header files from both are included by flint/arith.h
(arguments
- `(#:parallel-tests? #f)) ; seems to be necessary on arm
+ ;; Parallel tests failed in the past on ARM, this may need to be
+ ;; tested again.
+ `(#:parallel-tests? #f ;; seems to be necessary on arm,
+ ;;but maybe not any more...
+ ;; Prevent build machine specifics from ending up in the binary.
+ #:configure-flags '("--disable-assembly")
+ ;; Replace absolute path.
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'patch-makefile
+ (lambda _
+ (substitute* "Makefile"
+ (("/sbin/ldconfig") "ldconfig")))))))
(synopsis "Fast library for number theory")
(description
"FLINT is a C library for number theory. It supports arithmetic
@@ -472,7 +484,7 @@ (define-public flint
GCDs, factoring, solving linear systems, and evaluating special
functions. In addition, FLINT provides various low-level routines for
fast arithmetic.")
- (license license:lgpl2.1+)
+ (license license:lgpl3+)
(home-page "https://flintlib.org/")
(properties
'((release-monitoring-url . "http://flintlib.org/downloads.html")))))
@@ -996,7 +1008,8 @@ (define-public eigen
(guix build utils)
(guix build cmake-build-system))
- #:phases (modify-phases %standard-phases
+ #:phases
+ (modify-phases %standard-phases
(add-after 'unpack 'disable-some-tests
;; Not all platforms are well supported by the test suite.
(lambda _
base-commit: c8556379c3f2d3d095a178858915720f2eebc012
--
2.41.0