(address . guix-patches@gnu.org)(name . Aaron Covrig)(address . aaron.covrig.us@ieee.org)
* gnu/packages/crates-io.scm (rust-pcap-1): New variable
* gnu/packages/crates-io.scm (rust-pcap-0.11): New variable
* gnu/packages/crates-io.scm (rust-pcap-0.10): New variable
* gnu/packages/crates-io.scm (rust-gat-std-0.1): New variable
* gnu/packages/crates-io.scm (rust-gat-std-proc-0.1): New variable
* gnu/packages/crates-io.scm (rust-etherparse-0.14): New variable
* gnu/packages/crates-io.scm (rust-etherparse-0.9): New variable
* gnu/packages/crates-io.scm (rust-eui48-1): New variable
* gnu/packages/crates-io.scm (rust-tun-tap-0.1): New variable
* gnu/packages/patches/rust-mockall-restore-examples-and-tests.patch:
New file (provides tests and examples rust-mockall)
* gnu/packages/crates-io.scm (rust-mockall-0.12): New variable
* gnu/packages/crates-io.scm (rust-mockall-derive-0.12): New variable
* gnu/packages/crates-io.scm (rust-mockall-0.11): Bumps to 0.11.4
* gnu/packages/crates-io.scm (rust-mockall-derive-0.11): Bumps to 0.11.4
* gnu/packages/crates-io.scm (rust-mockall-double-0.3): Bumps to 0.3.1
* gnu/packages/crates-io.scm (rust-fragile-2): New variable
* gnu/packages/crates-io.scm (rust-fragile-1): Bumps to 1.2.2
* gnu/packages/crates-io.scm (rust-slab-0.4): Bumps to 0.4.9
---
gnu/packages/crates-io.scm | 453 +-
...t-mockall-restore-examples-and-tests.patch | 7611 +++++++++++++++++
2 files changed, 7976 insertions(+), 88 deletions(-)
create mode 100644 gnu/packages/patches/rust-mockall-restore-examples-and-tests.patch
Toggle diff (440 lines)
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index e99f0f991b..34916d251e 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -24519,25 +24519,41 @@ (define-public rust-form-urlencoded-1
syntax, as used by HTML forms.")
(license (list license:expat license:asl2.0))))
-(define-public rust-fragile-1
+(define-public rust-fragile-2
(package
(name "rust-fragile")
- (version "1.0.0")
+ (version "2.0.0")
(source
(origin
(method url-fetch)
(uri (crate-uri "fragile" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "1wlihmkjyhvl5rckal32p010piy1l15s6l81h7z31jcd971kk839"))))
+ (base32 "1ajfdnwdn921bhjlzyvsqvdgci8ab40ln6w9ly422lf8svb428bc"))))
(build-system cargo-build-system)
- (arguments `(#:skip-build? #t))
- (home-page "https://github.com/mitsuhiko/rust-fragile")
+ (arguments
+ `(#:cargo-inputs (("rust-slab" ,rust-slab-0.4))))
+ (home-page "https://github.com/mitsuhiko/fragile")
(synopsis "Wrapper types for sending non-send values to other threads")
(description "This package provides wrapper types for sending non-send
values to other threads.")
(license license:asl2.0)))
+(define-public rust-fragile-1
+ (package
+ (inherit rust-fragile-2)
+ (name "rust-fragile")
+ (version "1.2.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "fragile" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1s2rz4cmmba5zi0gf2h6hprrcrf0wm83c1y45sdls09z99f4qimp"))))
+ (arguments
+ `(#:cargo-inputs (("rust-fragile" ,rust-fragile-2))))))
+
(define-public rust-freetype-0.7
(package
(name "rust-freetype")
@@ -25974,6 +25990,48 @@ (define-public rust-galil-seiferas-0.1
time, for nonorderable alphabets.")
(license (list license:expat license:asl2.0))))
+(define-public rust-gat-std-0.1
+ (package
+ (name "rust-gat-std")
+ (version "0.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "gat-std" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "14v4ldnzi8y8zkcj2qq7rj4af5ygk0s9iklflssxpcdgqzsfp3p0"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs (("rust-gat-std-proc" ,rust-gat-std-proc-0.1))))
+ (home-page "https://github.com/CraftSpider/gat-std")
+ (synopsis "Variants of Rust std traits that use GATs")
+ (description
+ "A variant of Rust std traits that use GATs, as well as a macro to allow
+rewriting code to use these traits instead of the std equivalents.")
+ (license (list license:expat license:asl2.0))))
+
+(define-public rust-gat-std-proc-0.1
+ (package
+ (name "rust-gat-std-proc")
+ (version "0.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "gat-std-proc" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0br6d92fg4g7s81lsms6q3ayss1bl19fanqxc7v1csnic2vaw84c"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs (("rust-proc-macro2" ,rust-proc-macro2-1)
+ ("rust-quote" ,rust-quote-1)
+ ("rust-syn" ,rust-syn-1))))
+ (home-page "https://github.com/CraftSpider/gat-std")
+ (synopsis "Proc macros for gat-std")
+ (description "Proc macros for gat-std.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-gcc-0.3
(package
(name "rust-gcc")
@@ -38529,85 +38587,136 @@ (define-public rust-mock-instant-0.2
"This package provides a simple way to mock an std::time::Instant in rust.")
(license license:bsd-0)))
-(define-public rust-mockall-0.11
+(define-public rust-mockall-0.12
(package
(name "rust-mockall")
- (version "0.11.1")
- (source (origin
- (method url-fetch)
- (uri (crate-uri "mockall" version))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "0k3g3xxf195vsnzmwza047dv89zlg6h5yj5774wjlndgpdvf8han"))))
+ (version "0.12.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "mockall" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0j0a1wx6sb8yimjgg3q1svrn8jsnaiz9zqgz93ihvc83a8mnqxj3"))
+ (patches (search-patches
+ "rust-mockall-restore-examples-and-tests.patch"))))
(build-system cargo-build-system)
+ ;; Tests depend on additional includes, only running examples
(arguments
- `(#:tests? #f ; Not all files included.
- #:cargo-inputs
- (("rust-cfg-if" ,rust-cfg-if-1)
- ("rust-downcast" ,rust-downcast-0.11)
- ("rust-fragile" ,rust-fragile-1)
- ("rust-lazy-static" ,rust-lazy-static-1)
- ("rust-mockall-derive" ,rust-mockall-derive-0.11)
- ("rust-predicates" ,rust-predicates-2)
- ("rust-predicates-tree" ,rust-predicates-tree-1))
- #:cargo-development-inputs
- (("rust-async-trait" ,rust-async-trait-0.1)
- ("rust-futures" ,rust-futures-0.3)
- ("rust-mockall-double" ,rust-mockall-double-0.3)
- ("rust-serde" ,rust-serde-1)
- ("rust-serde-derive" ,rust-serde-derive-1)
- ("rust-serde-json" ,rust-serde-json-1)
- ("rust-tracing" ,rust-tracing-0.1))))
+ `(#:cargo-test-flags '("--release" "--examples" "--lib")
+ #:cargo-inputs (("rust-cfg-if" ,rust-cfg-if-1)
+ ("rust-downcast" ,rust-downcast-0.11)
+ ("rust-fragile" ,rust-fragile-2)
+ ("rust-lazy-static" ,rust-lazy-static-1)
+ ("rust-mockall-derive" ,rust-mockall-derive-0.12)
+ ("rust-predicates" ,rust-predicates-3)
+ ("rust-predicates-tree" ,rust-predicates-tree-1))
+ #:cargo-development-inputs (("rust-async-trait" ,rust-async-trait-0.1)
+ ("rust-futures" ,rust-futures-0.3)
+ ("rust-mockall-double" ,rust-mockall-double-0.3)
+ ("rust-serde" ,rust-serde-1)
+ ("rust-serde-derive" ,rust-serde-derive-1)
+ ("rust-serde-json" ,rust-serde-json-1)
+ ("rust-tracing" ,rust-tracing-0.1))))
(home-page "https://github.com/asomers/mockall")
(synopsis "Mock object library for Rust")
(description
"Mockall is a rich mocking library with a terse and ergonomic interface.")
(license (list license:expat license:asl2.0))))
-(define-public rust-mockall-derive-0.11
+(define-public rust-mockall-0.11
+ (package
+ (inherit rust-mockall-0.12)
+ (name "rust-mockall")
+ (version "0.11.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "mockall" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "15kww0a3wv300wkksc6zj0kz1jwk0hyly48daxs2vvpj300lk12c"))
+ (patches (search-patches
+ "rust-mockall-restore-examples-and-tests.patch"))))
+ (build-system cargo-build-system)
+ ;; Tests depend on additional includes, only running examples
+ (arguments
+ `(#:cargo-test-flags '("--release" "--examples" "--lib")
+ #:cargo-inputs (("rust-cfg-if" ,rust-cfg-if-1)
+ ("rust-downcast" ,rust-downcast-0.11)
+ ("rust-fragile" ,rust-fragile-2)
+ ("rust-lazy-static" ,rust-lazy-static-1)
+ ("rust-mockall-derive" ,rust-mockall-derive-0.11)
+ ("rust-predicates" ,rust-predicates-2)
+ ("rust-predicates-tree" ,rust-predicates-tree-1))
+ #:cargo-development-inputs (("rust-async-trait" ,rust-async-trait-0.1)
+ ("rust-futures" ,rust-futures-0.3)
+ ("rust-mockall-double" ,rust-mockall-double-0.3)
+ ("rust-serde" ,rust-serde-1)
+ ("rust-serde-derive" ,rust-serde-derive-1)
+ ("rust-serde-json" ,rust-serde-json-1)
+ ("rust-tracing" ,rust-tracing-0.1))))))
+
+(define-public rust-mockall-derive-0.12
(package
(name "rust-mockall-derive")
- (version "0.11.1")
- (source (origin
- (method url-fetch)
- (uri (crate-uri "mockall_derive" version))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "1ixhmsrg5ky4b2jlvbxhlpr3mbv7frd6wr8msm005vijb5rmcb96"))))
+ (version "0.12.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "mockall_derive" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1qhal0m997vy5vv8admrrbcibsq1cjkr1ajbypaa31f3kvkvqz5g"))))
(build-system cargo-build-system)
(arguments
- `(#:cargo-inputs
- (("rust-cfg-if" ,rust-cfg-if-1)
- ("rust-proc-macro2" ,rust-proc-macro2-1)
- ("rust-quote" ,rust-quote-1)
- ("rust-syn" ,rust-syn-1))
- #:cargo-development-inputs
- (("rust-pretty-assertions" ,rust-pretty-assertions-0.7))))
+ `(#:cargo-inputs (("rust-cfg-if" ,rust-cfg-if-1)
+ ("rust-proc-macro2" ,rust-proc-macro2-1)
+ ("rust-quote" ,rust-quote-1)
+ ("rust-syn" ,rust-syn-2))
+ #:cargo-development-inputs (("rust-pretty-assertions" ,rust-pretty-assertions-1))))
(home-page "https://github.com/asomers/mockall")
(synopsis "Procedural macros for the Mockall crate")
(description
"This package procides procedural macros for the Mockall crate.")
(license (list license:expat license:asl2.0))))
+(define-public rust-mockall-derive-0.11
+ (package
+ (inherit rust-mockall-derive-0.12)
+ (name "rust-mockall-derive")
+ (version "0.11.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "mockall_derive" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1fvc9kwjcc9ia6ng7z9z02b4qkl9dvsx9m4z51xz9i0mj1k7bki2"))))
+ (arguments
+ `(#:cargo-inputs (("rust-cfg-if" ,rust-cfg-if-1)
+ ("rust-proc-macro2" ,rust-proc-macro2-1)
+ ("rust-quote" ,rust-quote-1)
+ ("rust-syn" ,rust-syn-1))
+ #:cargo-development-inputs (("rust-pretty-assertions" ,rust-pretty-assertions-1))))))
+
(define-public rust-mockall-double-0.3
(package
(name "rust-mockall-double")
- (version "0.3.0")
- (source (origin
- (method url-fetch)
- (uri (crate-uri "mockall_double" version))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "1xk6hjr7m73zly4hg3zmma437vqvrwnjxy2wfxy1hxbk52xwfwdf"))))
+ (version "0.3.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "mockall_double" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1s0k85929bf8afvdgq8m2vs8haqpkg9ysdimw7inl99mmkjrdjpi"))))
(build-system cargo-build-system)
(arguments
`(#:cargo-inputs (("rust-cfg-if" ,rust-cfg-if-1)
("rust-proc-macro2" ,rust-proc-macro2-1)
("rust-quote" ,rust-quote-1)
- ("rust-syn" ,rust-syn-1))))
+ ("rust-syn" ,rust-syn-2))))
(home-page "https://github.com/asomers/mockall")
(synopsis "Double test adapter that works well with Mockall")
(description
@@ -46217,8 +46326,91 @@ (define-public rust-pathdiff-0.2
path.")
(license (list license:asl2.0 license:expat))))
+(define-public rust-pcap-1
+ (package
+ (name "rust-pcap")
+ (version "1.3.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "pcap" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0ygzsi7v2x9ld5cb61dfg8jgifs2rln6qlknypzqjjnmfgy3bscr"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs (("rust-bitflags" ,rust-bitflags-1)
+ ("rust-errno" ,rust-errno-0.2)
+ ("rust-etherparse" ,rust-etherparse-0.13)
+ ("rust-gat-std" ,rust-gat-std-0.1)
+ ("rust-futures" ,rust-futures-0.3)
+ ("rust-libc" ,rust-libc-0.2)
+ ("rust-tokio" ,rust-tokio-1)
+ ("rust-tun-tap" ,rust-tun-tap-0.1)
+ ("rust-windows-sys" ,rust-windows-sys-0.36))
+ #:cargo-development-inputs (("rust-eui48" ,rust-eui48-1)
+ ("rust-mockall" ,rust-mockall-0.11)
+ ("rust-once-cell" ,rust-once-cell-1)
+ ("rust-tempdir" ,rust-tempdir-0.3))))
+ (inputs (list libpcap))
+ (home-page "https://github.com/rust-pcap/pcap")
+ (synopsis "Rust packet capture API around pcap/wpcap")
+ (description "This is a Rust language crate for accessing the packet
+sniffing capabilities of libpcap (or Npcap on Windows).")
+ (license (list license:asl2.0 license:expat))))
+
+(define-public rust-pcap-0.11
+ (package
+ (inherit rust-pcap-1)
+ (name "rust-pcap")
+ (version "0.11.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "pcap" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0sk9d0ygqgpwn6rpdclx8lqxcz8gm470pyfspbdjcgjvyr5jvncq"))))
+ (arguments
+ `(#:cargo-inputs (("rust-bitflags" ,rust-bitflags-1)
+ ("rust-errno" ,rust-errno-0.2)
+ ("rust-futures" ,rust-futures-0.3)
+ ("rust-libc" ,rust-libc-0.2)
+ ("rust-windows-sys" ,rust-windows-sys-0.36)
+ ("rust-tokio" ,rust-tokio-1))
+ #:cargo-development-inputs (("rust-libloading" ,rust-libloading-0.6)
+ ("rust-pkg-config" ,rust-pkg-config-0.3)
+ ("rust-regex" ,rust-regex-1)
+ ("rust-eui48" ,rust-eui48-1)
+ ("rust-tempdir" ,rust-tempdir-0.3))))))
+
+(define-public rust-pcap-0.10
+ (package
+ (inherit rust-pcap-1)
+ (name "rust-pcap")
+ (version "0.10.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "pcap" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0yp1akb8y53faf993xv7l7va957waiv9qmjl8m3mpijw2744999d"))))
+ (arguments
+ `(#:cargo-inputs (("rust-bitflags" ,rust-bitflags-1)
+ ("rust-errno" ,rust-errno-0.2)
+ ("rust-futures" ,rust-futures-0.3)
+ ("rust-libc" ,rust-libc-0.2)
+ ("rust-windows-sys" ,rust-windows-sys-0.36)
+ ("rust-tokio" ,rust-tokio-1))
+ #:cargo-development-inputs (("rust-eui48" ,rust-eui48-1)
+ ("rust-libloading" ,rust-libloading-0.6)
+ ("rust-regex" ,rust-regex-1)
+ ("rust-tempdir" ,rust-tempdir-0.3))))))
+
(define-public rust-pcap-0.7
(package
+ (inherit rust-pcap-0.10)
(name "rust-pcap")
(version "0.7.0")
(source
@@ -46228,8 +46420,6 @@ (define-public rust-pcap-0.7
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32 "14blflnbj87z3ajlj1hszsl6k7rwa338y4aw2yjm2j0xdpjvj4pr"))))
- (native-inputs (list libpcap))
- (build-system cargo-build-system)
(arguments
`(#:tests? #f ; can't find crate for `futures`
#:cargo-inputs
@@ -46239,11 +46429,7 @@ (define-public rust-pcap-0.7
("rust-mio" ,rust-mio-0.6)
("rust-tokio-core" ,rust-tokio-core-0.1))
#:cargo-development-inputs
- (("rust-tempdir" ,rust-tempdir-0.3))))
- (home-page "https://github.com/rust-pcap/pcap")
- (synopsis "Packet capture API around pcap/wpcap")
- (description "This package provides a packet capture API around pcap/wpcap.")
- (license (list license:expat license:asl2.0))))
+ (("rust-tempdir" ,rust-tempdir-0.3))))))
(define-public rust-pcap-sys-0.1
(package
@@ -57118,29 +57304,91 @@ (define-public rust-ethtool-0.2
(description "Linux Ethtool Communication Library.")
(license license:expat)))
-(define-public rust-etherparse-0.13
+
+(define-public rust-etherparse-0.14
(package
(name "rust-etherparse")
- (version "0.13.0")
+ (version "0.14.2")
(source
(origin
(method url-fetch)
(uri (crate-uri "etherparse" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "146rcbnhlpcbl6c6csfhvz0227wbiwhk13md6acq8211b7m94wl2"))))
+ (base32 "1cf9qf089c8a5xlr7az2wcrr0i0l2zi1q9h2ixwalhsbxc1hd294"))))
(build-system cargo-build-system)
(arguments
`(#:cargo-inputs (("rust-arrayvec" ,rust-arrayvec-0.7))
- #:cargo-development-inputs (("rust-assert-matches" ,rust-assert-matches-1)
- ("rust-proptest" ,rust-proptest-1))))
+ #:cargo-development-inputs (("rust-proptest" ,rust-proptest-1))))
(home-page "https://github.com/JulianSchmid/etherparse")
- (synopsis "Library for parsing & writing a bunch of packet based protocols")
+ (synopsis
+ "Library for parsing & writing a bunch of packet based protocols")
(description
- "This package provides a library for parsing & writing a bunch of packet
-based protocols (@code{EthernetII}, IPv4, IPv6, UDP, TCP ...).")
+ "A zero allocation library for parsing & writing a bunch of
+packet based protocols (EthernetII, IPv4, IPv6, UDP, TCP ...).")
(license (list license:expat license:asl2.0))))
+(define-public rust-etherparse-0.13
+
This message was truncated. Download the full message here.