[PATCH] gnu: Add go-github-com-multiformats-go-varint.

  • Done
  • quality assurance status badge
Details
2 participants
  • Artyom V. Poptsov
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Artyom V. Poptsov
Severity
normal

Debbugs page

Artyom V. Poptsov wrote 12 months ago
(address . guix-patches@gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
1782b8c82eb20be7624c2fddf9123696deeaf199.1710677431.git.poptsov.artyom@gmail.com
* gnu/packages/golang.scm (go-github-com-multiformats-go-varint): New
variable.

Change-Id: Ib2f82fff0fbed00010c2aa7993134d5a855f0d7d
---
gnu/packages/golang.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index c386421bec..e78eb23a7a 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -5256,6 +5256,28 @@ (define-public go-github-com-multiformats-go-multiaddr-net
as conversion to and from @command{net.Addr}.")
(license license:expat))))
+(define-public go-github-com-multiformats-go-varint
+ (package
+ (name "go-github-com-multiformats-go-varint")
+ (version "0.0.7")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/multiformats/go-varint")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0l4s0z3rc3d350zp6qximl1jjhic6l8w74wkmx244jgfzsxd93af"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/mreiferson/go-options"))
+ (home-page "https://github.com/mreiferson/go-options")
+ (synopsis "Varint helpers that enforce minimal encoding")
+ (description
+ "Varint helpers that enforce minimal encoding.")
+ (license license:expat)))
+
(define-public go-github-com-whyrusleeping-tar-utils
(let ((commit "8c6c8ba81d5c71fd69c0f48dbde4b2fb422b6dfc")
(revision "0"))

base-commit: c5a8b46ffc535b7c3acc3dfa4af9ee275676dceb
--
2.41.0
Sharlatan Hellseher wrote 12 months ago
(address . 69842@debbugs.gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
CAO+9K5qwK8mCVfojjDQvCpub7FMz2R6h4t=8m4uskP8MQQsyLQ@mail.gmail.com
Hi,

Thank you for the patch.

Please avoid adding new packages into golang.scm, It is in a
proces of redistribution among submodules.

Pick up any of golang-*.scm modules.

--
Oleg
Attachment: file
Artyom V. Poptsov wrote 12 months ago
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 69842@debbugs.gnu.org)
87r0g8sz5j.fsf@gmail.com
Hello!

Toggle quote (3 lines)
> Please avoid adding new packages into golang.scm, It is in a
> proces of redistribution among submodules.

I know that you're working on splitting Go packages between more
specific modules.

I placed the new package into "golang.scm" only because other
"go-github-com-multiformats-*" packages are placed here.

Maybe it's reasonable to move all "go-github-com-multiformats-*" to
"golang-xyz.scm" first and then place the new packages from this group
here. What do you think?

Could you merge "go-github-com-multiformats-go-varint" after the review
process (and maybe with corrections to the package from my side) and
then move all "go-github-com-multiformats-*" to "golang-xyz.scm"?

Thanks!
- avp

--
Artyom "avp" Poptsov <poptsov.artyom@gmail.com>
CADR Hackerspace co-founder: https://cadrspace.ru/
GPG: D0C2 EAC1 3310 822D 98DE B57C E9C5 A2D9 0898 A02F
-----BEGIN PGP SIGNATURE-----

iQJNBAEBCgA3FiEEAf2F9Bp7f4IFgwalk16+BzbchX4FAmX3AAgZHHBvcHRzb3Yu
YXJ0eW9tQGdtYWlsLmNvbQAKCRCTXr4HNtyFfnoWEACLKadjVUTArwNTeWgH74yy
CqrHncbO001OzEfBAg4hBzAcZrbz3AGmT2AKOkPwY9abb1dyUyX/RTvTn45XZSjG
w5RIOAVFiOzp3ejRSt6cG3FICK7OiPznXKIyjoF7C0GSx6jluYzqhYAp89T+5Msz
+4xo9absEEfclt7Gyw5pkyvf6/+EDreIdTohBOSZhI30zPL1H1nmkmfgu4ve+LVg
bcjipwPIi/zDvDwD4CI1lfnj/mYj2pdi3hOoHWPpDghMfaSnYbBd8q5FwWgw5obj
hopTT+TiQZ8c4RL9ToNU0otBZS9ZhtsUYXZ9okgPBScaGlmC0ayCi6o1RWXdmW5p
s7WB6RbMHrqkeYPez9v/k7S5I2SP5l7JFM5VjCKyA2wDorqr+J9OeLVNrjrlC0FO
H9JYWT3myf/5HPoFRV0J0FxcXCuZJzcQJPFLpgXGMSQi6MucDjgiPrsaUun9xo9R
dW3tBEl6k2JPY9xloE0zXarEUfWYHrgIZjPuQsVReujcBVBb/eHj2cDShAA5llLR
gpnZiqem2aHqEylApH176Eb/rzRZodkV5Fv3Zj2qFqJHxeseJ+tUQlPVcPCyRlji
veVZiO7b22VZZ7x8e4VUc1pbQqgbuxQRtpSxdN5E/KcK0qVyZMS8g3dVQMxYC0bg
K7jZXR9wPx18MDKJPiSC5g==
=iRe9
-----END PGP SIGNATURE-----

Sharlatan Hellseher wrote 12 months ago
(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)(address . 69842@debbugs.gnu.org)
CAO+9K5r2_GyrkYiVh9uMy7JKMYgY1eoa8-yOWrvW_dqEHw7iOQ@mail.gmail.com
Hi,
Toggle quote (3 lines)
> Could you merge "go-github-com-multiformats-go-varint" after the review
> process (and maybe with corrections to the package from my side) and
> then move all "go-github-com-multiformats-*" to "golang-xyz.scm"?
Sounds like a plan!
Let's wait until QA picking it up and I'll move mentioned to golang-xyz.scm
--
VCS: https://github.incerto.xyz/;https://git.sr.ht/~hellseher/
GPG: 9847 81DE 689C 21C2 6418 0867 76D7 27BF F62C D2B5
… наш разум - превосходная объяснительная машина которая способна
найти смысл почти в чем угодно, истолковать любой феномен, но
совершенно не в состоянии принять мысль о непредсказуемости.
Sharlatan Hellseher wrote 12 months ago
[PATCH] gnu: Add go-github-com-multiformats-go-varint.
(address . 69842-done@debbugs.gnu.org)
87y1abw33k.fsf@gmail.com
Pushed as 791578befb7e129f682f38bfe903c23baa46fb91 to master.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmX8yU8ACgkQdtcnv/Ys
0rV3chAAn+C/VsVKEAVW2Z3Kued3E4qpuSxrSG67nKXHgcfnA1Fl1S0XeltgNKSL
zoTHI4BPjVf5DGlzsPtwhdeUcyuRbueug125M8z3TmIIOBllF+sTC7/fARn9a4Vl
2ryG5jHTd3/cS616uEv6F3J8+1V7FcqB9NLN/RT/oN6WQqhqJ+AnYn3Fuj/3Xari
oNo1qe8GnShp2uT3YBecQpMYRP+j9Xr1jwDNgWscStpXJxo57z+MXrXlE+3rEwrx
UbeiJ7rK/vHoGcLz+ujE7ynQw6xLCotIVHxkBxF4GQdiyvZjGP/ShvDhbMZBCiQz
YJxToSGFG/NjCKXo8uuwfd3ro8twRKQZTPXEstkmOgGrTKYw49AiFRPyero6D6jM
qMuoabos/0PIblbc9ue+s24WAMPVEzzd/rER/MNlta2IIO+LHaguqaQ09uQQqYBY
NVh31uotu4vOYfSMaFWWp8dBD1C7IkOhjPGKw+l/Y/QtPnxHF9kpxPFhFhuewtLJ
jWWfReaybtdTZlOZBgHClG/GWDMU+1fYCfO+3C9ZiyF7lNhfaWWSHdTqLpMoNv74
tR+dFqOFMTn5qh2p47ocj5FfpSSwvEEXWjUoYbQdw8fTpgoQm2TesVQhDHSGlKhE
mmiZNobwwquJuwXAnRNRY6z33J5BmjjM+ksHg3EUAnZPvgnRQro=
=F0vh
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 69842@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 69842
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help