[PATCH] gnu: Add go-pgregory-net-rapid.

  • Done
  • quality assurance status badge
Details
2 participants
  • Artyom V. Poptsov
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Artyom V. Poptsov
Severity
normal

Debbugs page

Artyom V. Poptsov wrote 12 months ago
(address . guix-patches@gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
c5a8b46ffc535b7c3acc3dfa4af9ee275676dceb.1710650837.git.poptsov.artyom@gmail.com
* gnu/packages/golang-check.scm (go-pgregory-net-rapid): New variable.

Change-Id: I09a89c779a352e6a102d0b4c7af3aa1f7c3cac70
---
gnu/packages/golang-check.scm | 39 +++++++++++++++++++++++++++++++++++
1 file changed, 39 insertions(+)

Toggle diff (54 lines)
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index 290afdd3b9..c4bdd75f00 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -804,6 +804,45 @@ (define-public go-honnef-co-go-tools
advanced Go linter.")
(license license:expat)))
+(define-public go-pgregory-net-rapid
+ (package
+ (name "go-pgregory-net-rapid")
+ (version "1.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/flyingmutant/rapid")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1alyhcbdq6113sfymx7xxmxpcbgvkaipsn15cgjrcqrx8ks1hm5i"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "pgregory.net/rapid"
+ #:go ,go-1.18))
+ (native-inputs (list go-github-com-stretchr-testify))
+ (home-page "https://pgregory.net/rapid/")
+ (synopsis "Modern Go property-based testing library")
+ (description
+ "@code{Rapid} is a Go library for property-based testing.
+
+Rapid checks that properties you define hold for a large number of automatically
+generated test cases. If a failure is found, rapid automatically minimizes the
+failing test case before presenting it.
+
+Features:
+@itemize
+@item Imperative Go API with type-safe data generation using generics.
+@item Data generation biased to explore \"small\" values and edge cases more
+thoroughly
+@item Fully automatic minimization of failing test cases.
+@item Persistence and automatic re-running of minimized failing test cases.
+@item Support for state machine (\"stateful\" or \"model-based\") testing
+@item No dependencies outside the Go standard library.
+@end itemize")
+ (license license:mpl2.0)))
+
;;;
;;; Executables:
;;;

base-commit: edfb05e16d409ab71f5cc5c91747b693f0054d59
--
2.41.0
Sharlatan Hellseher wrote 12 months ago
(address . 69838-done@debbugs.gnu.org)
871q83xhpc.fsf@gmail.com
- Modifications
- Remove any native-inputs as not required, to support the claim "no
dependencies outside the Go standard library"
- Adjust description style
- Adjust synopsis statement
- Use 'list' style

Pushed as 9a5b9dad0d542b94bc34d5d5cfab70bff6c29c90 to master.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmX8yR8ACgkQdtcnv/Ys
0rUV0Q//V+ufXbMb/W3FM0NLyPrhYGK0DV0EcOtWkZos4P++1MEpyM5x5Ht2Alxr
vTjN4uKB65N+yGYqano6pCjlAIoIG+95TxvYuyU5imK1WFYU7uEMQiIgLencUNLb
o5upkSC5K0RsJd3UU00zaVyJuCfmfBB62ESHqLh58y0v/o0Q40Djxz1ow2CEK0gC
h3wD7uDInZ9vpc5BbLQcCSzR4ncgGLe1aBWFC3ZOW+WINjpx9Vf0zxNYUvuAOs2M
QyySFawX8xqFdhQgzY7gzFPOy+4DBgZNkxxE8lC8k+BjDR2JBXHD+2zwxqzovnL9
20mKNEKkn9SpFJfWfl4Xn+TiqDwr2kvqSKbQADEZwnYs7NvJdVxaUq4t3uXQsdh0
8uuxHNAOydZPjqT99ycaJqMl7SPsckCJ27VLs9v31SqMPiRKEk7uY7cPHx1Kbnsl
BuiIJHHXhK6NbTKrtZkRwnGxeml7tJJvRBwrLKBbhd4x+Yd7JXdLdok/dpAhOFwk
oDRP9ZqohkZk8PZfUkbEKdtKs46RzzIoQJ3tTgasuJnNNlntLiyX4CEyg52loGH5
QKp/ncMseH2scwxWH+I7OOYpuKmM9suXuGAvxo8pfQqY6YNPtODBitgVNV2c6Tk2
ogeuEnnH0M+6clAt/ZGE9LAsjwJ4uvYY18sVZLOEIFWgiUtCrMc=
=gKIe
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 69838@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 69838
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help