greetd-wlgreet-sway-session unable to login (Respawning term-tty1)

  • Open
  • quality assurance status badge
Details
One participant
  • Franz Geffke
Owner
unassigned
Submitted by
Franz Geffke
Severity
normal
F
F
Franz Geffke wrote on 16 Mar 11:47 +0100
(address . bug-guix@gnu.org)
4675f523-6412-ace1-de90-794b2313308c@f-a.nz
It seems like `greetd-wlgreet-sway-session` broke for me, sometime in the last
10 days. Initially I suspected it's related to my hardware, or a newer kernel,
but I was able to rule these out with a clean config in the VM.
- It's working as of `3da49b1472919a62df1fe399638f23a246aa325d` (05.03) but does
not anymore.
- On my working setup (05.03), I use logind; but I also tried seatd, without change.
- I suspected maybe Sway 1.9, but using the previous 1.8.1 did not help.
- Maybe https://issues.guix.gnu.org/65769is related, but looks like a hardware
issue?

```
(define-public sway-legacy
(package
(inherit sway)
(name "sway")
(version "1.8.1")
...))


(service greetd-service-type
(greetd-configuration
(greeter-supplementary-groups (list "video" "input" "seat"))
(terminals
(list
(greetd-terminal-configuration
(terminal-vt "1")
(terminal-switch #t)
(default-session-command
(greetd-wlgreet-sway-session
(sway sway-legacy)
(wlgreet-session
(greetd-wlgreet-session
(command (file-append sway-legacy "/bin/sway")))))))

(greetd-terminal-configuration
(terminal-vt "2"))
(greetd-terminal-configuration
(terminal-vt "3"))
(greetd-terminal-configuration
(terminal-vt "4"))
(greetd-terminal-configuration
(terminal-vt "5"))
(greetd-terminal-configuration
(terminal-vt "6"))))))
```

Here's a bunch of logs:

```
tail -f /var/log/messages
Mar 16 09:49:33 localhost shepherd[1]: Respawning term-tty1.
Mar 16 09:49:33 localhost shepherd[1]: Starting service term-tty1...
Mar 16 09:49:33 localhost shepherd[1]: Service term-tty1 has been started.
Mar 16 09:49:33 localhost shepherd[1]: Service term-tty1 started.
Mar 16 09:49:33 localhost shepherd[1]: Service term-tty1 running with value 1382.
Mar 16 09:49:36 localhost shepherd[1]: Respawning term-tty1.
Mar 16 09:49:36 localhost shepherd[1]: Starting service term-tty1...
Mar 16 09:49:36 localhost shepherd[1]: Service term-tty1 has been started.
Mar 16 09:49:36 localhost shepherd[1]: Service term-tty1 started.
Mar 16 09:49:36 localhost shepherd[1]: Service term-tty1 running with value 1396.
```

dmesg

```
dmesg | greo greetd
[ 31.025881] shepherd[1]: Starting service file-system-/run/greetd/pam_mount...
[ 31.088881] shepherd[1]: Service file-system-/run/greetd/pam_mount started.
[ 31.118389] shepherd[1]: Service file-system-/run/greetd/pam_mount running
with value #t.
[ 31.131180] shepherd[1]: Service file-system-/run/greetd/pam_mount has been
started.
```

greetd-1.log

```
tail greetd-1.log
2024-03-16 10:00:13 error: check_children: greeter exited without creating a session
2024-03-16 10:00:16 error: check_children: greeter exited without creating a session
2024-03-16 10:00:19 error: check_children: greeter exited without creating a session
2024-03-16 10:00:22 error: check_children: greeter exited without creating a session
```

seatd-1.log

```
2024-03-16 09:59:58 00:14:15.066 [INFO] [seatd/seat.c:170] Added client 1 to seat0
2024-03-16 09:59:58 00:14:15.066 [INFO] [seatd/seat.c:480] Opened client 1 on seat0
2024-03-16 09:59:58 00:14:15.385 [INFO] [seatd/client.c:471] Client disconnected
2024-03-16 09:59:58 00:14:15.387 [INFO] [seatd/seat.c:418] No clients on seat0
to activate
2024-03-16 09:59:58 00:14:15.404 [INFO] [seatd/seat.c:524] Closed client 1 on seat0
2024-03-16 09:59:58 00:14:15.404 [INFO] [seatd/seat.c:192] Removed client 1 from
seat0
2024-03-16 10:00:01 00:14:18.072 [INFO] [seatd/server.c:145] New client
connected (pid: 3919, uid: 999, gid: 982)
2024-03-16 10:00:01 00:14:18.072 [INFO] [seatd/seat.c:170] Added client 1 to seat0
2024-03-16 10:00:01 00:14:18.073 [INFO] [seatd/seat.c:480] Opened client 1 on seat0
2024-03-16 10:00:02 00:14:18.405 [INFO] [seatd/client.c:471] Client disconnected
```

secure

```
Mar 16 09:56:45 localhost greetd: pam_unix(greetd:session): session closed for
user greeter
Mar 16 09:56:46 localhost greetd: pam_unix(greetd:session): session opened for
user greeter(uid=999) by (uid=0)
Mar 16 09:56:46 localhost greetd: gkr-pam: unable to locate daemon control file
Mar 16 09:56:46 localhost greetd: gkr-pam: gnome-keyring-daemon started properly
Mar 16 09:56:48 localhost greetd: pam_unix(greetd:session): session closed for
user greeter
Mar 16 09:56:49 localhost greetd: pam_unix(greetd:session): session opened for
user greeter(uid=999) by (uid=0)
```

And files;

```
ls /run/
avahi-daemon/ blkid/ booted-system containerd/ current-system docker/
greetd/ greetd-1423.sock greetd-208.sock greetd-214.sock greetd-219.sock
greetd-225.sock greetd-228.sock greetd.run pcscd/ seatd.sock setuid-programs/
tlp/ udev/ xtables.lock
```

I'm a bit at the end of my latin, or guix, I guess.

Am I missing something that changed recently?

Thank you.

Cheers,
Franz
F
F
Franz Geffke wrote on 16 Mar 13:08 +0100
741a3fde-65b6-7d23-d00e-1c010bcaa86a@f-a.nz
New information always turns up, the minute after you submit the report. Thanks
to a kind soul, I also found the greeter logs:

```
00:02:17.018 [INFO] [sway/commands.c:261] Handling command 'exec
"/gnu/store/w6ify3cx17hnq8wd6qf6swkwdj37l6wj-wlgreet-0.4.1/bin/wlgreet --config
/gnu/store/73ay0x7ngh7zz34r50hvbin2csgj0dac-wlgreet.toml;
/gnu/store/1kzi74isam7q5z8bsrm8h642hgx8pdq8-sway-1.9/bin/swaymsg exit"'
00:02:17.018 [DEBUG] [sway/commands/exec_always.c:58] Executing
/gnu/store/w6ify3cx17hnq8wd6qf6swkwdj37l6wj-wlgreet-0.4.1/bin/wlgreet --config
/gnu/store/73ay0x7ngh7zz34r50hvbin2csgj0dac-wlgreet.toml;
/gnu/store/1kzi74isam7q5z8bsrm8h642hgx8pdq8-sway-1.9/bin/swaymsg exit
00:02:17.038 [DEBUG] [sway/commands/exec_always.c:111] Child process created
with pid 929
00:02:17.039 [DEBUG] [sway/commands/exec_always.c:113] Recording workspace for
process 929
00:02:17.041 [INFO] [sway/server.c:396] Running compositor on wayland display
'wayland-1'
00:02:17.044 [ERROR] [wlr] [libseat] [libseat/backend/logind.c:83] Ping failed:
org.freedesktop.DBus.Error.NoReply: Method call timed out
00:02:17.047 [ERROR] [wlr] [libseat] [libseat/backend/logind.c:83] Ping failed:
org.freedesktop.DBus.Error.NoReply: Method call timed out
00:02:17.050 [DEBUG] [wlr] [render/swapchain.c:106] Allocating new swapchain buffer
00:02:17.061 [DEBUG] [wlr] [render/allocator/drm_dumb.c:106] Allocated 1280x800
DRM dumb buffer
00:02:17.063 [DEBUG] [wlr] [render/pixman/renderer.c:152] Created pixman buffer
1280x800
00:02:17.390 [DEBUG] [wlr] [types/wlr_compositor.c:692] New wlr_surface 0x72e830
(res 0x6d1730)
00:02:17.392 [DEBUG] [wlr] [types/wlr_layer_shell_v1.c:458] new layer_surface
0x6ab630 (res 0x6d28f0)
00:02:17.393 [DEBUG] [sway/desktop/layer_shell.c:646] new layer surface:
namespace layer 3 anchor 0 size 1x1 margin 0,0,0,0,
thread 'main' panicked at src/app.rs:473:48:
internal error: entered unreachable code
note: run with `RUST_BACKTRACE=1` environment variable to display a backtrace
[wayland-client error] A handler for wl_surface panicked.
00:02:17.425 [DEBUG] [sway/desktop/layer_shell.c:386] Layer surface destroyed ()
00:02:17.446 [DEBUG] [sway/ipc-server.c:197] New client: fd 33
00:02:17.448 [INFO] [sway/commands.c:261] Handling command 'exit'
00:02:17.451 [INFO] [sway/main.c:418] Shutting down sway
```

This is on:
- Libre kernel
- using logind
- Sway 1.9

Apparently this is a known issue:

Reverting Sway to 1.8.1 works.
F
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 69828@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 69828
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch