[PATCH 0/2] Update seahorse and libsecret.

  • Open
  • quality assurance status badge
Details
2 participants
  • Herman Rimm
  • Liliana Marie Prikler
Owner
unassigned
Submitted by
Herman Rimm
Severity
normal
H
H
Herman Rimm wrote on 15 Mar 17:43 +0100
(address . guix-patches@gnu.org)(name . Herman Rimm)(address . herman@rimm.ee)
cover.1710520759.git.herman@rimm.ee
Hello,

I built libsecret twice while running 'stress --cpu 24' and the test-
collection test did not fail. Does it pass for you as well?

Cheers,
Herman

Herman Rimm (2):
gnu: libsecret: Update to 0.21.4.
gnu: seahorse: Update to 43.0.

gnu/packages/gnome.scm | 23 ++++++++++-------------
1 file changed, 10 insertions(+), 13 deletions(-)


base-commit: 93aefca7bab5f5b40164176e3224221d26d708f1
--
2.41.0
L
L
Liliana Marie Prikler wrote on 15 Mar 19:31 +0100
48e05bb3e78b25de3a0cd9c73481ee32773ee19e.camel@gmail.com
Am Freitag, dem 15.03.2024 um 17:43 +0100 schrieb Herman Rimm:
Toggle quote (11 lines)
> Hello,
>
> I built libsecret twice while running 'stress --cpu 24' and the test-
> collection test did not fail. Does it pass for you as well?
>
> Cheers,
> Herman
>
> Herman Rimm (2):
>   gnu: libsecret: Update to 0.21.4.
>   gnu: seahorse: Update to 43.0.
Still missing the rest of the series. Did you send it?
H
H
Herman Rimm wrote on 15 Mar 19:33 +0100
[PATCH 1/2] gnu: libsecret: Update to 0.21.4.
(address . 69813@debbugs.gnu.org)(name . Herman Rimm)(address . herman@rimm.ee)
0bb0da35d0d0bf31f869c865a6fd73d885e7ef8f.1710520759.git.herman@rimm.ee
* gnu/packages/gnome.scm (libsecret): Update.

Change-Id: I8a785f1fa9ff9ddde6dfda9a52abd0405b5ab448
---
gnu/packages/gnome.scm | 10 ++--------
1 file changed, 2 insertions(+), 8 deletions(-)

Toggle diff (37 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 06256066bc..23fe921fb0 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -5172,7 +5172,7 @@ (define-public libsoup
(define-public libsecret
(package
(name "libsecret")
- (version "0.20.5")
+ (version "0.21.4")
(source (origin
(method url-fetch)
(uri (string-append
@@ -5181,7 +5181,7 @@ (define-public libsecret
"libsecret-" version ".tar.xz"))
(sha256
(base32
- "0k9bs47rzb3dwvznb4179d6nw7rbzjdyd4y8hx6vazfd1wscxcrz"))))
+ "081bj59ws08kb261cd1w1mkdkhfbzsjbbkkrm6wllvdyhgbhhg8n"))))
(build-system meson-build-system)
(arguments
(list
@@ -5189,12 +5189,6 @@ (define-public libsecret
#~(list "-Dgtk_doc=false") ;requires gi-docgen
#:phases
#~(modify-phases %standard-phases
- (add-after 'unpack 'disable-problematic-tests
- (lambda _
- (substitute* "libsecret/meson.build"
- ;; The test-collection test fails non-deterministically (see:
- ;; https://gitlab.gnome.org/GNOME/libsecret/-/issues/80).
- ((".*'test-collection',.*") ""))))
(delete 'check)
(add-after 'install 'check
(lambda* (#:key tests? test-options #:allow-other-keys)
--
2.41.0
H
H
Herman Rimm wrote on 15 Mar 19:34 +0100
[PATCH 2/2] gnu: seahorse: Update to 43.0.
(address . 69813@debbugs.gnu.org)(name . Herman Rimm)(address . herman@rimm.ee)
6d2e141983f3f2c3994e072df762e2f2c08c8330.1710520759.git.herman@rimm.ee
* gnu/packages/gnome.scm (seahorse): Update.

Change-Id: I13ce7c9e2cfb7c0b8d575148a502d81ddf30d13d
---
gnu/packages/gnome.scm | 13 ++++++++-----
1 file changed, 8 insertions(+), 5 deletions(-)

Toggle diff (47 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 23fe921fb0..3fcfe23761 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -4420,7 +4420,7 @@ (define-public drawing
(define-public seahorse
(package
(name "seahorse")
- (version "42.0")
+ (version "43.0")
(source
(origin
(method url-fetch)
@@ -4428,7 +4428,7 @@ (define-public seahorse
(version-major version) "/" name "-"
version ".tar.xz"))
(sha256
- (base32 "0c6nafhn4gcjwd1xbs5bjq9785114fc0pbhxbwp7wynyz3msq365"))))
+ (base32 "0bc3xbjzwa4245m6nqzl3v6hzp9hyfbf50iwgwi5hdjglzxin7av"))))
(build-system meson-build-system)
(arguments
'(#:glib-or-gtk? #t
@@ -4437,8 +4437,11 @@ (define-public seahorse
(add-after 'unpack 'skip-gtk-update-icon-cache
;; Don't create 'icon-theme.cache'.
(lambda _
- (substitute* "build-aux/meson_post_install.py"
- (("gtk-update-icon-cache") "true"))))
+ (substitute* "meson.build"
+ (("gtk_update_icon_cache: true")
+ "gtk_update_icon_cache: false")
+ (("update_desktop_database: true")
+ "update_desktop_database: false"))))
(add-before 'check 'pre-check
(lambda _
;; Tests require a writable HOME.
@@ -4454,7 +4457,7 @@ (define-public seahorse
libhandy
libpwquality
libsecret
- libsoup-minimal-2))
+ libsoup-minimal))
(native-inputs
(list gettext-minimal
`(,glib "bin")
--
2.41.0
?