Python fails to build on Alpine linux

  • Open
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Tomas Volf
Owner
unassigned
Submitted by
Tomas Volf
Severity
normal
T
T
Tomas Volf wrote on 15 Mar 16:08 +0100
(address . bug-guix@gnu.org)
ZfRkaV6UfhE8TC92@ws
Attachment: file
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEt4NJs4wUfTYpiGikL7/ufbZ/wakFAmX0ZGkACgkQL7/ufbZ/
wamyhRAAqaoYblpCpa4u+my4/WOwlRUpvr5Jmyk5mtkuQMf9X9tazK7oK6tYxBHl
ddSEMyxdemveBODxn2qT6mE6Bi6KuuzaENkgerZK2LupPzZIMa8OHw41r4yFtcV6
m1b/sGtc4F1QL7DLWcDzjNvUnaYDJhUt36ncX9CncQnyxmO1A1gvR5NgxfyAz/Wk
ZaTIb46I1O0ra9SyV7S5cAAIMi+S0KUQrTDLUoel5CjDDBQAJwXDu4HwPwS6sYju
KgTfqbtPoHrC+oNlLk4JcSWDb1wGPCfaqNxq/0K/X7ZNli0/EigVYIZNOk5JuUX9
phZqaneECJxVebvInfvRV+TyhlV5aSX4viuO1unp2s7abMq2tw+D0GkM1HfCh4d5
/Rnz83jiG2BpELEHYtYUPXlFms5IWkf7nytv15rtEdWSiwz2aOIIZoV3FPP5gxqN
kLWtUOx3OYG0Jl7dPvSm4QQCokTuBiNolZzVAWsvhVmgC1ylN+8ZygviheyTVCdi
eH5iR9VYakDG5ImIfbarShDSrurLLsw9EYZ5clzMjrSzGCn+qZWzAEZLrRJz2chr
Q02vKf3t8tuurmblSH0aCeFKSN2S/OIYKf9mFrJ1otpNJFlkJrkfVBAr3Ei5G/ZT
u2afJlBX7GYlEav6XIvA4l4ab9QBdGigB1+g5rJrN1EXz+ntnt0=
=1uN+
-----END PGP SIGNATURE-----


L
L
Ludovic Courtès wrote on 15 Mar 22:38 +0100
(name . Tomas Volf)(address . ~@wolfsden.cz)(address . 69812@debbugs.gnu.org)
87frwrfa62.fsf@gnu.org
Hi!

Tomas Volf <~@wolfsden.cz> skribis:

Toggle quote (12 lines)
> 0:02:13 load avg: 9.09 Re-running test_fcntl in verbose mode (matching: test_fcntl_64_bit)
> struct.pack: b'\x01\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00'
> test_fcntl_64_bit (test.test_fcntl.TestFcntl) ... ERROR
>
> ======================================================================
> ERROR: test_fcntl_64_bit (test.test_fcntl.TestFcntl)
> ----------------------------------------------------------------------
> Traceback (most recent call last):
> File "/tmp/guix-build-python-3.10.7.drv-0/Python-3.10.7/Lib/test/test_fcntl.py", line 140, in test_fcntl_64_bit
> fcntl.fcntl(fd, cmd, flags)
> OSError: [Errno 22] Invalid argument

This test looks like this:

Toggle snippet (16 lines)
def test_fcntl_64_bit(self):
# Issue #1309352: fcntl shouldn't fail when the third arg fits in a
# C 'long' but not in a C 'int'.
try:
cmd = fcntl.F_NOTIFY
# This flag is larger than 2**31 in 64-bit builds
flags = fcntl.DN_MULTISHOT
except AttributeError:
self.skipTest("F_NOTIFY or DN_MULTISHOT unavailable")
fd = os.open(os.path.dirname(os.path.abspath(TESTFN)), os.O_RDONLY)
try:
fcntl.fcntl(fd, cmd, flags)
finally:
os.close(fd)

I suspect this is due to:

# CONFIG_DNOTIFY is not set

On Guix System, I have:

Toggle snippet (6 lines)
$ zgrep CONFIG_DNOTIFY /proc/config.gz
CONFIG_DNOTIFY=y
$ uname -r
6.6.18-gnu

:-/

Ludo’.
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 69812@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 69812
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch