[PATCH] gnu: Add vim-conjure plugin.

  • Open
  • quality assurance status badge
Details
One participant
  • Herman Rimm
Owner
unassigned
Submitted by
Herman Rimm
Severity
normal
H
H
Herman Rimm wrote on 14 Mar 20:42 +0100
(address . guix-patches@gnu.org)(name . Herman Rimm)(address . herman@rimm.ee)
d41df60e3f06d71db47285eeba760a897f26174d.1710445355.git.herman@rimm.ee
* gnu/packages/vim.scm (vim-conjure): Add variable.
* doc/contributing.texi (Vim and NeoVim): Add example.

Change-Id: I939b95f1c4ac1e9c2c174b16a75143334b2e56b0
---
doc/contributing.texi | 5 ++++-
gnu/packages/vim.scm | 23 +++++++++++++++++++++++
2 files changed, 27 insertions(+), 1 deletion(-)

Toggle diff (62 lines)
diff --git a/doc/contributing.texi b/doc/contributing.texi
index a7d91724fb..afccfc6fbf 100644
--- a/doc/contributing.texi
+++ b/doc/contributing.texi
@@ -543,8 +543,11 @@ Vim and NeoVim
In NeoVim you can even make a similar setup to Geiser using
@url{https://conjure.fun/, Conjure} that lets you connect to a running Guile
-process and inject your code there live (sadly it's not packaged in Guix yet).
+process and inject your code there live:
+@example
+guix install vim-conjure
+@end example
@node Packaging Guidelines
@section Packaging Guidelines
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index 6b5eaabf8e..f6b56b7ccb 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -16,6 +16,7 @@
;;; Copyright © 2023 Charles Jackson <charles.b.jackson@protonmail.com>
;;; Copyright © 2023 Foundation Devices, Inc. <hello@foundationdevices.com>
;;; Copyright © 2023, 2024 Nguy?n Gia Phong <mcsinyx@disroot.org>
+;;; Copyright © 2024 Herman Rimm <herman@rimm.ee>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -291,6 +292,28 @@ (define-public vim-full
It includes a graphical interface, @command{gvim}, and support for plugins
written in the Python 3, Perl, Ruby, Tcl, and Lua programming languages.")))
+(define-public vim-conjure
+ (package
+ (name "vim-conjure")
+ (version "4.50.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/Olical/conjure/"
+ "archive/refs/tags/v" version ".tar.gz"))
+ (sha256
+ (base32
+ "1njyyvzy5fc5srvldfg33nplp5akwr972x995yxlr1jqk6sskd0h"))))
+ (build-system vim-build-system)
+ (synopsis "Interactive evaluation for Neovim")
+ (description
+ "Conjure is an interactive environment for evaluating code within
+your running program. The core features of Conjure are language agnostic,
+with each language client providing their own extra tools. You can find a
+@uref{https://github.com/Olical/conjure/wiki/Client-features, comparison
+table for all clients and supported features} in the wiki.")
+ (home-page "https://conjure.fun/")
+ (license license:unlicense)))
+
(define-public vim-neocomplete
(package
(name "vim-neocomplete")

base-commit: dc4842797bfdc5f9f3f5f725bf189c2b68bd6b5a
--
2.41.0
?