[PATCH] reconfigure: Skip starting new shepherd services with auto-start? #f

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Richard Sent
Owner
unassigned
Submitted by
Richard Sent
Severity
normal
R
R
Richard Sent wrote on 14 Mar 20:40 +0100
(address . guix-patches@gnu.org)(name . Richard Sent)(address . richard@freakingpenguin.com)
7370708f69a563b3f1a264c97b83d4e0e1707461.1710445211.git.richard@freakingpenguin.com

* guix/scripts/system/reconfigure.scm (upgrade-shepherd-services): Only add
new shepherd services with auto-start? #t to to-start list.

Change-Id: I268b921336fb1195ed76746eb6178889dbc258b4
---
guix/scripts/system/reconfigure.scm | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)

Toggle diff (18 lines)
diff --git a/guix/scripts/system/reconfigure.scm b/guix/scripts/system/reconfigure.scm
index ff6242ffb4..9418060158 100644
--- a/guix/scripts/system/reconfigure.scm
+++ b/guix/scripts/system/reconfigure.scm
@@ -194,7 +194,8 @@ (define* (upgrade-shepherd-services eval os)
(filter live-service-running live-services)))
(to-start (lset-difference eqv?
(map shepherd-service-canonical-name
- target-services)
+ (filter shepherd-service-auto-start?
+ target-services))
running))
(service-files (map shepherd-service-file target-services)))
(eval #~(parameterize ((current-warning-port (%make-void-port "w")))

base-commit: 7319b4d5286d31a9c6a889e81af72308efdaab41
--
2.41.0
L
L
Ludovic Courtès wrote on 21 Mar 14:56 +0100
(name . Richard Sent)(address . richard@freakingpenguin.com)
871q83wuwo.fsf@gnu.org
Richard Sent <richard@freakingpenguin.com> skribis:

Toggle quote (7 lines)
>
> * guix/scripts/system/reconfigure.scm (upgrade-shepherd-services): Only add
> new shepherd services with auto-start? #t to to-start list.
>
> Change-Id: I268b921336fb1195ed76746eb6178889dbc258b4

Applied, thanks!

Ludo'.
Closed
?