[PATCH] gnu: cl-croatoan: Update to 282145ff.

  • Done
  • quality assurance status badge
Details
2 participants
  • cage
  • Guillaume Le Vaillant
Owner
unassigned
Submitted by
cage
Severity
normal

Debbugs page

cage wrote 1 years ago
(address . guix-patches@gnu.org)
15ad2bebcdcae98d143275e47dd0bc62100ba00b.1710272464.git.cage-dev@twistfold.it
Change-Id: I8a7e93e9f0dabfa42e35845e610dd5bd2b63cec9
---
gnu/packages/lisp-xyz.scm | 62 ++++++++++++++++++++-------------------
1 file changed, 32 insertions(+), 30 deletions(-)

Toggle diff (81 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 779fd2628d..c0680d2aee 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -19070,37 +19070,39 @@ (define-public cl-tooter
(sbcl-package->cl-source-package sbcl-tooter))
(define-public sbcl-croatoan
- (package
- (name "sbcl-croatoan")
- (version "0.2")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/McParen/croatoan")
- (commit (string-append "v" version))))
- (file-name (git-file-name "cl-croatoan" version))
- (sha256
- (base32 "0x2rlckyn8kn5mqy0fib8piggz694g3naarz2dvha1hsy4jhb1wg"))))
- (build-system asdf-build-system/sbcl)
- (arguments
- '(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'fix-paths
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* "ncurses/ncurses.lisp"
- (("libncursesw.so")
- (search-input-file inputs "/lib/libncursesw.so"))))))))
- (inputs
- (list ncurses
- sbcl-cffi
- sbcl-trivial-gray-streams
- sbcl-bordeaux-threads))
- (synopsis "Common Lisp bindings for the ncurses terminal library")
- (description "Croatoan provides high-level Common Lisp CLOS bindings for
+ (let ((commit "282145ff9e9005fddc4241bc6827b3ab09c5bd25")
+ (revision "1"))
+ (package
+ (name "sbcl-croatoan")
+ (version (git-version "2.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/McParen/croatoan")
+ (commit commit)))
+ (file-name (git-file-name "cl-croatoan" version))
+ (sha256
+ (base32 "021h2f2yj4j9gynr3k7qi36x94jm5b95p3vaddbaih96wyzgbmq5"))))
+ (build-system asdf-build-system/sbcl)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-paths
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "ncurses/ncurses.lisp"
+ (("libncursesw.so")
+ (search-input-file inputs "/lib/libncursesw.so"))))))))
+ (inputs
+ (list ncurses
+ sbcl-cffi
+ sbcl-trivial-gray-streams
+ sbcl-bordeaux-threads))
+ (synopsis "Common Lisp bindings for the ncurses terminal library")
+ (description "Croatoan provides high-level Common Lisp CLOS bindings for
the ncurses terminal library.")
- (home-page "https://github.com/McParen/croatoan")
- (license license:expat)))
+ (home-page "https://github.com/McParen/croatoan")
+ (license license:expat))))
(define-public ecl-croatoan
(sbcl-package->ecl-package sbcl-croatoan))

base-commit: de24aaf13b17d6c019f3f240fd0eb0e1b8654970
prerequisite-patch-id: aa0b913d42bee51002e7243019d5529984321e91
prerequisite-patch-id: 71de41827792abd670416c70b9b0fa59064209c9
prerequisite-patch-id: f0e916158a3c6a40af198f59f41b821c54b03615
--
2.41.0
Guillaume Le Vaillant wrote 12 months ago
(name . cage)(address . cage-dev@twistfold.it)(address . 69760-done@debbugs.gnu.org)
875xxpdsrv.fsf@kitej
Patch applied as 6e4b1b450cf3b8ab431b5923d411bb3de85ecada.
Thanks.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCZfLOFA8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j87HwEAiikeM6B2IBtxEM6NVH1jz43n3UAY2KtjitQq
obU/BNoBAJlBAh04lhVM9XRq5lIAKKVXbH5xttxGs/hIRVx5UUmM
=htQd
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 69760@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 69760
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help