[PATCH gnome-team 0/1] Fix libgda for gnome-team

  • Done
  • quality assurance status badge
Details
3 participants
  • Liliana Marie Prikler
  • Christopher Baines
  • Vivien Kraus
Owner
unassigned
Submitted by
Vivien Kraus
Severity
normal

Debbugs page

Vivien Kraus wrote 12 months ago
(address . guix-patches@gnu.org)
cover.1710263604.git.vivien@planete-kraus.eu
Dear Guix,

libgda fails to build:


However, some time ago, the maintainers discovered that this specific test was
a pain to maintain, so they disabled it:


I just imported the patch as-is.

Best regards,

Vivien

Vivien Kraus (1):
gnu: libgda: Disable failing tests.

gnu/local.mk | 1 +
gnu/packages/gnome.scm | 1 +
.../libgda-disable-data-proxy-test.patch | 59 +++++++++++++++++++
3 files changed, 61 insertions(+)
create mode 100644 gnu/packages/patches/libgda-disable-data-proxy-test.patch


base-commit: 2ee54513196bad8e663e78ac695b6ffa0da49051
--
2.41.0
Vivien Kraus wrote 12 months ago
[PATCH gnome-team 1/1] gnu: libgda: Disable failing tests.
(address . 69756@debbugs.gnu.org)
5932f75d4ad0e186371f49ecb0fe4606e9d441fe.1710263604.git.vivien@planete-kraus.eu
* gnu/packages/patches/libgda-disable-data-proxy-test.patch: New file.
* gnu/local.mk (dist_patch_DATA): Register it here.
* gnu/packages/gnome.scm (libgda): Use it here.

Change-Id: I0a86fb75b1ad048eca99408750b26f4b8ff448c1
---
gnu/local.mk | 1 +
gnu/packages/gnome.scm | 1 +
.../libgda-disable-data-proxy-test.patch | 59 +++++++++++++++++++
3 files changed, 61 insertions(+)
create mode 100644 gnu/packages/patches/libgda-disable-data-proxy-test.patch

Toggle diff (91 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index 5546e33465..d85c11cba7 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1578,6 +1578,7 @@ dist_patch_DATA = \
%D%/packages/patches/libcyaml-libyaml-compat.patch \
%D%/packages/patches/libexpected-use-provided-catch2.patch \
%D%/packages/patches/libgda-cve-2021-39359.patch \
+ %D%/packages/patches/libgda-disable-data-proxy-test.patch \
%D%/packages/patches/libgda-fix-build.patch \
%D%/packages/patches/libgda-fix-missing-initialization.patch \
%D%/packages/patches/libgda-skip-postgresql-tests.patch \
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 97e7f25532..7e7d77a3a2 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -13505,6 +13505,7 @@ (define-public libgda
(sha256
(base32 "0w564z7krgjk19r39mi5qn4kggpdg9ggbyn9pb4aavb61r14npwr"))
(patches (search-patches "libgda-cve-2021-39359.patch"
+ "libgda-disable-data-proxy-test.patch"
"libgda-fix-build.patch"
"libgda-fix-missing-initialization.patch"
"libgda-skip-postgresql-tests.patch"))))
diff --git a/gnu/packages/patches/libgda-disable-data-proxy-test.patch b/gnu/packages/patches/libgda-disable-data-proxy-test.patch
new file mode 100644
index 0000000000..b93f9d3f9b
--- /dev/null
+++ b/gnu/packages/patches/libgda-disable-data-proxy-test.patch
@@ -0,0 +1,59 @@
+From c0bb1ed662011207ee13d5a20a70f9b55166aa13 Mon Sep 17 00:00:00 2001
+From: Daniel Espinosa <esodan@gmail.com>
+Date: Wed, 1 Nov 2023 15:00:40 -0500
+Subject: [PATCH] GdaDataProxy: is no thread save so disabling its test
+
+Has been difficutl to reproduce the problem when this test
+is running in Ci, so disabling until we can re-implement it
+is the better choice
+---
+ libgda/gda-data-proxy.h | 4 +++-
+ tests/data-models/meson.build | 17 +++++++++--------
+ 2 files changed, 12 insertions(+), 9 deletions(-)
+
+diff --git a/libgda/gda-data-proxy.h b/libgda/gda-data-proxy.h
+index 4c31ab69b..ba0fa72b3 100644
+--- a/libgda/gda-data-proxy.h
++++ b/libgda/gda-data-proxy.h
+@@ -77,7 +77,9 @@ struct _GdaDataProxyClass
+ * @stability: Stable
+ * @see_also: #GdaDataModel
+ *
+- * This object stores modifications to be made to a #GdaDataModel object which is proxied until the modifications are actually
++ * This object, is no thread save, so use with care.
++ *
++ * This object stores modifications to be made to a #GdaDataModel object which is proxied until the modifications are actually
+ * written to the #GdaDataModel, it can also filter the proxied data model to show only a subset (a defined number of continuous
+ * rows or by a filter to apply).
+ *
+diff --git a/tests/data-models/meson.build b/tests/data-models/meson.build
+index a8c6a29d8..e0ec8692a 100644
+--- a/tests/data-models/meson.build
++++ b/tests/data-models/meson.build
+@@ -61,14 +61,15 @@ tchkdp = executable('check_data_proxy',
+ ],
+ install: false
+ )
+-test('DataProxy', tchkdp,
+- timeout: 100,
+- workdir: meson.current_build_dir(),
+- env: [
+- 'GDA_TOP_SRC_DIR='+gda_top_src,
+- 'GDA_TOP_BUILD_DIR='+gda_top_build
+- ]
+- )
++# This test is no thread save so disabling
++#test('DataProxy', tchkdp,
++# timeout: 100,
++# workdir: meson.current_build_dir(),
++# env: [
++# 'GDA_TOP_SRC_DIR='+gda_top_src,
++# 'GDA_TOP_BUILD_DIR='+gda_top_build
++# ]
++# )
+
+ tchkmc = executable('check_model_copy',
+ ['check_model_copy.c'] + common_sources,
+--
+GitLab
+
--
2.41.0
Liliana Marie Prikler wrote 12 months ago
ed87dd77dae1bb203d5c681dce13067a1aca97c5.camel@gmail.com
Am Dienstag, dem 12.03.2024 um 18:12 +0100 schrieb Vivien Kraus:
Toggle quote (62 lines)
> * gnu/packages/patches/libgda-disable-data-proxy-test.patch: New
> file.
> * gnu/local.mk (dist_patch_DATA): Register it here.
> * gnu/packages/gnome.scm (libgda): Use it here.
>
> Change-Id: I0a86fb75b1ad048eca99408750b26f4b8ff448c1
> ---
>  gnu/local.mk                                  |  1 +
>  gnu/packages/gnome.scm                        |  1 +
>  .../libgda-disable-data-proxy-test.patch      | 59
> +++++++++++++++++++
>  3 files changed, 61 insertions(+)
>  create mode 100644 gnu/packages/patches/libgda-disable-data-proxy-
> test.patch
>
> diff --git a/gnu/local.mk b/gnu/local.mk
> index 5546e33465..d85c11cba7 100644
> --- a/gnu/local.mk
> +++ b/gnu/local.mk
> @@ -1578,6 +1578,7 @@ dist_patch_DATA
> =                                         \
>    %D%/packages/patches/libcyaml-libyaml-compat.patch           \
>    %D%/packages/patches/libexpected-use-provided-catch2.patch   \
>    %D%/packages/patches/libgda-cve-2021-39359.patch             \
> +  %D%/packages/patches/libgda-disable-data-proxy-test.patch     \
>    %D%/packages/patches/libgda-fix-build.patch                  \
>    %D%/packages/patches/libgda-fix-missing-initialization.patch \
>    %D%/packages/patches/libgda-skip-postgresql-tests.patch      \
> diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
> index 97e7f25532..7e7d77a3a2 100644
> --- a/gnu/packages/gnome.scm
> +++ b/gnu/packages/gnome.scm
> @@ -13505,6 +13505,7 @@ (define-public libgda
>         (sha256
>          (base32
> "0w564z7krgjk19r39mi5qn4kggpdg9ggbyn9pb4aavb61r14npwr"))
>         (patches (search-patches "libgda-cve-2021-39359.patch"
> +                                "libgda-disable-data-proxy-
> test.patch"
>                                  "libgda-fix-build.patch"
>                                  "libgda-fix-missing-
> initialization.patch"
>                                  "libgda-skip-postgresql-
> tests.patch"))))
> diff --git a/gnu/packages/patches/libgda-disable-data-proxy-
> test.patch b/gnu/packages/patches/libgda-disable-data-proxy-
> test.patch
> new file mode 100644
> index 0000000000..b93f9d3f9b
> --- /dev/null
> +++ b/gnu/packages/patches/libgda-disable-data-proxy-test.patch
> @@ -0,0 +1,59 @@
> +From c0bb1ed662011207ee13d5a20a70f9b55166aa13 Mon Sep 17 00:00:00
> 2001
> +From: Daniel Espinosa <esodan@gmail.com>
> +Date: Wed, 1 Nov 2023 15:00:40 -0500
> +Subject: [PATCH] GdaDataProxy: is no thread save so disabling its
> test
> +
> +Has been difficutl to reproduce the problem when this test
> +is running in Ci, so disabling until we can re-implement it
> +is the better choice
I assume the spelling is [sic]?

Toggle quote (54 lines)
> +---
> + libgda/gda-data-proxy.h       |  4 +++-
> + tests/data-models/meson.build | 17 +++++++++--------
> + 2 files changed, 12 insertions(+), 9 deletions(-)
> +
> +diff --git a/libgda/gda-data-proxy.h b/libgda/gda-data-proxy.h
> +index 4c31ab69b..ba0fa72b3 100644
> +--- a/libgda/gda-data-proxy.h
> ++++ b/libgda/gda-data-proxy.h
> +@@ -77,7 +77,9 @@ struct _GdaDataProxyClass
> +  * @stability: Stable
> +  * @see_also: #GdaDataModel
> +  *
> +- * This object stores modifications to be made to a #GdaDataModel
> object which is proxied until the modifications are actually
> ++ *  This object, is no thread save, so use with care.
> ++ *
> ++ *  This object stores modifications to be made to a #GdaDataModel
> object which is proxied until the modifications are actually
> +  *  written to the #GdaDataModel, it can also filter the proxied
> data model to show only a subset (a defined number of continuous
> +  *  rows or by a filter to apply).
> +  *
> +diff --git a/tests/data-models/meson.build b/tests/data-
> models/meson.build
> +index a8c6a29d8..e0ec8692a 100644
> +--- a/tests/data-models/meson.build
> ++++ b/tests/data-models/meson.build
> +@@ -61,14 +61,15 @@ tchkdp = executable('check_data_proxy',
> +               ],
> +       install: false
> +       )
> +-test('DataProxy', tchkdp,
> +-      timeout: 100,
> +-      workdir: meson.current_build_dir(),
> +-      env: [
> +-              'GDA_TOP_SRC_DIR='+gda_top_src,
> +-              'GDA_TOP_BUILD_DIR='+gda_top_build
> +-              ]
> +-      )
> ++# This test is no thread save so disabling
> ++#test('DataProxy', tchkdp,
> ++#     timeout: 100,
> ++#     workdir: meson.current_build_dir(),
> ++#     env: [
> ++#             'GDA_TOP_SRC_DIR='+gda_top_src,
> ++#             'GDA_TOP_BUILD_DIR='+gda_top_build
> ++#             ]
> ++#     )
> +
> + tchkmc = executable('check_model_copy',
> +       ['check_model_copy.c'] + common_sources,
> +--
> +GitLab
Otherwise LGTM
Vivien Kraus wrote 12 months ago
d35996fbccdaa39075774727489939847ab73223.camel@planete-kraus.eu
Le mardi 12 mars 2024 à 18:59 +0100, Liliana Marie Prikler a écrit :
Toggle quote (4 lines)
> > +Has been difficutl to reproduce the problem when this test
> > +is running in Ci, so disabling until we can re-implement it
> > +is the better choice
> I assume the spelling is [sic]?
Correct, I would consider it rude to reword a commit that was accepted
by another project. Although it’s the first time I’m facing this
situation, so maybe the etiquette says something different.
Liliana Marie Prikler wrote 12 months ago
ff03f9f24464ed908b88e1d7267c7d6eaaab3b32.camel@gmail.com
Am Dienstag, dem 12.03.2024 um 19:03 +0100 schrieb Vivien Kraus:
Toggle quote (8 lines)
> Le mardi 12 mars 2024 à 18:59 +0100, Liliana Marie Prikler a écrit :
> > > +Has been difficutl to reproduce the problem when this test
> > > +is running in Ci, so disabling until we can re-implement it
> > > +is the better choice
> > I assume the spelling is [sic]?
> Correct, I would consider it rude to reword a commit that was
> accepted by another project. Although it’s the first time I’m facing
> this situation, so maybe the etiquette says something different.
Well, we indeed prefer upstreamed patches, but some upstreams also add
their fixes on top of such patches, which we'd have to incorporate as
well in this case. In the case of libgda, it does however seem that
this is the newest modification to those files, so my worries were
somewhat unfounded.

Cheers
Christopher Baines wrote 12 months ago
Re: [bug#69756] [PATCH gnome-team 1/1] gnu: libgda: Disable failing tests.
(name . Liliana Marie Prikler)(address . liliana.prikler@gmail.com)
87bk7esaot.fsf@cbaines.net
Liliana Marie Prikler <liliana.prikler@gmail.com> writes:

Toggle quote (17 lines)
> Am Dienstag, dem 12.03.2024 um 19:03 +0100 schrieb Vivien Kraus:
>> Le mardi 12 mars 2024 à 18:59 +0100, Liliana Marie Prikler a écrit :
>> > > +Has been difficutl to reproduce the problem when this test
>> > > +is running in Ci, so disabling until we can re-implement it
>> > > +is the better choice
>> > I assume the spelling is [sic]?
>>
>> Correct, I would consider it rude to reword a commit that was
>> accepted by another project. Although it’s the first time I’m facing
>> this situation, so maybe the etiquette says something different.
>
> Well, we indeed prefer upstreamed patches, but some upstreams also add
> their fixes on top of such patches, which we'd have to incorporate as
> well in this case. In the case of libgda, it does however seem that
> this is the newest modification to those files, so my worries were
> somewhat unfounded.

Thanks both, I've pushed this to gnome-team as
64785a7941b5544f80c7f9cd286452fba296596a.

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmX1e+JfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XfRQBAAgi83ti54HFT4FHVJw+jYykHGNGvYYLHj
537q1dR9to4GSAyFC540Ry3amUwBrS7zs9Tn9+zQeZ/SqNftXqHdbihd1d4IDzOW
PVF5RVSazg36ocWd8HVp6EIhZgTPqle1khgaNW+W791cLLbA/yUvlLmqNpKUT5hW
mRXbzWXDhbEuPMhpoqOJwQRgLDo7vjFA0Fx2F7qp5LC7+HHkfUagUg/989/DG8BE
pMi2sRErRNxxh2Nr+7yAJ4cfqp0api7mNIWqOt8hk4uSHChgjQXbPEEx11V2p80v
/BC4YD7K+HDx2gjBAiWQVa2YBPK5YYty4+769II4yjm7jmPFepBxzzwxDblgZLKO
P+p7o24VXkKGMShxZcNMFbkogjio2C7A71NdWl13G590dTq3UxC8urSu6ad3uFMM
IM47dR07FDX82CBhbw6doNLF4yKqn69Bk+bTzNIjspIhfU5bFg+Q1UMdvEZRCwLH
Gjt/AUCKa6QQ1SZeFeAsVtEdzMNPB5RKDo+bImS9dIhlhXBdXXhArKMTvDQqvrOL
4t7MeqnwC9/wxWB5P8+kAclLEJhqR3oQwhjNBFtBClR3uFZfNcRHcWcWXH2it9oQ
mnFTnpbrb+iU/qxLMsV99VKxf3m96gOQXchDEYJOQXCQcxfwkMy+PYA1QeW0n3fw
0Ou6ADSGe7A=
=ClHx
-----END PGP SIGNATURE-----

?
Your comment

This issue is archived.

To comment on this conversation send an email to 69756@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 69756
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help