Git checkout fail after daemon checks permissions

  • Open
  • quality assurance status badge
Details
2 participants
  • Jean-Pierre De Jesus Diaz
  • Richard Sent
Owner
unassigned
Submitted by
Jean-Pierre De Jesus Diaz
Severity
normal
J
J
Jean-Pierre De Jesus Diaz wrote on 12 Mar 14:07 +0100
(address . bug-guix@gnu.org)
CAG1gdUr6sNny0oh5_SzsNNK85M6pTitxnsWm1qTAFO54JOKDQg@mail.gmail.com
Hello,

I've done a guix system reconfigure recently and after that I was
unable to build
packages that use Git to fetch the source, failing with this error:

```
Initialized empty Git repository in
/gnu/store/bm54hnvq0f8qbm2a4yvljrgl4nf2yain-rocblas-5.6.0-checkout/.git/
* tag rocm-5.6.0 -> FETCH_HEAD
Note: switching to 'FETCH_HEAD'.

You are in 'detached HEAD' state. You can look around, make experimental
changes and commit them, and you can discard any commits you make in this
state without impacting any branches by switching back to a branch.

If you want to create a new branch to retain commits you create, you may
do so (now or later) by using -c with the switch command. Example:

git switch -c <new-branch-name>

Or undo this operation with:

git switch -

Turn off this advice by setting config variable advice.detachedHead to false

HEAD is now at 4b0751e Merge pull request #1325 from
yoichiyoshida/fp16altrnz-5.6-hotfix2
suspicious ownership or permission on
`/gnu/store/bm54hnvq0f8qbm2a4yvljrgl4nf2yain-rocblas-5.6.0-checkout';
rejecting this build output
build of /gnu/store/xbvrh3nav0gcgvdxbv7k9rsqgw4d14c3-rocblas-5.6.0-checkout.drv
failed
View build log at
'/var/log/guix/drvs/xb/vrh3nav0gcgvdxbv7k9rsqgw4d14c3-rocblas-5.6.0-checkout.drv.gz'.
cannot build derivation
`/gnu/store/jr9vjappfafyjvwrx85g4jm28cim1b4k-rocblas-5.6.0.drv': 1
dependencies couldn't be built
guix build: error: build of
`/gnu/store/jr9vjappfafyjvwrx85g4jm28cim1b4k-rocblas-5.6.0.drv' failed
```

The output of guix describe for the system:

```
$ sudo -i guix describe
Password:
Generation 7 Mar 12 2024 12:13:17 (current)
guix a52701a
branch: master
commit: a52701a4d3c90327f6b88267173a5a98ef3db8e6
```

The permissions of the file in the store are:

```
$ ls -ld /gnu/store/bm54hnvq0f8qbm2a4yvljrgl4nf2yain-rocblas-5.6.0-checkout
drwxr-xr-x 11 root root 4096 Mar 12 14:03
/gnu/store/bm54hnvq0f8qbm2a4yvljrgl4nf2yain-rocblas-5.6.0-checkout/
```

I've noticed it also leaks the current date and time in the store.

Thanks,

Jean-Pierre De Jesus DIAZ
R
R
Richard Sent wrote on 20 Mar 18:53 +0100
(name . Jean-Pierre De Jesus Diaz)(address . jean@foundation.xyz)(address . 69753@debbugs.gnu.org)
878r2cdc2h.fsf@freakingpenguin.com
I've encountered this issue myself, so it's not an isolated incident. I
observed that it only occured when building packages from a custom
channel (or perhaps with -L, I don't recall for sure.)

The issue seemed to disappear after a while.

--
Take it easy,
Richard Sent
Making my computer weirder one commit at a time.
?