[PATCH] gnu: Add wget-next

  • Open
  • quality assurance status badge
Details
4 participants
  • Aaron Covrig
  • ashish.is
  • Andy Tai
  • Dale Mellor
Owner
unassigned
Submitted by
Andy Tai
Severity
normal
A
A
Andy Tai wrote on 11 Mar 05:56 +0100
(address . guix-patches@gnu.org)(name . Andy Tai)(address . atai@atai.org)
afd2ad899af2fc840dc627f49e784561ceb7a7b1.1710132987.git.atai@atai.org
* gnu/packages/wget.scm (wget-next): New variable

Change-Id: Ied567558ab0d794f567421e9c1c71ba58969cb33
---
gnu/packages/wget.scm | 12 ++++++++++++
1 file changed, 12 insertions(+)

Toggle diff (27 lines)
diff --git a/gnu/packages/wget.scm b/gnu/packages/wget.scm
index 6c6f7d3382..002873523b 100644
--- a/gnu/packages/wget.scm
+++ b/gnu/packages/wget.scm
@@ -75,6 +75,18 @@ (define-public wget
in downloaded documents to relative links.")
(license license:gpl3+))) ; some files are under GPLv2+
+
+(define-public wget-next
+ (package
+ (inherit wget)
+ (version "1.24.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/wget/wget-" version ".tar.lz"))
+ (sha256
+ (base32 "1vin1cwha883fjffv4rjy5rg6qw9b6nczzmgjkglzyaf3qahg8ap"))))))
+
(define-public wgetpaste
(package
(name "wgetpaste")

base-commit: b0b988c41c9e0e591274495a1b2d6f27fcdae15a
--
2.34.1
D
D
Dale Mellor wrote on 7 Jun 21:57 +0200
Why 'next'?
(address . 69721@debbugs.gnu.org)
a2b2048472ae49c20462310cbad33e0f65e849ab.camel@rdmp.org
Hello Andy,

Why are you adding a 'next' package instead of just bumping the version number?

Thanks, Dale
A
A
ashish.is wrote on 13 Nov 11:16 +0100
[PATCH] gnu: wget: Update to 1.25.0. [security fixes]
(address . 69721@debbugs.gnu.org)(name . Ashish SHUKLA)(address . ashish.is@lostca.se)
c8ed320437e9d855d9d1e5e46d7d0c01e0d874a2.1731492989.git.ashish.is@lostca.se
From: Ashish SHUKLA <ashish.is@lostca.se>

This fixes CVE-2024-10524.

* gnu/packages/wget.scm (wget-next): Update to 1.25.0.

Change-Id: I495bde3fbcb28629f9ae45160126d3ccf0d8f722
---
gnu/packages/wget.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/wget.scm b/gnu/packages/wget.scm
index 96fe2c7c02..30f421176e 100644
--- a/gnu/packages/wget.scm
+++ b/gnu/packages/wget.scm
@@ -78,13 +78,13 @@ (define-public wget
(define-public wget-next
(package
(inherit wget)
- (version "1.24.5")
+ (version "1.25.0")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://gnu/wget/wget-" version ".tar.lz"))
(sha256
- (base32 "1vin1cwha883fjffv4rjy5rg6qw9b6nczzmgjkglzyaf3qahg8ap"))))))
+ (base32 "07waw3s51zmjqzqq717xyyd353qc1ajcd38lh7y8i85hav3mq8hr"))))))
(define-public wgetpaste
(package

base-commit: 4edd1de72040687cfa4c43a50c684c90eee225b2
--
2.47.0
A
A
Aaron Covrig wrote 4 hours ago
[PATCH v2] gnu: wget-next: Graft wget to v1.25.0, fixing CVE-2024-10524
(address . 69721@debbugs.gnu.org)
20241123204232.137113-1-aaron.covrig.us@ieee.org
* gnu/packages/wget.scm (wget-next): new variable, graft wget
---
Hello all,

I have combined the most recent patch commit as it was done as a diff
against the original commit. Further more, I believe the reason the
update was done as `wget-next` is to allow it to be grafted in since
wget is a dependency for so many packages; to this end I have also updated
the commit to apply as a graft (for reviewers, this is my first time
submitting a patch using a graft, so I may have missed something).

gnu/packages/wget.scm | 13 +++++++++++++
1 file changed, 13 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/wget.scm b/gnu/packages/wget.scm
index 4bd4d3c87a..dc48fb1eb7 100644
--- a/gnu/packages/wget.scm
+++ b/gnu/packages/wget.scm
@@ -47,6 +47,7 @@ (define-public wget
(package
(name "wget")
(version "1.21.4")
+ (replacement wget-next)
(source
(origin
(method url-fetch)
@@ -74,6 +75,18 @@ (define-public wget
in downloaded documents to relative links.")
(license license:gpl3+))) ; some files are under GPLv2+
+
+(define-public wget-next
+ (package
+ (inherit wget)
+ (version "1.25.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/wget/wget-" version ".tar.lz"))
+ (sha256
+ (base32 "07waw3s51zmjqzqq717xyyd353qc1ajcd38lh7y8i85hav3mq8hr"))))))
+
(define-public wgetpaste
(package
(name "wgetpaste")

base-commit: 36f516bfcdf64185f5d70c21a908283be22a34fd
--
2.46.0
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 69721@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 69721
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch