[PATCH] gnu: Add wget-next

  • Open
  • quality assurance status badge
Details
2 participants
  • Andy Tai
  • Dale Mellor
Owner
unassigned
Submitted by
Andy Tai
Severity
normal
A
A
Andy Tai wrote on 11 Mar 05:56 +0100
(address . guix-patches@gnu.org)(name . Andy Tai)(address . atai@atai.org)
afd2ad899af2fc840dc627f49e784561ceb7a7b1.1710132987.git.atai@atai.org
* gnu/packages/wget.scm (wget-next): New variable

Change-Id: Ied567558ab0d794f567421e9c1c71ba58969cb33
---
gnu/packages/wget.scm | 12 ++++++++++++
1 file changed, 12 insertions(+)

Toggle diff (27 lines)
diff --git a/gnu/packages/wget.scm b/gnu/packages/wget.scm
index 6c6f7d3382..002873523b 100644
--- a/gnu/packages/wget.scm
+++ b/gnu/packages/wget.scm
@@ -75,6 +75,18 @@ (define-public wget
in downloaded documents to relative links.")
(license license:gpl3+))) ; some files are under GPLv2+
+
+(define-public wget-next
+ (package
+ (inherit wget)
+ (version "1.24.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/wget/wget-" version ".tar.lz"))
+ (sha256
+ (base32 "1vin1cwha883fjffv4rjy5rg6qw9b6nczzmgjkglzyaf3qahg8ap"))))))
+
(define-public wgetpaste
(package
(name "wgetpaste")

base-commit: b0b988c41c9e0e591274495a1b2d6f27fcdae15a
--
2.34.1
D
D
Dale Mellor wrote on 7 Jun 21:57 +0200
Why 'next'?
(address . 69721@debbugs.gnu.org)
a2b2048472ae49c20462310cbad33e0f65e849ab.camel@rdmp.org
Hello Andy,

Why are you adding a 'next' package instead of just bumping the version number?

Thanks, Dale
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 69721@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 69721
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch