[PATCH] gnu: Add go-github-com-hashicorp-go-cleanhttp.

  • Done
  • quality assurance status badge
Details
2 participants
  • Sharlatan Hellseher
  • Troy Figiel
Owner
unassigned
Submitted by
Troy Figiel
Severity
normal

Debbugs page

Troy Figiel wrote 1 years ago
(address . guix-patches@gnu.org)
87frwy2i36.fsf@troyfigiel.com
* gnu/packages/golang-web.scm (go-github-com-hashicorp-go-cleanhttp): New variable.
---
gnu/packages/golang-web.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 1d7ad01af2..b9dcdd46a7 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -964,6 +964,35 @@ (define-public go-github-com-gregjones-httpcache
shared proxy).")
(license license:expat))))
+(define-public go-github-com-hashicorp-go-cleanhttp
+ (package
+ (name "go-github-com-hashicorp-go-cleanhttp")
+ (version "0.5.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hashicorp/go-cleanhttp")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1i5xslizzwd966w81bz6dxjwzgml4q9bwqa186bsxd1vi8lqxl9p"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/hashicorp/go-cleanhttp"))
+ (home-page "https://github.com/hashicorp/go-cleanhttp")
+ (synopsis "Functions for accessing clean Go @code{http.Client} values")
+ (description
+ "The Go standard library contains a default @code{http.Client} and it is
+a common idiom to tweak it as necessary. Unfortunately, this is a shared
+value, and it is not uncommon for libraries to assume that they are free to
+modify it at will. This package provides some simple functions to get a
+\"clean\" @code{http.Client}, namely one that uses the same default values as
+the Go standard library, but returns a client that does not share any state
+with other clients.")
+ (license license:mpl2.0)))
+
(define-public go-github-com-hjson-hjson-go
(package
(name "go-github-com-hjson-hjson-go")

base-commit: c7836393be4d134861d652b2fcf09cf4e68275ca
--
2.42.0
Sharlatan Hellseher wrote 12 months ago
(address . 69711-done@debbugs.gnu.org)
877chvxhtl.fsf@gmail.com
Pushed as 8d27fe61d7f1a2bed0367fa861e4cae1f2f1546d to master.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmX8yIYACgkQdtcnv/Ys
0rXBMg/+MpUFAfQY9A0gejCj8i10xsWkBle4aJR9BtFJWubbkA2pm4IXGCIuD1/v
FwS60tCQE/oIQm4uR+9NCCO42kv+AjikMGfWOOD7wpj3bN3I8JPRn6qAK27sqBZV
UPBnw7c9gSzejzlFLHh1uD0Lv9ZEgXZd8hZwe+FieX49YJSfozrspJPdK4zh18M0
5pUmjeFHRykT+GJkq9Rsu+/uNVNR0HOmflqt4ChKieV2+RyZNyWJ73MfTdcWMK0J
H7f4RFcpexdnGN9Ms6vGoZL8Y5iu+pWogMvSQM8+g1OoW8T+kLpkof9OFXfyD1ZX
rpKYr59ICD2qUjfnR/nVP1nwE97a0q63A67CYbbwkyf0AYHomPdW2VlD6tgcDlKo
BtV5lpajuLRPUnrHBzT2dSPNOWTR6xzqNEPYJFd4fWv9Ct4S+3RsKTfuxbAyJWls
5VW1V2ITaTnctjsYAQ9cBRaigFYzQWYhIsz6TXNdqxYQnIRH8RzJr8/80itR6FOl
XyM82WlKA2UN+j0ys4Vrw1O9ME4XoWR/ZviXi9sRizeOR9C4Id+fWX6vMXl8X/0P
vYrdMmaxwZmg7c15PbX9t7NA0kENuZQiwSUvlnycIG/XGTseUjuopt/zJkSIumb0
WeiAeuwDGD++r2kqW7P/znsmj9IR5uqUIarHHudQYRiiHMXFKMM=
=xz1E
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 69711@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 69711
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help