Opam should be using a minimal version of extlib

  • Open
  • quality assurance status badge
Details
3 participants
  • Julien Lepiller
  • pukkamustard
  • Vivien Kraus
Owner
unassigned
Submitted by
Vivien Kraus
Severity
normal
V
V
Vivien Kraus wrote on 9 Mar 20:45 +0100
(name . bug-guix)(address . bug-guix@gnu.org)
933b0688e6dd31f6db3135d6401ac2e1e9d763f5.camel@planete-kraus.eu
Dear OCaml-aware Guix,

opam seems to imply that we have to use a minimal variant of ocaml-
extlib to build opam:


This is likely related to a build failure we are experiencing on the
gnome-team branch:



Best regards,

Vivien
V
V
Vivien Kraus wrote on 9 Mar 22:19 +0100
[PATCH 0/1] ocaml-extlib: Build with minimal=1.
(address . 69682@debbugs.gnu.org)
cover.1710019141.git.vivien@planete-kraus.eu
Dear Guix, brave ocaml-team members,


it looks like ocaml-extlib should build with minimal=1.

This also fixes a build failure on gnome-team.

What do you think?

Best regards,

Vivien

Vivien Kraus (1):
gnu: ocaml-extlib: Build with minimal=1.

gnu/packages/ocaml.scm | 8 +++++---
1 file changed, 5 insertions(+), 3 deletions(-)


base-commit: 2f441fc738976175d438f7942211b1894e2eb416
--
2.41.0
V
V
Vivien Kraus wrote on 9 Mar 22:03 +0100
[PATCH 1/1] gnu: ocaml-extlib: Build with minimal=1.
(address . 69682@debbugs.gnu.org)
5a3a080943ef3f6bc925728995e0ba96e12b4d33.1710019141.git.vivien@planete-kraus.eu
* gnu/packages/ocaml.scm (ocaml-extlib) [arguments]: Convert to list of
G-Expressions. Add #:make-flags.

Change-Id: I42ee3c21a52788f20ddc3381927ef6ef40b2a354
---
gnu/packages/ocaml.scm | 8 +++++---
1 file changed, 5 insertions(+), 3 deletions(-)

Toggle diff (21 lines)
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 0f4c351141..b911da8e5b 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -646,9 +646,11 @@ (define-public ocaml-extlib
"1jydzw2n84cfiz9y6lk4gih4wbr8jybanmiryfs01svd07g4vpjq"))))
(build-system ocaml-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (delete 'configure))))
+ (list
+ #:make-flags #~'("minimal=1")
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure))))
(native-inputs
(list ocaml-cppo))
(home-page "https://github.com/ygrek/ocaml-extlib")
--
2.41.0
J
J
Julien Lepiller wrote on 9 Mar 22:37 +0100
(address . pukkamustard@posteo.net)
5C4BFC4D-B183-4D5E-8CDD-DB9DAAC3CEF7@lepiller.eu
Ah, you sent this while I was writing to the other bug. Would it be possible to convert the recipe to use the dune-build-system instead? It sounds like it would be more future-proof, and it's also prefered by opam people.

Le 9 mars 2024 22:03:15 GMT+01:00, Vivien Kraus <vivien@planete-kraus.eu> a écrit :
Toggle quote (27 lines)
>* gnu/packages/ocaml.scm (ocaml-extlib) [arguments]: Convert to list of
>G-Expressions. Add #:make-flags.
>
>Change-Id: I42ee3c21a52788f20ddc3381927ef6ef40b2a354
>---
> gnu/packages/ocaml.scm | 8 +++++---
> 1 file changed, 5 insertions(+), 3 deletions(-)
>
>diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
>index 0f4c351141..b911da8e5b 100644
>--- a/gnu/packages/ocaml.scm
>+++ b/gnu/packages/ocaml.scm
>@@ -646,9 +646,11 @@ (define-public ocaml-extlib
> "1jydzw2n84cfiz9y6lk4gih4wbr8jybanmiryfs01svd07g4vpjq"))))
> (build-system ocaml-build-system)
> (arguments
>- `(#:phases
>- (modify-phases %standard-phases
>- (delete 'configure))))
>+ (list
>+ #:make-flags #~'("minimal=1")
>+ #:phases
>+ #~(modify-phases %standard-phases
>+ (delete 'configure))))
> (native-inputs
> (list ocaml-cppo))
> (home-page "https://github.com/ygrek/ocaml-extlib")
V
V
Vivien Kraus wrote on 9 Mar 22:03 +0100
[PATCH v2] gnu: ocaml-extlib: Convert to dune-build-system.
(address . 69682@debbugs.gnu.org)
9f11376ea26f33e40bbf750f2c55a54b6ef9cd7f.1710022390.git.vivien@planete-kraus.eu
* gnu/packages/ocaml.scm (ocaml-extlib) [build-system]: Convert to
dune-build-system.
[arguments]: Remove '#:phases' and add '#:package'.

Change-Id: Ia50c05423f3062200704fbcbb0680f2b326a7ca4
---
Opam still builds on gnome-team.

gnu/packages/ocaml.scm | 6 ++----
1 file changed, 2 insertions(+), 4 deletions(-)

Toggle diff (22 lines)
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 0f4c351141..b70e925d51 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -644,11 +644,9 @@ (define-public ocaml-extlib
(sha256
(base32
"1jydzw2n84cfiz9y6lk4gih4wbr8jybanmiryfs01svd07g4vpjq"))))
- (build-system ocaml-build-system)
+ (build-system dune-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (delete 'configure))))
+ (list #:package "extlib"))
(native-inputs
(list ocaml-cppo))
(home-page "https://github.com/ygrek/ocaml-extlib")

base-commit: 2f441fc738976175d438f7942211b1894e2eb416
--
2.41.0
P
P
pukkamustard wrote on 24 Mar 08:12 +0100
(name . Vivien Kraus)(address . vivien@planete-kraus.eu)
86wmps5cfg.fsf@posteo.net
Sorry for being late to the party. But the conversion to use
dune-build-system looks good to me!

I ran into the same issue when updating opam to 2.1.5 but never managed
to get to the bottom of it. Thanks for figuring this out!

-pukkamustard

Vivien Kraus <vivien@planete-kraus.eu> writes:

Toggle quote (31 lines)
> * gnu/packages/ocaml.scm (ocaml-extlib) [build-system]: Convert to
> dune-build-system.
> [arguments]: Remove '#:phases' and add '#:package'.
>
> Change-Id: Ia50c05423f3062200704fbcbb0680f2b326a7ca4
> ---
> Opam still builds on gnome-team.
>
> gnu/packages/ocaml.scm | 6 ++----
> 1 file changed, 2 insertions(+), 4 deletions(-)
>
> diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
> index 0f4c351141..b70e925d51 100644
> --- a/gnu/packages/ocaml.scm
> +++ b/gnu/packages/ocaml.scm
> @@ -644,11 +644,9 @@ (define-public ocaml-extlib
> (sha256
> (base32
> "1jydzw2n84cfiz9y6lk4gih4wbr8jybanmiryfs01svd07g4vpjq"))))
> - (build-system ocaml-build-system)
> + (build-system dune-build-system)
> (arguments
> - `(#:phases
> - (modify-phases %standard-phases
> - (delete 'configure))))
> + (list #:package "extlib"))
> (native-inputs
> (list ocaml-cppo))
> (home-page "https://github.com/ygrek/ocaml-extlib")
>
> base-commit: 2f441fc738976175d438f7942211b1894e2eb416
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 69682@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 69682
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch