clj (clojure-tools) fails with :deps alias

  • Open
  • quality assurance status badge
Details
2 participants
  • Ian Eure
  • Ryan Barber
Owner
unassigned
Submitted by
Ryan Barber
Severity
normal
R
R
Ryan Barber wrote on 9 Mar 17:14 +0100
(address . bug-guix@gnu.org)
CAC1NScJW1grMntfCOCuds73nZw24D-dNFUqQEaAaxpUjvbVBwA@mail.gmail.com
I am attempting to use the :deps tools to diagnose some library issues
using "-X:deps list" and "-X:deps tree", but I keep encountering the
same error.

This example is run from an empty directory, without a project deps.edn.

$ guix shell clojure-tools openjdk -- clj -M:deps
Warning: failed to load the S3TransporterFactory class
Warning: failed to load the S3TransporterFactory class
Warning: failed to load the S3TransporterFactory class
SLF4J: Failed to load class "org.slf4j.impl.StaticLoggerBinder".
SLF4J: Defaulting to no-operation (NOP) logger implementation
further details.
Warning: failed to load the S3TransporterFactory class
Warning: failed to load the S3TransporterFactory class
Warning: failed to load the S3TransporterFactory class
Warning: failed to load the S3TransporterFactory class
Warning: failed to load the S3TransporterFactory class
Error building classpath. Could not find artifact
org.clojure:tools.deps.alpha:jar:${project.version} in central
I
I
Ian Eure wrote on 13 Mar 05:06 +0100
(address . 69680@debbugs.gnu.org)
87msr2vju3.fsf@meson
Looks like the issue is a ${project.version} sitting in a deps.edn
in the resources of the JAR.

I have a patch that seems to solve this, but it’s ludicrous due to
clojure-build-system being buggy. Also, tools.deps.alpha has been
deprecated for two years and really shouldn’t be in Guix at all.
I’ve done some work on getting Clojure stuff in Guix into better
shape, but it’s not ready yet.

Patch incoming shortly.

— Ian
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 69680@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 69680
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch