[PATCH gnome-team 0/1] Update girara to 0.4.3

  • Done
  • quality assurance status badge
Details
4 participants
  • Liliana Marie Prikler
  • Christopher Baines
  • Maxim Cournoyer
  • Vivien Kraus
Owner
unassigned
Submitted by
Vivien Kraus
Severity
normal

Debbugs page

Vivien Kraus wrote 1 years ago
(address . guix-patches@gnu.org)
cover.1709969886.git.vivien@planete-kraus.eu
Dear Guix,

girara fails to build, but we can still update it. It has an optional
dependency on json-glib, so maybe we could have it too.

What do you think?

Best regards,

Vivien

Vivien Kraus (1):
gnu: girara: Update to 0.4.3.

gnu/packages/gtk.scm | 53 +++++++++++++++++++++++---------------------
1 file changed, 28 insertions(+), 25 deletions(-)


base-commit: 25c14c893f05019d746321285acf55d1aa65b943
--
2.41.0
Vivien Kraus wrote 1 years ago
[PATCH gnome-team 1/1] gnu: girara: Update to 0.4.3.
(address . 69669@debbugs.gnu.org)
47c1519438f47449ee0f44ecbb4f5d8e443d627f.1709969886.git.vivien@planete-kraus.eu
* gnu/packages/gtk.scm (girara): Update to 0.4.3.
[native-inputs]: Drop labels.
[propagated-inputs]: Add pango and json-glib.
[arguments]: Convert to list of G-Expressions.

Change-Id: I3c977cd33fa6d20fce3bb575ae2ad887b3061966
---
gnu/packages/gtk.scm | 53 +++++++++++++++++++++++---------------------
1 file changed, 28 insertions(+), 25 deletions(-)

Toggle diff (74 lines)
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index a00ce71b81..0c1b7fb5a0 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -2132,7 +2132,7 @@ (define-public perl-pango
(define-public girara
(package
(name "girara")
- (version "0.3.7")
+ (version "0.4.3")
(source
(origin
(method git-fetch)
@@ -2141,31 +2141,34 @@ (define-public girara
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0k93pi0lkf941vanvh1habm6n5wl1n63726j5kqxh34wdlv4mv4s"))))
- (native-inputs `(("pkg-config" ,pkg-config)
- ("check" ,check)
- ("gettext" ,gettext-minimal)
- ("glib:bin" ,glib "bin")
- ("xorg-server" ,xorg-server-for-tests)))
- ;; Listed in 'Requires.private' of 'girara.pc'.
- (propagated-inputs (list gtk+))
+ (base32 "0cbcs3810frgdmal5ia9pf3rk3k5h4xyzw1d2ia3rcg4nms5gcpx"))))
+ (native-inputs
+ (list pkg-config
+ check
+ gettext-minimal
+ `(,glib "bin")
+ xorg-server-for-tests))
+ ;; Listed in 'Requires.private' or 'Requires' of 'girara.pc'.
+ (propagated-inputs (list gtk+ pango json-glib))
(arguments
- `(#:phases (modify-phases %standard-phases
- (add-before 'check 'start-xserver
- ;; Tests require a running X server.
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((xorg-server (assoc-ref inputs "xorg-server"))
- (display ":1"))
- (setenv "DISPLAY" display)
-
- ;; On busy machines, tests may take longer than
- ;; the default of four seconds.
- (setenv "CK_DEFAULT_TIMEOUT" "20")
-
- ;; Don't fail due to missing '/etc/machine-id'.
- (setenv "DBUS_FATAL_WARNINGS" "0")
- (zero? (system (string-append xorg-server "/bin/Xvfb "
- display " &")))))))))
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'check 'start-xserver
+ ;; Tests require a running X server.
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((xorg-server (assoc-ref inputs "xorg-server"))
+ (display ":1"))
+ (setenv "DISPLAY" display)
+
+ ;; On busy machines, tests may take longer than
+ ;; the default of four seconds.
+ (setenv "CK_DEFAULT_TIMEOUT" "20")
+
+ ;; Don't fail due to missing '/etc/machine-id'.
+ (setenv "DBUS_FATAL_WARNINGS" "0")
+ (zero? (system (string-append xorg-server "/bin/Xvfb "
+ display " &")))))))))
(build-system meson-build-system)
(home-page "https://pwmt.org/projects/girara/")
(synopsis "Library for minimalistic gtk+3 user interfaces")
--
2.41.0
Liliana Marie Prikler wrote 1 years ago
5a6ad197dc94fafabc75784e9348134e2085ac33.camel@gmail.com
Am Samstag, dem 09.03.2024 um 08:33 +0100 schrieb Vivien Kraus:
Toggle quote (7 lines)
> * gnu/packages/gtk.scm (girara): Update to 0.4.3.
> [native-inputs]: Drop labels.
> [propagated-inputs]: Add pango and json-glib.
> [arguments]: Convert to list of G-Expressions.
>
> Change-Id: I3c977cd33fa6d20fce3bb575ae2ad887b3061966
> ---
Since you are already mixing cosmetic and non-cosmetic changes, you can
also sort the fields. Inputs typically go after arguments.
Toggle quote (40 lines)
>  gnu/packages/gtk.scm | 53 +++++++++++++++++++++++-------------------
> --
>  1 file changed, 28 insertions(+), 25 deletions(-)
>
> diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
> index a00ce71b81..0c1b7fb5a0 100644
> --- a/gnu/packages/gtk.scm
> +++ b/gnu/packages/gtk.scm
> @@ -2132,7 +2132,7 @@ (define-public perl-pango
>  (define-public girara
>    (package
>      (name "girara")
> -    (version "0.3.7")
> +    (version "0.4.3")
>      (source
>       (origin
>         (method git-fetch)
> @@ -2141,31 +2141,34 @@ (define-public girara
>               (commit version)))
>         (file-name (git-file-name name version))
>         (sha256
> -        (base32
> "0k93pi0lkf941vanvh1habm6n5wl1n63726j5kqxh34wdlv4mv4s"))))
> -    (native-inputs `(("pkg-config" ,pkg-config)
> -                     ("check" ,check)
> -                     ("gettext" ,gettext-minimal)
> -                     ("glib:bin" ,glib "bin")
> -                     ("xorg-server" ,xorg-server-for-tests)))
> -    ;; Listed in 'Requires.private' of 'girara.pc'.
> -    (propagated-inputs (list gtk+))
> +        (base32
> "0cbcs3810frgdmal5ia9pf3rk3k5h4xyzw1d2ia3rcg4nms5gcpx"))))
> +    (native-inputs
> +     (list pkg-config
> +           check
> +           gettext-minimal
> +           `(,glib "bin")
> +           xorg-server-for-tests))
> +    ;; Listed in 'Requires.private' or 'Requires' of 'girara.pc'.
> +    (propagated-inputs (list gtk+ pango json-glib))
I'd hazard a guess that some of these are already propagated through
gtk+.
Toggle quote (44 lines)
>      (arguments
> -     `(#:phases (modify-phases %standard-phases
> -                  (add-before 'check 'start-xserver
> -                    ;; Tests require a running X server.
> -                    (lambda* (#:key inputs #:allow-other-keys)
> -                      (let ((xorg-server (assoc-ref inputs "xorg-
> server"))
> -                            (display ":1"))
> -                        (setenv "DISPLAY" display)
> -
> -                        ;; On busy machines, tests may take longer
> than
> -                        ;; the default of four seconds.
> -                        (setenv "CK_DEFAULT_TIMEOUT" "20")
> -
> -                        ;; Don't fail due to missing '/etc/machine-
> id'.
> -                        (setenv "DBUS_FATAL_WARNINGS" "0")
> -                        (zero? (system (string-append xorg-server
> "/bin/Xvfb "
> -                                                      display "
> &")))))))))
> +     (list
> +      #:phases
> +      #~(modify-phases %standard-phases
> +          (add-before 'check 'start-xserver
> +            ;; Tests require a running X server.
> +            (lambda* (#:key inputs #:allow-other-keys)
> +              (let ((xorg-server (assoc-ref inputs "xorg-server"))
> +                    (display ":1"))
> +                (setenv "DISPLAY" display)
> +
> +                ;; On busy machines, tests may take longer than
> +                ;; the default of four seconds.
> +                (setenv "CK_DEFAULT_TIMEOUT" "20")
> +
> +                ;; Don't fail due to missing '/etc/machine-id'.
> +                (setenv "DBUS_FATAL_WARNINGS" "0")
> +                (zero? (system (string-append xorg-server "/bin/Xvfb
> "
> +                                              display " &")))))))))
>      (build-system meson-build-system)
>      (home-page "https://pwmt.org/projects/girara/")
>      (synopsis "Library for minimalistic gtk+3 user interfaces")
Cheers
Vivien Kraus wrote 1 years ago
[PATCH gnome-team v2 2/3] gnu: girara: Update to 0.4.3.
(address . 69669@debbugs.gnu.org)
dbca551c862c6828d814f256513f1201354d0e9b.1709974804.git.vivien@planete-kraus.eu
* gnu/packages/gtk.scm (girara): Update to 0.4.3.

Change-Id: I3c977cd33fa6d20fce3bb575ae2ad887b3061966
---
gnu/packages/gtk.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 033c5aee0f..950476815f 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -2132,7 +2132,7 @@ (define-public perl-pango
(define-public girara
(package
(name "girara")
- (version "0.3.7")
+ (version "0.4.3")
(source
(origin
(method git-fetch)
@@ -2141,7 +2141,7 @@ (define-public girara
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0k93pi0lkf941vanvh1habm6n5wl1n63726j5kqxh34wdlv4mv4s"))))
+ (base32 "0cbcs3810frgdmal5ia9pf3rk3k5h4xyzw1d2ia3rcg4nms5gcpx"))))
(arguments
(list
#:phases
--
2.41.0
Vivien Kraus wrote 1 years ago
[PATCH gnome-team v2 0/3] Update girara (better)
(address . 69669@debbugs.gnu.org)
cover.1709974804.git.vivien@planete-kraus.eu
Dear guix,

I split the cosmetic changes, and also split the non-cosmetic change in 2.
json-glib is an optional dependency, so girara can exist with and without it.

You were right, pango is already propagated from gtk+.

I also reordered the fields, but it does not look very intuitive, because it
looks like I moved the arguments field up and the native-inputs field down
instead of moving native-inputs and propagated-inputs down (thanks git).
Should I also split the style update?

Best regards,

Vivien

Vivien Kraus (3):
gnu: girara: Update style.
gnu: girara: Update to 0.4.3.
gnu: girara: Build with json-glib.

gnu/packages/gtk.scm | 53 +++++++++++++++++++++++---------------------
1 file changed, 28 insertions(+), 25 deletions(-)


base-commit: 25c14c893f05019d746321285acf55d1aa65b943
--
2.41.0
Vivien Kraus wrote 1 years ago
[PATCH gnome-team v2 1/3] gnu: girara: Update style.
(address . 69669@debbugs.gnu.org)
1a4864e2e1936be6053ca1330483a44da985730f.1709974804.git.vivien@planete-kraus.eu
* gnu/packages/gtk.scm (girara)[arguments]: Convert to list of G-Expressions.
[native-inputs]: Move after arguments.
[propagated-inputs]: Move after arguments.

Change-Id: I79a6f59f6ea671433f1a66a10cb79203f0b9bbae
---
gnu/packages/gtk.scm | 47 +++++++++++++++++++++++---------------------
1 file changed, 25 insertions(+), 22 deletions(-)

Toggle diff (62 lines)
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index a00ce71b81..033c5aee0f 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -2142,30 +2142,33 @@ (define-public girara
(file-name (git-file-name name version))
(sha256
(base32 "0k93pi0lkf941vanvh1habm6n5wl1n63726j5kqxh34wdlv4mv4s"))))
- (native-inputs `(("pkg-config" ,pkg-config)
- ("check" ,check)
- ("gettext" ,gettext-minimal)
- ("glib:bin" ,glib "bin")
- ("xorg-server" ,xorg-server-for-tests)))
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'check 'start-xserver
+ ;; Tests require a running X server.
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((xorg-server (assoc-ref inputs "xorg-server"))
+ (display ":1"))
+ (setenv "DISPLAY" display)
+
+ ;; On busy machines, tests may take longer than
+ ;; the default of four seconds.
+ (setenv "CK_DEFAULT_TIMEOUT" "20")
+
+ ;; Don't fail due to missing '/etc/machine-id'.
+ (setenv "DBUS_FATAL_WARNINGS" "0")
+ (zero? (system (string-append xorg-server "/bin/Xvfb "
+ display " &")))))))))
+ (native-inputs
+ (list pkg-config
+ check
+ gettext-minimal
+ `(,glib "bin")
+ xorg-server-for-tests))
;; Listed in 'Requires.private' of 'girara.pc'.
(propagated-inputs (list gtk+))
- (arguments
- `(#:phases (modify-phases %standard-phases
- (add-before 'check 'start-xserver
- ;; Tests require a running X server.
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((xorg-server (assoc-ref inputs "xorg-server"))
- (display ":1"))
- (setenv "DISPLAY" display)
-
- ;; On busy machines, tests may take longer than
- ;; the default of four seconds.
- (setenv "CK_DEFAULT_TIMEOUT" "20")
-
- ;; Don't fail due to missing '/etc/machine-id'.
- (setenv "DBUS_FATAL_WARNINGS" "0")
- (zero? (system (string-append xorg-server "/bin/Xvfb "
- display " &")))))))))
(build-system meson-build-system)
(home-page "https://pwmt.org/projects/girara/")
(synopsis "Library for minimalistic gtk+3 user interfaces")
--
2.41.0
Vivien Kraus wrote 1 years ago
[PATCH gnome-team v2 3/3] gnu: girara: Build with json-glib.
(address . 69669@debbugs.gnu.org)
e7e764d914a28cb4f97156cd730af9b531e90cd5.1709974804.git.vivien@planete-kraus.eu
* gnu/packages/gtk.scm (girara) [propagated-inputs]: Add json-glib.

Change-Id: I5bfe5a516885153014fce1c6643ac5799f0100e1
---
gnu/packages/gtk.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 950476815f..3b834d748c 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -2168,7 +2168,7 @@ (define-public girara
`(,glib "bin")
xorg-server-for-tests))
;; Listed in 'Requires.private' of 'girara.pc'.
- (propagated-inputs (list gtk+))
+ (propagated-inputs (list gtk+ json-glib))
(build-system meson-build-system)
(home-page "https://pwmt.org/projects/girara/")
(synopsis "Library for minimalistic gtk+3 user interfaces")
--
2.41.0
Liliana Marie Prikler wrote 1 years ago
Re: [PATCH gnome-team v2 0/3] Update girara (better)
db60bac0bb0bedd467a36bc63746434cbea906f9.camel@gmail.com
Am Samstag, dem 09.03.2024 um 10:00 +0100 schrieb Vivien Kraus:
Toggle quote (5 lines)
> Dear guix,
>
> I split the cosmetic changes, and also split the non-cosmetic change
> in 2. json-glib is an optional dependency, so girara can exist with
> and without it.
Would you care to elaborate? Depending on the exact changes between
the version, I might want to squash this into one commit.

Toggle quote (7 lines)
> You were right, pango is already propagated from gtk+.
>
> I also reordered the fields, but it does not look very intuitive,
> because it looks like I moved the arguments field up and the native-
> inputs field down instead of moving native-inputs and propagated-
> inputs down (thanks git).
> Should I also split the style update?
Nah, that's fine.

Cheers
Vivien Kraus wrote 1 years ago
44f7c690a0b2e7bddb40723bb678fe7df57b8e39.camel@planete-kraus.eu
Le samedi 09 mars 2024 à 10:24 +0100, Liliana Marie Prikler a écrit :
Toggle quote (8 lines)
> > I split the cosmetic changes, and also split the non-cosmetic
> > change
> > in 2.  json-glib is an optional dependency, so girara can exist
> > with
> > and without it.
> Would you care to elaborate?  Depending on the exact changes between
> the version, I might want to squash this into one commit.

In meson_options.txt, here is the description for the 'json' option: 

```
description: 'dump configuration using JSON'
```

The README has:

```
The following dependencies are optional:

* `json-glib-1.0`: configuration dumping support
```

The blame tells us it was added in september 2022, so later than the
0.3.7 release (february 2022).

I don’t really understand what it’s used for, I have never developed
with girara.

Does this help?

Vivien
Maxim Cournoyer wrote 1 years ago
Re: [PATCH gnome-team v2 3/3] gnu: girara: Build with json-glib.
(name . Vivien Kraus)(address . vivien@planete-kraus.eu)
87jzmbffyd.fsf@gmail.com
Hi Vivien,

Vivien Kraus <vivien@planete-kraus.eu> writes:

Toggle quote (18 lines)
> * gnu/packages/gtk.scm (girara) [propagated-inputs]: Add json-glib.
>
> Change-Id: I5bfe5a516885153014fce1c6643ac5799f0100e1
> ---
> gnu/packages/gtk.scm | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
> index 950476815f..3b834d748c 100644
> --- a/gnu/packages/gtk.scm
> +++ b/gnu/packages/gtk.scm
> @@ -2168,7 +2168,7 @@ (define-public girara
> `(,glib "bin")
> xorg-server-for-tests))
> ;; Listed in 'Requires.private' of 'girara.pc'.
> - (propagated-inputs (list gtk+))
> + (propagated-inputs (list gtk+ json-glib))

We'll want to revisit these propagated inputs after the core-updates
branch is merged, as Requires.private should only be needed when
producing static archives, not dynamic libraries (which pkgconf
interprets correctly).

--
Thanks,
Maxim
Maxim Cournoyer wrote 1 years ago
Re: [PATCH gnome-team v2 0/3] Update girara (better)
(name . Vivien Kraus)(address . vivien@planete-kraus.eu)
87frwzfftc.fsf@gmail.com
Hello,

Vivien Kraus <vivien@planete-kraus.eu> writes:

Toggle quote (22 lines)
> Dear guix,
>
> I split the cosmetic changes, and also split the non-cosmetic change in 2.
> json-glib is an optional dependency, so girara can exist with and without it.
>
> You were right, pango is already propagated from gtk+.
>
> I also reordered the fields, but it does not look very intuitive, because it
> looks like I moved the arguments field up and the native-inputs field down
> instead of moving native-inputs and propagated-inputs down (thanks git).
> Should I also split the style update?
>
> Best regards,
>
> Vivien
>
> Vivien Kraus (3):
> gnu: girara: Update style.
> gnu: girara: Update to 0.4.3.
> gnu: girara: Build with json-glib.
>

Reviewed-by: Maxim Cournoyer <maxim.cournoyer@gmail>

--
Thanks,
Maxim
Vivien Kraus wrote 1 years ago
Re: [PATCH gnome-team v2 3/3] gnu: girara: Build with json-glib.
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)
aaaeac3dcc5e3ae3ceca8f90f7a7f4243a4ae92d.camel@planete-kraus.eu
Le samedi 09 mars 2024 à 12:55 -0500, Maxim Cournoyer a écrit :
Toggle quote (8 lines)
> > -    (propagated-inputs (list gtk+))
> > +    (propagated-inputs (list gtk+ json-glib))
>
> We'll want to revisit these propagated inputs after the core-updates
> branch is merged, as Requires.private should only be needed when
> producing static archives, not dynamic libraries (which pkgconf
> interprets correctly).

Should I do something in the mean time?
Liliana Marie Prikler wrote 1 years ago
Re: [PATCH gnome-team v2 0/3] Update girara (better)
a255f6624762ebe84caba284457271700b044af5.camel@gmail.com
Am Samstag, dem 09.03.2024 um 12:58 -0500 schrieb Maxim Cournoyer:
Toggle quote (30 lines)
> Hello,
>
> Vivien Kraus <vivien@planete-kraus.eu> writes:
>
> > Dear guix,
> >
> > I split the cosmetic changes, and also split the non-cosmetic
> > change in 2.
> > json-glib is an optional dependency, so girara can exist with and
> > without it.
> >
> > You were right, pango is already propagated from gtk+.
> >
> > I also reordered the fields, but it does not look very intuitive,
> > because it looks like I moved the arguments field up and the
> > native-inputs field down instead of moving native-inputs and
> > propagated-inputs down (thanks git).
> > Should I also split the style update?
> >
> > Best regards,
> >
> > Vivien
> >
> > Vivien Kraus (3):
> >   gnu: girara: Update style.
> >   gnu: girara: Update to 0.4.3.
> >   gnu: girara: Build with json-glib.
> >
>
> Reviewed-by: Maxim Cournoyer <maxim.cournoyer@gmail>
Hi, I've went ahead and pushed 1 and 2. For 3, I'd like you to clarify
whether we ought to use propagated-inputs now or how else to handle
this.

Cheers
Maxim Cournoyer wrote 1 years ago
Re: [PATCH gnome-team v2 3/3] gnu: girara: Build with json-glib.
(name . Vivien Kraus)(address . vivien@planete-kraus.eu)
87cys0cds0.fsf@gmail.com
Hi,

Vivien Kraus <vivien@planete-kraus.eu> writes:

Toggle quote (11 lines)
> Le samedi 09 mars 2024 à 12:55 -0500, Maxim Cournoyer a écrit :
>> > -    (propagated-inputs (list gtk+))
>> > +    (propagated-inputs (list gtk+ json-glib))
>>
>> We'll want to revisit these propagated inputs after the core-updates
>> branch is merged, as Requires.private should only be needed when
>> producing static archives, not dynamic libraries (which pkgconf
>> interprets correctly).
>
> Should I do something in the mean time?

No, or if you want, you could leave a 'TODO: Remove propagated inputs
after core-updates is merged' or similar.

--
Thanks,
Maxim
Vivien Kraus wrote 1 years ago
[PATCH gnome-team v3] gnu: girara: Build with json-glib.
(address . 69669@debbugs.gnu.org)
9a9ad145b2f8de3e05cb82267c5994ea1981bde5.1710228906.git.vivien@planete-kraus.eu
* gnu/packages/gtk.scm (girara) [propagated-inputs]: Add json-glib.

Change-Id: I5bfe5a516885153014fce1c6643ac5799f0100e1
---
The added comment has a date, so that the maintainer of the future knows
whether they can safely apply the change.

Best regards,

Vivien

gnu/packages/gtk.scm | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)

Toggle diff (26 lines)
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 950476815f..abbfc6fa16 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -2130,6 +2130,8 @@ (define-public perl-pango
(license license:lgpl2.1+)))
(define-public girara
+ ;; TODO: Move propagated inputs to inputs after core-updates is merged (as
+ ;; of 2024-03)
(package
(name "girara")
(version "0.4.3")
@@ -2168,7 +2170,7 @@ (define-public girara
`(,glib "bin")
xorg-server-for-tests))
;; Listed in 'Requires.private' of 'girara.pc'.
- (propagated-inputs (list gtk+))
+ (propagated-inputs (list gtk+ json-glib))
(build-system meson-build-system)
(home-page "https://pwmt.org/projects/girara/")
(synopsis "Library for minimalistic gtk+3 user interfaces")

base-commit: fe2b2f860e1fd7dfdc333f65893e65f131e290c7
--
2.41.0
Maxim Cournoyer wrote 1 years ago
(name . Vivien Kraus)(address . vivien@planete-kraus.eu)
874jdbd1gb.fsf@gmail.com
Vivien Kraus <vivien@planete-kraus.eu> writes:

Toggle quote (4 lines)
> * gnu/packages/gtk.scm (girara) [propagated-inputs]: Add json-glib.
>
> Change-Id: I5bfe5a516885153014fce1c6643ac5799f0100e1

Reviewed-by: Maxim Cournoyer <maxim.cournoyer@gmail>

--
Thanks,
Maxim
Christopher Baines wrote 12 months ago
Re: [bug#69669] [PATCH gnome-team v3] gnu: girara: Build with json-glib.
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)
87y1aiqvv8.fsf@cbaines.net
Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:

Toggle quote (8 lines)
> Vivien Kraus <vivien@planete-kraus.eu> writes:
>
>> * gnu/packages/gtk.scm (girara) [propagated-inputs]: Add json-glib.
>>
>> Change-Id: I5bfe5a516885153014fce1c6643ac5799f0100e1
>
> Reviewed-by: Maxim Cournoyer <maxim.cournoyer@gmail>

Thanks all, I've pushed this to gnome-team as
1caa0eeee5042f33bc0bb66dc38bed7513cad0fb.

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmX1fStfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XfCfQ/7BN6xV1nWe/F0p+jPc/5hqmshSzB75J22
uilx20/4ByjKjwrj6GGZQgtB1j27MQkcPm0Y0CzTlJESiGVHkkj25HvgP+A7H9K7
OiOoJdmOLSeJiO6Oi77+WSo6Bz1kZMNrVX/p0M0rLdZLkwkh7/1IiklsnQY8Ty6z
66xbqOwH/NEtTR03owHEcVZDmuei3txjDRH1GYylxw7UiAP1sSvZLUxRmWQTxjS1
5VWFFKjtYRRSTo5UYHuD5cgTPb+3bADe4S5dRMHjTq922bkFtwKK5yfWKUiNZLuD
rtcZOd7UqYCkb3WPECyYWBDQUiIR00z2b6K68FmCcjt+4hFcEROEjzW50wZwl6yh
PeJwR5o7NwnKJsqopJgLt1B0+M9qqWmeYE83LEkPpXNgQ1QDwkFbHpgGPPwddEzU
M/1ag9UyV4aRf6M2WXaEIjLbxux/eyqduSaAiKP4STyCRe57yOG4X0QlLTypKzgO
5s+KnQXogQOQfQcxWKFZbNYIsgLNxtuKzeiwu4ZE2ZwpD3ZAopUiVU8MI6bsLh+X
+ZYotDjrxBrK3Kk7ELDmBaGpqLtbH+Elx9OLSADDK68m9scEQqRWoYaUTLNjRD7k
tmIJjE/wEUnJ5N3rnDLA6dKQOp/zCi+A/G3pggMgayQ5m3U8Qk5kodlvVcP2wa1F
yo6vt6bLz6A=
=iKH3
-----END PGP SIGNATURE-----

?
Your comment

This issue is archived.

To comment on this conversation send an email to 69669@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 69669
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help