build of sway-1.9-checkout.drv failed

  • Done
  • quality assurance status badge
Details
5 participants
  • chris
  • Hilton Chain
  • Ignas Lap?nas
  • Isaac van Bakel
  • ???
Owner
unassigned
Submitted by
chris
Severity
normal
C
(address . bug-guix@gnu.org)(address . chris@bumblehead.com)
ZewF3Gl0IUBnlzuA@guix-xps
guix home reconfigure fails at sway-1.9. The bottom of the drv file shows this,
```
`source is at 'sway-1.9-checkout'
Backtrace:
10 (primitive-load "/gnu/store/5ahfcp5009pgdh17lg5y01w4vhv…")
In ice-9/eval.scm:
619:8 9 (_ #(#(#<directory (guile-user) 7ffff77f7c80> "swa…") #))
In ice-9/boot-9.scm:
142:2 8 (dynamic-wind _ _ #<procedure 7ffff77aa3c0 at ice-9/eva…>)
In system/base/compile.scm:
352:28 7 (compile _ #:from _ #:to _ #:env _ #:optimization-level …)
265:44 6 (_ _ _)
265:44 5 (_ _ _)
265:44 4 (_ _ _)
261:27 3 (_ _ _)
In ice-9/boot-9.scm:
2836:4 2 (save-module-excursion #<procedure 7ffff3d9bb40 at lang…>)
In language/bytecode/spec.scm:
43:19 1 (_)
In unknown file:
0 (delete-file "contrib/grimshot.1")

ERROR: In procedure delete-file:
In procedure delete-file: No such file or directory
/gnu/store/5wqhngwwzaa9b9g1apxr8lawk3g8sxwm-sway-1.9-checkout/assets/Sway_Wallpaper_Blue_1136x640_Portrait.png' -> `sway-1.9-checkout/assets/Sway_Wallpaper_Blue_1136x640_Portrait.png'
`/gnu/store/5wqhngwwzaa9b9g1apxr8lawk3g8sxwm-sway-1.9-checkout/assets/Sway_Wallpaper_Blue_768x1024.png' -> `sway-1.9-checkout/assets/Sway_Wallpaper_Blue_768x1024.png'
`/gnu/store/5wqhngwwzaa9b9g1apxr8lawk3g8sxwm-sway-1.9-checkout/assets/Sway_Wallpaper_Blue_1920x1080.png' -> `sway-1.9-checkout/assets/Sway_Wallpaper_Blue_1920x1080.png'
`/gnu/store/5wqhngwwzaa9b9g1apxr8lawk3g8sxwm-sway-1.9-checkout/assets/Sway_Logo+Text_Ver3.svg' -> `sway-1.9-checkout/assets/Sway_Logo+Text_Ver3.svg'
`/gnu/store/5wqhngwwzaa9b9g1apxr8lawk3g8sxwm-sway-1.9-checkout/assets/Sway_Tree.svg' -> `sway-1.9-checkout/assets/Sway_Tree.svg'
`/gnu/store/5wqhngwwzaa9b9g1apxr8lawk3g8sxwm-sway-1.9-checkout/assets/Sway_Logo+Text_Ver1_1500x716.png' -> `sway-1.9-checkout/assets/Sway_Logo+Text_Ver1_1500x716.png'
`/gnu/store/5wqhngwwzaa9b9g1apxr8lawk3g8sxwm-sway-1.9-checkout/assets/Sway_Logo+Text_Ver4.png' -> `sway-1.9-checkout/assets/Sway_Logo+Text_Ver4.png'
```
?
(name . chris)(address . chris@bumblehead.com)(address . 69667@debbugs.gnu.org)
877ciael14.fsf@envs.net
chris <chris@bumblehead.com> writes:

Toggle quote (7 lines)
> guix home reconfigure fails at sway-1.9. The bottom of the drv file shows this,
> ```
> `source is at 'sway-1.9-checkout'
> [...]
> ERROR: In procedure delete-file:
> In procedure delete-file: No such file or directory

Hello, sway build fine for me (and CI), this seems like a disk or
filesystem issue on your side.
C
(name . ???)(address . iyzsong@envs.net)(address . 69667@debbugs.gnu.org)
Ze2xl16qxi22mQKo@guix-xps
On 3?10? ?, ??? wrote:
Toggle quote (4 lines)
>
> Hello, sway build fine for me (and CI), this seems like a disk or
> filesystem issue on your side.

Removing grimshot resolved the issue for me.
C
(name . ???)(address . iyzsong@envs.net)(address . 69667@debbugs.gnu.org)
Ze24lsMZL-Iww4DN@guix-xps
On 3?10? ?, ??? wrote:
Toggle quote (4 lines)
>
> Hello, sway build fine for me (and CI), this seems like a disk or
> filesystem issue on your side.

Booting to sway 1.9 results in a flashing screen and its necessary to restart and boot to a previous generation. This system uses seat and wlgreet. Have not tried to debug yet.
C
(name . ???)(address . iyzsong@envs.net)(address . 69667@debbugs.gnu.org)
Ze6ZT_ghcIe2ETk0@guix-xps
All issues were resolved by removing grimshot and wlgreet
I
I
Isaac van Bakel wrote on 11 Mar 15:07 +0100
build of sway-1.9-checkout.drv failed
(address . 69667@debbugs.gnu.org)
8cbaec18-6b21-0365-0d71-56077b92c842@inf.ethz.ch
grimshot was removed from the sway repo[0] and moved to a standalone
user-contributions repo[1]. This build failure is visible in CI. It is
possible to use grimshot from the new repository, if you delete the
'chdir phase.

wlgreet seems to have a known issue with sway 1.9[2] that causes the
startup failure, though this should go in a separate issue, since it's
unrelated to the checkout error which is linked to grimshot.

 2:
I
I
I
Ignas Lap?nas wrote on 12 Mar 07:33 +0100
(address . 69667@debbugs.gnu.org)
878r2oc5tx.fsf@lapenas.dev
Dropping this here, if anyone still needs it. Still looking how would I
go to send a merge request or a patch. Also as I see this might just be
a duplication of work with Isaac van Bakel. Sorry about that.

#+BEGIN_SRC Guile
(define-module (packages sway)
#:use-module (guix packages)
#:use-module (gnu packages base)
#:use-module (guix download)
#:use-module (guix build-system copy)
#:use-module (guix git-download)
#:use-module (gnu packages wm)
#:use-module (gnu packages image)
#:use-module (gnu packages web)
#:use-module (gnu packages gnome)
#:use-module (gnu packages xdisorg)
#:use-module (gnu packages man)
#:use-module (guix gexp)
#:use-module (guix utils)
#:use-module ((guix licenses) #:prefix license:))

(define-public grimshot
(package
(name "grimshot")
(version "1.9-contrib.0")
(source (origin
(method git-fetch)
(uri (git-reference
(commit version)))
(sha256
(base32
"16fa8l81zjy25nsky1i525hb7zjprqz74mbirm9b76pvksschdv5"))))
(build-system copy-build-system)
(arguments
(list #:install-plan #~`(("grimshot" "bin/")
("grimshot.1" "share/man/man1/"))
#:phases #~(modify-phases %standard-phases
(add-after 'chdir 'patch-script-dependencies
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "grimshot"
(("\\b(date|grim|jq|notify-send|slurp|swaymsg|wl-copy)\\b"
_ binary)
(search-input-file
inputs (string-append "bin/" binary))))))
(add-after 'patch-script-dependencies 'build-man-page
(lambda _
(with-input-from-file "grimshot.1.scd"
(lambda _
(with-output-to-file "grimshot.1"
(lambda _
(invoke "scdoc"))))))))))
(native-inputs (list scdoc))
(inputs (list coreutils
grim
jq
libnotify
slurp
sway
wl-clipboard))
(synopsis "Screenshot utility for the Sway window manager")
(description "Grimshot is a screenshot utility for @code{sway}. It provides
an interface over @code{grim}, @code{slurp} and @code{jq}, and supports storing
the screenshot either directly to the clipboard using @code{wl-copy} or to a
file.")
(license license:expat)))
#+END_SRC scm

--
Best regards,
Ignas Lap?nas
H
H
Hilton Chain wrote on 17 Mar 02:05 +0100
(name . chris)(address . chris@bumblehead.com)
87ttl5llay.wl-hako@ultrarare.space
Hi,

On Mon, 11 Mar 2024 13:40:31 +0800,
chris wrote:
Toggle quote (3 lines)
>
> All issues were resolved by removing grimshot and wlgreet

Fixed grimshot and wlgreet with fcf0fc0f33e6fc4ac96e585db5b048be620c3438 and
edfb05e16d409ab71f5cc5c91747b693f0054d59.

Thanks for reporting!
Closed
?