[PATCH] gnu: Add go-github-com-whyrusleeping-go-sysinfo.

  • Done
  • quality assurance status badge
Details
2 participants
  • Artyom V. Poptsov
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Artyom V. Poptsov
Severity
normal

Debbugs page

Artyom V. Poptsov wrote 1 years ago
(address . guix-patches@gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
06fefad7396d0e3eac5322eca446cb8a8d7649b2.1709936515.git.poptsov.artyom@gmail.com
* gnu/packages/golang-xyz.scm (go-github-com-whyrusleeping-go-sysinfo): New
variable.

Change-Id: I73cd3fa1ab3a73545121bb3a047795ca2850c0f7
---
gnu/packages/golang-xyz.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 0b3db6e379..f46edd3768 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -1685,6 +1685,28 @@ (define-public go-github-com-vividcortex-ewma
weighted moving averages}.")
(license license:expat)))
+(define-public go-github-com-whyrusleeping-go-sysinfo
+ (package
+ (name "go-github-com-whyrusleeping-go-sysinfo")
+ (version "0.0.0-20190219211824-4a357d4b90b1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/whyrusleeping/go-sysinfo")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0s6yjp9incc579wbbga33vq0hcanv8j2xh9l90ya0r4fihz39jiq"))))
+ (build-system go-build-system)
+ (inputs (list go-github-com-dustin-go-humanize))
+ (arguments
+ '(#:import-path "github.com/whyrusleeping/go-sysinfo"))
+ (home-page "https://github.com/whyrusleeping/go-sysinfo")
+ (synopsis "Package to extract system information")
+ (description "Package to extract system information.")
+ (license license:expat)))
+
(define-public go-go-uber-org-automaxprocs
(package
(name "go-go-uber-org-automaxprocs")

base-commit: 09346fd05f19da3846635e1a0f1c844050d59f26
--
2.41.0
Sharlatan Hellseher wrote 1 years ago
(address . 69658@debbugs.gnu.org)
CAO+9K5pq-+kE9inj7N-gw7EujsxYYXj=jgT66yko_2E0prWOVg@mail.gmail.com
Hi,

Thank you for the patch.

I know it's hard with some golang module documentation but try to
add a little bit more info in package description than it's in synopsis.

I started reviewing aggregated patches related to golang.

Thanks,
Oleg
Attachment: file
Sharlatan Hellseher wrote 12 months ago
(address . 69658-done@debbugs.gnu.org)
87frwpiuiy.fsf@gmail.com
Hi,

I've adjusted descripton and checked the project status

Pushed as 85c816c7ad0c9486fe71c72a5c15d6e625da7458 to master

--
Oleg
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmX2NfUACgkQdtcnv/Ys
0rVr2g//Wk3jXV5DKcjN5csqKoYT1W8Syj7PwArjap99yVe6/QHrK9VWEp8Q8GeB
ylC5yB7E7BIblo95HPhG/41p4et9zxqyoekzxJFF1XA05iiLeGlyBqGqfdDGXZ8S
rfrNxDu61nLQigd57aBZ00udIEzyGaYjH9VC2+ilRsUcX+MX3y3qNoDvOffHsx2Q
PHyknLJquJH7A67JD14O9TPe7jPyLHIcteLntmlU5Ew1ZooQq2CRpZazyAv+z1Q4
zqcCZC/nVCDRLnhn+0oUTqxiTgyFBT0E1XVcqZfmYxL2HicljbI5p1VLZcGoYHMj
qboyl2zIIRZIdLlabBOhr31ukX1TOSrTPD5m/kZfiNmY5R0KNjl1E3njXGQZVGbp
baT52ZNXZsBJas/yi5XDtpDI+QJ05xJAgPwV/DBEAe1bo9pu1kdfASGEYZBoubC7
fSgabyg2NxTkbQyehR7XYdK1qG9BD2i377QefAIp1HGj8iCB3O3Arakp7eNrrQP7
1i1fX/DwAbJ7MofHoT+c/6NXgO8reY+0kawqH8TsVQroMpqchfbsHOWERV4k9wIn
mKPIxz/bAYAB/aW9ET+Gj2s7ZYuLoTzN3uh2yZ2WSBvV2tVfyj9pN+c9iIoLa/J1
XhUL9S53LTosf+5mNLYefwI6JgirjKddPiXzd0s8PdoyD+Dnqm0=
=xEwS
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 69658@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 69658
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help