[PATCH 0/3] Add go-github-com-jbenet packages.

  • Done
  • quality assurance status badge
Details
2 participants
  • Artyom V. Poptsov
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Artyom V. Poptsov
Severity
normal

Debbugs page

Artyom V. Poptsov wrote 1 years ago
(address . guix-patches@gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
cover.1709921226.git.poptsov.artyom@gmail.com
This patch series adds some go-github-com-jbenet packages that are required
for the newer Kubo (IPFS) versions.

Artyom V. Poptsov (3):
gnu: Add go-github-com-jbenet-goprocess.
gnu: Add go-github-com-jbenet-go-temp-err-catcher.
gnu: Add go-github-com-jbenet-go-random.

gnu/packages/golang-xyz.scm | 73 +++++++++++++++++++++++++++++++++++++
1 file changed, 73 insertions(+)


base-commit: 8b0500729754e208bff983563bfe60836de9f30b
--
2.41.0
Artyom V. Poptsov wrote 1 years ago
[PATCH 1/3] gnu: Add go-github-com-jbenet-goprocess.
(address . 69654@debbugs.gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
bf6398d3694c7518c3ce660362cdde950a828820.1709921226.git.poptsov.artyom@gmail.com
* gnu/packages/golang-xyz.scm (go-github-com-jbenet-goprocess): New variable.

Change-Id: I5683a9e0df7bb1a17b2e813ab6c611f0b6c2ea9c
---
gnu/packages/golang-xyz.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 0b3db6e379..7e71dca14c 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -987,6 +987,32 @@ (define-public go-github-com-hhrutter-tiff
@end itemize")
(license license:bsd-3)))
+(define-public go-github-com-jbenet-goprocess
+ (package
+ (name "go-github-com-jbenet-goprocess")
+ (version "0.1.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jbenet/goprocess")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1z4a5skx9kh2c727pc6zz0vhf9v8acd320s7z0f1kwy3y1nbdhjk"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/jbenet/goprocess"))
+ (home-page "https://github.com/jbenet/goprocess")
+ (synopsis "Manage process life cycles in Go")
+ (description
+ "@code{goprocess} introduces a way to manage process lifecycles in
+Go. It is much like @code{go.net/context} (it actually uses a Context), but it is
+more like a Context-WaitGroup hybrid. @code{goprocess} is about being able to start
+and stop units of work, which may receive @code{Close} signals from many clients.")
+ (license license:expat)))
+
(define-public go-github-com-jinzhu-copier
(package
(name "go-github-com-jinzhu-copier")
--
2.41.0
Artyom V. Poptsov wrote 1 years ago
[PATCH 2/3] gnu: Add go-github-com-jbenet-go-temp-err-catcher.
(address . 69654@debbugs.gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
55a8d1f5c009cb85b432735a0c228eb49b2eff55.1709921226.git.poptsov.artyom@gmail.com
* gnu/packages/golang-xyz.scm (go-github-com-jbenet-go-temp-err-catcher): New
variable.

Change-Id: Ic92f036cb9f45a8f55872a218aa42e18716cc2b9
---
gnu/packages/golang-xyz.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 7e71dca14c..979e964a03 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -987,6 +987,29 @@ (define-public go-github-com-hhrutter-tiff
@end itemize")
(license license:bsd-3)))
+(define-public go-github-com-jbenet-go-temp-err-catcher
+ (package
+ (name "go-github-com-jbenet-go-temp-err-catcher")
+ (version "0.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jbenet/go-temp-err-catcher")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0n482jhh6jwq43jj21xkq8grqzx78hjh7f44p0q3n01zp1dsh97r"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/jbenet/go-temp-err-catcher"))
+ (home-page "https://github.com/jbenet/go-temp-err-catcher")
+ (synopsis "Error handling helper library")
+ (description "Package @code{temperrcatcher} provides a @code{TempErrCatcher}
+object, which implements simple error-retrying functionality.")
+ (license license:expat)))
+
(define-public go-github-com-jbenet-goprocess
(package
(name "go-github-com-jbenet-goprocess")
--
2.41.0
Artyom V. Poptsov wrote 1 years ago
[PATCH 3/3] gnu: Add go-github-com-jbenet-go-random.
(address . 69654@debbugs.gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
66625927bafff017daebf5161356ce3901c82d42.1709921226.git.poptsov.artyom@gmail.com
* gnu/packages/golang-xyz.scm (go-github-com-jbenet-go-random): New variable.

Change-Id: I7b7f510af61f4bf79aa633ffaa4bd4852f55fc47
---
gnu/packages/golang-xyz.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 979e964a03..7af3193f14 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -987,6 +987,30 @@ (define-public go-github-com-hhrutter-tiff
@end itemize")
(license license:bsd-3)))
+(define-public go-github-com-jbenet-go-random
+ (package
+ (name "go-github-com-jbenet-go-random")
+ (version "0.0.0-20190219211222-123a90aedc0c")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jbenet/go-random")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0kgx19m8p76rmin8s8y6j1padciv1dx37qzy7jkh9bw49ai3haw3"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/jbenet/go-random"))
+ (home-page "https://github.com/jbenet/go-random")
+ (synopsis "Go library and a program that outputs randomness")
+ (description
+ "This is a Unix utility that outputs randomness. It is a thin
+wrapper around @code{crypto/rand}.")
+ (license license:expat)))
+
(define-public go-github-com-jbenet-go-temp-err-catcher
(package
(name "go-github-com-jbenet-go-temp-err-catcher")
--
2.41.0
Sharlatan Hellseher wrote 12 months ago
[PATCH 0/3] Add go-github-com-jbenet packages.
(address . 69654-done@debbugs.gnu.org)
87il1liulj.fsf@gmail.com
Hi,

Pushed as af714ebcee..e1e65c5930 to master.

--
Oleg
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmX2NZgACgkQdtcnv/Ys
0rUYuw//a4Fk1cYJzBiVw74/pCiNYd8c7LFC/LQ2PC5AmkRZld6XEudKg8gDEZEq
GvJ8Be5YJ2jZsaGw3sk/smcRVDzWwmpqGh5rg/fCjzOqaTfO0A3zD2pZ9TixSrAc
IcUL6XqRgcvKLQqXnL6gw7csTZL73i0BpzHpJvAFJWRc89S3jELImCGP+qU+BF6+
YxeZxo4Pa5HP9Xxryw0744igeCCz0HDxLckp3xvDfpe5lEqcvBC8+XJ9SbuQDo+w
fg36ZmMCuK/nAFZRCbl8mmY7m9bchyrk5K4PFnUSqBylNB4ImPHjm9Q1rEms7NfP
J4NT9Yg7cB+xB5j0JthPTk2A9C80EoK3YFcKS/Y9/ELxujGU9fLlCAyZWihwQKI9
NVVPw5fIqevpkhELBFGhH74lwFIzb6NMEAZaSeXfIiHRAV7m4ILvjcPSkH12U9jc
rpyfuuoFiqbW8kzuZt6Mh9PjcR1xKCGnr1qarpQYJeD7jKlycIxIq6IxEhqXQ5hQ
+4pYyLV0hLhJ7fhEwbwGW6vfcTmdybDas8LCZzGhscLUBultU1kqdNc9BoNGFsX+
WDq7x9IkfoEnofUvdhpx+UIlihHsI6BuYi1ocvKUoEp3UnzHzxQ/g92D9e2XVnws
3w3j7Qf6+cdoRz7bIs1rU9tjz0TmDOX8p1JdU+/0uCkcyhqab2E=
=ONlo
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 69654@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 69654
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help