[PATCH gnome-team 0/1] What should we do with orbit2?

  • Done
  • quality assurance status badge
Details
4 participants
  • Aaron Covrig
  • Liliana Marie Prikler
  • Maxim Cournoyer
  • Vivien Kraus
Owner
unassigned
Submitted by
Vivien Kraus
Severity
normal

Debbugs page

Vivien Kraus wrote 1 years ago
(address . guix-patches@gnu.org)
cover.1709918975.git.vivien@planete-kraus.eu
Dear Guix,

Orbit2 is an old, unmaintained package that was used for the Gtk+2 stack, as
far as I understand. We still have Gtk+2 around, mainly for OCaml lablgtk2
(and _3, yes).

On gnome-team, this package fails to build on 32-bit systems. I fail to
understand why it would fail on gnome-team and not on master. If I
understood, maybe a clear solution would appear. As of now, I can see
different mitigations:
— pretend there is no problem, skip the failing tests (they are everywhere, so
maybe skip tests entirely) and ship it;
— remove it (I can’t see it on Debian, for instance);
— fix the test crashes (I won’t, and it is unmaintained);
— mark it as unsupported.

I went with the last option because I feel it is the most neutral thing to do.

What do you think?

Best regards,

Vivien

Vivien Kraus (1):
gnu: orbit2: Mark it unsupported in 32-bits systems.

gnu/packages/gnome.scm | 53 ++++++++++++++++++++++--------------------
1 file changed, 28 insertions(+), 25 deletions(-)


base-commit: 25c14c893f05019d746321285acf55d1aa65b943
--
2.41.0
Vivien Kraus wrote 1 years ago
[PATCH gnome-team 1/1] gnu: orbit2: Mark it unsupported in 32-bits systems.
(address . 69652@debbugs.gnu.org)
f4d66a6dd79c865b94a50523f6c4464399e13389.1709918975.git.vivien@planete-kraus.eu
* gnu/packages/gnome.scm (orbit2) [supported-systems]: New field.
[arguments]: Convert to list of G-Expressions.

Change-Id: I55766c43e7abc703815c30dccf38faf640ffc07e
---
gnu/packages/gnome.scm | 53 ++++++++++++++++++++++--------------------
1 file changed, 28 insertions(+), 25 deletions(-)

Toggle diff (69 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 13cad0add2..711890d617 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -3798,34 +3798,37 @@ (define-public orbit2
(sha256
(base32
"0l3mhpyym9m5iz09fz0rgiqxl2ym6kpkwpsp1xrr4aa80nlh1jam"))))
+ ;; Many tests fail on 32-bit systems.
+ (supported-systems %64bit-supported-systems)
(build-system gnu-build-system)
(arguments
- `(;; The "timeout-server" test hangs when run in parallel.
- #:parallel-tests? #f
- #:configure-flags
- '(;; We don't need static libraries, plus they don't build reproducibly
- ;; (non-deterministic ordering of .o files in the archive.)
- "--disable-static"
-
- ;; The programmer kindly gives us a hook to turn off deprecation
- ;; warnings ...
- "DISABLE_DEPRECATED_CFLAGS=-DGLIB_DISABLE_DEPRECATION_WARNINGS")
- ;; ... which they then completly ignore !!
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'fix-parallel-build
- ;; Parallel build fails because of a failed dependency,
- ;; https://bugzilla.gnome.org/show_bug.cgi?id=732274
- (lambda _
- (substitute* "src/services/name/Makefile.am"
- (("orbit_name_server_2_DEPENDENCIES = \\$(DEPS) CosNaming.h")
- "orbit_name_server_2_DEPENDENCIES = \
+ (list
+ ;; The "timeout-server" test hangs when run in parallel.
+ #:parallel-tests? #f
+ #:configure-flags
+ #~'(;; We don't need static libraries, plus they don't build reproducibly
+ ;; (non-deterministic ordering of .o files in the archive.)
+ "--disable-static"
+
+ ;; The programmer kindly gives us a hook to turn off deprecation
+ ;; warnings ...
+ "DISABLE_DEPRECATED_CFLAGS=-DGLIB_DISABLE_DEPRECATION_WARNINGS")
+ ;; ... which they then completly ignore !!
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'fix-parallel-build
+ ;; Parallel build fails because of a failed dependency,
+ ;; https://bugzilla.gnome.org/show_bug.cgi?id=732274
+ (lambda _
+ (substitute* "src/services/name/Makefile.am"
+ (("orbit_name_server_2_DEPENDENCIES = \\$(DEPS) CosNaming.h")
+ "orbit_name_server_2_DEPENDENCIES = \
$(DEPS) CosNaming.h libname-server-2.a"))))
- (add-before 'configure 'ignore-deprecations
- (lambda _
- (substitute* "linc2/src/Makefile.in"
- (("-DG_DISABLE_DEPRECATED")
- "-DGLIB_DISABLE_DEPRECATION_WARNINGS")))))))
+ (add-before 'configure 'ignore-deprecations
+ (lambda _
+ (substitute* "linc2/src/Makefile.in"
+ (("-DG_DISABLE_DEPRECATED")
+ "-DGLIB_DISABLE_DEPRECATION_WARNINGS")))))))
(inputs (list glib libidl))
(native-inputs
(list pkg-config))
--
2.41.0
Liliana Marie Prikler wrote 1 years ago
21fccba3ffea43414af7d8d441e03689ad41474b.camel@gmail.com
Am Freitag, dem 08.03.2024 um 18:20 +0100 schrieb Vivien Kraus:
Toggle quote (20 lines)
> * gnu/packages/gnome.scm (orbit2) [supported-systems]: New field.
> [arguments]: Convert to list of G-Expressions.
>
> Change-Id: I55766c43e7abc703815c30dccf38faf640ffc07e
> ---
>  gnu/packages/gnome.scm | 53 ++++++++++++++++++++++------------------
> --
>  1 file changed, 28 insertions(+), 25 deletions(-)
>
> diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
> index 13cad0add2..711890d617 100644
> --- a/gnu/packages/gnome.scm
> +++ b/gnu/packages/gnome.scm
> @@ -3798,34 +3798,37 @@ (define-public orbit2
>                (sha256
>                 (base32
>                 
> "0l3mhpyym9m5iz09fz0rgiqxl2ym6kpkwpsp1xrr4aa80nlh1jam"))))
> +    ;; Many tests fail on 32-bit systems.
> +    (supported-systems %64bit-supported-systems)
Prefer the “disable-failing-tests” pattern, but first investigate why
they fail. Note that this would make icecat and icedove 64-bit only
(that is if Rust doesn't do so already).
Toggle quote (63 lines)
>      (build-system gnu-build-system)
>      (arguments
> -     `(;; The "timeout-server" test hangs when run in parallel.
> -       #:parallel-tests? #f
> -       #:configure-flags
> -       '(;; We don't need static libraries, plus they don't build
> reproducibly
> -         ;; (non-deterministic ordering of .o files in the archive.)
> -         "--disable-static"
> -
> -         ;; The programmer kindly gives us a hook to turn off
> deprecation
> -         ;; warnings ...
> -         "DISABLE_DEPRECATED_CFLAGS=-
> DGLIB_DISABLE_DEPRECATION_WARNINGS")
> -       ;; ... which they then completly ignore !!
> -       #:phases
> -       (modify-phases %standard-phases
> -         (add-after 'unpack 'fix-parallel-build
> -           ;; Parallel build fails because of a failed dependency,
> -           ;; https://bugzilla.gnome.org/show_bug.cgi?id=732274
> -           (lambda _
> -             (substitute* "src/services/name/Makefile.am"
> -               (("orbit_name_server_2_DEPENDENCIES = \\$(DEPS)
> CosNaming.h")
> -                "orbit_name_server_2_DEPENDENCIES = \
> +     (list
> +      ;; The "timeout-server" test hangs when run in parallel.
> +      #:parallel-tests? #f
> +      #:configure-flags
> +      #~'(;; We don't need static libraries, plus they don't build
> reproducibly
> +          ;; (non-deterministic ordering of .o files in the
> archive.)
> +          "--disable-static"
> +
> +          ;; The programmer kindly gives us a hook to turn off
> deprecation
> +          ;; warnings ...
> +          "DISABLE_DEPRECATED_CFLAGS=-
> DGLIB_DISABLE_DEPRECATION_WARNINGS")
> +      ;; ... which they then completly ignore !!
> +      #:phases
> +      #~(modify-phases %standard-phases
> +          (add-after 'unpack 'fix-parallel-build
> +            ;; Parallel build fails because of a failed dependency,
> +            ;; https://bugzilla.gnome.org/show_bug.cgi?id=732274
> +            (lambda _
> +              (substitute* "src/services/name/Makefile.am"
> +                (("orbit_name_server_2_DEPENDENCIES = \\$(DEPS)
> CosNaming.h")
> +                 "orbit_name_server_2_DEPENDENCIES = \
>  $(DEPS) CosNaming.h libname-server-2.a"))))
> -         (add-before 'configure 'ignore-deprecations
> -           (lambda _
> -             (substitute* "linc2/src/Makefile.in"
> -               (("-DG_DISABLE_DEPRECATED")
> -                "-DGLIB_DISABLE_DEPRECATION_WARNINGS")))))))
> +          (add-before 'configure 'ignore-deprecations
> +            (lambda _
> +              (substitute* "linc2/src/Makefile.in"
> +                (("-DG_DISABLE_DEPRECATED")
> +                 "-DGLIB_DISABLE_DEPRECATION_WARNINGS")))))))
What changes in this hunk?

Cheers
Vivien Kraus wrote 1 years ago
bb4f05a0cf5eabd3035ee3cf679d189f06b41ffb.camel@planete-kraus.eu
Le vendredi 08 mars 2024 à 20:11 +0100, Liliana Marie Prikler a écrit :
Toggle quote (4 lines)
> Prefer the “disable-failing-tests” pattern, but first investigate why
> they fail.  Note that this would make icecat and icedove 64-bit only
> (that is if Rust doesn't do so already).

Rust has already been introduced in both.

Toggle quote (13 lines)
> > $(DEPS) CosNaming.h libname-server-2.a"))))
> > - (add-before 'configure 'ignore-deprecations
> > - (lambda _
> > - (substitute* "linc2/src/Makefile.in"
> > - (("-DG_DISABLE_DEPRECATED")
> > - "-DGLIB_DISABLE_DEPRECATION_WARNINGS")))))))
> > + (add-before 'configure 'ignore-deprecations
> > + (lambda _
> > + (substitute* "linc2/src/Makefile.in"
> > + (("-DG_DISABLE_DEPRECATED")
> > + "-DGLIB_DISABLE_DEPRECATION_WARNINGS")))))))
> What changes in this hunk?
>
It’s hard to see, but the indentation changed. Should it be ignored?
Liliana Marie Prikler wrote 1 years ago
f7ca81780c50140f904498a4302040029d76bf5f.camel@gmail.com
Am Freitag, dem 08.03.2024 um 21:03 +0100 schrieb Vivien Kraus:
Toggle quote (7 lines)
> Le vendredi 08 mars 2024 à 20:11 +0100, Liliana Marie Prikler a
> écrit :
> > Prefer the “disable-failing-tests” pattern, but first investigate
> > why they fail.  Note that this would make icecat and icedove 64-bit
> > only (that is if Rust doesn't do so already).
>
> Rust has already been introduced in both.
I'd still like to avoid overconstraining if possible.

Toggle quote (14 lines)
> > >  $(DEPS) CosNaming.h libname-server-2.a"))))
> > > -         (add-before 'configure 'ignore-deprecations
> > > -           (lambda _
> > > -             (substitute* "linc2/src/Makefile.in"
> > > -               (("-DG_DISABLE_DEPRECATED")
> > > -                "-DGLIB_DISABLE_DEPRECATION_WARNINGS")))))))
> > > +          (add-before 'configure 'ignore-deprecations
> > > +            (lambda _
> > > +              (substitute* "linc2/src/Makefile.in"
> > > +                (("-DG_DISABLE_DEPRECATED")
> > > +                 "-DGLIB_DISABLE_DEPRECATION_WARNINGS")))))))
> > What changes in this hunk?
> >
> It’s hard to see, but the indentation changed.  Should it be ignored?
Rather, the cosmetic change should be separated from the semantic
change.

Cheers
Vivien Kraus wrote 1 years ago
[PATCH gnome-team v2 0/3] FIX that damn orbit2
(address . 69652@debbugs.gnu.org)
cover.1709974034.git.vivien@planete-kraus.eu
Dear Guix,

Our new glib was the first to not let orbit2 get away with terrible bad
practice. I explained the situation in the patch.

Best regards,

Vivien

Vivien Kraus (3):
gnu: orbit2: Update style.
gnu: orbit2: Propagate inputs.
gnu: orbit2: Fix bug on 32-bit systems.

gnu/local.mk | 1 +
gnu/packages/gnome.scm | 61 ++++++++++---------
.../orbit2-fix-array-allocation-32bit.patch | 40 ++++++++++++
3 files changed, 73 insertions(+), 29 deletions(-)
create mode 100644 gnu/packages/patches/orbit2-fix-array-allocation-32bit.patch


base-commit: 25c14c893f05019d746321285acf55d1aa65b943
--
2.41.0
Vivien Kraus wrote 1 years ago
[PATCH gnome-team v2 1/3] gnu: orbit2: Update style.
(address . 69652@debbugs.gnu.org)
1a1cf98038cc19b4212b055f74cf0bb9858d52cb.1709974034.git.vivien@planete-kraus.eu
* gnu/packages/gnome.scm (orbit2) [arguments]: Convert to list of G-Expressions.
[native-inputs]: Write the native-input list on one line.

Change-Id: I6a09616719c07cbb48195cf0c59d8b799c404d47
---
gnu/packages/gnome.scm | 54 +++++++++++++++++++++---------------------
1 file changed, 27 insertions(+), 27 deletions(-)

Toggle diff (69 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 13cad0add2..fa911e1e59 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -3800,35 +3800,35 @@ (define-public orbit2
"0l3mhpyym9m5iz09fz0rgiqxl2ym6kpkwpsp1xrr4aa80nlh1jam"))))
(build-system gnu-build-system)
(arguments
- `(;; The "timeout-server" test hangs when run in parallel.
- #:parallel-tests? #f
- #:configure-flags
- '(;; We don't need static libraries, plus they don't build reproducibly
- ;; (non-deterministic ordering of .o files in the archive.)
- "--disable-static"
-
- ;; The programmer kindly gives us a hook to turn off deprecation
- ;; warnings ...
- "DISABLE_DEPRECATED_CFLAGS=-DGLIB_DISABLE_DEPRECATION_WARNINGS")
- ;; ... which they then completly ignore !!
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'fix-parallel-build
- ;; Parallel build fails because of a failed dependency,
- ;; https://bugzilla.gnome.org/show_bug.cgi?id=732274
- (lambda _
- (substitute* "src/services/name/Makefile.am"
- (("orbit_name_server_2_DEPENDENCIES = \\$(DEPS) CosNaming.h")
- "orbit_name_server_2_DEPENDENCIES = \
+ (list
+ ;; The "timeout-server" test hangs when run in parallel.
+ #:parallel-tests? #f
+ #:configure-flags
+ #~'(;; We don't need static libraries, plus they don't build reproducibly
+ ;; (non-deterministic ordering of .o files in the archive.)
+ "--disable-static"
+
+ ;; The programmer kindly gives us a hook to turn off deprecation
+ ;; warnings ...
+ "DISABLE_DEPRECATED_CFLAGS=-DGLIB_DISABLE_DEPRECATION_WARNINGS")
+ ;; ... which they then completly ignore !!
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'fix-parallel-build
+ ;; Parallel build fails because of a failed dependency,
+ ;; https://bugzilla.gnome.org/show_bug.cgi?id=732274
+ (lambda _
+ (substitute* "src/services/name/Makefile.am"
+ (("orbit_name_server_2_DEPENDENCIES = \\$(DEPS) CosNaming.h")
+ "orbit_name_server_2_DEPENDENCIES = \
$(DEPS) CosNaming.h libname-server-2.a"))))
- (add-before 'configure 'ignore-deprecations
- (lambda _
- (substitute* "linc2/src/Makefile.in"
- (("-DG_DISABLE_DEPRECATED")
- "-DGLIB_DISABLE_DEPRECATION_WARNINGS")))))))
+ (add-before 'configure 'ignore-deprecations
+ (lambda _
+ (substitute* "linc2/src/Makefile.in"
+ (("-DG_DISABLE_DEPRECATED")
+ "-DGLIB_DISABLE_DEPRECATION_WARNINGS")))))))
(inputs (list glib libidl))
- (native-inputs
- (list pkg-config))
+ (native-inputs (list pkg-config))
(home-page "https://projects.gnome.org/orbit2/")
(synopsis "CORBA 2.4-compliant Object Request Broker")
(description "ORBit2 is a CORBA 2.4-compliant Object Request Broker (orb)
--
2.41.0
Vivien Kraus wrote 1 years ago
[PATCH gnome-team v2 2/3] gnu: orbit2: Propagate inputs.
(address . 69652@debbugs.gnu.org)
935981c3a5355ceef31396031da7fa37a4bf920f.1709974034.git.vivien@planete-kraus.eu
* gnu/packages/gnome.scm (orbit2) [inputs]: Move to 'propagated-inputs'.

Change-Id: I09e613cb4fee7962c50f62459ad6272bb7ffaea4
---
gnu/packages/gnome.scm | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index fa911e1e59..8b69a231af 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -3827,7 +3827,8 @@ (define-public orbit2
(substitute* "linc2/src/Makefile.in"
(("-DG_DISABLE_DEPRECATED")
"-DGLIB_DISABLE_DEPRECATION_WARNINGS")))))))
- (inputs (list glib libidl))
+ ;; These are required in the installed pkg-config files.
+ (propagated-inputs (list glib libidl))
(native-inputs (list pkg-config))
(home-page "https://projects.gnome.org/orbit2/")
(synopsis "CORBA 2.4-compliant Object Request Broker")
--
2.41.0
Vivien Kraus wrote 1 years ago
[PATCH gnome-team v2 3/3] gnu: orbit2: Fix bug on 32-bit systems.
(address . 69652@debbugs.gnu.org)
6bb82d56807c366da0609ea763a01b18205baf2b.1709974034.git.vivien@planete-kraus.eu
* gnu/packages/patches/orbit2-fix-array-allocation-32bit.patch: New file.
* gnu/local.mk (dist_patch_DATA): Register it here.
* gnu/packages/gnome.scm (orbit2): Use it here.

Change-Id: I72e10fc9d8a5421a7ec6b4ccf1425008b322ea3f
---
gnu/local.mk | 1 +
gnu/packages/gnome.scm | 4 +-
.../orbit2-fix-array-allocation-32bit.patch | 40 +++++++++++++++++++
3 files changed, 44 insertions(+), 1 deletion(-)
create mode 100644 gnu/packages/patches/orbit2-fix-array-allocation-32bit.patch

Toggle diff (75 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index dcd320fec4..9fbfc754a0 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1781,6 +1781,7 @@ dist_patch_DATA = \
%D%/packages/patches/opentaxsolver-file-browser-fix.patch \
%D%/packages/patches/open-zwave-hidapi.patch \
%D%/packages/patches/orangeduck-mpc-fix-pkg-config.patch \
+ %D%/packages/patches/orbit2-fix-array-allocation-32bit.patch \
%D%/packages/patches/orpheus-cast-errors-and-includes.patch \
%D%/packages/patches/osip-CVE-2017-7853.patch \
%D%/packages/patches/ots-no-include-missing-file.patch \
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 8b69a231af..103065141e 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -3797,7 +3797,9 @@ (define-public orbit2
upstream-name "-" version ".tar.bz2")))
(sha256
(base32
- "0l3mhpyym9m5iz09fz0rgiqxl2ym6kpkwpsp1xrr4aa80nlh1jam"))))
+ "0l3mhpyym9m5iz09fz0rgiqxl2ym6kpkwpsp1xrr4aa80nlh1jam"))
+ (patches
+ (search-patches "orbit2-fix-array-allocation-32bit.patch"))))
(build-system gnu-build-system)
(arguments
(list
diff --git a/gnu/packages/patches/orbit2-fix-array-allocation-32bit.patch b/gnu/packages/patches/orbit2-fix-array-allocation-32bit.patch
new file mode 100644
index 0000000000..377c09d0a5
--- /dev/null
+++ b/gnu/packages/patches/orbit2-fix-array-allocation-32bit.patch
@@ -0,0 +1,40 @@
+From 28067b88ad91e794675734bc92bd9c8653b4a46a Mon Sep 17 00:00:00 2001
+Message-ID: <28067b88ad91e794675734bc92bd9c8653b4a46a.1709973702.git.vivien@planete-kraus.eu>
+From: Vivien Kraus <vivien@planete-kraus.eu>
+Date: Sat, 9 Mar 2024 09:36:56 +0100
+Subject: [PATCH] corba-loc: Do not allocate more tokens than necessary.
+
+To split the list of locations, the code calls g_strsplit with the
+last argument set to G_MAXINT. It means that g_strsplit will try to
+allocate a huge array (G_MAXINT + 1, for the final NULL), mostly
+filled with NULL. Unfortunately, on 32-bit systems, this is one past
+the authorized length for an array. Previous versions of glib would
+not care, but the new version now raises an error if this happens.
+
+To get an array of the appropriate size, we can just pass -1 to the
+last argument.
+
+* src/orb/orb-core/corba-loc.c (ORBit_corbaloc_parse): Replace
+G_MAXINT with -1.
+---
+ src/orb/orb-core/corba-loc.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/orb/orb-core/corba-loc.c b/src/orb/orb-core/corba-loc.c
+index abfcaa29..6492d392 100644
+--- a/src/orb/orb-core/corba-loc.c
++++ b/src/orb/orb-core/corba-loc.c
+@@ -309,7 +309,7 @@ ORBit_corbaloc_parse (const gchar *corbaloc)
+ if (!(objkey = orbit_url_decode (okey)))
+ goto ret_error;
+
+- if (!(token = g_strsplit (loc, ",", G_MAXINT)))
++ if (!(token = g_strsplit (loc, ",", -1)))
+ goto ret_error;
+
+ /* [ 'iiop' ] ':' [ '//' ] [ version '@' ] host [ ':' port ] */
+
+base-commit: 144be2e9860286c83f009e7689250e0af977cc5e
+--
+2.41.0
+
--
2.41.0
Aaron Covrig wrote 1 years ago
[PATCH gnome-team 0/1] What should we do with orbit2?
(address . 69652@debbugs.gnu.org)
CAK7qAcQ2YZgX5s+4aLkaoEQs=nPPrM+yisbQ16wDLERyeKm6gg@mail.gmail.com
Is the version of glib on the gnome branch different from that on the
master branch? If so, what happens if you pin to the version on master?

Aaron
Attachment: file
Maxim Cournoyer wrote 1 years ago
Re: [PATCH gnome-team v2 0/3] FIX that damn orbit2
(name . Vivien Kraus)(address . vivien@planete-kraus.eu)
87o7bnfg5l.fsf@gmail.com
Hi!

Vivien Kraus <vivien@planete-kraus.eu> writes:

Toggle quote (16 lines)
> Dear Guix,
>
> Our new glib was the first to not let orbit2 get away with terrible bad
> practice. I explained the situation in the patch.
>
> Best regards,
>
> Vivien
>
> Vivien Kraus (3):
> gnu: orbit2: Update style.
> gnu: orbit2: Propagate inputs.
> gnu: orbit2: Fix bug on 32-bit systems.
>
> gnu/local.mk | 1 +

Reviewed-by: Maxim Cournoyer <maxim.cournoyer@gmail>

--
Thanks,
Maxim
Liliana Marie Prikler wrote 1 years ago
c95b51104ae81f3bcf733001a7afbc6a81e3235d.camel@gmail.com
Am Samstag, dem 09.03.2024 um 12:50 -0500 schrieb Maxim Cournoyer:
Toggle quote (21 lines)
> Hi!
>
> Vivien Kraus <vivien@planete-kraus.eu> writes:
>
> > Dear Guix,
> >
> > Our new glib was the first to not let orbit2 get away with terrible
> > bad practice.  I explained the situation in the patch.
> >
> > Best regards,
> >
> > Vivien
> >
> > Vivien Kraus (3):
> >   gnu: orbit2: Update style.
> >   gnu: orbit2: Propagate inputs.
> >   gnu: orbit2: Fix bug on 32-bit systems.
> >
> >  gnu/local.mk                                  |  1 +
>
> Reviewed-by: Maxim Cournoyer <maxim.cournoyer@gmail>
And pushed.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 69652@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 69652
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help