[PATCH] gnu: Add go-github-com-klauspost-pgzip.

  • Done
  • quality assurance status badge
Details
2 participants
  • Sharlatan Hellseher
  • Troy Figiel
Owner
unassigned
Submitted by
Troy Figiel
Severity
normal

Debbugs page

Troy Figiel wrote 1 years ago
(address . guix-patches@gnu.org)
87h6hgizj1.fsf@troyfigiel.com
* gnu/packages/golang-compression.scm (go-github-com-klauspost-pgzip): New variable.
---
gnu/packages/golang-compression.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/golang-compression.scm b/gnu/packages/golang-compression.scm
index b999c063ee..504491e8e0 100644
--- a/gnu/packages/golang-compression.scm
+++ b/gnu/packages/golang-compression.scm
@@ -140,6 +140,33 @@ (define-public go-github-com-klauspost-compress
(description "@code{compress} provides various compression algorithms.")
(license license:bsd-3)))
+(define-public go-github-com-klauspost-pgzip
+ (package
+ (name "go-github-com-klauspost-pgzip")
+ (version "1.2.6")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/klauspost/pgzip")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1j29wr6nd9ncdbkjphyziv0h8p5s2mj222cgcfqxmzjnfn7623d8"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/klauspost/pgzip"))
+ (propagated-inputs (list go-github-com-klauspost-compress))
+ (home-page "https://github.com/klauspost/pgzip")
+ (synopsis "Parallel (de)compression of gzip files in Go")
+ (description
+ "This package implements parallel gzip compression and decompression in
+Golang and is fully compatible with @code{compress/gzip} from the standard
+library. This is beneficial for large amounts of data, say more than 1MB at a
+time, as otherwise the internal gzip library will likely be faster.")
+ (license (list license:bsd-3 license:expat))))
+
(define-public go-github-com-nwaples-rardecode-v2
(package
(name "go-github-com-nwaples-rardecode-v2")

base-commit: d79c88e8809d2079452fd276bf4d17eb16636ff9
--
2.42.0
Sharlatan Hellseher wrote 12 months ago
(address . 69640-done@debbugs.gnu.org)
878r2hiuec.fsf@gmail.com
Hi,

Pushed as d7e6c3cae0762d6a299162f2d7d8c44ca1390dd7 to master.

--
Oleg
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmX2NpsACgkQdtcnv/Ys
0rU5Dg//VRBZR/hKq57tkRQ/agLtYLKagKeiCLKBlKmNZtaurxTk0O0Eaea1kZEQ
SF3fZapkGZWiELBbqRee6QsViH0NiEK2ZXyZMytBCE6DVdOesri6YnD/bMLoEEgP
BuRWoZOp5r44ZGKi8epdGjVUn4gW7hua1KE8EEFO+M/7IRP+filOy71orom4NK+p
mthOqiLOMZwehR7ZM9AzywXBlaA1tY2mzJuPCBk4tw8S7i7hbXegr1bReh48rvrz
gwZj4SzYkbe3VJz5c76HcufsEqw/pHj8fwc+01AWDz1tz1W3pRvFDqXzsot+UCLs
eawPfwLcnig6wjpoXoIiY15mhAiz+tcf8bSBiUuM8WX19ERLCabFNXHcfgfb0mBF
1r5TA82N4U9ErGT2COHHV27eMajvYGW45F7wEyREzgTs2nJ0/Nlm4hGIs2wzSntN
LAHIfg9n+bHY8TFl/zE9mzYKcvO9kfs+6QurFsKH5qXjLCx7HcNnCdnIQ5vd7mPd
ITPnA3xgU5Ci+7AFXvtRP5Zl6qo89f/y9naSSxgDUZigNgNpZPY591wZvb7mrZf+
Qy8YMTdfpFawZIJ4lbcYgEv5LQ72Wt1Ky7nSD3r+iXnf8x5b2/kfBAPDPSxGKHW4
saaWQ5OU7UHsrZo4wKHaLt5E7zgkGn+U7WFavuXLXvL4WdcByJY=
=4s+g
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 69640@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 69640
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help