[PATCH] gnu: hypre: don't run test phase when tests? is false

  • Done
  • quality assurance status badge
Details
2 participants
  • Efraim Flashner
  • Lars Bilke
Owner
unassigned
Submitted by
Lars Bilke
Severity
normal

Debbugs page

Lars Bilke wrote 1 years ago
(address . guix-patches@gnu.org)(name . Lars Bilke)(address . lars.bilke@ufz.de)
7822b92627251e60d6f107369e0e102dd592c080.1709896091.git.lars.bilke@ufz.de
Without this patch it is not possible to build hypre with --tune on
machines which do not support the architecture to optimize for. The
check phase no honors the tests? property.

Change-Id: I475fabd7d9f73ed320b97a4767830d82190c2b15
---
gnu/packages/maths.scm | 25 +++++++++++++++----------
1 file changed, 15 insertions(+), 10 deletions(-)

Toggle diff (40 lines)
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 1f61ee0583..6b3a5e2e55 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -7135,16 +7135,21 @@ (define-public hypre
(lambda _
(invoke "make" "-C" "docs")))
(replace 'check
- (lambda _
- (setenv "LD_LIBRARY_PATH" (string-append (getcwd) "/hypre/lib"))
- (setenv "PATH" (string-append "." ":" (getenv "PATH")))
- (invoke "make" "check" "CHECKRUN=")
- (for-each (lambda (filename)
- (let ((size (stat:size (stat filename))))
- (when (positive? size)
- (error (format #f "~a size ~d; error indication~%"
- filename size)))))
- (find-files "test" ".*\\.err$"))))
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (setenv "LD_LIBRARY_PATH"
+ (string-append (getcwd) "/hypre/lib"))
+ (setenv "PATH"
+ (string-append "." ":"
+ (getenv "PATH")))
+ (invoke "make" "check" "CHECKRUN=")
+ (for-each (lambda (filename)
+ (let ((size (stat:size (stat filename))))
+ (when (positive? size)
+ (error (format #f
+ "~a size ~d; error indication~%"
+ filename size)))))
+ (find-files "test" ".*\\.err$")))))
(add-after 'install 'install-docs
(lambda* (#:key outputs #:allow-other-keys)
;; Custom install because docs/Makefile doesn't honor ${docdir}.

base-commit: 75bad75367fcf2c289fae3b40dbcc850f92177be
--
2.43.0
Efraim Flashner wrote 1 years ago
(name . Lars Bilke)(address . lars.bilke@ufz.de)
ZfBCajrxMtOG1tIT@3900XT
Thanks. Patch pushed!

--
Efraim Flashner <efraim@flashner.co.il> רנשלפ םירפא
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmXwQmoACgkQQarn3Mo9
g1EEuw//UExbRvDjrrLe55Q9cLTLNeZOMo2M2P+TzsBjMgJumB7fcFcf3YL9xL0c
4EN4+nvSWJMDw31zWNT3+DGYzqyf4DuHTdg8Tr/FVflpOoa1pJClMhQtQkYhbExb
c1zqpHOjWKZzSO12Hh5DHZF6K0Pcbnwg8Vxvlogsi6awFHzLft81wyMUKQWipTTB
vGlamVfDbwj+jsMWeg8/kHg5BI1T01ygHzfE5eMgLq8JF0FqfL6vNzUO4Kf8b94+
tlvDLoHM6nPxZBDQiXu5IFNcn0xnPi3r/hOMzG7ZM5hWRbLObsy5Ax/9Rh1p0bmu
TuqRl6mAo924JaXyP9icX0MlDbbCySTiZERTBHo26GjuLrmsGXm7dxLOC+lQ8dtX
7cneohQtnS+57Q442vU8813jrybodthEynnMKwJwfROlv2t3+Qz8+gMqlKEY2v+7
QOrwCGKESs80XxnisAZS39FMY0burYCsn3vVi55Gm4600hrzWXJUcD2pj33iIAbU
F6EjR0OrquX3sGD/EK8sA751v6Gx60CsjpOD63cKxZvA1M1v7hCkkvOOo25dJeVv
UrwXuulobNbyAfVGMQJG/PUGyiomrCHskQqlWOSyMQcPHkkRxYWaKfahb87LzUo3
hn1fDa9MKPK2XqEgCMWIkpInMKVCCc11px4QA/n9x/fR+E1nIa4=
=5c6N
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 69634@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 69634
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help