Apoorv wrote 1 years ago
(name . Guix Patches)(address . guix-patches@gnu.org)
evil-mode was causing issues because of corfu. Looking around it seems like the issue is because of some change in evil-collection, which in Guix ATM is pretty outdated. So I created this issue on their repo, https://github.com/emacs-evil/evil-collection/issues/786
and they have a new tag up now, I created this patch to update emacs-evil-collection package to the latest tag now.
--
Sent with Tuta; enjoy secure & ad-free emails:
Toggle diff (22 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 7fa5df9202..4093af9747 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -16298,7 +16298,7 @@ (define-public emacs-evil
(define-public emacs-evil-collection
(package
(name "emacs-evil-collection")
- (version "0.0.9")
+ (version "0.0.10")
(source
(origin
(method git-fetch)
@@ -16307,7 +16307,7 @@ (define-public emacs-evil-collection
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "1y1ig4shqaaiiwqm5pv8hvh8ynr6irhffkgmpyzmhdaaicxnfazc"))))
+ (base32 "09hnxb8nh3g0hi93fz9f1y164gv9iyh5994wfn6fsq2v1xdz8phm"))))
(build-system emacs-build-system)
(arguments
(list