[PATCH] gnu: emacs-xyz: Add emacs-xref-union.

  • Done
  • quality assurance status badge
Details
2 participants
  • Daniel Ziltener
  • Nicolas Goaziou
Owner
unassigned
Submitted by
Daniel Ziltener
Severity
normal

Debbugs page

Daniel Ziltener wrote 1 years ago
(address . guix-patches@gnu.org)(address . dziltener@lyrion.ch)
0bac841b57156acb9b121d244e14f953@lyrion.ch
---
gnu/packages/emacs-xyz.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 7d3e2dc17e..d9c4600f34 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -37633,6 +37633,34 @@ (define-public emacs-xref
commands, in particular @code{find-definition}.")
(license license:gpl3+)))
+(define-public emacs-xref-union
+ (package
+ (name "emacs-xref-union")
+ (version "0.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://elpa.gnu.org/packages/xref-union-"
+ version ".tar"))
+ (sha256
+ (base32
+ "0kcmg9fm9gcpdxfwx7c6zz29krf69j5nh6knv2x3df65sbzwdj0b"))))
+ (build-system emacs-build-system)
+ (home-page "https://elpa.gnu.org/packages/xref-union.html")
+ (synopsis "Combine multiple Xref backends")
+ (description
+ "This package provides a way to combine multiple Xref source
+(e.g. Etags and Eglot) and have the results all at once.
+
+To enable, toggle the @code{xref-union-mode} minor mode. If you want to
+exclude certain modes, take a look at the user option
+`xref-union-excluded-backends'.
+
+You can also manually make use of @code{xref-union} by adding an object
+of the form @code{(union XREF-BACKEND-1 XREF-BACKEND-2 ...)} to
+@code{xref-backend-functions}.")
+ (license license:gpl3+)))
+
(define-public emacs-burly
(package
(name "emacs-burly")
--
2.43.0
Nicolas Goaziou wrote 10 months ago
(name . Daniel Ziltener via Guix-patches via)(address . guix-patches@gnu.org)(name . Daniel Ziltener)(address . dziltener@lyrion.ch)(address . 69618-done@debbugs.gnu.org)
87wmo7xgrw.fsf@nicolasgoaziou.fr
Hello,

Daniel Ziltener via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (2 lines)
> +(define-public emacs-xref-union

Applied. Thank you.

Regards,
--
Nicolas Goaziou
?
Your comment

This issue is archived.

To comment on this conversation send an email to 69618@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 69618
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help