[PATCH] gnu: mc: Update to 4.8.31

  • Done
  • quality assurance status badge
Details
3 participants
  • Andy Tai
  • 宋文武
  • Juliana Sims
Owner
unassigned
Submitted by
Andy Tai
Severity
normal

Debbugs page

Andy Tai wrote 1 years ago
(address . guix-patches@gnu.org)(name . Andy Tai)(address . atai@atai.org)
8e83f0c35e1896953a987ef7291b67b9998da125.1709789082.git.atai@atai.org
* gnu/packages/mc.scm (mc): Update to 4.8.31

Change-Id: Ib610e76b2ef5e6c1a1f49f34073015c0b260ea77
---
gnu/packages/mc.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (25 lines)
diff --git a/gnu/packages/mc.scm b/gnu/packages/mc.scm
index 994f89f524..5181718306 100644
--- a/gnu/packages/mc.scm
+++ b/gnu/packages/mc.scm
@@ -40,14 +40,14 @@ (define-module (gnu packages mc)
(define-public mc
(package
(name "mc")
- (version "4.8.30")
+ (version "4.8.31")
(source
(origin
(method url-fetch)
(uri (string-append "https://ftp.osuosl.org/pub/midnightcommander/mc-"
version ".tar.xz"))
(sha256
- (base32 "1py7jm620lsas7rcv5j69608gdshmp25d9gx958hr5sb2jr3rg2y"))))
+ (base32 "06mbnhxd2k29jah4wp1ciicw1gb51a5d3af43zivhxbncvw1q694"))))
(build-system gnu-build-system)
(arguments
(list

base-commit: b4107ca3ad8bb8a6b8e669c298be2f14ff0237da
--
2.41.0
Juliana Sims wrote 1 years ago
[PATCH v2] gnu: mc: Update to 4.8.31
(address . 69600@debbugs.gnu.org)(address . atai@atai.org)
59017f7b636416aef75f8a15e5402278b90d39df.1709857008.git.juli@incana.org
From: Andy Tai <atai@atai.org>

Hello,

This patch failed to build because `mkstemp` could not find
"src/vfs/fish/fish.c.XXXXXX". Removing the reference to "src/vfs/fish/fish.c" in
the first `substitute*` form of the `patch-file-names` phase results in a
successful build. Attached is a patch making that very minor correction.

With that change made, this builds fine on x86 and aarch64, so I'm comfortable
saying it's good to go :)

Thanks,
Juli

* gnu/packages/mc.scm (mc): Update to 4.8.31

Change-Id: Ib610e76b2ef5e6c1a1f49f34073015c0b260ea77
---
gnu/packages/mc.scm | 5 ++---
1 file changed, 2 insertions(+), 3 deletions(-)

Toggle diff (33 lines)
diff --git a/gnu/packages/mc.scm b/gnu/packages/mc.scm
index 994f89f5248..8cf760ac53c 100644
--- a/gnu/packages/mc.scm
+++ b/gnu/packages/mc.scm
@@ -40,14 +40,14 @@ (define-module (gnu packages mc)
(define-public mc
(package
(name "mc")
- (version "4.8.30")
+ (version "4.8.31")
(source
(origin
(method url-fetch)
(uri (string-append "https://ftp.osuosl.org/pub/midnightcommander/mc-"
version ".tar.xz"))
(sha256
- (base32 "1py7jm620lsas7rcv5j69608gdshmp25d9gx958hr5sb2jr3rg2y"))))
+ (base32 "06mbnhxd2k29jah4wp1ciicw1gb51a5d3af43zivhxbncvw1q694"))))
(build-system gnu-build-system)
(arguments
(list
@@ -68,7 +68,6 @@ (define-public mc
(list "lib/utilunix.c"
"src/filemanager/ext.c"
"src/usermenu.c"
- "src/vfs/fish/fish.c"
;; This file hard-codes other shells, but they're never
;; tried after mc's first choice (bash) is found.
"lib/shell.c")

base-commit: 06e61f9cd2f4c317e19bf4eca817737af6544c42
--
2.41.0
Andy Tai wrote 1 years ago
(name . Juliana Sims)(address . juli@incana.org)(address . 69600@debbugs.gnu.org)
CAJsg1E8fFs49FhELCcvYqVhqtxFQVChVd1cFiZj=t_-iP_kE+g@mail.gmail.com
the modified patch looks good to me. Hope a commiter picks it up and commit

On Thu, Mar 7, 2024 at 4:31 PM Juliana Sims <juli@incana.org> wrote:
Toggle quote (57 lines)
>
> From: Andy Tai <atai@atai.org>
>
> Hello,
>
> This patch failed to build because `mkstemp` could not find
> "src/vfs/fish/fish.c.XXXXXX". Removing the reference to "src/vfs/fish/fish.c" in
> the first `substitute*` form of the `patch-file-names` phase results in a
> successful build. Attached is a patch making that very minor correction.
>
> With that change made, this builds fine on x86 and aarch64, so I'm comfortable
> saying it's good to go :)
>
> Thanks,
> Juli
>
> * gnu/packages/mc.scm (mc): Update to 4.8.31
>
> Change-Id: Ib610e76b2ef5e6c1a1f49f34073015c0b260ea77
> ---
> gnu/packages/mc.scm | 5 ++---
> 1 file changed, 2 insertions(+), 3 deletions(-)
>
> diff --git a/gnu/packages/mc.scm b/gnu/packages/mc.scm
> index 994f89f5248..8cf760ac53c 100644
> --- a/gnu/packages/mc.scm
> +++ b/gnu/packages/mc.scm
> @@ -40,14 +40,14 @@ (define-module (gnu packages mc)
> (define-public mc
> (package
> (name "mc")
> - (version "4.8.30")
> + (version "4.8.31")
> (source
> (origin
> (method url-fetch)
> (uri (string-append "https://ftp.osuosl.org/pub/midnightcommander/mc-"
> version ".tar.xz"))
> (sha256
> - (base32 "1py7jm620lsas7rcv5j69608gdshmp25d9gx958hr5sb2jr3rg2y"))))
> + (base32 "06mbnhxd2k29jah4wp1ciicw1gb51a5d3af43zivhxbncvw1q694"))))
> (build-system gnu-build-system)
> (arguments
> (list
> @@ -68,7 +68,6 @@ (define-public mc
> (list "lib/utilunix.c"
> "src/filemanager/ext.c"
> "src/usermenu.c"
> - "src/vfs/fish/fish.c"
> ;; This file hard-codes other shells, but they're never
> ;; tried after mc's first choice (bash) is found.
> "lib/shell.c")
>
> base-commit: 06e61f9cd2f4c317e19bf4eca817737af6544c42
> --
> 2.41.0
>
Andy Tai wrote 1 years ago
[PATCH v2] gnu: mc: Update to 4.8.31
(address . 69600@debbugs.gnu.org)(name . Andy Tai)(address . atai@atai.org)
8f25a9cf5120d57fada86b29187b801b484a381b.1709879475.git.atai@atai.org
* gnu/packages/mc.scm (mc): Update to 4.8.31

Change-Id: Ib610e76b2ef5e6c1a1f49f34073015c0b260ea77
---
gnu/packages/mc.scm | 5 ++---
1 file changed, 2 insertions(+), 3 deletions(-)

Toggle diff (33 lines)
diff --git a/gnu/packages/mc.scm b/gnu/packages/mc.scm
index 994f89f524..8cf760ac53 100644
--- a/gnu/packages/mc.scm
+++ b/gnu/packages/mc.scm
@@ -40,14 +40,14 @@ (define-module (gnu packages mc)
(define-public mc
(package
(name "mc")
- (version "4.8.30")
+ (version "4.8.31")
(source
(origin
(method url-fetch)
(uri (string-append "https://ftp.osuosl.org/pub/midnightcommander/mc-"
version ".tar.xz"))
(sha256
- (base32 "1py7jm620lsas7rcv5j69608gdshmp25d9gx958hr5sb2jr3rg2y"))))
+ (base32 "06mbnhxd2k29jah4wp1ciicw1gb51a5d3af43zivhxbncvw1q694"))))
(build-system gnu-build-system)
(arguments
(list
@@ -68,7 +68,6 @@ (define-public mc
(list "lib/utilunix.c"
"src/filemanager/ext.c"
"src/usermenu.c"
- "src/vfs/fish/fish.c"
;; This file hard-codes other shells, but they're never
;; tried after mc's first choice (bash) is found.
"lib/shell.c")

base-commit: f18d13b5f89c161c6ee88d15ecdaa8d973ee4503
--
2.34.1
Andy Tai wrote 1 years ago
(address . 69600@debbugs.gnu.org)
CAJsg1E8j7h7Z3=S-Ne69cFZdShCQZ8WMv7Y18AUMmd5XcEtBrg@mail.gmail.com
new patch v2 to make Juliana's suggested change official so Guix QA
can pick it up


On Thu, Mar 7, 2024 at 10:31 PM Andy Tai <atai@atai.org> wrote:
Toggle quote (42 lines)
>
> * gnu/packages/mc.scm (mc): Update to 4.8.31
>
> Change-Id: Ib610e76b2ef5e6c1a1f49f34073015c0b260ea77
> ---
> gnu/packages/mc.scm | 5 ++---
> 1 file changed, 2 insertions(+), 3 deletions(-)
>
> diff --git a/gnu/packages/mc.scm b/gnu/packages/mc.scm
> index 994f89f524..8cf760ac53 100644
> --- a/gnu/packages/mc.scm
> +++ b/gnu/packages/mc.scm
> @@ -40,14 +40,14 @@ (define-module (gnu packages mc)
> (define-public mc
> (package
> (name "mc")
> - (version "4.8.30")
> + (version "4.8.31")
> (source
> (origin
> (method url-fetch)
> (uri (string-append "https://ftp.osuosl.org/pub/midnightcommander/mc-"
> version ".tar.xz"))
> (sha256
> - (base32 "1py7jm620lsas7rcv5j69608gdshmp25d9gx958hr5sb2jr3rg2y"))))
> + (base32 "06mbnhxd2k29jah4wp1ciicw1gb51a5d3af43zivhxbncvw1q694"))))
> (build-system gnu-build-system)
> (arguments
> (list
> @@ -68,7 +68,6 @@ (define-public mc
> (list "lib/utilunix.c"
> "src/filemanager/ext.c"
> "src/usermenu.c"
> - "src/vfs/fish/fish.c"
> ;; This file hard-codes other shells, but they're never
> ;; tried after mc's first choice (bash) is found.
> "lib/shell.c")
>
> base-commit: f18d13b5f89c161c6ee88d15ecdaa8d973ee4503
> --
> 2.34.1
>
宋文武 wrote 1 years ago
Re: [bug#69600] [PATCH v2] gnu: mc: Update to 4.8.31
(name . Andy Tai)(address . atai@atai.org)(address . 69600-done@debbugs.gnu.org)
87edck6pfe.fsf@envs.net
Andy Tai <atai@atai.org> writes:

Toggle quote (4 lines)
> * gnu/packages/mc.scm (mc): Update to 4.8.31
>
> Change-Id: Ib610e76b2ef5e6c1a1f49f34073015c0b260ea77

Applied as commit d13cfbc3f9, thank you!
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 69600@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 69600
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help