[PATCH] gnu: python-joblib: Update to 1.3.2.

  • Done
  • quality assurance status badge
Details
3 participants
  • Christopher Baines
  • Nicolas Graves
  • Vagrant Cascadian
Owner
unassigned
Submitted by
Nicolas Graves
Severity
normal
N
N
Nicolas Graves wrote on 6 Mar 10:38 +0100
(address . guix-patches@gnu.org)(address . ngraves@ngraves.fr)
20240306093803.4725-1-ngraves@ngraves.fr
* gnu/packages/python-xyz.scm (python-joblib): Update to 1.3.2.
[build-system]: Update to pyproject-build-system.
[arguments]
<#:phases>: Remove check phase.
<#:test-flags>: Keep former test flag.
[propagated-inputs]: Add python-psutil.

Change-Id: Ide110a19431b1d26e1d7dd8d1adc3b3f0f417749
---
gnu/packages/python-xyz.scm | 22 ++++++++--------------
1 file changed, 8 insertions(+), 14 deletions(-)

Toggle diff (41 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 46232d3c98..122dca6e4e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -6169,26 +6169,20 @@ (define-public python-pystitcher
(define-public python-joblib
(package
(name "python-joblib")
- (version "1.1.1")
+ (version "1.3.2")
(source (origin
(method url-fetch)
(uri (pypi-uri "joblib" version))
(sha256
(base32
- "0019p280s2k941mihl67l7y6amwx86639xp3zvpsg1lmyish67rh"))))
- (build-system python-build-system)
+ "1cbjjzsh9hzaqr2cqja95673p7j88b8bd02hjpkq8xz147k6by4j"))))
+ (build-system pyproject-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (setenv "JOBLIB_MULTIPROCESSING" "0")
- (invoke "pytest" "-v" "joblib"
- ;; We disable this test to avoid having to depend on ipython/jupyter
- "-k" "not test_parallel_call_cached_function_defined_in_jupyter")))))))
- (native-inputs
- (list python-pytest))
+ (list
+ #:test-flags ; disabled to avoid having to depend on ipython/jupyter
+ #~(list "-k" "not test_parallel_call_cached_function_defined_in_jupyter")))
+ (native-inputs (list python-pytest))
+ (propagated-inputs (list python-psutil))
(home-page "https://joblib.readthedocs.io/")
(synopsis "Using Python functions as pipeline jobs")
(description
--
2.41.0
V
V
Vagrant Cascadian wrote on 8 Mar 21:29 +0100
(address . 69579@debbugs.gnu.org)(address . ngraves@ngraves.fr)
87ttlgbh6y.fsf@wireframe
On 2024-03-06, Nicolas Graves wrote:
Toggle quote (54 lines)
> * gnu/packages/python-xyz.scm (python-joblib): Update to 1.3.2.
> [build-system]: Update to pyproject-build-system.
> [arguments]
> <#:phases>: Remove check phase.
> <#:test-flags>: Keep former test flag.
> [propagated-inputs]: Add python-psutil.
>
> Change-Id: Ide110a19431b1d26e1d7dd8d1adc3b3f0f417749
> ---
> gnu/packages/python-xyz.scm | 22 ++++++++--------------
> 1 file changed, 8 insertions(+), 14 deletions(-)
>
> diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
> index 46232d3c98..122dca6e4e 100644
> --- a/gnu/packages/python-xyz.scm
> +++ b/gnu/packages/python-xyz.scm
> @@ -6169,26 +6169,20 @@ (define-public python-pystitcher
> (define-public python-joblib
> (package
> (name "python-joblib")
> - (version "1.1.1")
> + (version "1.3.2")
> (source (origin
> (method url-fetch)
> (uri (pypi-uri "joblib" version))
> (sha256
> (base32
> - "0019p280s2k941mihl67l7y6amwx86639xp3zvpsg1lmyish67rh"))))
> - (build-system python-build-system)
> + "1cbjjzsh9hzaqr2cqja95673p7j88b8bd02hjpkq8xz147k6by4j"))))
> + (build-system pyproject-build-system)
> (arguments
> - `(#:phases
> - (modify-phases %standard-phases
> - (replace 'check
> - (lambda* (#:key tests? #:allow-other-keys)
> - (when tests?
> - (setenv "JOBLIB_MULTIPROCESSING" "0")
> - (invoke "pytest" "-v" "joblib"
> - ;; We disable this test to avoid having to depend on ipython/jupyter
> - "-k" "not test_parallel_call_cached_function_defined_in_jupyter")))))))
> - (native-inputs
> - (list python-pytest))
> + (list
> + #:test-flags ; disabled to avoid having to depend on ipython/jupyter
> + #~(list "-k" "not test_parallel_call_cached_function_defined_in_jupyter")))
> + (native-inputs (list python-pytest))
> + (propagated-inputs (list python-psutil))
> (home-page "https://joblib.readthedocs.io/")
> (synopsis "Using Python functions as pipeline jobs")
> (description
> --
> 2.41.0

I did a local test build, and tried to build the moderately large list
of dependents (~90 if I recall), which seems to fix some builds and
introduces some new failures, and some still fail in both cases...

with python-joblib 1.3.2 patch:

guix build: error: build of
`/gnu/store/1f7fjigxbran1bn1lwvy4v7vfdfz09rj-python-pingouin-0.5.2.drv',
`/gnu/store/4g2r98m4d5zkwvlgghdqgvnda8p5b8lf-tadbit-1.0.1-1.5c4c1dd.drv',
`/gnu/store/8gkvizln2kjpdjn4m89vws9xpj3f62dw-python-scikit-allel-1.3.5.drv',
`/gnu/store/cm2dr4npm0bn9w7xiyrfizcq097laibw-python-pyts-0.13.0.drv',
`/gnu/store/h5l1cymbzrz2havw6ygn0gafxwvf5k9m-python-matplotlib-documentation-3.8.2.drv',
`/gnu/store/ijg5hbhwj3h89bzh0n9l8zrg595bnscz-python-openturns-1.21.3.drv',
`/gnu/store/n0f7flida4sag8ifsvmczg4r33r07ry8-python-pytorch-geometric-2.4.0.drv',
`/gnu/store/yl5rndzgfprfr0lpcrhdwmvix61zyccr-python-poliastro-0.17.0.drv'
failed

without python-joblib 1.3.2 patch:

guix build: error: build of
`/gnu/store/rhd4p3n7ih0apdbqn552dvgf67ljmj5s-python-pingouin-0.5.2.drv',
`/gnu/store/mdcf9g773mz96397fpy7hbhj624svdai-python-scikit-allel-1.3.5.drv',
`/gnu/store/7b2px2nkw02i62zbc8izh5wlc08bvpp3-python-matplotlib-documentation-3.5.2.drv',
`/gnu/store/36hdl27cw8gb9s7alf3ginmqk40lzjzm-python-xgboost-1.5.2.drv',
`/gnu/store/jja4pvcnsxd63mb6jxlilkyjjf0a524m-python-hicexplorer-3.7.2.drv',
`/gnu/store/mqzg965f7qhiz1rk93yqlq5p6p93h30j-python-episcanpy-0.4.0.drv',
`/gnu/store/r4bx6mx0bkhk25zq4g91wma0s5ll016q-python-multivelo-0.1.2.drv',
`/gnu/store/wrpm94hkilphkznif8nzan8gblaflrqp-python-ikarus-0.0.2.drv' failed
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQRlgHNhO/zFx+LkXUXcUY/If5cWqgUCZet1NQAKCRDcUY/If5cW
qjWZAP9M0RFOGaQ/ye8Lv6yeEaNud3uw/KJnWGdSYx+U0u6OcAD/edC9cyiIbUrP
37hikpmcFDrottH1A3L4xfRh22M4bAs=
=mQsU
-----END PGP SIGNATURE-----

N
N
Nicolas Graves wrote on 8 Mar 23:20 +0100
875xxw4b81.fsf@ngraves.fr
On 2024-03-08 12:29, Vagrant Cascadian wrote:

Toggle quote (84 lines)
> On 2024-03-06, Nicolas Graves wrote:
>> * gnu/packages/python-xyz.scm (python-joblib): Update to 1.3.2.
>> [build-system]: Update to pyproject-build-system.
>> [arguments]
>> <#:phases>: Remove check phase.
>> <#:test-flags>: Keep former test flag.
>> [propagated-inputs]: Add python-psutil.
>>
>> Change-Id: Ide110a19431b1d26e1d7dd8d1adc3b3f0f417749
>> ---
>> gnu/packages/python-xyz.scm | 22 ++++++++--------------
>> 1 file changed, 8 insertions(+), 14 deletions(-)
>>
>> diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
>> index 46232d3c98..122dca6e4e 100644
>> --- a/gnu/packages/python-xyz.scm
>> +++ b/gnu/packages/python-xyz.scm
>> @@ -6169,26 +6169,20 @@ (define-public python-pystitcher
>> (define-public python-joblib
>> (package
>> (name "python-joblib")
>> - (version "1.1.1")
>> + (version "1.3.2")
>> (source (origin
>> (method url-fetch)
>> (uri (pypi-uri "joblib" version))
>> (sha256
>> (base32
>> - "0019p280s2k941mihl67l7y6amwx86639xp3zvpsg1lmyish67rh"))))
>> - (build-system python-build-system)
>> + "1cbjjzsh9hzaqr2cqja95673p7j88b8bd02hjpkq8xz147k6by4j"))))
>> + (build-system pyproject-build-system)
>> (arguments
>> - `(#:phases
>> - (modify-phases %standard-phases
>> - (replace 'check
>> - (lambda* (#:key tests? #:allow-other-keys)
>> - (when tests?
>> - (setenv "JOBLIB_MULTIPROCESSING" "0")
>> - (invoke "pytest" "-v" "joblib"
>> - ;; We disable this test to avoid having to depend on ipython/jupyter
>> - "-k" "not test_parallel_call_cached_function_defined_in_jupyter")))))))
>> - (native-inputs
>> - (list python-pytest))
>> + (list
>> + #:test-flags ; disabled to avoid having to depend on ipython/jupyter
>> + #~(list "-k" "not test_parallel_call_cached_function_defined_in_jupyter")))
>> + (native-inputs (list python-pytest))
>> + (propagated-inputs (list python-psutil))
>> (home-page "https://joblib.readthedocs.io/")
>> (synopsis "Using Python functions as pipeline jobs")
>> (description
>> --
>> 2.41.0
>
> I did a local test build, and tried to build the moderately large list
> of dependents (~90 if I recall), which seems to fix some builds and
> introduces some new failures, and some still fail in both cases...
>
> with python-joblib 1.3.2 patch:
>
> guix build: error: build of
> `/gnu/store/1f7fjigxbran1bn1lwvy4v7vfdfz09rj-python-pingouin-0.5.2.drv',
> `/gnu/store/4g2r98m4d5zkwvlgghdqgvnda8p5b8lf-tadbit-1.0.1-1.5c4c1dd.drv',
> `/gnu/store/8gkvizln2kjpdjn4m89vws9xpj3f62dw-python-scikit-allel-1.3.5.drv',
> `/gnu/store/cm2dr4npm0bn9w7xiyrfizcq097laibw-python-pyts-0.13.0.drv',
> `/gnu/store/h5l1cymbzrz2havw6ygn0gafxwvf5k9m-python-matplotlib-documentation-3.8.2.drv',
> `/gnu/store/ijg5hbhwj3h89bzh0n9l8zrg595bnscz-python-openturns-1.21.3.drv',
> `/gnu/store/n0f7flida4sag8ifsvmczg4r33r07ry8-python-pytorch-geometric-2.4.0.drv',
> `/gnu/store/yl5rndzgfprfr0lpcrhdwmvix61zyccr-python-poliastro-0.17.0.drv'
> failed
>
> without python-joblib 1.3.2 patch:
>
> guix build: error: build of
> `/gnu/store/rhd4p3n7ih0apdbqn552dvgf67ljmj5s-python-pingouin-0.5.2.drv',
> `/gnu/store/mdcf9g773mz96397fpy7hbhj624svdai-python-scikit-allel-1.3.5.drv',
> `/gnu/store/7b2px2nkw02i62zbc8izh5wlc08bvpp3-python-matplotlib-documentation-3.5.2.drv',
> `/gnu/store/36hdl27cw8gb9s7alf3ginmqk40lzjzm-python-xgboost-1.5.2.drv',
> `/gnu/store/jja4pvcnsxd63mb6jxlilkyjjf0a524m-python-hicexplorer-3.7.2.drv',
> `/gnu/store/mqzg965f7qhiz1rk93yqlq5p6p93h30j-python-episcanpy-0.4.0.drv',
> `/gnu/store/r4bx6mx0bkhk25zq4g91wma0s5ll016q-python-multivelo-0.1.2.drv',
> `/gnu/store/wrpm94hkilphkznif8nzan8gblaflrqp-python-ikarus-0.0.2.drv' failed

Thanks for this, I'll investigate further.

--
Best regards,
Nicolas Graves
N
N
Nicolas Graves wrote on 13 Mar 07:46 +0100
87ttlaljc9.fsf@ngraves.fr
On 2024-03-08 12:29, Vagrant Cascadian wrote:

Toggle quote (59 lines)
> On 2024-03-06, Nicolas Graves wrote:
>> * gnu/packages/python-xyz.scm (python-joblib): Update to 1.3.2.
>> [build-system]: Update to pyproject-build-system.
>> [arguments]
>> <#:phases>: Remove check phase.
>> <#:test-flags>: Keep former test flag.
>> [propagated-inputs]: Add python-psutil.
>>
>> Change-Id: Ide110a19431b1d26e1d7dd8d1adc3b3f0f417749
>> ---
>> gnu/packages/python-xyz.scm | 22 ++++++++--------------
>> 1 file changed, 8 insertions(+), 14 deletions(-)
>>
>> diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
>> index 46232d3c98..122dca6e4e 100644
>> --- a/gnu/packages/python-xyz.scm
>> +++ b/gnu/packages/python-xyz.scm
>> @@ -6169,26 +6169,20 @@ (define-public python-pystitcher
>> (define-public python-joblib
>> (package
>> (name "python-joblib")
>> - (version "1.1.1")
>> + (version "1.3.2")
>> (source (origin
>> (method url-fetch)
>> (uri (pypi-uri "joblib" version))
>> (sha256
>> (base32
>> - "0019p280s2k941mihl67l7y6amwx86639xp3zvpsg1lmyish67rh"))))
>> - (build-system python-build-system)
>> + "1cbjjzsh9hzaqr2cqja95673p7j88b8bd02hjpkq8xz147k6by4j"))))
>> + (build-system pyproject-build-system)
>> (arguments
>> - `(#:phases
>> - (modify-phases %standard-phases
>> - (replace 'check
>> - (lambda* (#:key tests? #:allow-other-keys)
>> - (when tests?
>> - (setenv "JOBLIB_MULTIPROCESSING" "0")
>> - (invoke "pytest" "-v" "joblib"
>> - ;; We disable this test to avoid having to depend on ipython/jupyter
>> - "-k" "not test_parallel_call_cached_function_defined_in_jupyter")))))))
>> - (native-inputs
>> - (list python-pytest))
>> + (list
>> + #:test-flags ; disabled to avoid having to depend on ipython/jupyter
>> + #~(list "-k" "not test_parallel_call_cached_function_defined_in_jupyter")))
>> + (native-inputs (list python-pytest))
>> + (propagated-inputs (list python-psutil))
>> (home-page "https://joblib.readthedocs.io/")
>> (synopsis "Using Python functions as pipeline jobs")
>> (description
>> --
>> 2.41.0
>
> I did a local test build, and tried to build the moderately large list
> of dependents (~90 if I recall), which seems to fix some builds and
> introduces some new failures, and some still fail in both cases...

For the packages that were failing before but not after applying the
patch, I don't see why they're relevant, so I'll ignore them here.

For the following packages, they fail in both cases and are not about
this patch, I do not consider them in the review:

Toggle quote (3 lines)
> `/gnu/store/1f7fjigxbran1bn1lwvy4v7vfdfz09rj-python-pingouin-0.5.2.drv',
> `/gnu/store/8gkvizln2kjpdjn4m89vws9xpj3f62dw-python-scikit-allel-1.3.5.drv',

The following packages build properly on my side, so they either failed
because of some determinism or system issue, or were simply fixes in the
meantime :

Toggle quote (5 lines)
> `/gnu/store/ijg5hbhwj3h89bzh0n9l8zrg595bnscz-python-openturns-1.21.3.drv',
> `/gnu/store/cm2dr4npm0bn9w7xiyrfizcq097laibw-python-pyts-0.13.0.drv',
> `/gnu/store/n0f7flida4sag8ifsvmczg4r33r07ry8-python-pytorch-geometric-2.4.0.drv',
> `/gnu/store/yl5rndzgfprfr0lpcrhdwmvix61zyccr-python-poliastro-0.17.0.drv'

Now there are still some relevant failures, but they seem to come from
changes in the meantime, you probably have some patches differing
between both tries, since python-matplotlib-documentation is not the
same version between both.

Toggle quote (5 lines)
> `/gnu/store/4g2r98m4d5zkwvlgghdqgvnda8p5b8lf-tadbit-1.0.1-1.5c4c1dd.drv',

>> File "/gnu/store/vkj58jsab13ybc871aiqrxdkmi54ijxn-tadbit-1.0.1-1.5c4c1dd/lib/python3.10/site-packages/pytadbit/mapping/restriction_enzymes.py", line 12, in <module>
>> from scipy.stats import binom_test

The error in tadbit I get actually comes from scipy update. This should
be fixed in a tadbit-specific patch or update, rather than here.
Toggle quote (2 lines)
> `/gnu/store/h5l1cymbzrz2havw6ygn0gafxwvf5k9m-python-matplotlib-documentation-3.8.2.drv',

This one is about missing python-pyyaml and unsubmitted python-sphinx-design
packages at least. This should be fixed in a matplotlib-specific patch,
rather than here.

I've also tried to rebuild all dependent packages on
447e9c96259e8fa15a828de9b2dd3400e2ffafe6, I also see the following
failures among dependents :
- music21@7.1.0 : missing dependency on numpy, to fix in a dedicated
patch
- python-orange-canvas-core : probably some qt version mismatch here, to
fix in a dedicated patch

All in all, I don't see a precise reason why this patch is responsible
for any of the failures.

--
Best regards,
Nicolas Graves
C
C
Christopher Baines wrote on 13 Mar 13:39 +0100
(name . Nicolas Graves)(address . ngraves@ngraves.fr)
87plvyuwxj.fsf@cbaines.net
Nicolas Graves via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (42 lines)
> On 2024-03-08 12:29, Vagrant Cascadian wrote:
>
>> On 2024-03-06, Nicolas Graves wrote:
>>> * gnu/packages/python-xyz.scm (python-joblib): Update to 1.3.2.
>>> [build-system]: Update to pyproject-build-system.
>>> [arguments]
>>> <#:phases>: Remove check phase.
>>> <#:test-flags>: Keep former test flag.
>>> [propagated-inputs]: Add python-psutil.
>>>
>>> Change-Id: Ide110a19431b1d26e1d7dd8d1adc3b3f0f417749
>>> ---
>>> gnu/packages/python-xyz.scm | 22 ++++++++--------------
>>> 1 file changed, 8 insertions(+), 14 deletions(-)
>>>
>>> diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
>>> index 46232d3c98..122dca6e4e 100644
>>> --- a/gnu/packages/python-xyz.scm
>>> +++ b/gnu/packages/python-xyz.scm
>>> @@ -6169,26 +6169,20 @@ (define-public python-pystitcher
>>> (define-public python-joblib
>>> (package
>>> (name "python-joblib")
>>> - (version "1.1.1")
>>> + (version "1.3.2")
>>> (source (origin
>>> (method url-fetch)
>>> (uri (pypi-uri "joblib" version))
>>> (sha256
>>> (base32
>>> - "0019p280s2k941mihl67l7y6amwx86639xp3zvpsg1lmyish67rh"))))
>>> - (build-system python-build-system)
>>> + "1cbjjzsh9hzaqr2cqja95673p7j88b8bd02hjpkq8xz147k6by4j"))))
>>> + (build-system pyproject-build-system)
>>> (arguments
>>> - `(#:phases
>>> - (modify-phases %standard-phases
>>> - (replace 'check
>>> - (lambda* (#:key tests? #:allow-other-keys)
>>> - (when tests?
>>> - (setenv "JOBLIB_MULTIPROCESSING" "0")

We should look at why this was added, and whether it should be kept.

Toggle quote (3 lines)
> All in all, I don't see a precise reason why this patch is responsible
> for any of the failures.

QA seems to agree at least, there looks to be some issues, but this
change seems to not make the situation worse at least.
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmXxnshfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XcQXw/+LTwFvfoCwAsY0vnpVqMKNdnDRnnz5MXF
sqleg3bsuk5tITDkgVhVOCliZjfQ4kWld8aiq+jj9B6i7XuAAb1saT73rE/C/KXR
VGDp9Jw4Eqa9NKwgRgFxs6tcODT9HZUJqGpirOe0hvEM/SaHrJ8obLs25yAG1ZA0
lGgkuS/YpYC7VHO81qkR6nxH3kFu+4o2UUW5sSw4Etyto4/Ys0eUBh9ekoXYIixR
AwngdH3Fw17iBa/ARoH3uccfdJfCuP/RIm3doSg9b0JQkFg1be9fE6B/2hWvHsMJ
xZYMIf/XIJbneNUrt0ufEfGlx1y04LDtei3kKwaruUL+q8Sd6JngAq6J6/07S5Sw
RFS3+XBTfrhqAGLIJvKNk2RwHoBJJ0ZVLSuk045FoOZ2bTajOxWrACZchtEw8n4i
iVuaBTcU6JWVQEiaKBX5oYAE0bgakJ2kel4DZNr9r/SqbR8e7FMQF1lB5MDGiOd5
+3xXLJAuAAd/LE7xCm32Zhpfv+C0b81jpKE+Ee3mdpF3Xw+oY+mZgqlvwKS2flYq
74XJDUGDt7mnvyGt0FFaH/GmcX56reMoLh2HAeVvwYaNsBUw0peemA0m4NrMxyPm
t2sepEcRjTo924B35F+43DYf9ynEjPtXPzs2nS/RJzEO4nPi350FG1BVEmBwzxI0
Mr+P5BnapU8=
=DvzO
-----END PGP SIGNATURE-----

N
N
Nicolas Graves wrote on 13 Mar 14:16 +0100
(name . Christopher Baines)(address . mail@cbaines.net)
87wmq6p907.fsf@ngraves.fr
On 2024-03-13 12:39, Christopher Baines wrote:

Toggle quote (46 lines)
> Nicolas Graves via Guix-patches via <guix-patches@gnu.org> writes:
>
>> On 2024-03-08 12:29, Vagrant Cascadian wrote:
>>
>>> On 2024-03-06, Nicolas Graves wrote:
>>>> * gnu/packages/python-xyz.scm (python-joblib): Update to 1.3.2.
>>>> [build-system]: Update to pyproject-build-system.
>>>> [arguments]
>>>> <#:phases>: Remove check phase.
>>>> <#:test-flags>: Keep former test flag.
>>>> [propagated-inputs]: Add python-psutil.
>>>>
>>>> Change-Id: Ide110a19431b1d26e1d7dd8d1adc3b3f0f417749
>>>> ---
>>>> gnu/packages/python-xyz.scm | 22 ++++++++--------------
>>>> 1 file changed, 8 insertions(+), 14 deletions(-)
>>>>
>>>> diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
>>>> index 46232d3c98..122dca6e4e 100644
>>>> --- a/gnu/packages/python-xyz.scm
>>>> +++ b/gnu/packages/python-xyz.scm
>>>> @@ -6169,26 +6169,20 @@ (define-public python-pystitcher
>>>> (define-public python-joblib
>>>> (package
>>>> (name "python-joblib")
>>>> - (version "1.1.1")
>>>> + (version "1.3.2")
>>>> (source (origin
>>>> (method url-fetch)
>>>> (uri (pypi-uri "joblib" version))
>>>> (sha256
>>>> (base32
>>>> - "0019p280s2k941mihl67l7y6amwx86639xp3zvpsg1lmyish67rh"))))
>>>> - (build-system python-build-system)
>>>> + "1cbjjzsh9hzaqr2cqja95673p7j88b8bd02hjpkq8xz147k6by4j"))))
>>>> + (build-system pyproject-build-system)
>>>> (arguments
>>>> - `(#:phases
>>>> - (modify-phases %standard-phases
>>>> - (replace 'check
>>>> - (lambda* (#:key tests? #:allow-other-keys)
>>>> - (when tests?
>>>> - (setenv "JOBLIB_MULTIPROCESSING" "0")
>
> We should look at why this was added, and whether it should be kept.

This is only present in the check phase, not in the final package. I
guess when we switched to the pyproject-build-system or simply updated,
this simply wasn't necessary anymore.

Since tests were consistantly (--check) passing, I do not see the need
to investigate that.

Toggle quote (7 lines)
>
>> All in all, I don't see a precise reason why this patch is responsible
>> for any of the failures.
>
> QA seems to agree at least, there looks to be some issues, but this
> change seems to not make the situation worse at least.

--
Best regards,
Nicolas Graves
N
N
Nicolas Graves wrote on 15 Mar 20:15 +0100
(name . Christopher Baines)(address . mail@cbaines.net)
87bk7f2to3.fsf@ngraves.fr
On 2024-03-13 14:16, Nicolas Graves wrote:

Toggle quote (55 lines)
> On 2024-03-13 12:39, Christopher Baines wrote:
>
>> Nicolas Graves via Guix-patches via <guix-patches@gnu.org> writes:
>>
>>> On 2024-03-08 12:29, Vagrant Cascadian wrote:
>>>
>>>> On 2024-03-06, Nicolas Graves wrote:
>>>>> * gnu/packages/python-xyz.scm (python-joblib): Update to 1.3.2.
>>>>> [build-system]: Update to pyproject-build-system.
>>>>> [arguments]
>>>>> <#:phases>: Remove check phase.
>>>>> <#:test-flags>: Keep former test flag.
>>>>> [propagated-inputs]: Add python-psutil.
>>>>>
>>>>> Change-Id: Ide110a19431b1d26e1d7dd8d1adc3b3f0f417749
>>>>> ---
>>>>> gnu/packages/python-xyz.scm | 22 ++++++++--------------
>>>>> 1 file changed, 8 insertions(+), 14 deletions(-)
>>>>>
>>>>> diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
>>>>> index 46232d3c98..122dca6e4e 100644
>>>>> --- a/gnu/packages/python-xyz.scm
>>>>> +++ b/gnu/packages/python-xyz.scm
>>>>> @@ -6169,26 +6169,20 @@ (define-public python-pystitcher
>>>>> (define-public python-joblib
>>>>> (package
>>>>> (name "python-joblib")
>>>>> - (version "1.1.1")
>>>>> + (version "1.3.2")
>>>>> (source (origin
>>>>> (method url-fetch)
>>>>> (uri (pypi-uri "joblib" version))
>>>>> (sha256
>>>>> (base32
>>>>> - "0019p280s2k941mihl67l7y6amwx86639xp3zvpsg1lmyish67rh"))))
>>>>> - (build-system python-build-system)
>>>>> + "1cbjjzsh9hzaqr2cqja95673p7j88b8bd02hjpkq8xz147k6by4j"))))
>>>>> + (build-system pyproject-build-system)
>>>>> (arguments
>>>>> - `(#:phases
>>>>> - (modify-phases %standard-phases
>>>>> - (replace 'check
>>>>> - (lambda* (#:key tests? #:allow-other-keys)
>>>>> - (when tests?
>>>>> - (setenv "JOBLIB_MULTIPROCESSING" "0")
>>
>> We should look at why this was added, and whether it should be kept.
>
> This is only present in the check phase, not in the final package. I
> guess when we switched to the pyproject-build-system or simply updated,
> this simply wasn't necessary anymore.
>
> Since tests were consistantly (--check) passing, I do not see the need
> to investigate that.

Christopher, is that good enough of an explanation to get this one
merged or would you rather have mpe really investigating it?

Toggle quote (8 lines)
>
>>
>>> All in all, I don't see a precise reason why this patch is responsible
>>> for any of the failures.
>>
>> QA seems to agree at least, there looks to be some issues, but this
>> change seems to not make the situation worse at least.

--
Best regards,
Nicolas Graves
C
C
Christopher Baines wrote on 16 Mar 13:08 +0100
(name . Nicolas Graves)(address . ngraves@ngraves.fr)
87plvuqsww.fsf@cbaines.net
Nicolas Graves <ngraves@ngraves.fr> writes:

Toggle quote (60 lines)
> On 2024-03-13 14:16, Nicolas Graves wrote:
>
>> On 2024-03-13 12:39, Christopher Baines wrote:
>>
>>> Nicolas Graves via Guix-patches via <guix-patches@gnu.org> writes:
>>>
>>>> On 2024-03-08 12:29, Vagrant Cascadian wrote:
>>>>
>>>>> On 2024-03-06, Nicolas Graves wrote:
>>>>>> * gnu/packages/python-xyz.scm (python-joblib): Update to 1.3.2.
>>>>>> [build-system]: Update to pyproject-build-system.
>>>>>> [arguments]
>>>>>> <#:phases>: Remove check phase.
>>>>>> <#:test-flags>: Keep former test flag.
>>>>>> [propagated-inputs]: Add python-psutil.
>>>>>>
>>>>>> Change-Id: Ide110a19431b1d26e1d7dd8d1adc3b3f0f417749
>>>>>> ---
>>>>>> gnu/packages/python-xyz.scm | 22 ++++++++--------------
>>>>>> 1 file changed, 8 insertions(+), 14 deletions(-)
>>>>>>
>>>>>> diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
>>>>>> index 46232d3c98..122dca6e4e 100644
>>>>>> --- a/gnu/packages/python-xyz.scm
>>>>>> +++ b/gnu/packages/python-xyz.scm
>>>>>> @@ -6169,26 +6169,20 @@ (define-public python-pystitcher
>>>>>> (define-public python-joblib
>>>>>> (package
>>>>>> (name "python-joblib")
>>>>>> - (version "1.1.1")
>>>>>> + (version "1.3.2")
>>>>>> (source (origin
>>>>>> (method url-fetch)
>>>>>> (uri (pypi-uri "joblib" version))
>>>>>> (sha256
>>>>>> (base32
>>>>>> - "0019p280s2k941mihl67l7y6amwx86639xp3zvpsg1lmyish67rh"))))
>>>>>> - (build-system python-build-system)
>>>>>> + "1cbjjzsh9hzaqr2cqja95673p7j88b8bd02hjpkq8xz147k6by4j"))))
>>>>>> + (build-system pyproject-build-system)
>>>>>> (arguments
>>>>>> - `(#:phases
>>>>>> - (modify-phases %standard-phases
>>>>>> - (replace 'check
>>>>>> - (lambda* (#:key tests? #:allow-other-keys)
>>>>>> - (when tests?
>>>>>> - (setenv "JOBLIB_MULTIPROCESSING" "0")
>>>
>>> We should look at why this was added, and whether it should be kept.
>>
>> This is only present in the check phase, not in the final package. I
>> guess when we switched to the pyproject-build-system or simply updated,
>> this simply wasn't necessary anymore.
>>
>> Since tests were consistantly (--check) passing, I do not see the need
>> to investigate that.
>
> Christopher, is that good enough of an explanation to get this one
> merged or would you rather have mpe really investigating it?

I think it's good to check the commit message at least:


Given that there's no reasoning there for this change, I think it's fine
to remove.
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmX1jB9fFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XcIWw/+PpTEK35yKOP6RCgjhs2pP0UlgnuV4xk9
deL9SqElU0hVaDWSttC+YcbB+i5hTmvzROJr1D/DgRwg8CL5TnhSGOLo4cvNIO5p
+8GzIEU5VIqe8b+xTeku2rKZN97S4xpl9Hns1EcwrYTOnl8Y9hspedMgBthIal6M
UVIPCe9ZT2lrOPEkF5QFkbspGLwvjd6U8uVhtvl4xJk+qkHD0EwRZRhMwzElVLSW
ede/JLKX4xEMLe9Hk6pb3NYgI6cc50h9IeEiwj38QdAuFRH2PkgT5eMvI6jey7hT
QMThISFQ1s04ShKJDwmWy7OafGvSo7vli4iqMKw2yZPOZ0pwiCRKRfoftUfLm2fc
QswvKmsVyR7g2MiUsEJRgSJveCw/dS9RaVXeiYekRUQy6T49F11nRiC8IMIItGh+
XS2VrKnLQ8+8My8cKonYIEcEdvtqn4OPZ4qmxEh77SsjZh/KF9BtDxwE/vtchY4n
kzGrnmoKMY3Nzc058Wf8xjnlaq32Iiq+uaxM21bzDqO+iEv2IDD/O/g5VgvJNY0H
ulghMvf+kTGuWSTmwZdgAP9CLSCx3gRyZVMumPNi4QZ8h5Nw9I51OWmQJDetbJMu
h7kHDxDDj7iRPWTkZSinGYgxQYAUsoWqskC34KNLqdnUHpL47bR6jFGrAKU50guf
KDtxZCD4uSk=
=HeHu
-----END PGP SIGNATURE-----

C
C
Christopher Baines wrote on 20 Mar 18:45 +0100
87sf0kkda4.fsf@cbaines.net
Christopher Baines <mail@cbaines.net> writes:

Toggle quote (69 lines)
> Nicolas Graves <ngraves@ngraves.fr> writes:
>
>> On 2024-03-13 14:16, Nicolas Graves wrote:
>>
>>> On 2024-03-13 12:39, Christopher Baines wrote:
>>>
>>>> Nicolas Graves via Guix-patches via <guix-patches@gnu.org> writes:
>>>>
>>>>> On 2024-03-08 12:29, Vagrant Cascadian wrote:
>>>>>
>>>>>> On 2024-03-06, Nicolas Graves wrote:
>>>>>>> * gnu/packages/python-xyz.scm (python-joblib): Update to 1.3.2.
>>>>>>> [build-system]: Update to pyproject-build-system.
>>>>>>> [arguments]
>>>>>>> <#:phases>: Remove check phase.
>>>>>>> <#:test-flags>: Keep former test flag.
>>>>>>> [propagated-inputs]: Add python-psutil.
>>>>>>>
>>>>>>> Change-Id: Ide110a19431b1d26e1d7dd8d1adc3b3f0f417749
>>>>>>> ---
>>>>>>> gnu/packages/python-xyz.scm | 22 ++++++++--------------
>>>>>>> 1 file changed, 8 insertions(+), 14 deletions(-)
>>>>>>>
>>>>>>> diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
>>>>>>> index 46232d3c98..122dca6e4e 100644
>>>>>>> --- a/gnu/packages/python-xyz.scm
>>>>>>> +++ b/gnu/packages/python-xyz.scm
>>>>>>> @@ -6169,26 +6169,20 @@ (define-public python-pystitcher
>>>>>>> (define-public python-joblib
>>>>>>> (package
>>>>>>> (name "python-joblib")
>>>>>>> - (version "1.1.1")
>>>>>>> + (version "1.3.2")
>>>>>>> (source (origin
>>>>>>> (method url-fetch)
>>>>>>> (uri (pypi-uri "joblib" version))
>>>>>>> (sha256
>>>>>>> (base32
>>>>>>> - "0019p280s2k941mihl67l7y6amwx86639xp3zvpsg1lmyish67rh"))))
>>>>>>> - (build-system python-build-system)
>>>>>>> + "1cbjjzsh9hzaqr2cqja95673p7j88b8bd02hjpkq8xz147k6by4j"))))
>>>>>>> + (build-system pyproject-build-system)
>>>>>>> (arguments
>>>>>>> - `(#:phases
>>>>>>> - (modify-phases %standard-phases
>>>>>>> - (replace 'check
>>>>>>> - (lambda* (#:key tests? #:allow-other-keys)
>>>>>>> - (when tests?
>>>>>>> - (setenv "JOBLIB_MULTIPROCESSING" "0")
>>>>
>>>> We should look at why this was added, and whether it should be kept.
>>>
>>> This is only present in the check phase, not in the final package. I
>>> guess when we switched to the pyproject-build-system or simply updated,
>>> this simply wasn't necessary anymore.
>>>
>>> Since tests were consistantly (--check) passing, I do not see the need
>>> to investigate that.
>>
>> Christopher, is that good enough of an explanation to get this one
>> merged or would you rather have mpe really investigating it?
>
> I think it's good to check the commit message at least:
>
> https://git.savannah.gnu.org/cgit/guix.git/commit/?id=a41f93c39d03143ce9007ad278a04fa30498bc0b
>
> Given that there's no reasoning there for this change, I think it's fine
> to remove.

I've gone ahead and pushed this to master as
a24aa227f72544ae4b95510c62f968d219148efc.

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmX7IMNfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XfoFg/+NuW4KcdzFkfD8H1bM13kYjwjJjFb4uZx
9aO7OTlxI9G7oCGGsY944Og1mf2wp5z5jWn/AlDCucNq9GrRtQSYIwz3slj6C1i8
32CbqrAmNyufczlh1wSIYxccNU1NbY95Xo9EiQD/awpt6EvbHlilQRYNOjAmxRaC
ttf4UWrN0iv5q2n4tmWALVhuaJ3GV+D+AUxNhVahK7urRQX+WlYOX/5+oUbcWizT
xO2dC14z9MTWJ/AIgbvOWzR+WPXQWpJVUxuynikH4HmzToDuwGf3HVpdw928gjIw
2SH4NtIGNBiTPZEDR+t2bZXahPa/fdqptODvL2pBypw783ue37AhMOsuA6q3Ze8B
ub/R6W0CAHBGDBp1Bb/OsGpUA/Z5FPIdns85vRlkaBu4ICM+UMzFNkfvZJCZBczz
lurbE33SAbr49hzy96hUMP1O4LliX1YIrJsi7bnWyJQigyI/g25ZKVFTcKVo2wxG
oONtLTvcsD1FtImBxSZnzqaysMHbvoTcx7T2zOJj5JDNOJxQIbYwvAXJz7Rk9zWD
I+S65ptGdDPZXN9qncq1K2WEr1aBfYFiZkQ5gJCsBpdSDNDoacJ2aKPIfw0q7+H6
gLgpj/Mz8gPayI6c+R9DROcYT4XoDQidGykD78wULja38IydfkD2HX7rO08awdgG
9XIiP3df8M8=
=tqS9
-----END PGP SIGNATURE-----

Closed
?