[PATCH] gnu: Add gvisor-tap-vsock.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Tomas Volf
Owner
unassigned
Submitted by
Tomas Volf
Severity
normal

Debbugs page

Tomas Volf wrote 1 years ago
(address . guix-patches@gnu.org)(name . Tomas Volf)(address . ~@wolfsden.cz)
b43dcddb2274a883c8998401ee695644277ea68c.1709682536.git.~@wolfsden.cz
* gnu/packages/containers.scm (gvisor-tap-vsock): New variable.

Change-Id: I50c51613509e84998f17b4be593ce80c16002778
---
The binary name is mentioned in the description because I expect that to be what
most people search for. I knew I need `gvproxy', I had no idea what was the
actual name of the project.

gnu/packages/containers.scm | 44 +++++++++++++++++++++++++++++++++++++
1 file changed, 44 insertions(+)

Toggle diff (57 lines)
diff --git a/gnu/packages/containers.scm b/gnu/packages/containers.scm
index aa270a25f3..d041263f3a 100644
--- a/gnu/packages/containers.scm
+++ b/gnu/packages/containers.scm
@@ -336,6 +336,50 @@ (define-public cni-plugins
configure network interfaces in Linux containers.")
(license license:asl2.0)))

+(define-public gvisor-tap-vsock
+ (package
+ (name "gvisor-tap-vsock")
+ (version "0.7.3")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/containers/gvisor-tap-vsock")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1q1zism0c63k2aq6yhkjqc3b2zsm4lwn0bk39p2kl79h798wfyp4"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:make-flags `(list ,(string-append "GIT_VERSION=v" version))
+ #:test-target "test"
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure)
+ (add-before 'build 'setenv
+ (lambda _
+ ;; For golang toolchain.
+ (setenv "HOME" "/tmp")))
+ (add-before 'check 'prune-tests
+ (lambda _
+ ;; Requires internet connection to fetch QEMU image.
+ (invoke "rm" "-r" "test")))
+ (replace 'install
+ (lambda _
+ (install-file "bin/gvproxy" (string-append #$output "/bin")))))))
+ (native-inputs (list go-1.20))
+ (home-page "https://github.com/containers/gvisor-tap-vsock")
+ (synopsis "Network stack for virtualization based on gVisor")
+ (description "This package provides a replacement for @code{libslirp} and
+@code{VPNKit}, written in pure Go. It is based on the network stack of gVisor
+and brings a configurable DNS server and dynamic port forwarding.
+
+It can be used with QEMU, Hyperkit, Hyper-V and User Mode Linux.
+
+The binary is called gvproxy.")
+ (license license:asl2.0)))
+
;; For podman to work, the user needs to run
;; `sudo mount -t cgroup2 none /sys/fs/cgroup`


base-commit: f18d13b5f89c161c6ee88d15ecdaa8d973ee4503
--
2.41.0
Ludovic Courtès wrote 12 months ago
(name . Tomas Volf)(address . ~@wolfsden.cz)(address . 69572-done@debbugs.gnu.org)
877chutuwf.fsf@gnu.org
Hi,

Tomas Volf <~@wolfsden.cz> skribis:

Toggle quote (4 lines)
> * gnu/packages/containers.scm (gvisor-tap-vsock): New variable.
>
> Change-Id: I50c51613509e84998f17b4be593ce80c16002778

Applied with these oh-so-important changes:
Toggle diff (16 lines)
diff --git a/gnu/packages/containers.scm b/gnu/packages/containers.scm
index eca7a697b7..61c7e74c78 100644
--- a/gnu/packages/containers.scm
+++ b/gnu/packages/containers.scm
@@ -375,9 +375,9 @@ (define-public gvisor-tap-vsock
@code{VPNKit}, written in pure Go. It is based on the network stack of gVisor
and brings a configurable DNS server and dynamic port forwarding.
-It can be used with QEMU, Hyperkit, Hyper-V and User Mode Linux.
+It can be used with QEMU, Hyperkit, Hyper-V and User-Mode Linux.
-The binary is called gvproxy.")
+The binary is called @command{gvproxy}.")
(license license:asl2.0)))
;; For podman to work, the user needs to run
Thanks,
Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 69572@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 69572
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help