Tomas Volf wrote 1 years ago
(address . guix-patches@gnu.org)(name . Tomas Volf)(address . ~@wolfsden.cz)
* gnu/packages/containers.scm (gvisor-tap-vsock): New variable.
Change-Id: I50c51613509e84998f17b4be593ce80c16002778
---
The binary name is mentioned in the description because I expect that to be what
most people search for. I knew I need `gvproxy', I had no idea what was the
actual name of the project.
gnu/packages/containers.scm | 44 +++++++++++++++++++++++++++++++++++++
1 file changed, 44 insertions(+)
Toggle diff (57 lines)
diff --git a/gnu/packages/containers.scm b/gnu/packages/containers.scm
index aa270a25f3..d041263f3a 100644
--- a/gnu/packages/containers.scm
+++ b/gnu/packages/containers.scm
@@ -336,6 +336,50 @@ (define-public cni-plugins
configure network interfaces in Linux containers.")
(license license:asl2.0)))
+(define-public gvisor-tap-vsock
+ (package
+ (name "gvisor-tap-vsock")
+ (version "0.7.3")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/containers/gvisor-tap-vsock")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1q1zism0c63k2aq6yhkjqc3b2zsm4lwn0bk39p2kl79h798wfyp4"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:make-flags `(list ,(string-append "GIT_VERSION=v" version))
+ #:test-target "test"
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure)
+ (add-before 'build 'setenv
+ (lambda _
+ ;; For golang toolchain.
+ (setenv "HOME" "/tmp")))
+ (add-before 'check 'prune-tests
+ (lambda _
+ ;; Requires internet connection to fetch QEMU image.
+ (invoke "rm" "-r" "test")))
+ (replace 'install
+ (lambda _
+ (install-file "bin/gvproxy" (string-append #$output "/bin")))))))
+ (native-inputs (list go-1.20))
+ (home-page "https://github.com/containers/gvisor-tap-vsock")
+ (synopsis "Network stack for virtualization based on gVisor")
+ (description "This package provides a replacement for @code{libslirp} and
+@code{VPNKit}, written in pure Go. It is based on the network stack of gVisor
+and brings a configurable DNS server and dynamic port forwarding.
+
+It can be used with QEMU, Hyperkit, Hyper-V and User Mode Linux.
+
+The binary is called gvproxy.")
+ (license license:asl2.0)))
+
;; For podman to work, the user needs to run
;; `sudo mount -t cgroup2 none /sys/fs/cgroup`
base-commit: f18d13b5f89c161c6ee88d15ecdaa8d973ee4503
--
2.41.0