[PATCH 0/2] libtheora: Fix cross-compiling to riscv64-linux.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Zheng Junjie
Owner
unassigned
Submitted by
Zheng Junjie
Severity
normal
Z
Z
Zheng Junjie wrote on 4 Mar 13:24 +0100
(address . guix-patches@gnu.org)
cover.1709554982.git.zhengjunjie@iscas.ac.cn
libtheora: Fix cross-compiling to riscv64-linux.

Zheng Junjie (2):
gnu: libtheora: Use Gexps.
gnu: libtheora: Fix cross-compiling to riscv64-linux.

gnu/packages/xiph.scm | 26 ++++++++++++++++++++++++--
1 file changed, 24 insertions(+), 2 deletions(-)


base-commit: 8850782392d4e58384d4c4da36a4f0bd5c8abdb1
--
2.41.0
Z
Z
Zheng Junjie wrote on 4 Mar 18:19 +0100
[PATCH 2/2] gnu: libtheora: Fix cross-compiling to riscv64-linux.
(address . 69549@debbugs.gnu.org)
56cec25717d3d0990351efad4acbe05eebe0d895.1709554982.git.zhengjunjie@iscas.ac.cn
* gnu/packages/xiph.scm (libtheora):
[native-inputs]: When cross compiling to riscv64-linux-gnu, add config.
[arguments]: When target riscv64-linux-gnu, add update-config phase.

Change-Id: Ie055cd4f6cb9d2a4601b93d1f9db227598349c7c
---
gnu/packages/xiph.scm | 22 +++++++++++++++++++++-
1 file changed, 21 insertions(+), 1 deletion(-)

Toggle diff (42 lines)
diff --git a/gnu/packages/xiph.scm b/gnu/packages/xiph.scm
index 879d8e8d39..f3603c39bb 100644
--- a/gnu/packages/xiph.scm
+++ b/gnu/packages/xiph.scm
@@ -46,6 +46,7 @@ (define-module (gnu packages xiph)
#:use-module (gnu packages xml)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
+ #:use-module (guix utils)
#:use-module (guix download)
#:use-module (guix git-download)
#:use-module (guix build-system gnu)
@@ -117,7 +118,26 @@ (define-public libtheora
(patches (search-patches "libtheora-config-guess.patch"))))
(build-system gnu-build-system)
(arguments
- (list #:configure-flags #~'("--disable-static")))
+ (append
+ (if (and (target-riscv64?)
+ (%current-target-system))
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'update-config
+ (lambda* (#:key native-inputs inputs #:allow-other-keys)
+ (for-each (lambda (file)
+ (install-file
+ (search-input-file
+ (or native-inputs inputs)
+ (string-append "/bin/" file)) "."))
+ '("config.guess" "config.sub"))))))
+ '())
+ (list #:configure-flags #~'("--disable-static"))))
+ (native-inputs
+ (if (and (target-riscv64?)
+ (%current-target-system))
+ (list config)
+ '()))
(inputs (list libvorbis))
;; The .pc files refer to libogg.
(propagated-inputs (list libogg))
--
2.41.0
Z
Z
Zheng Junjie wrote on 4 Mar 18:19 +0100
[PATCH 1/2] gnu: libtheora: Use Gexps.
(address . 69549@debbugs.gnu.org)
54eed70c09251e598db22f5f6d4bd98aaf4c8ff2.1709554982.git.zhengjunjie@iscas.ac.cn
* gnu/packages/xiph.scm (libtheora): Use Gexps.

Change-Id: Ie055cd4f6cb9d2a4601b93d1f9db227598349c7c
---
gnu/packages/xiph.scm | 6 ++++--
1 file changed, 4 insertions(+), 2 deletions(-)

Toggle diff (33 lines)
diff --git a/gnu/packages/xiph.scm b/gnu/packages/xiph.scm
index b47c718fb6..879d8e8d39 100644
--- a/gnu/packages/xiph.scm
+++ b/gnu/packages/xiph.scm
@@ -13,6 +13,7 @@
;;; Copyright © 2021 Brendan Tildesley <mail@brendan.scot>
;;; Copyright © 2021 Matthew James Kraai <kraai@ftbfs.org>
;;; Copyright © 2021 Vinicius Monego <monego@posteo.net>
+;;; Copyright © 2024 Zheng Junjie <873216071@qq.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -47,7 +48,8 @@ (define-module (gnu packages xiph)
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix git-download)
- #:use-module (guix build-system gnu))
+ #:use-module (guix build-system gnu)
+ #:use-module (guix gexp))
(define-public libogg
(package
@@ -115,7 +117,7 @@ (define-public libtheora
(patches (search-patches "libtheora-config-guess.patch"))))
(build-system gnu-build-system)
(arguments
- '(#:configure-flags '("--disable-static")))
+ (list #:configure-flags #~'("--disable-static")))
(inputs (list libvorbis))
;; The .pc files refer to libogg.
(propagated-inputs (list libogg))
--
2.41.0
L
L
Ludovic Courtès wrote on 6 Mar 23:24 +0100
Re: [bug#69549] [PATCH 0/2] libtheora: Fix cross-compiling to riscv64-linux.
(name . Zheng Junjie)(address . zhengjunjie@iscas.ac.cn)(address . 69549-done@debbugs.gnu.org)
87msrb6lsb.fsf@gnu.org
Hi,

Zheng Junjie <zhengjunjie@iscas.ac.cn> skribis:

Toggle quote (3 lines)
> gnu: libtheora: Use Gexps.
> gnu: libtheora: Fix cross-compiling to riscv64-linux.

Applied, thanks!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 69549@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 69549
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch