[PATCH 0/2] gnu: Add go-github-com-hhrutter-tiff.

  • Done
  • quality assurance status badge
Details
2 participants
  • Sharlatan Hellseher
  • Troy Figiel
Owner
unassigned
Submitted by
Troy Figiel
Severity
normal
T
T
Troy Figiel wrote on 3 Mar 17:57 +0100
(address . guix-patches@gnu.org)
87v863p7v9.fsf@troyfigiel.com
This patch series adds go-github-com-hhrutter-tiff and its dependency go-github-com-hhrutter-lzw.

Troy Figiel (2):
gnu: Add go-github-com-hhrutter-lzw.
gnu: Add go-github-com-hhrutter-tiff.

gnu/packages/golang-xyz.scm | 53 +++++++++++++++++++++++++++++++++++++
1 file changed, 53 insertions(+)


base-commit: f00f56514d90ebba5d9e08ec786c8118e437097c
--
2.42.0
T
T
Troy Figiel wrote on 3 Mar 17:35 +0100
[PATCH 1/2] gnu: Add go-github-com-hhrutter-lzw.
(address . 69527@debbugs.gnu.org)
87ttlnp7r6.fsf@troyfigiel.com
* gnu/packages/golang-xyz.scm (go-github-com-hhrutter-lzw): New variable.
---
gnu/packages/golang-xyz.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index e68948e495..a0004244a4 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -686,6 +686,29 @@ (define-public go-github-com-gabriel-vasile-mimetype
@end itemize")
(license license:expat)))
+(define-public go-github-com-hhrutter-lzw
+ (package
+ (name "go-github-com-hhrutter-lzw")
+ (version "1.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hhrutter/lzw")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1n13qhf8ih08jzm10wprdvjy56ylmy6fhakyqrddm6nszf397wch"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/hhrutter/lzw"))
+ (home-page "https://github.com/hhrutter/lzw")
+ (synopsis "Extended version of @code{compress/lzw}")
+ (description "This package is an enhanced version of @code{compress/lzw}
+in the standard library and supports GIF, TIFF and PDF.")
+ (license license:bsd-3)))
+
(define-public go-github-com-jinzhu-copier
(package
(name "go-github-com-jinzhu-copier")
--
2.42.0
T
T
Troy Figiel wrote on 3 Mar 17:54 +0100
[PATCH 2/2] gnu: Add go-github-com-hhrutter-tiff.
(address . 69527@debbugs.gnu.org)
87sf17p7pr.fsf@troyfigiel.com
* gnu/packages/golang-xyz.scm (go-github-com-hhrutter-tiff): New variable.
---
gnu/packages/golang-xyz.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index a0004244a4..e39eaa541a 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -709,6 +709,36 @@ (define-public go-github-com-hhrutter-lzw
in the standard library and supports GIF, TIFF and PDF.")
(license license:bsd-3)))
+(define-public go-github-com-hhrutter-tiff
+ (package
+ (name "go-github-com-hhrutter-tiff")
+ (version "1.0.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hhrutter/tiff")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "09fzgvxwkd34izbfd26ln8vdbhc4j9gxpar3s7h9h125psrjvg0k"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/hhrutter/tiff"))
+ (propagated-inputs (list go-golang-org-x-image go-github-com-hhrutter-lzw))
+ (home-page "https://github.com/hhrutter/tiff")
+ (synopsis "Extended version of @code{golang.org/x/image/tiff}")
+ (description "This package is an enhanced version of the
+@code{golang.org/x/image/tiff} library featuring:
+
+@itemize
+@item Read support for CCITT Group3/4 compressed images.
+@item Read/write support for LZW compressed images.
+@item Read/write support for the CMYK color model.
+@end itemize")
+ (license license:bsd-3)))
+
(define-public go-github-com-jinzhu-copier
(package
(name "go-github-com-jinzhu-copier")
--
2.42.0
T
T
Troy Figiel wrote on 3 Mar 21:58 +0100
[PATCH v2 0/2] gnu: Add go-github-com-hhrutter-tiff.
(address . 69527@debbugs.gnu.org)
87r0growgh.fsf@troyfigiel.com
golang-compression.scm is a better location for
go-github-com-hhrutter-lzw. Copyrights have also been added.

Troy Figiel (2):
gnu: Add go-github-com-hhrutter-lzw.
gnu: Add go-github-com-hhrutter-tiff.

gnu/packages/golang-compression.scm | 26 ++++++++++++++++++++++++
gnu/packages/golang-xyz.scm | 31 +++++++++++++++++++++++++++++
2 files changed, 57 insertions(+)


base-commit: f00f56514d90ebba5d9e08ec786c8118e437097c
--
2.42.0
T
T
Troy Figiel wrote on 3 Mar 21:54 +0100
[PATCH v2 1/2] gnu: Add go-github-com-hhrutter-lzw.
(address . 69527@debbugs.gnu.org)
87plwbowcm.fsf@troyfigiel.com
* gnu/packages/golang-compression.scm (go-github-com-hhrutter-lzw): New variable.
---
gnu/packages/golang-compression.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (47 lines)
diff --git a/gnu/packages/golang-compression.scm b/gnu/packages/golang-compression.scm
index 568fdd12b9..031ff54f8a 100644
--- a/gnu/packages/golang-compression.scm
+++ b/gnu/packages/golang-compression.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2021 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2021 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2022 Sharlatan Hellseher <sharlatanus@gmail.com>
+;;; Copyright © 2024 Troy Figiel <troy@troyfigiel.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -84,6 +85,30 @@ (define-public go-github-com-golang-snappy
compression format.")
(license license:bsd-3)))
+(define-public go-github-com-hhrutter-lzw
+ (package
+ (name "go-github-com-hhrutter-lzw")
+ (version "1.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hhrutter/lzw")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1n13qhf8ih08jzm10wprdvjy56ylmy6fhakyqrddm6nszf397wch"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/hhrutter/lzw"))
+ (home-page "https://github.com/hhrutter/lzw")
+ (synopsis "Extended version of @code{compress/lzw}")
+ (description
+ "This package provides an enhanced version of the @code{compress/lzw}
+library included in the stdlib, and supports GIF, TIFF and PDF.")
+ (license license:bsd-3)))
+
(define-public go-github-com-klauspost-compress
(package
(name "go-github-com-klauspost-compress")

base-commit: f00f56514d90ebba5d9e08ec786c8118e437097c
--
2.42.0
T
T
Troy Figiel wrote on 3 Mar 17:54 +0100
[PATCH v2 2/2] gnu: Add go-github-com-hhrutter-tiff.
(address . 69527@debbugs.gnu.org)
87o7bvowbr.fsf@troyfigiel.com
* gnu/packages/golang-xyz.scm (go-github-com-hhrutter-tiff): New variable.
---
gnu/packages/golang-xyz.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (51 lines)
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index e68948e495..e8260cffcf 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -15,6 +15,7 @@
;;; Copyright © 2023 Timo Wilken <guix@twilken.net>
;;; Copyright © 2023, 2024 Sharlatan Hellseher <sharlatanus@gmail.com>
;;; Copyright © 2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>
+;;; Copyright © 2024 Troy Figiel <troy@troyfigiel.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -686,6 +687,36 @@ (define-public go-github-com-gabriel-vasile-mimetype
@end itemize")
(license license:expat)))
+(define-public go-github-com-hhrutter-tiff
+ (package
+ (name "go-github-com-hhrutter-tiff")
+ (version "1.0.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hhrutter/tiff")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "09fzgvxwkd34izbfd26ln8vdbhc4j9gxpar3s7h9h125psrjvg0k"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/hhrutter/tiff"))
+ (propagated-inputs (list go-golang-org-x-image go-github-com-hhrutter-lzw))
+ (home-page "https://github.com/hhrutter/tiff")
+ (synopsis "Extended version of @code{golang.org/x/image/tiff}")
+ (description "This package is an enhanced version of the
+@code{golang.org/x/image/tiff} library featuring:
+
+@itemize
+@item Read support for CCITT Group3/4 compressed images.
+@item Read/write support for LZW compressed images.
+@item Read/write support for the CMYK color model.
+@end itemize")
+ (license license:bsd-3)))
+
(define-public go-github-com-jinzhu-copier
(package
(name "go-github-com-jinzhu-copier")
--
2.42.0
S
S
Sharlatan Hellseher wrote on 7 Mar 00:59 +0100
[PATCH 0/2] gnu: Add go-github-com-hhrutter-tiff.
(address . 69527-done@debbugs.gnu.org)
874jdi6hf3.fsf@gmail.com
Pushed as 1583fe7e24..da582bcf50 to master.

--
Oleg
-----BEGIN PGP SIGNATURE-----

iQIyBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmXpA1AACgkQdtcnv/Ys
0rWKWQ/44eZ4AQAboLE/wA5yHIGhE/qdC/N6Jk9Ujr3tyfbeeO9xClbgA/5kYxCl
v7/XO6vOHHFLLeESeGpu9JsYFgwtEqvmKJuDYN+UFSZNUUc6jaEthhvlgFXKCeL3
pLEs91+pat9Jwtdx7bCOjCkodmkVcokahSn4VvaTahSX0SuyZ3YWWjQQhabXYJZG
bOVloxk8oBoU7bhuVuEvJX7k4jGYEMlRRpAErosJITPQ1741+Ql4SO+5Bw7gZzja
Qxd34x9xW3oVIxShgEc2Qk6dbuRqwU6pN3XL8m80Tk8mfvHzg97awRD1UChJxq4E
I1zicXFJ00q7ec5rraPHwFGFVBMK7pfMkKsT5GjDhfXJ8uQ9fo/mUW3bhNy+hgVg
PzsqM1Sx5o8A0ErXqIxD1uDb/e+MbUOyFEG6yr87R4LmBgouH0U8WfkmGYMhfNeV
8mGqeQ8lFqMMr/dWIldsw69RySJqkorDONKcLf3ZwzLRL5x8URjFtzLdOk3xNLVR
D6iIoMCdhTKk7BJ9iNlCytue/vC5id7D+cairyBXuLYwwdQEAOgVuYrxkIEF+cVc
Zrn7vvRKSUY2Y2AnoyKVlOhSixEtXqyr/D/Mta6JQGIDwdUf61wguie4dnw0VpF/
JTk7TPdkJ3ws8VGWptABCXywhabjcRvw81ogLRvTi3h/RRaoZQ==
=xnxp
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 69527@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 69527
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch