[PATCH] gnu: python-pandera: Update to 0.18.0.

  • Open
  • quality assurance status badge
Details
2 participants
  • Troy Figiel
  • Vagrant Cascadian
Owner
unassigned
Submitted by
Troy Figiel
Severity
normal
T
T
Troy Figiel wrote on 2 Mar 21:46 +0100
(address . guix-patches@gnu.org)
87wmqkpcuq.fsf@troyfigiel.com
* gnu/packages/python-science.scm (python-pandera): Update to 0.18.0.
[source]: Remove snippet.
[arguments]<#:phases>: Add 'fix-tests phase.
---
gnu/packages/python-science.scm | 22 ++++++++++++----------
1 file changed, 12 insertions(+), 10 deletions(-)

Toggle diff (51 lines)
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index b6a116f16b..93b5c5c91d 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -826,7 +826,7 @@ (define-public python-pandarallel
(define-public python-pandera
(package
(name "python-pandera")
- (version "0.17.2")
+ (version "0.18.0")
(source
(origin
;; No tests in the PyPI tarball.
@@ -836,14 +836,7 @@ (define-public python-pandera
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1mnqk583z90k1n0z3lfa4rd0ng40v7hqfk7phz5gjmxlzfjbxa1x"))
- (modules '((guix build utils)))
- ;; These tests require PySpark and Modin. We need to remove the entire
- ;; directory, since the conftest.py in these directories contain
- ;; imports. (See: https://github.com/pytest-dev/pytest/issues/7452)
- (snippet '(begin
- (delete-file-recursively "tests/pyspark")
- (delete-file-recursively "tests/modin")))))
+ (base32 "14b5aij5zjkwvsimg0v00qvp59mhhq7ljim4qghcn432vkg9gh47"))))
(build-system pyproject-build-system)
(arguments
(list
@@ -854,7 +847,16 @@ (define-public python-pandera
;; positives. These tests currently fail.
"not test_python_std_list_dict_generics"
" and not test_python_std_list_dict_empty_and_none"
- " and not test_pandas_modules_importable"))))
+ " and not test_pandas_modules_importable"))
+ #:phases #~(modify-phases %standard-phases
+ (add-before 'check 'fix-tests
+ (lambda _
+ ;; These tests require PySpark and Modin. We need to
+ ;; remove the entire directory, since the conftest.py
+ ;; in these directories contain imports. (See:
+ ;; https://github.com/pytest-dev/pytest/issues/7452)
+ (for-each delete-file-recursively
+ '("tests/pyspark" "tests/modin")))))))
;; Pandera comes with a lot of extras. We test as many as possible, but do
;; not include all of them in the propagated-inputs. Currently, we have to
;; skip the pyspark and io tests due to missing packages python-pyspark

base-commit: 6f5ea7ac1acb3d1c53baf7620cca66cc87fe5a73
--
2.42.0
V
V
Vagrant Cascadian wrote on 9 Mar 07:44 +0100
87h6hfj44l.fsf@contorta
On 2024-03-02, Troy Figiel wrote:
Toggle quote (4 lines)
> diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
> index b6a116f16b..93b5c5c91d 100644
> --- a/gnu/packages/python-science.scm
> +++ b/gnu/packages/python-science.scm
...
Toggle quote (35 lines)
> @@ -836,14 +836,7 @@ (define-public python-pandera
> (commit (string-append "v" version))))
> (file-name (git-file-name name version))
> (sha256
> - (base32 "1mnqk583z90k1n0z3lfa4rd0ng40v7hqfk7phz5gjmxlzfjbxa1x"))
> - (modules '((guix build utils)))
> - ;; These tests require PySpark and Modin. We need to remove the entire
> - ;; directory, since the conftest.py in these directories contain
> - ;; imports. (See: https://github.com/pytest-dev/pytest/issues/7452)
> - (snippet '(begin
> - (delete-file-recursively "tests/pyspark")
> - (delete-file-recursively "tests/modin")))))
> + (base32 "14b5aij5zjkwvsimg0v00qvp59mhhq7ljim4qghcn432vkg9gh47"))))
> (build-system pyproject-build-system)
> (arguments
> (list
> @@ -854,7 +847,16 @@ (define-public python-pandera
> ;; positives. These tests currently fail.
> "not test_python_std_list_dict_generics"
> " and not test_python_std_list_dict_empty_and_none"
> - " and not test_pandas_modules_importable"))))
> + " and not test_pandas_modules_importable"))
> + #:phases #~(modify-phases %standard-phases
> + (add-before 'check 'fix-tests
> + (lambda _
> + ;; These tests require PySpark and Modin. We need to
> + ;; remove the entire directory, since the conftest.py
> + ;; in these directories contain imports. (See:
> + ;; https://github.com/pytest-dev/pytest/issues/7452)
> + (for-each delete-file-recursively
> + '("tests/pyspark" "tests/modin")))))))
> ;; Pandera comes with a lot of extras. We test as many as possible, but do
> ;; not include all of them in the propagated-inputs. Currently, we have to
> ;; skip the pyspark and io tests due to missing packages python-pyspark

Any compelling reason why the test removal should be moved from a
snippet to a phase? The documentation admits to this being an elusive
distinction, not really clearing things up much:


Other than that, this looks like a trivial version bump. :)

Builds fine, no dependents...

live well,
vagrant
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQRlgHNhO/zFx+LkXUXcUY/If5cWqgUCZewFWwAKCRDcUY/If5cW
qhfEAQDcdr/rd/ehzfICNmMDjlwyd0Y4veu2lY1z5kZK7jQnHAD/QwJ1DStTCZa6
aCvw3ArC0lkFP3n5bqQ3S3zXCc9JFgw=
=G6eK
-----END PGP SIGNATURE-----

T
T
Troy Figiel wrote on 9 Mar 09:50 +0100
c2052043-1928-46e5-acc1-2672513353b7@troyfigiel.com
Hi vagrant,

On 2024-03-09 07:44, Vagrant Cascadian wrote:
Toggle quote (5 lines)
> Any compelling reason why the test removal should be moved from a
> snippet to a phase? The documentation admits to this being an elusive
> distinction, not really clearing things up much:
>

I read the following as stating we should keep any source code that
could be used to build the package on different systems, including tests
that could be run on other systems:

Toggle snippet (5 lines)
The source derived from an origin should produce a source that can be
used to build the package on any system that the upstream package
supports (i.e., act as the corresponding source).

Other than that, no reason and either would be fine in my opinion. The
current documentation is more confusing rather than enlightening in this
case.

Best wishes,

Troy
?