[PATCH] gnu: Add go-github-com-hashicorp-go-multierror.

  • Done
  • quality assurance status badge
Details
2 participants
  • Artyom V. Poptsov
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Artyom V. Poptsov
Severity
normal

Debbugs page

Artyom V. Poptsov wrote 1 years ago
(address . guix-patches@gnu.org)
87msrgbck0.fsf@gmail.com
Hello,

this patchset adds two packages: "go-github-com-hashicorp-errwrap"[1]
and "go-github-com-hashicorp-go-multierror"[2].
From 8ac21911360fa825fc0b13bd58ef64c5c9151ec7 Mon Sep 17 00:00:00 2001
Message-ID: <8ac21911360fa825fc0b13bd58ef64c5c9151ec7.1709411277.git.poptsov.artyom@gmail.com>
From: "Artyom V. Poptsov" <poptsov.artyom@gmail.com>
Date: Sat, 2 Mar 2024 23:25:06 +0300
Subject: [PATCH 1/2] gnu: Add go-github-com-hashicorp-errwrap.

* gnu/packages/golang-xyz.scm (go-github-com-hashicorp-errwrap): New
variable.

Change-Id: I4a0e7c23f9aaab4e29c81a68d976dafcd86dd2d1
---
gnu/packages/golang-xyz.scm | 38 +++++++++++++++++++++++++++++++++++++
1 file changed, 38 insertions(+)

Toggle diff (53 lines)
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index e68948e495..b52753c9bb 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -686,6 +686,44 @@ (define-public go-github-com-gabriel-vasile-mimetype
@end itemize")
(license license:expat)))
+(define-public go-github-com-hashicorp-errwrap
+ (package
+ (name "go-github-com-hashicorp-errwrap")
+ (version "1.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hashicorp/errwrap")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0p5wdz8p7dmwphmb33gwhy3iwci5k9wkfqmmfa6ay1lz0cqjwp7a"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/hashicorp/errwrap"))
+ (home-page "https://github.com/hashicorp/errwrap")
+ (synopsis "Go library for wrapping and querying errors")
+ (description
+ "@code{errwrap} is a package for Go that formalizes the pattern of wrapping
+errors and checking if an error contains another error.
+
+There is a common pattern in Go of taking a returned @code{error} value and then
+wrapping it (such as with @code{fmt.Errorf}) before returning it. The problem with
+this pattern is that you completely lose the original @code{error} structure.
+
+Arguably the correct approach is that you should make a custom structure implementing
+the @code{error} interface, and have the original error as a field on that structure,
+such as @url{http://golang.org/pkg/os/#PathError, this example}. This is a good
+approach, but you have to know the entire chain of possible rewrapping that happens,
+when you might just care about one.
+
+@code{errwrap} formalizes this pattern (it doesn't matter what approach you use
+above) by giving a single interface for wrapping errors, checking if a specific error
+is wrapped, and extracting that error.")
+ (license license:mpl2.0)))
+
(define-public go-github-com-jinzhu-copier
(package
(name "go-github-com-jinzhu-copier")

base-commit: 6f5ea7ac1acb3d1c53baf7620cca66cc87fe5a73
--
2.41.0
From 7887e3d855da22c33306bbd5729d396b607d78ad Mon Sep 17 00:00:00 2001
Message-ID: <7887e3d855da22c33306bbd5729d396b607d78ad.1709411277.git.poptsov.artyom@gmail.com>
In-Reply-To: <8ac21911360fa825fc0b13bd58ef64c5c9151ec7.1709411277.git.poptsov.artyom@gmail.com>
References: <8ac21911360fa825fc0b13bd58ef64c5c9151ec7.1709411277.git.poptsov.artyom@gmail.com>
From: "Artyom V. Poptsov" <poptsov.artyom@gmail.com>
Date: Sat, 2 Mar 2024 23:26:40 +0300
Subject: [PATCH 2/2] gnu: Add go-github-com-hashicorp-go-multierror.

* gnu/packages/golang-xyz.scm (go-github-com-hashicorp-go-multierror): New
variable.

Change-Id: I6b09a52dc314c4cc6903690738debf4b6c99393f
---
gnu/packages/golang-xyz.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)

Toggle diff (46 lines)
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index b52753c9bb..3dcfd690a3 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -724,6 +724,39 @@ (define-public go-github-com-hashicorp-errwrap
is wrapped, and extracting that error.")
(license license:mpl2.0)))
+(define-public go-github-com-hashicorp-go-multierror
+ (package
+ (name "go-github-com-hashicorp-go-multierror")
+ (version "1.1.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hashicorp/go-multierror")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0l4s41skdpifndn9s8y6s9vzgghdzg4z8z0lld9qjr28888wzp00"))))
+ (build-system go-build-system)
+ (inputs (list go-github-com-hashicorp-errwrap))
+ (arguments
+ (list
+ #:import-path "github.com/hashicorp/go-multierror"))
+ (home-page "https://github.com/hashicorp/go-multierror")
+ (synopsis "Go package for representing a errors list as a single error")
+ (description
+ "@code{go-multierror} is a package for Go that provides a mechanism for
+representing a list of @code{error} values as a single @code{error}.
+
+This allows a function in Go to return an @code{error} that might actually be a list
+of errors. If the caller knows this, they can unwrap the list and access the errors.
+If the caller doesn't know, the error formats to a nice human-readable format.
+
+@code{go-multierror} is fully compatible with the Go standard library @code{errors}
+package, including the functions @code{As}, @code{Is}, and @code{Unwrap}. This
+provides a standardized approach for introspecting on error values.")
+ (license license:mpl2.0)))
+
(define-public go-github-com-jinzhu-copier
(package
(name "go-github-com-jinzhu-copier")
--
2.41.0
Those packages are required for the newer Kubo (IPFS) versions. [3]

References:

--
Artyom "avp" Poptsov <poptsov.artyom@gmail.com>
CADR Hackerspace co-founder: https://cadrspace.ru/
GPG: D0C2 EAC1 3310 822D 98DE B57C E9C5 A2D9 0898 A02F
-----BEGIN PGP SIGNATURE-----

iQJNBAEBCgA3FiEEAf2F9Bp7f4IFgwalk16+BzbchX4FAmXjjK8ZHHBvcHRzb3Yu
YXJ0eW9tQGdtYWlsLmNvbQAKCRCTXr4HNtyFfvGWD/4kJNJuTN1sZwiCetRYOiYl
aiXyOzHbF1unFA/u3hDMW4tkaexvPnQwduhwqWygG4A+PrLAeltcC/ejrhDYvQl8
PC8ryxaQFxevEAm+7/J7cixAscOMXkvb48dLplwsN5cm6zrR/J12qnkTa9IS5lk3
Mh3NnwIwnTmfWB5EMbVVtaiECgjipzf+QgfAL79EN/qNFuzt3eR8b+I33Nddf4W8
Y5HuRrJkbUwiU0o4tnKrRXwKg6buv8RUXkrg8KihIzWHK2QZHbjsgrqoRWAvCaIG
xzY1wDCgqB1jtRec4wMOV2K0+CmFDkJottRQnSaXNyql/BH4JFuwKjAf70vxx040
bp56HQQrCzfVBiNSrPhBcS3rpogrpGkAR/Pd19QYu33iDIS5QFfEi37o8LNy4Rbg
11suHGVnlAuOYZA6uFsrF852mDomRtu6RwT6nQ+Omgg2nh+YNWTdFW9eB16X31YF
juYG09liRcLu4shtkC/8ABIKoNxLqmAcMgvwfgQJi5o3sJKVszDXdddIdzGawrYF
ca+aHbqOtmKwEvaux2GJgZSgGI7fdSBOZuaVkWkJk6GP24LheBzllw6RbOiyabWE
zTIIykj/8jdUjbbYMjZmaP2VJVfTvtvVF2wudliE2aHjy1MmUs9g7cWxCgLMPWdh
6pAH9d1NoR0uytj10b3kvg==
=LEbP
-----END PGP SIGNATURE-----

Sharlatan Hellseher wrote 1 years ago
(address . 69512@debbugs.gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
CAO+9K5qD1gS7HVfpB1mJ1tgs0z9Gx8+LAs2rQpSNVGG=o5viWg@mail.gmail.com
Hi,

Thank you for the patches!

There is a conflict to apply these patches, may you check please?

I would suggest to place go-github-com-hashicorp-go-multierror
in golang-check, It seams to me more suitable module.

--
Oleg
Attachment: file
Artyom V. Poptsov wrote 1 years ago
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 69512@debbugs.gnu.org)
87ttlnf7kb.fsf@gmail.com
Hi!

Toggle quote (2 lines)
> Thank you for the patches!

Thank you for the patch review. ;-)

Toggle quote (2 lines)
> There is a conflict to apply these patches, may you check please?

Okay, I re-based my patchset onto the "master" branch; no conflicts
were found in the process.

Toggle quote (3 lines)
> I would suggest to place go-github-com-hashicorp-go-multierror
> in golang-check, It seams to me more suitable module.

I see that the "golang-check" module is for testing-related Go packages,
but it seems to me that "go-multierror" has wider range of use cases
than mere testing purposes (judging by its description at least.)

Could you elaborate?

Thanks!

- avp

--
Artyom "avp" Poptsov <poptsov.artyom@gmail.com>
CADR Hackerspace co-founder: https://cadrspace.ru/
GPG: D0C2 EAC1 3310 822D 98DE B57C E9C5 A2D9 0898 A02F
-----BEGIN PGP SIGNATURE-----

iQJNBAEBCgA3FiEEAf2F9Bp7f4IFgwalk16+BzbchX4FAmXkzPQZHHBvcHRzb3Yu
YXJ0eW9tQGdtYWlsLmNvbQAKCRCTXr4HNtyFfkRHD/0TCD3Eq7TvKQGHpmx71X4S
5IJYE5aPx5vrlM9yp7jO8iehpb1e5U6rEgnMwnkLEzr9+Dbe2PbdOW+VDf8d+R4X
NkjdHFX3PrJJBaF45/AM4pJMGOAQC0vZ0hitFuqKrlApxEvPAa1Y9/l06tN2vm7k
4p1y+r/ImiRZFe8GNprnwzIKurV5+ifpnPBKTnuMrW7RaZbmoQhjZhzHzIegYut+
1bBDf0b577YC7bQwfruyHxvGSL5voxWYSQbtNg3Sx7DNc1G/tIk3+6ldN3UnaG3c
72VY6ijtVQfWiAdxlFequzpFcj6RZusRXIgaJnrI/jtG+I+q6lEOhGlbed5oh0tQ
bsakbkbn14r2lT/YeR7BN46OeKEleL1gGsj3QrJOQp05eORheaIIkcVQ05czjyHg
80tILNY81yEBBSZb3pUkePe5Ieq8C6l3qEFYkKZ9dH87z98NITqP1c+GefBDaSuM
ugEecnZ3rH2atL0Knza2TQ95admBP2Vqdp7uuCu3fSL/IYHH8iYt2DlEUpKMXFM0
tZjozp1LyCxXIDErlJ+tDphBXIGZfyipDxvRt0qRg3iH9DGpPqYboU+qNaaXX7CX
JOw6Y+KEkt5QXc3U4ICStFvpdB9OtYsSy9fm4M0F+iq8dZYT0kNQIVTUg7sWuFBm
8aGAeWInVQ7zgrESo5J71Q==
=DlQG
-----END PGP SIGNATURE-----

Sharlatan Hellseher wrote 1 years ago
[PATCH] gnu: Add go-github-com-hashicorp-go-multierror.
(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)(address . 69512@debbugs.gnu.org)
87jzmhnfyr.fsf@gmail.com
Hi Aryom!

I've re-read description and made a review of the GitHub page of the
project, you are right about the purpose of this module so let's keep in
in golang-xyz.

I'm not sure if can access https://qa.guix.gnu.org/issue/69512. I
referred to this warning in QA:
Toggle snippet (11 lines)
Unable to apply patches
Skipping: gnu: Add go-github-com-hashicorp-go-multierror.
Applying: gnu: Add go-github-com-hashicorp-go-multierror.
error: sha1 information is lacking or useless (gnu/packages/golang-xyz.scm).
error: could not build fake ancestor
hint: Use 'git am --show-current-patch=diff' to see the failed patch
Patch failed at 0002 gnu: Add go-github-com-hashicorp-go-multierror.
When you have resolved this problem, run "git am --continue".
If you prefer to skip this patch, run "git am --skip" instead.
To restore the original branch and stop patching, run "git am --abort".
Perhaps it is no longer relevant, I'll check it locally.

Thanks,
Oleg
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmXm8GwACgkQdtcnv/Ys
0rVHZA/9FshAtx6zH05XxFCYeVK00rW/wYdSxkiaIir56QgK/ErNrbGhzZI0Mo4Y
msUsNerYGxiV1gX589SszPc1REEwh54LngmROzV5/apaHbte5j/xOQWcHz6VfPYI
0x23RcCrqWgWL7RKq/IizCsBzyRcBjoJUAwV6L3ihGLwCTRsdwSRTrm7/kn8+iA/
RTypP/OehT69S7G0tYRpbJe8ubunX6apEFfiof2iA+F0xQG+48jAO3jwXX5EH3D/
Em9RbrWbjmMhvOAZvDnJ2SKO/lZ5vZjJ+wyetB1yWKP80/KV1w08qqQNMUAOj2VJ
otOJkWvNxkyr00ZrkIXhBF3w/SzzMb1xdgzzcSpt/sCL7Ueq9oMFw7+t7SgDj0qW
Zb+4hM/yaGAHOmKRP4ceCGKEVeHbM5jVdv8v8JAT4p83q+/C8SGXRU/PXGE57yIu
fQrbJQIoqC9A88vv4XQbSG7B6ENY+aw3mjgdho8aWZhlgpzYSEw29Ixe2eGoHtfr
9ljQGkpZvnmdqocXk1kyzzLbzxzvyhKtYY74bakt5AcZb2LbZY8U3keuiumz9URj
9pOxefwAIPq9N6WkR17jymdlG5pCwxiarRhsFes8n4EkRrjlrx3YeAL+OMf3Y6rj
yupd2C2qnXuRErX9tiEbhZUe0C7H42Gu6Cy6C59x8ZHh1epluSI=
=ngcP
-----END PGP SIGNATURE-----

Artyom V. Poptsov wrote 1 years ago
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 69512@debbugs.gnu.org)
87edco8nqh.fsf@gmail.com
Hello Oleg,

here are re-based patches -- maybe it'll help to solve build problems.
From d2a20e0d9659b3fbdfd6593c01067dafd61cf157 Mon Sep 17 00:00:00 2001
Message-ID: <d2a20e0d9659b3fbdfd6593c01067dafd61cf157.1709667844.git.poptsov.artyom@gmail.com>
From: "Artyom V. Poptsov" <poptsov.artyom@gmail.com>
Date: Sat, 2 Mar 2024 23:25:06 +0300
Subject: [PATCH 1/2] gnu: Add go-github-com-hashicorp-errwrap.

* gnu/packages/golang-xyz.scm (go-github-com-hashicorp-errwrap): New
variable.

Change-Id: I4a0e7c23f9aaab4e29c81a68d976dafcd86dd2d1
---
gnu/packages/golang-xyz.scm | 38 +++++++++++++++++++++++++++++++++++++
1 file changed, 38 insertions(+)

Toggle diff (53 lines)
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index e68948e495..b52753c9bb 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -686,6 +686,44 @@ (define-public go-github-com-gabriel-vasile-mimetype
@end itemize")
(license license:expat)))
+(define-public go-github-com-hashicorp-errwrap
+ (package
+ (name "go-github-com-hashicorp-errwrap")
+ (version "1.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hashicorp/errwrap")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0p5wdz8p7dmwphmb33gwhy3iwci5k9wkfqmmfa6ay1lz0cqjwp7a"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/hashicorp/errwrap"))
+ (home-page "https://github.com/hashicorp/errwrap")
+ (synopsis "Go library for wrapping and querying errors")
+ (description
+ "@code{errwrap} is a package for Go that formalizes the pattern of wrapping
+errors and checking if an error contains another error.
+
+There is a common pattern in Go of taking a returned @code{error} value and then
+wrapping it (such as with @code{fmt.Errorf}) before returning it. The problem with
+this pattern is that you completely lose the original @code{error} structure.
+
+Arguably the correct approach is that you should make a custom structure implementing
+the @code{error} interface, and have the original error as a field on that structure,
+such as @url{http://golang.org/pkg/os/#PathError, this example}. This is a good
+approach, but you have to know the entire chain of possible rewrapping that happens,
+when you might just care about one.
+
+@code{errwrap} formalizes this pattern (it doesn't matter what approach you use
+above) by giving a single interface for wrapping errors, checking if a specific error
+is wrapped, and extracting that error.")
+ (license license:mpl2.0)))
+
(define-public go-github-com-jinzhu-copier
(package
(name "go-github-com-jinzhu-copier")

base-commit: b6dec0108f99d75066bad15aaa124b84bb0261f3
--
2.41.0
From f728a31c50c34a13efdfc4dec1a928efbbd35e39 Mon Sep 17 00:00:00 2001
Message-ID: <f728a31c50c34a13efdfc4dec1a928efbbd35e39.1709667844.git.poptsov.artyom@gmail.com>
In-Reply-To: <d2a20e0d9659b3fbdfd6593c01067dafd61cf157.1709667844.git.poptsov.artyom@gmail.com>
References: <d2a20e0d9659b3fbdfd6593c01067dafd61cf157.1709667844.git.poptsov.artyom@gmail.com>
From: "Artyom V. Poptsov" <poptsov.artyom@gmail.com>
Date: Sat, 2 Mar 2024 23:26:40 +0300
Subject: [PATCH 2/2] gnu: Add go-github-com-hashicorp-go-multierror.

* gnu/packages/golang-xyz.scm (go-github-com-hashicorp-go-multierror): New
variable.

Change-Id: I6b09a52dc314c4cc6903690738debf4b6c99393f
---
gnu/packages/golang-xyz.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)

Toggle diff (46 lines)
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index b52753c9bb..3dcfd690a3 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -724,6 +724,39 @@ (define-public go-github-com-hashicorp-errwrap
is wrapped, and extracting that error.")
(license license:mpl2.0)))
+(define-public go-github-com-hashicorp-go-multierror
+ (package
+ (name "go-github-com-hashicorp-go-multierror")
+ (version "1.1.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hashicorp/go-multierror")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0l4s41skdpifndn9s8y6s9vzgghdzg4z8z0lld9qjr28888wzp00"))))
+ (build-system go-build-system)
+ (inputs (list go-github-com-hashicorp-errwrap))
+ (arguments
+ (list
+ #:import-path "github.com/hashicorp/go-multierror"))
+ (home-page "https://github.com/hashicorp/go-multierror")
+ (synopsis "Go package for representing a errors list as a single error")
+ (description
+ "@code{go-multierror} is a package for Go that provides a mechanism for
+representing a list of @code{error} values as a single @code{error}.
+
+This allows a function in Go to return an @code{error} that might actually be a list
+of errors. If the caller knows this, they can unwrap the list and access the errors.
+If the caller doesn't know, the error formats to a nice human-readable format.
+
+@code{go-multierror} is fully compatible with the Go standard library @code{errors}
+package, including the functions @code{As}, @code{Is}, and @code{Unwrap}. This
+provides a standardized approach for introspecting on error values.")
+ (license license:mpl2.0)))
+
(define-public go-github-com-jinzhu-copier
(package
(name "go-github-com-jinzhu-copier")
--
2.41.0
- avp

--
Artyom "avp" Poptsov <poptsov.artyom@gmail.com>
CADR Hackerspace co-founder: https://cadrspace.ru/
GPG: D0C2 EAC1 3310 822D 98DE B57C E9C5 A2D9 0898 A02F
-----BEGIN PGP SIGNATURE-----

iQJNBAEBCgA3FiEEAf2F9Bp7f4IFgwalk16+BzbchX4FAmXndtYZHHBvcHRzb3Yu
YXJ0eW9tQGdtYWlsLmNvbQAKCRCTXr4HNtyFfsGYD/944CHM60QSNklpSWjZm+qA
E8oFExQu4SHuH77La35SAhbhKs/yKl6Klwq48f+bkfBQOBGZjDlags+w3WnxHA7v
1WUpko8pyLMeKTp/g8ncA/1yTfEj1OhAHg+urEtYus1lillji7t1Z7jxfh6uRYJ0
EmwHiiywFq0t0i1uga3ULlxA/9K+/ybt9F7ILDFKtPUeInjXPtk4zmlCDyP9hnTx
h2orGWw6OVIw4TTsvym0DyJ6I4VEUYIKv5ziJoiXNEMfT+SsaTZebImD8PxvOsis
D4esg9Rb7q8SAh1lRRnGKDgoUPvlcazRcLcEiT0y26hQ2hJsgvqOm6ug+2zhGDNe
L1mSomMaJQ+EnAyGtzx/XltXHT8Y/v1ehDf8688AwKqP9KdU55/zUPmqKa6JADnf
/4DtWyPhkF80V1eRiWjWRCFRGij130kugV11wMLTymrk+AWl0Oa72OiY448lhzsM
xwad97M+neEAaU6IKpPVk7vDicnpbVu4emimR1nitvE2EJEmZPI71ymTFeuUYV9J
6A1Od/Lj59Vaq2FiFPJIabHJyxBwQD3bVKAT52Qv7IHdbKQLvmMIyvqTB2BuyP2F
ENEFJjCLBg6huxGa/jXGIoGfcuLyYoDMrBnw7i+DHIORKuIhiC0GBzDxvlFks6aD
+RgineVtCmGcggRaTj8tmQ==
=R6qd
-----END PGP SIGNATURE-----

Sharlatan Hellseher wrote 1 years ago
[PATCH] gnu: Add go-github-com-hashicorp-go-multierror.
(address . 69512-done@debbugs.gnu.org)
87jzme52n9.fsf@gmail.com
Pushed as d7abe61507..b577550c00 to master.

--
Oleg
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmXpBFoACgkQdtcnv/Ys
0rUZzQ/9H71kd4U3tnEesjoVRHo+9Vqsek9XX92+M2rWKCxm6zfX4+1yCC1qviie
YlP+oQfGRLxv55plzm+Igxf11QWipM07lH8RKPVY5mjlSILFdO92jpUr9jI9zeme
yvxvUudVy/J+2ORtqdOhCXuwJy/ebHoMpeY1L1BXeXsj+6dOImv4LIGbUjQNCVex
9TYKjdXW6iI87ygCuRQktQNAg9qEo3Kh/pcO8eLO10CKQR/5q5kYbrx8avluolAN
kNQcQOfn6AmYzEkKCrHHqFXYjykOvxTDtOwln/ZRWXfSaqEwTId7Dbm9nb5uF+J8
j6khoHjvDerX1jlbkJf9WV1poMtFmAWPsnKXDBU5oWQLGEBz3uhvCSY+WH624+pt
5R+EpSsGAxOeoG2+bE+SYMki5jh5AhdDHRkOU6iqqbgb9Pl8yTXpMOyD+k3e+5u5
ZuY5YoHQNDqjPZIaO9SsjelOgQC/pXf2lXqZWUELUm/SaRSfr8Xs79LyNUubSqw2
lMSGArX5ITSuWCoTyAABiei+ldAlyqUqSmqdBehisUqsvw9i6B+o8IqOVLGMPzXi
WkOmmogAMPNmsDlem0oH/UDL9N5Q14EZKg4JNVbdTGQIRnWo9HoXm0G2KUmMhUhf
dmyJLTJUf7qEzqAdqOsl0U4DJ/P6L7X7cw+gP/aQ6xUpfFW3Ruk=
=2cbx
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 69512@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 69512
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help