Artyom V. Poptsov wrote 1 years ago
(address . guix-patches@gnu.org)
Hello,
this patchset adds two packages: "go-github-com-hashicorp-errwrap"[1]
and "go-github-com-hashicorp-go-multierror"[2].
From 8ac21911360fa825fc0b13bd58ef64c5c9151ec7 Mon Sep 17 00:00:00 2001
Message-ID: <8ac21911360fa825fc0b13bd58ef64c5c9151ec7.1709411277.git.poptsov.artyom@gmail.com>
From: "Artyom V. Poptsov" <poptsov.artyom@gmail.com>
Date: Sat, 2 Mar 2024 23:25:06 +0300
Subject: [PATCH 1/2] gnu: Add go-github-com-hashicorp-errwrap.
* gnu/packages/golang-xyz.scm (go-github-com-hashicorp-errwrap): New
variable.
Change-Id: I4a0e7c23f9aaab4e29c81a68d976dafcd86dd2d1
---
gnu/packages/golang-xyz.scm | 38 +++++++++++++++++++++++++++++++++++++
1 file changed, 38 insertions(+)
Toggle diff (53 lines)
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index e68948e495..b52753c9bb 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -686,6 +686,44 @@ (define-public go-github-com-gabriel-vasile-mimetype
@end itemize")
(license license:expat)))
+(define-public go-github-com-hashicorp-errwrap
+ (package
+ (name "go-github-com-hashicorp-errwrap")
+ (version "1.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hashicorp/errwrap")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0p5wdz8p7dmwphmb33gwhy3iwci5k9wkfqmmfa6ay1lz0cqjwp7a"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/hashicorp/errwrap"))
+ (home-page "https://github.com/hashicorp/errwrap")
+ (synopsis "Go library for wrapping and querying errors")
+ (description
+ "@code{errwrap} is a package for Go that formalizes the pattern of wrapping
+errors and checking if an error contains another error.
+
+There is a common pattern in Go of taking a returned @code{error} value and then
+wrapping it (such as with @code{fmt.Errorf}) before returning it. The problem with
+this pattern is that you completely lose the original @code{error} structure.
+
+Arguably the correct approach is that you should make a custom structure implementing
+the @code{error} interface, and have the original error as a field on that structure,
+such as @url{http://golang.org/pkg/os/#PathError, this example}. This is a good
+approach, but you have to know the entire chain of possible rewrapping that happens,
+when you might just care about one.
+
+@code{errwrap} formalizes this pattern (it doesn't matter what approach you use
+above) by giving a single interface for wrapping errors, checking if a specific error
+is wrapped, and extracting that error.")
+ (license license:mpl2.0)))
+
(define-public go-github-com-jinzhu-copier
(package
(name "go-github-com-jinzhu-copier")
base-commit: 6f5ea7ac1acb3d1c53baf7620cca66cc87fe5a73
--
2.41.0
From 7887e3d855da22c33306bbd5729d396b607d78ad Mon Sep 17 00:00:00 2001
Message-ID: <7887e3d855da22c33306bbd5729d396b607d78ad.1709411277.git.poptsov.artyom@gmail.com>
In-Reply-To: <8ac21911360fa825fc0b13bd58ef64c5c9151ec7.1709411277.git.poptsov.artyom@gmail.com>
References: <8ac21911360fa825fc0b13bd58ef64c5c9151ec7.1709411277.git.poptsov.artyom@gmail.com>
From: "Artyom V. Poptsov" <poptsov.artyom@gmail.com>
Date: Sat, 2 Mar 2024 23:26:40 +0300
Subject: [PATCH 2/2] gnu: Add go-github-com-hashicorp-go-multierror.
* gnu/packages/golang-xyz.scm (go-github-com-hashicorp-go-multierror): New
variable.
Change-Id: I6b09a52dc314c4cc6903690738debf4b6c99393f
---
gnu/packages/golang-xyz.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)
Toggle diff (46 lines)
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index b52753c9bb..3dcfd690a3 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -724,6 +724,39 @@ (define-public go-github-com-hashicorp-errwrap
is wrapped, and extracting that error.")
(license license:mpl2.0)))
+(define-public go-github-com-hashicorp-go-multierror
+ (package
+ (name "go-github-com-hashicorp-go-multierror")
+ (version "1.1.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hashicorp/go-multierror")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0l4s41skdpifndn9s8y6s9vzgghdzg4z8z0lld9qjr28888wzp00"))))
+ (build-system go-build-system)
+ (inputs (list go-github-com-hashicorp-errwrap))
+ (arguments
+ (list
+ #:import-path "github.com/hashicorp/go-multierror"))
+ (home-page "https://github.com/hashicorp/go-multierror")
+ (synopsis "Go package for representing a errors list as a single error")
+ (description
+ "@code{go-multierror} is a package for Go that provides a mechanism for
+representing a list of @code{error} values as a single @code{error}.
+
+This allows a function in Go to return an @code{error} that might actually be a list
+of errors. If the caller knows this, they can unwrap the list and access the errors.
+If the caller doesn't know, the error formats to a nice human-readable format.
+
+@code{go-multierror} is fully compatible with the Go standard library @code{errors}
+package, including the functions @code{As}, @code{Is}, and @code{Unwrap}. This
+provides a standardized approach for introspecting on error values.")
+ (license license:mpl2.0)))
+
(define-public go-github-com-jinzhu-copier
(package
(name "go-github-com-jinzhu-copier")
--
2.41.0
Those packages are required for the newer Kubo (IPFS) versions. [3]
References:
--
Artyom "avp" Poptsov <poptsov.artyom@gmail.com>
Home page: https://memory-heap.org/~avp/
CADR Hackerspace co-founder: https://cadrspace.ru/
GPG: D0C2 EAC1 3310 822D 98DE B57C E9C5 A2D9 0898 A02F
-----BEGIN PGP SIGNATURE-----
iQJNBAEBCgA3FiEEAf2F9Bp7f4IFgwalk16+BzbchX4FAmXjjK8ZHHBvcHRzb3Yu
YXJ0eW9tQGdtYWlsLmNvbQAKCRCTXr4HNtyFfvGWD/4kJNJuTN1sZwiCetRYOiYl
aiXyOzHbF1unFA/u3hDMW4tkaexvPnQwduhwqWygG4A+PrLAeltcC/ejrhDYvQl8
PC8ryxaQFxevEAm+7/J7cixAscOMXkvb48dLplwsN5cm6zrR/J12qnkTa9IS5lk3
Mh3NnwIwnTmfWB5EMbVVtaiECgjipzf+QgfAL79EN/qNFuzt3eR8b+I33Nddf4W8
Y5HuRrJkbUwiU0o4tnKrRXwKg6buv8RUXkrg8KihIzWHK2QZHbjsgrqoRWAvCaIG
xzY1wDCgqB1jtRec4wMOV2K0+CmFDkJottRQnSaXNyql/BH4JFuwKjAf70vxx040
bp56HQQrCzfVBiNSrPhBcS3rpogrpGkAR/Pd19QYu33iDIS5QFfEi37o8LNy4Rbg
11suHGVnlAuOYZA6uFsrF852mDomRtu6RwT6nQ+Omgg2nh+YNWTdFW9eB16X31YF
juYG09liRcLu4shtkC/8ABIKoNxLqmAcMgvwfgQJi5o3sJKVszDXdddIdzGawrYF
ca+aHbqOtmKwEvaux2GJgZSgGI7fdSBOZuaVkWkJk6GP24LheBzllw6RbOiyabWE
zTIIykj/8jdUjbbYMjZmaP2VJVfTvtvVF2wudliE2aHjy1MmUs9g7cWxCgLMPWdh
6pAH9d1NoR0uytj10b3kvg==
=LEbP
-----END PGP SIGNATURE-----