[PATCH emacs-team 0/2] Update emacs-next

  • Open
  • quality assurance status badge
Details
2 participants
  • Andrew Tropin
  • Liliana Marie Prikler
Owner
unassigned
Submitted by
Liliana Marie Prikler
Severity
normal
L
L
Liliana Marie Prikler wrote on 2 Mar 18:08 +0100
(address . guix-patches@gnu.org)
cover.1709399317.git.liliana.prikler@gmail.com
Liliana Marie Prikler (2):
guix: emacs-utils: Make emacs-compile-directory forwards-compatible.
gnu: emacs-next-minimal: Update to 30.0.50-2.170c655.

gnu/packages/aux-files/emacs/comp-integrity.el | 5 ++++-
gnu/packages/emacs.scm | 6 +++---
guix/build/emacs-utils.scm | 11 +++++++++--
3 files changed, 16 insertions(+), 6 deletions(-)


base-commit: 3d4fc910f73220f47e5f2459853333a7c83c5d1d
--
2.41.0
L
L
Liliana Marie Prikler wrote on 2 Mar 16:56 +0100
[PATCH emacs-team 1/2] guix: emacs-utils: Make emacs-compile-directory forwards-compatible.
(address . 69510@debbugs.gnu.org)(name . Mekeor Melire)(address . mekeor@posteo.de)
7f3f70eedbbec74481a0ca9fea4c19250961685e.1709446767.git.liliana.prikler@gmail.com
Newer (development) builds of Emacs 30 mark a number of functions related to
native compilation as ‘internal’. Since we rely on such functions and there
does not appear to be a high-level replacement at the moment, let's work
around this case.

* guix/build/emacs-utils.scm (emacs-compile-directory): Require comp early
and check if ‘comp-write-bytecode-file’ is available.

Fixes: Upstream renamed comp-write-bytecode-file https://bugs.gnu.org/69201
---
guix/build/emacs-utils.scm | 11 +++++++++--
1 file changed, 9 insertions(+), 2 deletions(-)

Toggle diff (33 lines)
diff --git a/guix/build/emacs-utils.scm b/guix/build/emacs-utils.scm
index eca42bf305..aeb364133a 100644
--- a/guix/build/emacs-utils.scm
+++ b/guix/build/emacs-utils.scm
@@ -136,7 +136,14 @@ (define* (emacs-compile-directory dir)
(emacs-batch-eval
`(let ((byte-compile-debug t) ; for proper exit status
(byte+native-compile (native-comp-available-p))
- (files (directory-files-recursively ,dir "\\.el$")))
+ (files (directory-files-recursively ,dir "\\.el$"))
+ (write-bytecode
+ (and (native-comp-available-p)
+ (progn
+ (require 'comp)
+ (if (fboundp 'comp-write-bytecode-file)
+ 'comp-write-bytecode-file
+ 'comp--write-bytecode-file)))))
(mapc
(lambda (file)
(let (byte-to-native-output-buffer-file
@@ -152,7 +159,7 @@ (define* (emacs-compile-directory dir)
(byte-compile-file file))
;; After native compilation, write the bytecode file.
(unless (null byte-to-native-output-buffer-file)
- (comp-write-bytecode-file nil))))
+ (funcall write-bytecode nil))))
files))
#:dynamic? #t))

base-commit: 3d4fc910f73220f47e5f2459853333a7c83c5d1d
--
2.41.0
L
L
Liliana Marie Prikler wrote on 2 Mar 17:13 +0100
[PATCH emacs-team 2/2] gnu: emacs-next-minimal: Update to 30.0.50-2.170c655.
(address . 69510@debbugs.gnu.org)(name . Mekeor Melire)(address . mekeor@posteo.de)
84e125eb27bc97dc00c260bb03238447134f6d5c.1709446767.git.liliana.prikler@gmail.com
* gnu/packages/emacs.scm (emacs-next-minimal): Update to 30.0.50-2.170c655.
* gnu/packages/aux-files/emacs/comp-integrity.el: Adjust accordingly.
---
gnu/packages/aux-files/emacs/comp-integrity.el | 5 ++++-
gnu/packages/emacs.scm | 6 +++---
2 files changed, 7 insertions(+), 4 deletions(-)

Toggle diff (42 lines)
diff --git a/gnu/packages/aux-files/emacs/comp-integrity.el b/gnu/packages/aux-files/emacs/comp-integrity.el
index ed6a348fed..9692d9bf97 100644
--- a/gnu/packages/aux-files/emacs/comp-integrity.el
+++ b/gnu/packages/aux-files/emacs/comp-integrity.el
@@ -89,7 +89,10 @@
(expect-native mouse-wheel-change-button)
(expect-native advice-function-mapc)
(expect-native comment-string-strip)
-(expect-native obarray-make)
+(if (>= emacs-major-version 30)
+ (expect-builtin obarray-make)
+ (expect-native obarray-make))
+(expect-native obarray-map)
(expect-native oclosure-type)
(expect-native forward-page)
(expect-native sentence-end)
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index e6f2b699ac..e89c6cff16 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -549,8 +549,8 @@ (define-public emacs-wide-int
#~(cons "--with-wide-int" #$flags))))))
(define-public emacs-next-minimal
- (let ((commit "9d27b95b263473fb41a30e3f6ea5607c99e93a61")
- (revision "1"))
+ (let ((commit "170c6557922dad7e6e9bc0d6dadf6c080108fd42")
+ (revision "2"))
(package
(inherit emacs-minimal)
(name "emacs-next-minimal")
@@ -563,7 +563,7 @@ (define-public emacs-next-minimal
(commit commit)))
(file-name (git-file-name name version))
(sha256
- (base32 "00mwpq1msr3jij281w5piqmbwq968xr8dn9hqbf4r947ck754kn9"))
+ (base32 "04carva3b6h9fnlzazrsxsj41hcnjc26kxjij07l159azi40l6sk"))
(patches
(search-patches "emacs-next-exec-path.patch"
"emacs-fix-scheme-indent-function.patch"
--
2.41.0
A
A
Andrew Tropin wrote on 4 Mar 15:45 +0100
Re: [bug#69510] [PATCH emacs-team 1/2] guix: emacs-utils: Make emacs-compile-directory forwards-compatible.
878r2yaweh.fsf@trop.in
On 2024-03-02 16:56, Liliana Marie Prikler wrote:

Toggle quote (45 lines)
> Newer (development) builds of Emacs 30 mark a number of functions related to
> native compilation as ‘internal’. Since we rely on such functions and there
> does not appear to be a high-level replacement at the moment, let's work
> around this case.
>
> * guix/build/emacs-utils.scm (emacs-compile-directory): Require comp early
> and check if ‘comp-write-bytecode-file’ is available.
>
> Fixes: Upstream renamed comp-write-bytecode-file <https://bugs.gnu.org/69201>
> ---
> guix/build/emacs-utils.scm | 11 +++++++++--
> 1 file changed, 9 insertions(+), 2 deletions(-)
>
> diff --git a/guix/build/emacs-utils.scm b/guix/build/emacs-utils.scm
> index eca42bf305..aeb364133a 100644
> --- a/guix/build/emacs-utils.scm
> +++ b/guix/build/emacs-utils.scm
> @@ -136,7 +136,14 @@ (define* (emacs-compile-directory dir)
> (emacs-batch-eval
> `(let ((byte-compile-debug t) ; for proper exit status
> (byte+native-compile (native-comp-available-p))
> - (files (directory-files-recursively ,dir "\\.el$")))
> + (files (directory-files-recursively ,dir "\\.el$"))
> + (write-bytecode
> + (and (native-comp-available-p)
> + (progn
> + (require 'comp)
> + (if (fboundp 'comp-write-bytecode-file)
> + 'comp-write-bytecode-file
> + 'comp--write-bytecode-file)))))
> (mapc
> (lambda (file)
> (let (byte-to-native-output-buffer-file
> @@ -152,7 +159,7 @@ (define* (emacs-compile-directory dir)
> (byte-compile-file file))
> ;; After native compilation, write the bytecode file.
> (unless (null byte-to-native-output-buffer-file)
> - (comp-write-bytecode-file nil))))
> + (funcall write-bytecode nil))))
> files))
> #:dynamic? #t))
>
>
> base-commit: 3d4fc910f73220f47e5f2459853333a7c83c5d1d

Hi Liliana!

Looks reasonable to me.

--
Best regards,
Andrew Tropin
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEKEGaxlA4dEDH6S/6IgjSCVjB3rAFAmXl3nYACgkQIgjSCVjB
3rCt3Q//QQ2kWj+fSw2BURC8LBS24w0GWQ6PYJi24IaBxO5cWDRvYsNb9HpZ3Kav
JrGPvc+DNya/XVOM44SHgI4s20O/ri2nA9UBmTcg/BSqvkvEAbakeWhub5qbYn13
ETCZbsz1YtJcOLvtRtdRHDr3XTwkD7VUAS/3FRYOU/LCvb+9rZf81RX7teszDX4y
jtRZ+n7BTLcmreZ2axfsO9Kjw56xadpgLPNQAQ4zsA1tEr981GNvW0c4myGaRCzl
H4xJtWCuTjIHqbiMRaaad9VHgouwXosY+mTfxX7r7vUrqloHc/mmC6Pf28Ass+3p
4Mxg5DbZTZXnT/iA2GG7/twGlK0LwF78hFZ0MjZp3f2bGylPJfAc2J5tB0BdgVvW
oPIpfCntvihXBuSO9/Sfr47W5KUzJ2Ss+d2pojTZu34NQMyjU2W226KQLAls4BQ0
w5UovNW1A5zsJo5/VBth+myoD8WyY1DR0HJVQmYR++gVHbkqIZ2IuoEjdnEvudYc
TO+9Jq6ixxh1chW2JkFH+KRvPs71jYMCGRLt9qOfSJBfeLHO1w2ORhi6mz0SEXAC
IMZ62/EadSKZX2Wba0UHKOU+KscRP0Cr1uTOT3G2Ai0MIJbWe8Zs9xYJMxll3SLd
KSjUuapB8t1VGJe4v74vn06y9BvFxXZvCPEbKckpcKeulsem9lw=
=r1wn
-----END PGP SIGNATURE-----

?