[PATCH 0/6] Update GIMP

  • Done
  • quality assurance status badge
Details
One participant
  • Liliana Marie Prikler
Owner
unassigned
Submitted by
Liliana Marie Prikler
Severity
normal
L
L
Liliana Marie Prikler wrote on 29 Feb 18:53 +0100
(address . guix-patches@gnu.org)
cover.1709229203.git.liliana.prikler@gmail.com
Hi Guix,

this series updates gimp to the latest stable version and also adds
a preview for the soon-to-be-released gimp 3. I've built both locally,
but haven't tested them so far.

Hope you find them helpful, cheers!

Liliana Marie Prikler (6):
gnu: babl: Update to 0.1.108.
gnu: gegl: Update to 0.4.48.
gnu: babl: Build with introspection.
gnu: gegl: Build with introspection.
gnu: gimp: Update to 2.10.36.
gnu: Add gimp-next.

gnu/packages/gimp.scm | 66 +++++++++++++++++++++++++++++++++++--------
1 file changed, 55 insertions(+), 11 deletions(-)


base-commit: b402a438f8179119109633200fb6b1b890eedd99
--
2.41.0
L
L
Liliana Marie Prikler wrote on 29 Feb 06:16 +0100
[PATCH 1/6] gnu: babl: Update to 0.1.108.
(address . 69477@debbugs.gnu.org)
3c75bee8dc8efa7bb4888300c62030b75a9d21a8.1709229203.git.liliana.prikler@gmail.com
* gnu/packages/gimp.scm (babl): Update to 0.1.108.
---
gnu/packages/gimp.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/gimp.scm b/gnu/packages/gimp.scm
index b1ff08d652..5287ec78d5 100644
--- a/gnu/packages/gimp.scm
+++ b/gnu/packages/gimp.scm
@@ -175,7 +175,7 @@ (define-public mrg
(define-public babl
(package
(name "babl")
- (version "0.1.96")
+ (version "0.1.108")
(source (origin
(method url-fetch)
(uri (list (string-append "https://download.gimp.org/pub/babl/"
@@ -189,7 +189,7 @@ (define-public babl
"/babl-" version ".tar.xz")))
(sha256
(base32
- "1xj5hlmm834lb84rpjlfxbqnm5piswgzhjas4h8z90x9b7j3yrrk"))))
+ "0x8lxvnhfpssj84x47y3y06vsvhd5afb9jknw38c8ymbxafzxpi6"))))
(build-system meson-build-system)
(arguments
`(#:configure-flags
--
2.41.0
L
L
Liliana Marie Prikler wrote on 29 Feb 18:47 +0100
[PATCH 5/6] gnu: gimp: Update to 2.10.36.
(address . 69477@debbugs.gnu.org)
7e2631bdb2ca64bfd5b33c2438cce4c77d15252b.1709229203.git.liliana.prikler@gmail.com
* gnu/packages/gimp.scm (gimp): Update to 2.10.36.
---
gnu/packages/gimp.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/gimp.scm b/gnu/packages/gimp.scm
index d065182c7f..ebe1e20c97 100644
--- a/gnu/packages/gimp.scm
+++ b/gnu/packages/gimp.scm
@@ -285,7 +285,7 @@ (define-public gegl
(define-public gimp
(package
(name "gimp")
- (version "2.10.32")
+ (version "2.10.36")
(source
(origin
(method url-fetch)
@@ -293,7 +293,7 @@ (define-public gimp
(version-major+minor version)
"/gimp-" version ".tar.bz2"))
(sha256
- (base32 "09csp2d8bzf012n7hvbbwngwr9phv3rnip768qdwqpdgah2wf59z"))))
+ (base32 "1cnvgkni2q4psv8syyl5yd9kk84fv5g3imd2kgm3mnsbkb3c6frx"))))
(build-system gnu-build-system)
(outputs '("out"
"doc")) ; 9 MiB of gtk-doc HTML
--
2.41.0
L
L
Liliana Marie Prikler wrote on 29 Feb 06:17 +0100
[PATCH 2/6] gnu: gegl: Update to 0.4.48.
(address . 69477@debbugs.gnu.org)
5ef2caf92f2f1ee78e0559133f2e26b5a3c2dd14.1709229203.git.liliana.prikler@gmail.com
* gnu/packages/gimp.scm (gegl): Update to 0.4.48.
---
gnu/packages/gimp.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/gimp.scm b/gnu/packages/gimp.scm
index 5287ec78d5..555a170665 100644
--- a/gnu/packages/gimp.scm
+++ b/gnu/packages/gimp.scm
@@ -215,7 +215,7 @@ (define-public babl
(define-public gegl
(package
(name "gegl")
- (version "0.4.42")
+ (version "0.4.48")
(source
(origin
(method url-fetch)
@@ -229,7 +229,7 @@ (define-public gegl
(version-major+minor version)
"/gegl-" version ".tar.xz")))
(sha256
- (base32 "0bg0vlmj4n9x1291b9fsjqxsal192zlg48pa57f6xid6p863ma5b"))))
+ (base32 "0iw2wag3sls7va4c3dmczisbs9na4ml0rppnk1ymv0789gcjd321"))))
(build-system meson-build-system)
(arguments
`(#:configure-flags
--
2.41.0
L
L
Liliana Marie Prikler wrote on 29 Feb 18:47 +0100
[PATCH 6/6] gnu: Add gimp-next.
(address . 69477@debbugs.gnu.org)
260586dc4bda46c68443a8c8db97abfc0724d3eb.1709229203.git.liliana.prikler@gmail.com
* gnu/packages/gimp.scm (gimp-next): New variable.
---
gnu/packages/gimp.scm | 47 +++++++++++++++++++++++++++++++++++++++++++
1 file changed, 47 insertions(+)

Toggle diff (67 lines)
diff --git a/gnu/packages/gimp.scm b/gnu/packages/gimp.scm
index ebe1e20c97..3c4353f8a0 100644
--- a/gnu/packages/gimp.scm
+++ b/gnu/packages/gimp.scm
@@ -38,6 +38,7 @@ (define-module (gnu packages gimp)
#:use-module (gnu packages)
#:use-module (gnu packages algebra)
#:use-module (gnu packages autotools)
+ #:use-module (gnu packages backup)
#:use-module (gnu packages base)
#:use-module (gnu packages build-tools)
#:use-module (gnu packages documentation)
@@ -367,6 +368,52 @@ (define-public gimp
that is extensible via a plugin system.")
(license license:gpl3+))) ; some files are lgplv3
+(define-public gimp-next
+ (package
+ (inherit gimp)
+ (name "gimp-next")
+ (version "2.99.18")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://download.gimp.org/pub/gimp/v"
+ (version-major+minor version)
+ "/gimp-" version ".tar.xz"))
+ (sha256
+ (base32 "0vnvdl7x88njyyxkbgdbhz6jwz1qasrxh0fpwk6x1m609alvf6wc"))))
+ (build-system meson-build-system)
+ (arguments
+ (list #:modules `((ice-9 popen)
+ (ice-9 rdelim)
+ (guix build meson-build-system)
+ (guix build utils))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'remove-gcc-reference
+ ;; Avoid reference to GCC.
+ (lambda _
+ (let* ((port (open-input-pipe "gcc -v 2>&1 | tail -n 1"))
+ (cc-version (read-line port)))
+ (close-pipe port)
+ (substitute* "app/gimp-version.c"
+ (("CC_VERSION") (string-append "\"" cc-version "\""))))))
+ (add-after 'install 'move-doc
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out"))
+ (doc (assoc-ref outputs "doc")))
+ (mkdir-p (string-append doc "/share"))
+ (rename-file (string-append out "/share/doc")
+ (string-append doc "/share/doc"))))))))
+ (inputs (modify-inputs (package-inputs gimp)
+ (replace "gtk+" gtk+)
+ (prepend libxmu libxt)
+ (prepend python gjs)
+ (prepend libxslt)))
+ (native-inputs (modify-inputs (package-native-inputs gimp)
+ (prepend appstream-glib
+ gi-docgen
+ libarchive)))))
+
(define-public gimp-fourier
(package
(name "gimp-fourier")
--
2.41.0
L
L
Liliana Marie Prikler wrote on 29 Feb 06:17 +0100
[PATCH 3/6] gnu: babl: Build with introspection.
(address . 69477@debbugs.gnu.org)
f3a84874a1d3a80b8be77b94893f2f465bee7728.1709229203.git.liliana.prikler@gmail.com
* gnu/packages/gimp.scm (babl)[#:configure-flags]: Remove “-Denable-gir=false”.
---
gnu/packages/gimp.scm | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/gimp.scm b/gnu/packages/gimp.scm
index 555a170665..07581a4595 100644
--- a/gnu/packages/gimp.scm
+++ b/gnu/packages/gimp.scm
@@ -193,8 +193,7 @@ (define-public babl
(build-system meson-build-system)
(arguments
`(#:configure-flags
- (list "-Denable-gir=false"
- "-Dwith-docs=false")))
+ (list "-Dwith-docs=false")))
(native-inputs
(list gobject-introspection pkg-config vala))
(propagated-inputs
--
2.41.0
L
L
Liliana Marie Prikler wrote on 29 Feb 06:18 +0100
[PATCH 4/6] gnu: gegl: Build with introspection.
(address . 69477@debbugs.gnu.org)
e2d0e577b27b44c06fa0576fa9eb0a4621b764c9.1709229203.git.liliana.prikler@gmail.com
* gnu/packages/gimp.scm (gegl)[arguments]: Remove #:configure-flags.
---
gnu/packages/gimp.scm | 4 +---
1 file changed, 1 insertion(+), 3 deletions(-)

Toggle diff (17 lines)
diff --git a/gnu/packages/gimp.scm b/gnu/packages/gimp.scm
index 07581a4595..d065182c7f 100644
--- a/gnu/packages/gimp.scm
+++ b/gnu/packages/gimp.scm
@@ -231,9 +231,7 @@ (define-public gegl
(base32 "0iw2wag3sls7va4c3dmczisbs9na4ml0rppnk1ymv0789gcjd321"))))
(build-system meson-build-system)
(arguments
- `(#:configure-flags
- (list "-Dintrospection=false")
- #:phases
+ `(#:phases
(modify-phases %standard-phases
(add-after 'unpack 'extend-test-time-outs
(lambda _
--
2.41.0
L
L
Liliana Marie Prikler wrote on 9 Mar 07:45 +0100
Re: [PATCH 6/6] gnu: Add gimp-next.
(address . 69477-done@debbugs.gnu.org)
4a0bf5a0ed59d0cbac1251562af4a5fa1f965360.camel@gmail.com
Am Donnerstag, dem 29.02.2024 um 18:47 +0100 schrieb Liliana Marie
Prikler:
Toggle quote (2 lines)
> * gnu/packages/gimp.scm (gimp-next): New variable.
> ---
Pushed.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 69477@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 69477
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch