[PATCH] gnu: Add python-sqlalchemy-2.

  • Open
  • quality assurance status badge
Details
One participant
  • Tanguy Le Carrour
Owner
unassigned
Submitted by
Tanguy Le Carrour
Severity
normal
T
T
Tanguy Le Carrour wrote on 28 Feb 15:30 +0100
(address . guix-patches@gnu.org)(name . Tanguy Le Carrour)(address . tanguy@bioneland.org)
b573ae1f8c32a32b6b4c9b1dd4aa4e212ad83d2d.1709130457.git.tanguy@bioneland.org
Hi Guix,

This patch adds SQLAlchemy version 2.
I disabled some (more) expensive tests. I also removed sanity check
on greenlet, for it is optional according to the documentation.

Regards.

* gnu/packages/databases.scm (python-sqlalchemy-2): New variable.

Change-Id: I6de8a9d9ab5938b6d7129f884fe31902df828889
---
gnu/packages/databases.scm | 46 ++++++++++++++++++++++++++++++++++++++
1 file changed, 46 insertions(+)

Toggle diff (61 lines)
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index c8824b09c9..7a4e13bb06 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -3594,6 +3594,52 @@ (define-public python-sqlalchemy
simple and Pythonic domain language.")
(license license:x11)))
+(define-public python-sqlalchemy-2
+ (package
+ (name "python-sqlalchemy")
+ (version "2.0.27")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "SQLAlchemy" version))
+ (sha256
+ (base32 "1y1l4lwhvgs7ivwhcp4vljjdsaha77x9859kz65virhzlxlyv9l6"))))
+ (build-system pyproject-build-system)
+ (native-inputs (list python-pytest python-setuptools python-wheel))
+ (propagated-inputs (list python-typing-extensions))
+ (arguments
+ (list
+ #:phases #~(modify-phases %standard-phases
+ (add-after 'unpack 'disable-tests
+ (lambda _
+ ;; Remove expensive tests.
+ (for-each delete-file
+ '("test/ext/mypy/test_mypy_plugin_py3k.py"
+ "test/typing/test_mypy.py"
+ "test/aaa_profiling/test_memusage.py"))
+ (substitute* "test/engine/test_pool.py"
+ ;; Disable a test that fails randomly.
+ (("def test_recycle_pool_no_race")
+ "def _test_recycle_pool_no_race")) #t))
+ ;; According to the pyproject.toml, greenlet is optional.
+ (add-after 'unpack 'remove-dependency-on-greenlet
+ (lambda _
+ (substitute* "setup.cfg"
+ (("greenlet != 0.4.17")
+ "#greenlet != 0.4.17"))
+ (substitute* "PKG-INFO"
+ (("Requires-Dist: greenlet")
+ "#Requires-Dist: greenlet")))))))
+ (home-page "https://www.sqlalchemy.org")
+ (synopsis "SQL toolkit and object relational mapper")
+ (description
+ "SQLAlchemy is the Python SQL toolkit and @acronym{ORM, Object Relational Mapper}
+that gives application developers the full power and flexibility of SQL. It provides
+a full suite of well known enterprise-level persistence patterns, designed for
+efficient and high-performing database access, adapted into a simple and Pythonic
+domain language.")
+ (license license:expat))) ;; MIT
+
(define-public python-sqlalchemy-stubs
(package
(name "python-sqlalchemy-stubs")

base-commit: 03a03ed64a62e23b9d3da8758dbf7754b186982f
--
2.41.0
?