(address . guix-patches@gnu.org)(name . Tanguy Le Carrour)(address . tanguy@bioneland.org)
Hi Guix,
This patch adds Mistune v3, but… we already have 2 other versions of
Mistune:
- python-mistune (0.8.4)
- python-mistune-next (2.0.4)
Would it be ok if, in a following patch, I renamed python-mistune-next to
python-mistune-2 and change the 3 packages that use it?
Regards.
* gnu/packages/python-xyz.scm (python-mistune-3): New variable.
Change-Id: I59adfb92ed65a10292090c758108e889467f28d7
---
gnu/packages/python-xyz.scm | 18 ++++++++++++++++++
1 file changed, 18 insertions(+)
Toggle diff (33 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 8691f70375..4ecc2e5e5d 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -14155,6 +14155,24 @@ (define-public python-mistune-next
(invoke "pytest" "-vv")))))))
(native-inputs (list python-pytest))))
+(define-public python-mistune-3
+ (package
+ (name "python-mistune")
+ (version "3.0.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "mistune" version))
+ (sha256
+ (base32 "1s4ba1m69yldrhnyfj8lm4bl3axbi95g1dicxya27j9hv7g96zzw"))))
+ (build-system pyproject-build-system)
+ (native-inputs (list python-pytest python-setuptools python-wheel))
+ (home-page "https://github.com/lepture/mistune")
+ (synopsis "Markdown parser in pure Python")
+ (description "This package provides a fast markdown parser in pure
+Python.")
+ (license license:bsd-3)))
+
(define-public python-markdown
(package
(name "python-markdown")
base-commit: 178c36e1ee6915a27f042f64a6357d5ed9c8cb49
--
2.41.0