[PATCH python-team 0/9] gnu: Add python-flask-3.

  • Open
  • quality assurance status badge
Details
One participant
  • Tanguy Le Carrour
Owner
unassigned
Submitted by
Tanguy Le Carrour
Severity
normal
T
T
Tanguy Le Carrour wrote on 28 Feb 10:42 +0100
(address . guix-patches@gnu.org)(name . Tanguy Le Carrour)(address . tanguy@bioneland.org)
cover.1709112911.git.tanguy@bioneland.org
Hi Guix, hi Python team,

Here is a patch set that adds Flask 3. As it is a major version,
I decided to add a new variable. And, as it depends on Werkzeug 3,
I did the same for it. Please let me know if you think it was not
the proper way to go.

I also submit some trivial package updates to the python-team branch,
as some of them trigger quite a lot of rebuilds (3500+ for python-jinja2).

Regards,

Tanguy Le Carrour (9):
gnu: python-itsdangerous: Update to 2.1.2.
gnu: python-jinja2: Update to 3.1.3.
gnu: python-click: Update to 8.1.7.
gnu: python-blinker: Update to 1.7.0.
gnu: Add python-ephemeral-port-reserve.
gnu: python-werkzeug: Rename variable to python-werkzeug-2.
gnu: Add python-werkzeug-3.
gnu: python-flask: Rename to python-flask-2.
gnu: Add python-flask-3.

gnu/packages/python-web.scm | 80 +++++++++++++++++++++++++++++++++++--
gnu/packages/python-xyz.scm | 41 ++++++++++++++-----
2 files changed, 106 insertions(+), 15 deletions(-)


base-commit: b77f45a62c71e326aeaab486c700bc51af29760c
--
2.41.0
T
T
Tanguy Le Carrour wrote on 28 Feb 11:15 +0100
[PATCH python-team 1/9] gnu: python-itsdangerous: Update to 2.1.2.
(address . 69449@debbugs.gnu.org)(name . Tanguy Le Carrour)(address . tanguy@bioneland.org)
163ccb8f11cfc9e0da9f5f98566b98c8250b5d43.1709112911.git.tanguy@bioneland.org
* gnu/packages/python-xyz.scm (python-itsdangerous): Update to 2.1.2.

Change-Id: I59ad3927995fc5f8b63f578a4f7fc4c0ea60678e
---
gnu/packages/python-xyz.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (32 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e5aeeef14e..bdcdf8c7c8 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -65,7 +65,7 @@
;;; Copyright © 2019 Jacob MacDonald <jaccarmac@gmail.com>
;;; Copyright © 2019-2021, 2023, 2024 Giacomo Leidi <goodoldpaul@autistici.org>
;;; Copyright © 2019 Wiktor ?elazny <wzelazny@vurv.cz>
-;;; Copyright © 2019, 2020, 2021, 2022 Tanguy Le Carrour <tanguy@bioneland.org>
+;;; Copyright © 2019, 2020, 2021, 2022, 2024 Tanguy Le Carrour <tanguy@bioneland.org>
;;; Copyright © 2019, 2021-2023 M?d?lin Ionel Patra?cu <madalinionel.patrascu@mdc-berlin.de>
;;; Copyright © 2020 Riku Viitanen <riku.viitanen@protonmail.com>
;;; Copyright © 2020 Jakub K?dzio?ka <kuba@kadziolka.net>
@@ -5743,14 +5743,14 @@ (define-public python-pympler
(define-public python-itsdangerous
(package
(name "python-itsdangerous")
- (version "2.0.1")
+ (version "2.1.2")
(source
(origin
(method url-fetch)
(uri (pypi-uri "itsdangerous" version))
(sha256
(base32
- "1w6gfb2zhbcmrfj6digwzw1z68w6zg1q87rm6la2m412zil4swly"))))
+ "0shmfj4c67xgdawxxri2zqxzrhsxaiiif0pr4zrl4pky665wdfsx"))))
(build-system python-build-system)
(home-page "https://palletsprojects.com/p/itsdangerous/")
(synopsis "Python library for passing data to/from untrusted environments")
--
2.41.0
T
T
Tanguy Le Carrour wrote on 28 Feb 11:15 +0100
[PATCH python-team 5/9] gnu: Add python-ephemeral-port-reserve.
(address . 69449@debbugs.gnu.org)(name . Tanguy Le Carrour)(address . tanguy@bioneland.org)
6d1553d1951618972c75ba4951c09966cb476fd0.1709112912.git.tanguy@bioneland.org
* gnu/packages/python-xyz.scm (python-ephemeral-port-reserve): New variable.

Change-Id: I98d153179ac533fad3fa7c12a838bd12bb615a15
---
gnu/packages/python-xyz.scm | 18 ++++++++++++++++++
1 file changed, 18 insertions(+)

Toggle diff (31 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index a6f3aec7ed..348b3084b5 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -16439,6 +16439,24 @@ (define-public python-epc
from elisp.")
(license license:gpl3)))
+(define-public python-ephemeral-port-reserve
+ (package
+ (name "python-ephemeral-port-reserve")
+ (version "1.1.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "ephemeral_port_reserve" version))
+ (sha256
+ (base32 "1chl9hil7ggz6l4sfhmp0l2j55qcskbc3pj9360b0309jwndmxxq"))))
+ (build-system pyproject-build-system)
+ (native-inputs (list python-setuptools python-wheel))
+ (home-page "https://github.com/Yelp/ephemeral-port-reserve/")
+ (synopsis "Utility to bind to an ephemeral port")
+ (description
+ "Bind to an ephemeral port, force it into the TIME_WAIT state, and unbind it.")
+ (license license:expat))) ;; MIT
+
(define-public python-forex-python
(package
(name "python-forex-python")
--
2.41.0
T
T
Tanguy Le Carrour wrote on 28 Feb 11:15 +0100
[PATCH python-team 7/9] gnu: Add python-werkzeug-3.
(address . 69449@debbugs.gnu.org)(name . Tanguy Le Carrour)(address . tanguy@bioneland.org)
a61664ebf35236552ac68ea81b57acfa57835b2c.1709112912.git.tanguy@bioneland.org
* gnu/packages/python-web.scm (python-werkzeug-3): New variable.

Change-Id: I9e53b3a5e303cc36aeaf7b3cfb678fb6aab1b6a7
---
gnu/packages/python-web.scm | 35 +++++++++++++++++++++++++++++++++++
1 file changed, 35 insertions(+)

Toggle diff (48 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 960ad0d879..e8edc1604c 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -5030,6 +5030,41 @@ (define-public python-werkzeug-1.0
(native-inputs
(list python-pytest python-pytest-timeout))))
+(define-public python-werkzeug-3
+ (package
+ (name "python-werkzeug")
+ (version "3.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "werkzeug" version))
+ (sha256
+ (base32 "1k0x7fxlbvshcpbr9d16z2w1s3irngadwyll0jj1hax7rqg82zjh"))))
+ (build-system pyproject-build-system)
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? inputs outputs #:allow-other-keys)
+ (when tests?
+ ;; Some tests rely on the network and on a newer version
+ ;; or python-watchdog.
+ (delete-file "tests/test_serving.py")
+ (invoke "python" "-m" "pytest")))))))
+ (propagated-inputs (list))
+ (native-inputs (list python-ephemeral-port-reserve python-flit-core
+ python-markupsafe python-watchdog
+ python-pytest python-pytest-timeout
+ python-pytest-xprocess))
+ (home-page "https://werkzeug.palletsprojects.com")
+ (synopsis "Utilities for WSGI applications")
+ (description
+ "One of the most advanced WSGI utility modules. It includes a
+powerful debugger, full-featured request and response objects, HTTP utilities to
+handle entity tags, cache control headers, HTTP dates, cookie handling, file
+uploads, a powerful URL routing system and a bunch of community-contributed
+addon modules.")
+ (license license:bsd-3)))
+
(define-public python-werkzeug python-werkzeug-2)
(define-public python-bottle
--
2.41.0
T
T
Tanguy Le Carrour wrote on 28 Feb 11:15 +0100
[PATCH python-team 2/9] gnu: python-jinja2: Update to 3.1.3.
(address . 69449@debbugs.gnu.org)(name . Tanguy Le Carrour)(address . tanguy@bioneland.org)
d5c36bd851980db92396daf8d685b5940f56c88a.1709112911.git.tanguy@bioneland.org
* gnu/packages/python-xyz.scm (python-jinja2): Update to 3.1.3.

Change-Id: I2dc33972577c579fa255f031705cc1961c2c4f7f
---
gnu/packages/python-xyz.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (23 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index bdcdf8c7c8..3348cc0d58 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -6019,14 +6019,14 @@ (define-public python-markupsafe
(define-public python-jinja2
(package
(name "python-jinja2")
- (version "3.1.1")
+ (version "3.1.3")
(source
(origin
(method url-fetch)
(uri (pypi-uri "Jinja2" version))
(sha256
(base32
- "1saawzys14l1p4kafs7hkihmnvqjq8fwxjmkjiqx3jq1nm5ys2v4"))))
+ "145s4mcjshv5snpc66z80xzxm3xs1gl5k8gk5dwwkcjb9madd2xc"))))
(build-system python-build-system)
(arguments
'(#:phases (modify-phases %standard-phases
--
2.41.0
T
T
Tanguy Le Carrour wrote on 28 Feb 11:15 +0100
[PATCH python-team 3/9] gnu: python-click: Update to 8.1.7.
(address . 69449@debbugs.gnu.org)(name . Tanguy Le Carrour)(address . tanguy@bioneland.org)
663811f3f2157936d1979ef0e95a04824f497586.1709112911.git.tanguy@bioneland.org
* gnu/packages/python-xyz.scm (python-click): Update to 8.1.7.

Change-Id: Ifac59bb2a373c519bb0da0f3f8e818d9e869cbf5
---
gnu/packages/python-xyz.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (23 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 3348cc0d58..c7492650cc 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5175,14 +5175,14 @@ (define-public python-cli-helpers
(define-public python-click
(package
(name "python-click")
- (version "8.1.3")
+ (version "8.1.7")
(source
(origin
(method url-fetch)
(uri (pypi-uri "click" version))
(sha256
(base32
- "13kvp8visj5xh9d43brnda6q0kc1s40flxa5cw0p0a9hzf5dr0kn"))))
+ "1pm6khdv88h764scik67jki98xbyj367h591j8hpwy4y8nnm766a"))))
(build-system python-build-system)
(arguments
`(#:phases
--
2.41.0
T
T
Tanguy Le Carrour wrote on 28 Feb 11:15 +0100
[PATCH python-team 6/9] gnu: python-werkzeug: Rename variable to python-werkzeug-2.
(address . 69449@debbugs.gnu.org)(name . Tanguy Le Carrour)(address . tanguy@bioneland.org)
b117f7245c6313188479943e2a17e6a1dcb5e7c9.1709112912.git.tanguy@bioneland.org
* gnu/packages/python-web.scm (python-werkzeug): Rename to...
(python-werkzeug-2): ... this. Add new variable defining
default python-werkzeug.

Change-Id: I6b77baf7731303735bcd7ae707fdd68f8b956c99
---
gnu/packages/python-web.scm | 8 +++++---
1 file changed, 5 insertions(+), 3 deletions(-)

Toggle diff (42 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 88e40959c3..960ad0d879 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -30,7 +30,7 @@
;;; Copyright © 2019 Vagrant Cascadian <vagrant@debian.org>
;;; Copyright © 2019 Brendan Tildesley <mail@brendan.scot>
;;; Copyright © 2019 Pierre Langlois <pierre.langlois@gmx.com>
-;;; Copyright © 2019, 2020 Tanguy Le Carrour <tanguy@bioneland.org>
+;;; Copyright © 2019, 2020, 2024 Tanguy Le Carrour <tanguy@bioneland.org>
;;; Copyright © 2020 Jakub K?dzio?ka <kuba@kadziolka.net>
;;; Copyright © 2020 Evan Straw <evan.straw99@gmail.com>
;;; Copyright © 2020 Alexandros Theodotou <alex@zrythm.org>
@@ -4971,7 +4971,7 @@ (define-public python-publicsuffix2
List. Forked from and using the same API as the publicsuffix package.")
(license (list license:expat license:mpl2.0))))
-(define-public python-werkzeug
+(define-public python-werkzeug-2
(package
(name "python-werkzeug")
(version "2.0.2")
@@ -5008,7 +5008,7 @@ (define-public python-werkzeug
(define-public python-werkzeug-1.0
(package
- (inherit python-werkzeug)
+ (inherit python-werkzeug-2)
(version "1.0.1")
(source (origin
(method url-fetch)
@@ -5030,6 +5030,8 @@ (define-public python-werkzeug-1.0
(native-inputs
(list python-pytest python-pytest-timeout))))
+(define-public python-werkzeug python-werkzeug-2)
+
(define-public python-bottle
(package
(name "python-bottle")
--
2.41.0
T
T
Tanguy Le Carrour wrote on 28 Feb 11:15 +0100
[PATCH python-team 9/9] gnu: Add python-flask-3.
(address . 69449@debbugs.gnu.org)(name . Tanguy Le Carrour)(address . tanguy@bioneland.org)
03a03ed64a62e23b9d3da8758dbf7754b186982f.1709112912.git.tanguy@bioneland.org
* gnu/packages/python-web.scm (python-flask-3): New variable.

Change-Id: I8556a3e2fed74368c6d4db99cd859ecb33a3d573
---
gnu/packages/python-web.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)

Toggle diff (46 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 3bdabc311a..215cdd2335 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -3957,6 +3957,39 @@ (define-public python-flask-2
presume or force a developer to use a particular tool or library.")
(license license:bsd-3)))
+(define-public python-flask-3
+ (package
+ (name "python-flask")
+ (version "3.0.2")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "flask" version))
+ (sha256
+ (base32
+ "0zfbxxgl5zpbvswxywrr6fam6rj0vknv317flx84484rnzs06b42"))))
+ (build-system pyproject-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "python" "-m" "pytest" "-vv" "tests")))))))
+ (native-inputs
+ (list python-flit-core python-pytest))
+ (propagated-inputs
+ (list python-blinker
+ python-click
+ python-itsdangerous
+ python-jinja2
+ python-werkzeug-3))
+ (home-page "https://flask.palletsprojects.com")
+ (synopsis "Microframework based on Werkzeug, Jinja2 and good intentions")
+ (description "Flask is a micro web framework based on the Werkzeug toolkit
+and Jinja2 template engine. It is called a micro framework because it does not
+presume or force a developer to use a particular tool or library.")
+ (license license:bsd-3)))
+
(define-public python-flask python-flask-2)
(define-public python-flask-compress
--
2.41.0
T
T
Tanguy Le Carrour wrote on 28 Feb 11:15 +0100
[PATCH python-team 4/9] gnu: python-blinker: Update to 1.7.0.
(address . 69449@debbugs.gnu.org)(name . Tanguy Le Carrour)(address . tanguy@bioneland.org)
3c8515a565a2c610972746757cbb7d1529ff0414.1709112912.git.tanguy@bioneland.org
* gnu/packages/python-xyz.scm (python-blinker): Update to 1.7.0.
[build-system]: Use pyproject-build-system.
[native-inputs]: Add python-flit-core, python-pytest and
python-pytest-asyncio.

Change-Id: Ie825fb38b326facf54b0788c78733b8de4a74920
---
gnu/packages/python-xyz.scm | 9 +++++----
1 file changed, 5 insertions(+), 4 deletions(-)

Toggle diff (28 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c7492650cc..a6f3aec7ed 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -7654,16 +7654,17 @@ (define-public python-black-macchiato
(define-public python-blinker
(package
(name "python-blinker")
- (version "1.4")
+ (version "1.7.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "blinker" version))
(sha256
(base32
- "1dpq0vb01p36jjwbhhd08ylvrnyvcc82yxx3mwjx6awrycjyw6j7"))))
- (build-system python-build-system)
- (home-page "https://pythonhosted.org/blinker/")
+ "10k1k4raxkfdan2vj4p1zvj4gxf394vjihj74y71skafzbv0z0p6"))))
+ (build-system pyproject-build-system)
+ (native-inputs (list python-flit-core python-pytest python-pytest-asyncio))
+ (home-page "https://blinker.readthedocs.io")
(synopsis "Fast, simple object-to-object and broadcast signaling")
(description
"Blinker provides a fast dispatching system that allows any number of
--
2.41.0
T
T
Tanguy Le Carrour wrote on 28 Feb 11:15 +0100
[PATCH python-team 8/9] gnu: python-flask: Rename to python-flask-2.
(address . 69449@debbugs.gnu.org)(name . Tanguy Le Carrour)(address . tanguy@bioneland.org)
dadeb45ce6743118275731d6d8c523dacb4c5811.1709112912.git.tanguy@bioneland.org
* gnu/packages/python-web.scm (python-flask): Rename to...
(python-flask-2): ... this. Add new variable defining
default python-flask.

Change-Id: Ibcfa805089f1ea17de52525b75e20dc5c2d54ee8
---
gnu/packages/python-web.scm | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index e8edc1604c..3bdabc311a 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -3923,7 +3923,7 @@ (define-public python-webtest
minimum of WSGI.")
(license license:expat)))
-(define-public python-flask
+(define-public python-flask-2
(package
(name "python-flask")
(version "2.1.1")
@@ -3957,6 +3957,8 @@ (define-public python-flask
presume or force a developer to use a particular tool or library.")
(license license:bsd-3)))
+(define-public python-flask python-flask-2)
+
(define-public python-flask-compress
(package
(name "python-flask-compress")
--
2.41.0
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 69449@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 69449
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch