[PATCH] gnu: Add python-mord.

  • Done
  • quality assurance status badge
Details
3 participants
  • Ekaitz Zarraga
  • Ludovic Courtès
  • King, Spencer
Owner
unassigned
Submitted by
King, Spencer
Severity
normal

Debbugs page

King, Spencer wrote 1 years ago
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)(name . ekaitz@elenq.tech)(address . ekaitz@elenq.tech)
CH3PR02MB97469B311C76B954DC66C3EA90592@CH3PR02MB9746.namprd02.prod.outlook.com

Attachment: 0001-gnu-Add-python-mord.patch (.00 MiB)
Ekaitz Zarraga wrote 1 years ago
(address . 69441@debbugs.gnu.org)
c5d99ad7-e273-bc59-8efb-f808558a8804@elenq.tech
I made a minor change and rebased to current `master`.
Ekaitz Zarraga wrote 1 years ago
(address . 69441@debbugs.gnu.org)(name . spencer.king@geneoscopy.com)(address . spencer.king@geneoscopy.com)
1e7e1bdd-a8e3-b12e-d7f6-b9b1cf270aa1@elenq.tech
LoL I forgot to attach.

On 2024-02-28 14:24, Ekaitz Zarraga wrote:
Toggle quote (1 lines)
> I made a minor change and rebased to current `master`.
From ddba870c692e17ef25f98ce660072c67184d6e49 Mon Sep 17 00:00:00 2001
Message-ID: <ddba870c692e17ef25f98ce660072c67184d6e49.1709127412.git.ekaitz@elenq.tech>
From: Spencer King <spencer.king@geneoscopy.com>
Date: Tue, 27 Feb 2024 22:03:12 +0000
Subject: [PATCH] gnu: Add python-mord.

* gnu/packages/machine-learning.scm (python-mord): New variable.

Change-Id: I1a495fece72a0b998a69cb518544ed8835b12a40
---
gnu/packages/machine-learning.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (46 lines)
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 6e94e21f3e..e758132d31 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -26,6 +26,7 @@
;;; Copyright © 2024 Sharlatan Hellseher <sharlatanus@gmail.com>
;;; Copyright © 2024 David Pflug <david@pflug.io>
;;; Copyright © 2024 Timothee Mathieu <timothee.mathieu@inria.fr>
+;;; Copyright © 2024 Spencer King <spencer.king@geneoscopy.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1782,6 +1783,29 @@ (define-public python-scikit-learn-extra
citation number.")
(license license:bsd-3))))
+(define-public python-mord
+ (package
+ (name "python-mord")
+ (version "0.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "mord" version))
+ (sha256
+ (base32 "1cvv9b9w69v0inq0zgcw0vmkiq3zn9q9r6clkynpzjik9rrh405n"))))
+ (build-system pyproject-build-system)
+ ;; v0.7 does not provide any test cases
+ ;; v0.6 relies on deprecated scikit-learn functionality
+ (arguments `(#:tests? #f))
+ (inputs (list python-numpy python-scipy python-scikit-learn))
+ (home-page "https://pypi.org/project/mord/")
+ (synopsis "Ordinal regression models for scikit-learn")
+ (description
+ "This package provides a collection of ordinal regression models for
+machine learning in Python. They are intended to be used with scikit-learn
+and are compatible with its API.")
+ (license license:bsd-3)))
+
(define-public python-thinc
(package
(name "python-thinc")

base-commit: f29f80c194d0c534a92354b2bc19022a9b70ecf8
--
2.41.0
Ekaitz Zarraga wrote 1 years ago
[PATCH] gnu: Add python-mord.
(address . 69441@debbugs.gnu.org)(name . Spencer King)(address . spencer.king@geneoscopy.com)
ddba870c692e17ef25f98ce660072c67184d6e49.1709126530.git.ekaitz@elenq.tech
From: Spencer King <spencer.king@geneoscopy.com>

* gnu/packages/machine-learning.scm (python-mord): New variable.

Change-Id: I1a495fece72a0b998a69cb518544ed8835b12a40
---
gnu/packages/machine-learning.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (46 lines)
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 6e94e21f3e..e758132d31 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -26,6 +26,7 @@
;;; Copyright © 2024 Sharlatan Hellseher <sharlatanus@gmail.com>
;;; Copyright © 2024 David Pflug <david@pflug.io>
;;; Copyright © 2024 Timothee Mathieu <timothee.mathieu@inria.fr>
+;;; Copyright © 2024 Spencer King <spencer.king@geneoscopy.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1782,6 +1783,29 @@ (define-public python-scikit-learn-extra
citation number.")
(license license:bsd-3))))
+(define-public python-mord
+ (package
+ (name "python-mord")
+ (version "0.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "mord" version))
+ (sha256
+ (base32 "1cvv9b9w69v0inq0zgcw0vmkiq3zn9q9r6clkynpzjik9rrh405n"))))
+ (build-system pyproject-build-system)
+ ;; v0.7 does not provide any test cases
+ ;; v0.6 relies on deprecated scikit-learn functionality
+ (arguments `(#:tests? #f))
+ (inputs (list python-numpy python-scipy python-scikit-learn))
+ (home-page "https://pypi.org/project/mord/")
+ (synopsis "Ordinal regression models for scikit-learn")
+ (description
+ "This package provides a collection of ordinal regression models for
+machine learning in Python. They are intended to be used with scikit-learn
+and are compatible with its API.")
+ (license license:bsd-3)))
+
(define-public python-thinc
(package
(name "python-thinc")

base-commit: f29f80c194d0c534a92354b2bc19022a9b70ecf8
--
2.41.0
Ekaitz Zarraga wrote 1 years ago
QA review for 69441
(address . control@debbugs.gnu.org)(address . 69441@debbugs.gnu.org)
30983dcf-0808-54d8-d5b7-0e82a03eeb8d@elenq.tech
user guix
usertag 69441 + reviewed-looks-good
thanks

Guix QA review form submission:
It has no dependent packages, it builds properly. Linter doesn't
complain about it.

Items marked as checked: Lint warnings, Package builds, Commit messages,
New package licenses, New package tests, New package synopsis and
descriptions
Ludovic Courtès wrote 1 years ago
Re: [bug#69441] [PATCH] gnu: Add python-mord.
(name . Ekaitz Zarraga)(address . ekaitz@elenq.tech)(address . 69441-done@debbugs.gnu.org)(name . spencer.king@geneoscopy.com)(address . spencer.king@geneoscopy.com)
87wmqkd3p9.fsf@gnu.org
Hi,

Ekaitz Zarraga <ekaitz@elenq.tech> skribis:

Toggle quote (10 lines)
> From ddba870c692e17ef25f98ce660072c67184d6e49 Mon Sep 17 00:00:00 2001
> Message-ID: <ddba870c692e17ef25f98ce660072c67184d6e49.1709127412.git.ekaitz@elenq.tech>
> From: Spencer King <spencer.king@geneoscopy.com>
> Date: Tue, 27 Feb 2024 22:03:12 +0000
> Subject: [PATCH] gnu: Add python-mord.
>
> * gnu/packages/machine-learning.scm (python-mord): New variable.
>
> Change-Id: I1a495fece72a0b998a69cb518544ed8835b12a40

Thanks to both of you, applied!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 69441@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 69441
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help