[PATCH 0/3] Update Chiron fonts and split outputs.

  • Done
  • quality assurance status badge
Details
2 participants
  • Hilton Chain
  • ???
Owner
unassigned
Submitted by
Hilton Chain
Severity
normal
H
H
Hilton Chain wrote on 27 Feb 16:25 +0100
(address . guix-patches@gnu.org)(name . Hilton Chain)(address . hako@ultrarare.space)
cover.1709046857.git.hako@ultrarare.space
Before:
Toggle snippet (6 lines)
$ guix size font-chiron-sung-hk
store item total self
/gnu/store/782wxa5iwbmh10gkgmfw2q6ljmkzrzn6-font-chiron-sung-hk-1.010 1887.4 1887.4 100.0%
total: 1887.4 MiB

Toggle snippet (7 lines)
$ guix size font-chiron-hei-hk
store item total self
/gnu/store/nf5sl46zv2hymzzf3ifajr367xrcpanv-font-chiron-hei-hk-2.508 1202.4 1202.4 100.0%
total: 1202.4 MiB


After:
Toggle snippet (8 lines)
$ ./pre-inst-env guix build font-chiron-sung-hk | xargs guix size
store item total self
/gnu/store/sq059cfram5jasjyf209krnx5vf2w7j2-font-chiron-sung-hk-1.011-otf 814.1 814.1 47.7%
/gnu/store/9vwjbg3yb266aib5h2332nsh6yqf5ik2-font-chiron-sung-hk-1.011-ttf 755.6 755.6 44.3%
/gnu/store/mlpxz8mvsrnh6q9zrhpdxgn2cxrdmkbl-font-chiron-sung-hk-1.011 137.2 137.2 8.0%
total: 1707.0 MiB

Toggle snippet (9 lines)
$ ./pre-inst-env guix build font-chiron-hei-hk | xargs guix size
store item total self
/gnu/store/52jwkwqwkcvmnc31m508mv1zzm2qj42n-font-chiron-hei-hk-2.509-otf 550.5 550.5 50.5%
/gnu/store/7cb0n9rw78p7vv7gmya0vxw24f14a7sq-font-chiron-hei-hk-2.509-ttf 465.9 465.9 42.7%
/gnu/store/961dw8avnhxyck577jxvsamb5v7ddzhh-font-chiron-hei-hk-2.509 74.5 74.5 6.8%
total: 1090.9 MiB


Hilton Chain (3):
gnu: font-chiron-sung-hk: Update to 1.011.
gnu: font-chiron-hei-hk: Update to 2.509.
gnu: font-chiron-sung-hk: Split outputs.

gnu/packages/fonts.scm | 30 ++++++++++++++++++++++++++----
1 file changed, 26 insertions(+), 4 deletions(-)


base-commit: 75bad75367fcf2c289fae3b40dbcc850f92177be
--
2.41.0
H
H
Hilton Chain wrote on 27 Feb 16:58 +0100
[PATCH 1/3] gnu: font-chiron-sung-hk: Update to 1.011.
(address . 69429@debbugs.gnu.org)(name . Hilton Chain)(address . hako@ultrarare.space)
4768e23ba3bb7521066a5e9909cf73929a94459e.1709046857.git.hako@ultrarare.space
* gnu/packages/fonts.scm (font-chiron-sung-hk): Update to 1.011.

Change-Id: Ib462e1707e611a2ff8053d69d38d28324e8d1cfe
---
gnu/packages/fonts.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 2cc420f7ba..5274c132f3 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -3321,7 +3321,7 @@ (define-public font-lxgw-wenkai-tc
(define-public font-chiron-sung-hk
(package
(name "font-chiron-sung-hk")
- (version "1.010")
+ (version "1.011")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -3330,7 +3330,7 @@ (define-public font-chiron-sung-hk
(file-name (git-file-name name version))
(sha256
(base32
- "065p1gc5xjwc4kfw8bqpsbhaf1p4w0k4l0j04vjsjhcl4k9vyvfz"))))
+ "1916bb834y4r4312g14zid7w3pbx1i70jcgkkfbf4z20grrj891m"))))
(build-system font-build-system)
(home-page "https://chiron-fonts.github.io/")
(synopsis "Traditional Chinese Song typeface")
--
2.41.0
H
H
Hilton Chain wrote on 27 Feb 16:58 +0100
[PATCH 2/3] gnu: font-chiron-hei-hk: Update to 2.509.
(address . 69429@debbugs.gnu.org)(name . Hilton Chain)(address . hako@ultrarare.space)
b97c78b013ca9174677e2c53b43311983cbc8638.1709046857.git.hako@ultrarare.space
* gnu/packages/fonts.scm (font-chiron-hei-hk): Update to 2.509.

Change-Id: I29f2ad3409eaa9ecbdf964397d03110d83a91f75
---
gnu/packages/fonts.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 5274c132f3..73041ce79c 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -3345,7 +3345,7 @@ (define-public font-chiron-hei-hk
(package
(inherit font-chiron-sung-hk)
(name "font-chiron-hei-hk")
- (version "2.508")
+ (version "2.509")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -3354,7 +3354,7 @@ (define-public font-chiron-hei-hk
(file-name (git-file-name name version))
(sha256
(base32
- "0drvkqk629z63k62v3ds559phl82dmkyvpx2r8mi99nnsz22a8ps"))))
+ "0bwx909sijpnc474355hlfjwgxin0m9yxd5k9qwmgxkp2rzqiwnk"))))
(synopsis "Traditional Chinese Gothic typeface")
(description
"Chiron Hei HK is a Traditional Chinese Gothic typeface based on the Hong
--
2.41.0
H
H
Hilton Chain wrote on 27 Feb 16:58 +0100
[PATCH 3/3] gnu: font-chiron-sung-hk: Split outputs.
(address . 69429@debbugs.gnu.org)(name . Hilton Chain)(address . hako@ultrarare.space)
300bc46ba7044331916e7b89ec49267fcbda718d.1709046857.git.hako@ultrarare.space
* gnu/packages/fonts.scm (font-chiron-sung-hk)[arguments]: Split outputs.
[outputs]: Add "otf" and "ttf".

Change-Id: Id96bba47e8f9ae9404a528bcceab3e110a05db4e
---
gnu/packages/fonts.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 73041ce79c..7b2cd7a396 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -3332,6 +3332,28 @@ (define-public font-chiron-sung-hk
(base32
"1916bb834y4r4312g14zid7w3pbx1i70jcgkkfbf4z20grrj891m"))))
(build-system font-build-system)
+ (arguments
+ (list #:modules
+ '((guix build font-build-system)
+ (guix build utils)
+ (srfi srfi-26))
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'install
+ (lambda _
+ (let ((var-dir (string-append
+ #$output "/share/fonts/opentype"))
+ (otf-dir (string-append
+ #$output:otf "/share/fonts/opentype"))
+ (ttf-dir (string-append
+ #$output:ttf "/share/fonts/truetype")))
+ (for-each (cut install-file <> var-dir)
+ (find-files "VAR" "\\.otf$"))
+ (mkdir-p (dirname otf-dir))
+ (copy-recursively "OTF" otf-dir)
+ (mkdir-p (dirname ttf-dir))
+ (copy-recursively "TTF" ttf-dir)))))))
+ (outputs '("out" "otf" "ttf"))
(home-page "https://chiron-fonts.github.io/")
(synopsis "Traditional Chinese Song typeface")
(description
--
2.41.0
H
H
Hilton Chain wrote on 28 Feb 04:20 +0100
[PATCH v2 0/3] Update Chiron fonts and split outputs.
(address . 69429@debbugs.gnu.org)(name . Hilton Chain)(address . hako@ultrarare.space)
cover.1709090139.git.hako@ultrarare.space
V1->V2: Simplify phases.

Hilton Chain (3):
gnu: font-chiron-sung-hk: Update to 1.011.
gnu: font-chiron-hei-hk: Update to 2.509.
gnu: font-chiron-sung-hk: Split outputs.

gnu/packages/fonts.scm | 22 ++++++++++++++++++----
1 file changed, 18 insertions(+), 4 deletions(-)


base-commit: 8c0282cf543fe205a5b89201cd7bb8889121a07c
--
2.41.0
H
H
Hilton Chain wrote on 28 Feb 04:27 +0100
[PATCH v2 1/3] gnu: font-chiron-sung-hk: Update to 1.011.
(address . 69429@debbugs.gnu.org)(name . Hilton Chain)(address . hako@ultrarare.space)
6ee8dd98a2f9583c6f9337e2e9c361366eb3017a.1709090139.git.hako@ultrarare.space
* gnu/packages/fonts.scm (font-chiron-sung-hk): Update to 1.011.

Change-Id: Ib462e1707e611a2ff8053d69d38d28324e8d1cfe
---
gnu/packages/fonts.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 2cc420f7ba..5274c132f3 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -3321,7 +3321,7 @@ (define-public font-lxgw-wenkai-tc
(define-public font-chiron-sung-hk
(package
(name "font-chiron-sung-hk")
- (version "1.010")
+ (version "1.011")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -3330,7 +3330,7 @@ (define-public font-chiron-sung-hk
(file-name (git-file-name name version))
(sha256
(base32
- "065p1gc5xjwc4kfw8bqpsbhaf1p4w0k4l0j04vjsjhcl4k9vyvfz"))))
+ "1916bb834y4r4312g14zid7w3pbx1i70jcgkkfbf4z20grrj891m"))))
(build-system font-build-system)
(home-page "https://chiron-fonts.github.io/")
(synopsis "Traditional Chinese Song typeface")
--
2.41.0
H
H
Hilton Chain wrote on 28 Feb 04:27 +0100
[PATCH v2 2/3] gnu: font-chiron-hei-hk: Update to 2.509.
(address . 69429@debbugs.gnu.org)(name . Hilton Chain)(address . hako@ultrarare.space)
c20aac554ac8a1956f9e0f0a527047ab3e0a7e31.1709090139.git.hako@ultrarare.space
* gnu/packages/fonts.scm (font-chiron-hei-hk): Update to 2.509.

Change-Id: I29f2ad3409eaa9ecbdf964397d03110d83a91f75
---
gnu/packages/fonts.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 5274c132f3..73041ce79c 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -3345,7 +3345,7 @@ (define-public font-chiron-hei-hk
(package
(inherit font-chiron-sung-hk)
(name "font-chiron-hei-hk")
- (version "2.508")
+ (version "2.509")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -3354,7 +3354,7 @@ (define-public font-chiron-hei-hk
(file-name (git-file-name name version))
(sha256
(base32
- "0drvkqk629z63k62v3ds559phl82dmkyvpx2r8mi99nnsz22a8ps"))))
+ "0bwx909sijpnc474355hlfjwgxin0m9yxd5k9qwmgxkp2rzqiwnk"))))
(synopsis "Traditional Chinese Gothic typeface")
(description
"Chiron Hei HK is a Traditional Chinese Gothic typeface based on the Hong
--
2.41.0
H
H
Hilton Chain wrote on 28 Feb 04:27 +0100
[PATCH v2 3/3] gnu: font-chiron-sung-hk: Split outputs.
(address . 69429@debbugs.gnu.org)(name . Hilton Chain)(address . hako@ultrarare.space)
1089ac68d3b7b2e2c80d0e4bb64d5b4edef0647b.1709090139.git.hako@ultrarare.space
* gnu/packages/fonts.scm (font-chiron-sung-hk)[arguments]: Split outputs.
[outputs]: Add "otf" and "ttf".

Change-Id: Id96bba47e8f9ae9404a528bcceab3e110a05db4e
---
gnu/packages/fonts.scm | 14 ++++++++++++++
1 file changed, 14 insertions(+)

Toggle diff (27 lines)
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 73041ce79c..a21e76400e 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -3332,6 +3332,20 @@ (define-public font-chiron-sung-hk
(base32
"1916bb834y4r4312g14zid7w3pbx1i70jcgkkfbf4z20grrj891m"))))
(build-system font-build-system)
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (replace 'install
+ (lambda _
+ (let ((install (assoc-ref %standard-phases 'install)))
+ (with-directory-excursion "VAR"
+ (for-each delete-file (find-files "." "\\.ttf$"))
+ (install #:outputs `(("out" . ,#$output))))
+ (with-directory-excursion "OTF"
+ (install #:outputs `(("out" . ,#$output:otf))))
+ (with-directory-excursion "TTF"
+ (install #:outputs `(("out" . ,#$output:ttf))))))))))
+ (outputs '("out" "otf" "ttf"))
(home-page "https://chiron-fonts.github.io/")
(synopsis "Traditional Chinese Song typeface")
(description
--
2.41.0
?
Re: [bug#69429] [PATCH v2 0/3] Update Chiron fonts and split outputs.
(name . Hilton Chain)(address . hako@ultrarare.space)
877cies5a3.fsf@envs.net
Hilton Chain <hako@ultrarare.space> writes:

Toggle quote (7 lines)
> V1->V2: Simplify phases.
>
> Hilton Chain (3):
> gnu: font-chiron-sung-hk: Update to 1.011.
> gnu: font-chiron-hei-hk: Update to 2.509.
> gnu: font-chiron-sung-hk: Split outputs.

Looks good to me, please push, thanks!
H
H
Hilton Chain wrote on 9 Mar 04:18 +0100
(name . ????)(address . iyzsong@envs.net)
8734t0t7ng.wl-hako@ultrarare.space
Hi,

On Thu, 07 Mar 2024 18:30:28 +0800,
??? wrote:
Toggle quote (12 lines)
>
> Hilton Chain <hako@ultrarare.space> writes:
>
> > V1->V2: Simplify phases.
> >
> > Hilton Chain (3):
> > gnu: font-chiron-sung-hk: Update to 1.011.
> > gnu: font-chiron-hei-hk: Update to 2.509.
> > gnu: font-chiron-sung-hk: Split outputs.
>
> Looks good to me, please push, thanks!

Thank you! I have applied v2 as c8529c32010a...a900fa3c6c81.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 69429@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 69429
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch