[PATCH] gnu: zeal: Update to 0.7.0.

  • Open
  • quality assurance status badge
Details
One participant
  • Felix Gruber
Owner
unassigned
Submitted by
Felix Gruber
Severity
normal
F
F
Felix Gruber wrote on 26 Feb 16:58 +0100
(address . guix-patches@gnu.org)(name . Felix Gruber)(address . felgru@posteo.net)
0517714c696bf3d32f66d84d6c8ff3ba41b791d9.1708963090.git.felgru@posteo.net
* gnu/packages/documentation.scm (zeal): Update to 0.7.0.
[arguments]: Convert to gexp.
[inputs]: Use new label-less style.

Change-Id: I9d2851ee303f2e8ebed80b4a1e463aa290bea111
---
gnu/packages/documentation.scm | 84 +++++++++++++++++-----------------
1 file changed, 41 insertions(+), 43 deletions(-)

Toggle diff (106 lines)
diff --git a/gnu/packages/documentation.scm b/gnu/packages/documentation.scm
index 5d455431d3..8fd06326dc 100644
--- a/gnu/packages/documentation.scm
+++ b/gnu/packages/documentation.scm
@@ -13,6 +13,7 @@
;;; Copyright © 2021, 2022 Marius Bakke <marius@gnu.org>
;;; Copyright © 2022 Maxim Cournoyer <maxim.counoyer@gmail.com>
;;; Copyright © 2023 Janneke Nieuwenhuizen <janneke@gnu.org>
+;;; Copyright © 2024 Felix Gruber <felgru@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -380,49 +381,46 @@ (define-public scrollkeeper
(license lgpl2.1+)))
(define-public zeal
- (let ((commit "1cfa7c637f745be9d98777f06b4f8dec90892bf2")
- (revision "1"))
- (package
- (name "zeal")
- (version (git-version "0.6.1" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/zealdocs/zeal")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "1m7pp3cwc21x03718vhwfd9j2n8md3hv5dp10s234vcsd755s7a3"))))
- (build-system qt-build-system)
- (arguments
- `(#:tests? #f ;no tests
- #:phases
- (modify-phases %standard-phases
+ (package
+ (name "zeal")
+ (version "0.7.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/zealdocs/zeal")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0nlya5r6dfvxqxyw9srav70ni5c11q9d4kmhywx63dfm65mmlldk"))))
+ (build-system qt-build-system)
+ (arguments
+ (list
+ #:tests? #f ;no tests
+ #:phases
+ #~(modify-phases %standard-phases
(add-after 'wrap 'wrap-qt-process-path
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (bin (string-append out "/bin/zeal"))
- (qt-process-path (string-append
- (assoc-ref inputs "qtwebengine-5")
- "/lib/qt5/libexec/QtWebEngineProcess")))
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let* ((bin (string-append #$output "/bin/zeal"))
+ (qt-process-path
+ (search-input-file inputs
+ "/lib/qt5/libexec/QtWebEngineProcess")))
(wrap-program bin
- `("QTWEBENGINEPROCESS_PATH" = (,qt-process-path)))
- #t))))))
- (native-inputs
- (list extra-cmake-modules pkg-config))
- (inputs
- `(("libarchive" ,libarchive)
- ("sqlite" ,sqlite)
- ("qtbase" ,qtbase-5)
- ("qtdeclarative-5" ,qtdeclarative-5)
- ("qtwebchannel-5" ,qtwebchannel-5)
- ("qtwebengine-5" ,qtwebengine-5)
- ("qtquickcontrols-5" ,qtquickcontrols-5)
- ("qtx11extras" ,qtx11extras)
- ("xcb-util-keyms" ,xcb-util-keysyms)))
- (home-page "https://zealdocs.org/")
- (synopsis "Offline documentation browser inspired by Dash")
- (description "Zeal is a simple offline documentation browser
+ `("QTWEBENGINEPROCESS_PATH" = (,qt-process-path)))))))))
+ (native-inputs
+ (list extra-cmake-modules pkg-config))
+ (inputs
+ (list libarchive
+ sqlite
+ qtbase-5
+ qtdeclarative-5
+ qtwebchannel-5
+ qtwebengine-5
+ qtquickcontrols-5
+ qtx11extras
+ xcb-util-keysyms))
+ (home-page "https://zealdocs.org/")
+ (synopsis "Offline documentation browser inspired by Dash")
+ (description "Zeal is a simple offline documentation browser
inspired by Dash.")
- (license gpl3+))))
+ (license gpl3+)))

base-commit: 1d85f921f6977875d98de68ffdedf43be3dfcd9d
--
2.43.0
?