[PATCH] gnu: gama: Update to 2.29

  • Done
  • quality assurance status badge
Details
2 participants
  • Andy Tai
  • Guillaume Le Vaillant
Owner
unassigned
Submitted by
Andy Tai
Severity
normal

Debbugs page

Andy Tai wrote 1 years ago
(address . guix-patches@gnu.org)(name . Andy Tai)(address . atai@atai.org)
47a71dbc204b0d9281e2ae849aae4de96958e846.1708844714.git.atai@atai.org
* gnu/packages/gps.scm (gama): Update to 2.29
[native-inputs]: Add yaml-cpp

Change-Id: Ie4ffc8abea85ee9b11f35f58054c6213404c3d7e
---
gnu/packages/gps.scm | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)

Toggle diff (25 lines)
diff --git a/gnu/packages/gps.scm b/gnu/packages/gps.scm
index 96bc58c519..3c0c7183d5 100644
--- a/gnu/packages/gps.scm
+++ b/gnu/packages/gps.scm
@@ -48,6 +48,7 @@ (define-module (gnu packages gps)
#:use-module (gnu packages python)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages qt)
+ #:use-module (gnu packages serialization)
#:use-module (gnu packages sqlite)
#:use-module (gnu packages xml))
@@ -157,7 +158,7 @@ (define-public gama
(build-system gnu-build-system)
(arguments '(#:parallel-tests? #f)) ; race condition
(native-inputs
- (list libxml2))
+ (list libxml2 yaml-cpp))
(inputs
(list expat sqlite))
(home-page "https://www.gnu.org/software/gama/")

base-commit: 05bbe9993f687da1fd684a31474c621f2a1c37b2
--
2.34.1
Andy Tai wrote 1 years ago
[PATCH v2] gnu: gama: Update to 2.29
(address . 69374@debbugs.gnu.org)(name . Andy Tai)(address . atai@atai.org)
e363969d98c0092789d3dd8a6ddba36983defa5e.1708847519.git.atai@atai.org
* gnu/packages/gps.scm (gama): Update to 2.29
[native-inputs]: Add yaml-cpp

Change-Id: Ie4ffc8abea85ee9b11f35f58054c6213404c3d7e
---
gnu/packages/gps.scm | 7 ++++---
1 file changed, 4 insertions(+), 3 deletions(-)

Toggle diff (43 lines)
diff --git a/gnu/packages/gps.scm b/gnu/packages/gps.scm
index 0ece311cde..3c0c7183d5 100644
--- a/gnu/packages/gps.scm
+++ b/gnu/packages/gps.scm
@@ -48,6 +48,7 @@ (define-module (gnu packages gps)
#:use-module (gnu packages python)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages qt)
+ #:use-module (gnu packages serialization)
#:use-module (gnu packages sqlite)
#:use-module (gnu packages xml))
@@ -140,7 +141,7 @@ (define-public gpscorrelate
(define-public gama
(package
(name "gama")
- (version "2.28")
+ (version "2.29")
(source
(origin
(method url-fetch)
@@ -148,7 +149,7 @@ (define-public gama
version ".tar.gz"))
(sha256
(base32
- "06kblr43yxkn5y77nigwy42r81cmi5pxz3kp50z271vvj3h3zisx"))
+ "04dlh1pdaiq059ssrxa4yn24iqgjrzy2mq7s9n1pgrzlzz3a63y0"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -157,7 +158,7 @@ (define-public gama
(build-system gnu-build-system)
(arguments '(#:parallel-tests? #f)) ; race condition
(native-inputs
- (list libxml2))
+ (list libxml2 yaml-cpp))
(inputs
(list expat sqlite))
(home-page "https://www.gnu.org/software/gama/")

base-commit: 05bbe9993f687da1fd684a31474c621f2a1c37b2
--
2.34.1
Guillaume Le Vaillant wrote 1 years ago
(name . Andy Tai)(address . atai@atai.org)(address . 69374-done@debbugs.gnu.org)
87edczqyxm.fsf@kitej
Patch applied as 66321bd94c1843d531a52516df36197c29ad325c.
Thanks.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCZdxtpg8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j/+zQD8DENgcgp183lIKZuNHbUWR664o3QblV4iXZwZ
Fxn782QBAJ1wBqVa6dlbvgvfAL8Mx8nGFgJkVJ0obrCYex8xeTqe
=D9FM
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 69374@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 69374
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help