[PATCH 00/13] Update Clingo to 5.7.1, etc pp

  • Done
  • quality assurance status badge
Details
2 participants
  • Efraim Flashner
  • Liliana Marie Prikler
Owner
unassigned
Submitted by
Liliana Marie Prikler
Severity
normal
L
L
Liliana Marie Prikler wrote on 24 Feb 11:41 +0100
(address . guix-patches@gnu.org)
cover.1708771294.git.liliana.prikler@gmail.com
Hi Guix,

this series updates Clingo and the rest of our potassco stuff
to the newest version. There is one exception, python-clinguin,
which would require deeeeeeeeeep cuts into our current python
ecosystem and next to juggling emacs-team and gnome-team I don't
want to open that box of Pandora.

Cheers

Liliana Marie Prikler (13):
gnu: Add wide-integer.
gnu: python-scikit-build: Install cmake modules.
gnu: libpotassco: Update to 0.0-2.69b677f.
gnu: clasp: Update to 3.3.10.
gnu: clingo: Update to 5.7.1.
gnu: clingo: Build from actual sources.
gnu: clingo-dl: Update to 1.5.0.
gnu: python-clingo: Fix build.
gnu: python-clingo-dl: Fix build.
gnu: python-clorm: Update to 1.5.0.
gnu: python-plingo: Update to 1.1.0.
gnu: python-telingo: Update to 2.1.3.
gnu: python: python-scikit-build: Add more non-deterministic test
failures.

gnu/local.mk | 1 -
gnu/packages/cpp.scm | 31 +++++++++++
.../python-telingo-fix-comparison.patch | 19 -------
gnu/packages/potassco.scm | 55 ++++++++++++-------
gnu/packages/python-xyz.scm | 13 ++++-
5 files changed, 78 insertions(+), 41 deletions(-)
delete mode 100644 gnu/packages/patches/python-telingo-fix-comparison.patch


base-commit: c0f88cd18649c31c75bcddf8247b14ef3e3a66a5
--
2.41.0
L
L
Liliana Marie Prikler wrote on 24 Feb 07:56 +0100
[PATCH 01/13] gnu: Add wide-integer.
(address . 69352@debbugs.gnu.org)
0bd819c52f78fcc59848438a6fd743a6805e9c5d.1708771294.git.liliana.prikler@gmail.com
* gnu/packages/cpp.scm (wide-integer): New variable.
---
gnu/packages/cpp.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index e530d1d2a8..64816b7400 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -2703,6 +2703,37 @@ (define-public safeint
64-bit integers.")
(license license:expat)))
+(define-public wide-integer
+ (let ((commit "22b8428746248e682d5276f8e8b7fb52af73ea47")
+ (revision "1314")) ; commit count
+ (package
+ (name "wide-integer")
+ (version (git-version "0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ckormanyos/wide-integer")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0bhjnbdcphv5kddddh8kpwjpjix23m12vmfsz0r6wjc5d27md33z"))
+ (modules '((guix build utils)))
+ (snippet #~(substitute* "CMakeLists.txt"
+ (("WideIntegerTargets") "wide-integer-targets")
+ (("WideIntegerConfig") "wide-integer-config")
+ (("WideInteger") "wide-integer")))))
+ (build-system cmake-build-system)
+ (native-inputs (list boost))
+ (home-page "https://github.com/ckormanyos/wide-integer")
+ (synopsis "C++ template for arbitrary-precision integers")
+ (description "This package implements a generic template for extended
+width signed and unsigned integral types. Up to 63 limbs of any built-in
+integer type are supported, and can be used to build powers of two like
+int128_t, uint256_t, but also somewhat esoteric types such as int24_t,
+uint80_t, or uint1536_t. The provided types can be used in much the same
+way as basic integer types.")
+ (license license:boost1.0))))
+
(define-public wdl
;; No tag is available.
(let ((commit "da86a62d11e46e4ecd8b16f9775cb5188340a0e2")
--
2.41.0
L
L
Liliana Marie Prikler wrote on 24 Feb 07:57 +0100
[PATCH 02/13] gnu: python-scikit-build: Install cmake modules.
(address . 69352@debbugs.gnu.org)
f86c33280e53842c69c7dde73625dbc261ef9c22.1708771294.git.liliana.prikler@gmail.com
* gnu/packages/python-xyz.scm (python-scikit-build)[#:phases]: Add
‘install-cmake’.
---
gnu/packages/python-xyz.scm | 10 +++++++++-
1 file changed, 9 insertions(+), 1 deletion(-)

Toggle diff (23 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index a051f5a8db..88dadb9f4a 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -31930,7 +31930,15 @@ (define-public python-scikit-build
;; nondeterministically (see:
;; https://github.com/scikit-build/scikit-build/issues/711).
"and not test_generator_cleanup "
- "and not test_generator_selection "))))))))
+ "and not test_generator_selection ")))))
+ (add-after 'install 'install-cmake
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((lib (string-append (assoc-ref outputs "out")
+ "/lib/cmake/modules")))
+ (mkdir-p lib)
+ (with-directory-excursion "skbuild/resources/cmake"
+ (for-each (lambda (file) (install-file file lib))
+ (find-files "." "\\.cmake")))))))))
(native-inputs
(list cmake-minimal
gfortran
--
2.41.0
L
L
Liliana Marie Prikler wrote on 24 Feb 08:51 +0100
[PATCH 03/13] gnu: libpotassco: Update to 0.0-2.69b677f.
(address . 69352@debbugs.gnu.org)
bc3f33d26a05cd486d27b52f58b905bb3dac78a0.1708771294.git.liliana.prikler@gmail.com
* gnu/packages/potassco.scm (libpotassco): Update to 0.0-2.69b677f.
---
gnu/packages/potassco.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (26 lines)
diff --git a/gnu/packages/potassco.scm b/gnu/packages/potassco.scm
index 39edb3096b..01cada7b77 100644
--- a/gnu/packages/potassco.scm
+++ b/gnu/packages/potassco.scm
@@ -46,8 +46,8 @@ (define-module (gnu packages potassco)
(define-public libpotassco
;; No public release, update together with clasp
- (let ((revision "1")
- (commit "2f9fb7ca2c202f1b47643aa414054f2f4f9c1821"))
+ (let ((revision "2")
+ (commit "69b677f026c53d5a0a794db17691a1eb8bce8c6b"))
(package
(name "libpotassco")
(version (git-version "0.0" revision commit))
@@ -65,7 +65,7 @@ (define-public libpotassco
(("\"catch.hpp\"") "<catch/catch.hpp>"))))
(sha256
(base32
- "1c32f9gqclf7qx07lpx8wd720vfhkjqhzc6nyy8mjmgwpmb3iyyn"))))
+ "1c69njg30dha1zy6j17gghjg3lgambz0pipxkgxadmrkvsb20z2k"))))
(arguments
`(#:configure-flags '("-DLIB_POTASSCO_BUILD_TESTS=on"
"-DLIB_POTASSCO_INSTALL_LIB=on"
--
2.41.0
L
L
Liliana Marie Prikler wrote on 24 Feb 08:52 +0100
[PATCH 04/13] gnu: clasp: Update to 3.3.10.
(address . 69352@debbugs.gnu.org)
5c91d8eee45bb5a51f6fdad13e1e27a03d471fa9.1708771294.git.liliana.prikler@gmail.com
* gnu/packages/potassco.scm (clasp): Update to 3.3.10.
---
gnu/packages/potassco.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/potassco.scm b/gnu/packages/potassco.scm
index 01cada7b77..05d5a3b754 100644
--- a/gnu/packages/potassco.scm
+++ b/gnu/packages/potassco.scm
@@ -103,7 +103,7 @@ (define-public libpotassco
(define-public clasp
(package
(name "clasp")
- (version "3.3.9")
+ (version "3.3.10")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -112,7 +112,7 @@ (define-public clasp
(file-name (git-file-name name version))
(sha256
(base32
- "163ps9zq7xppqy9hj5qnw6z5lcjnm4xf5fwjsavpia5ynm3hngcw"))))
+ "0qap7rar8a5mkqz28n2hnvr4cfv5x0rh4zs3wdp919dw4d034chr"))))
(build-system cmake-build-system)
(arguments
`(#:configure-flags '("-DCLASP_BUILD_TESTS=on"
--
2.41.0
L
L
Liliana Marie Prikler wrote on 24 Feb 08:54 +0100
[PATCH 05/13] gnu: clingo: Update to 5.7.1.
(address . 69352@debbugs.gnu.org)
76170fd2a156a68883eac81d527f0f1a7f8e3685.1708771294.git.liliana.prikler@gmail.com
* gnu/packages/potassco.scm (clingo): Update to 5.7.1.
---
gnu/packages/potassco.scm | 11 +++++++----
1 file changed, 7 insertions(+), 4 deletions(-)

Toggle diff (52 lines)
diff --git a/gnu/packages/potassco.scm b/gnu/packages/potassco.scm
index 05d5a3b754..602d0455d2 100644
--- a/gnu/packages/potassco.scm
+++ b/gnu/packages/potassco.scm
@@ -146,7 +146,7 @@ (define-public clasp
(define-public clingo
(package
(name "clingo")
- (version "5.6.2")
+ (version "5.7.1")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -160,7 +160,7 @@ (define-public clingo
(delete-file-recursively "third_party")))
(sha256
(base32
- "19s59ndcm2yj0kxlikfxnx2bmp6b7n31wq1zvwc7hyk37rqarwys"))))
+ "1mxl3gwx55sf2ifcb92mfy989c50yqpnq0d0r2mxdqr0riy40hjb"))))
(build-system cmake-build-system)
(arguments
(list
@@ -184,6 +184,7 @@ (define-public clingo
"find_package(mpark_variant)\n"
"find_package(tsl-sparse-map)\n"
"find_package(tsl-ordered-map)\n"
+ "find_package(wide-integer)\n"
"find_package(Catch2 3 REQUIRED)")))
(substitute* "libclingo/CMakeLists.txt"
(("\"cmake/Clingo\"") "\"cmake/clingo\"")
@@ -191,7 +192,8 @@ (define-public clingo
(("ClingoConfigVersion\\.cmake")
"clingo-config-version.cmake"))
(substitute* "libgringo/CMakeLists.txt"
- (("mpark::variant") "mpark_variant"))
+ (("mpark::variant") "mpark_variant")
+ (("math::wide_integer") "wide-integer::wide-integer"))
(substitute* "cmake/ClingoConfig.cmake.in"
(("find_package\\(Clasp") "find_package(clasp"))
(rename-file "cmake/ClingoConfig.cmake.in"
@@ -217,7 +219,8 @@ (define-public clingo
tl-optional
tsl-hopscotch-map
tsl-ordered-map
- tsl-sparse-map))
+ tsl-sparse-map
+ wide-integer))
(home-page "https://potassco.org/")
(synopsis "Grounder and solver for logic programs")
(description "Clingo computes answer sets for a given logic program.")
--
2.41.0
L
L
Liliana Marie Prikler wrote on 24 Feb 08:54 +0100
[PATCH 06/13] gnu: clingo: Build from actual sources.
(address . 69352@debbugs.gnu.org)
f68c082527535380f8c741c00449debccb19e3c1.1708771294.git.liliana.prikler@gmail.com
* gnu/packages/potassco.scm (clingo)[source]: Modify snippet to remove
generated sources.
[native-inputs]: Add bison and re2c.
---
gnu/packages/potassco.scm | 6 +++++-
1 file changed, 5 insertions(+), 1 deletion(-)

Toggle diff (40 lines)
diff --git a/gnu/packages/potassco.scm b/gnu/packages/potassco.scm
index 602d0455d2..fd049e2e73 100644
--- a/gnu/packages/potassco.scm
+++ b/gnu/packages/potassco.scm
@@ -32,6 +32,7 @@ (define-module (gnu packages potassco)
#:use-module (guix build-system emacs)
#:use-module (guix build-system python)
#:use-module (guix build-system pyproject)
+ #:use-module (gnu packages bison)
#:use-module (gnu packages check)
#:use-module (gnu packages cpp)
#:use-module (gnu packages graphviz)
@@ -42,6 +43,7 @@ (define-module (gnu packages potassco)
#:use-module (gnu packages python-build)
#:use-module (gnu packages python-web)
#:use-module (gnu packages python-xyz)
+ #:use-module (gnu packages re2c)
#:use-module (gnu packages sphinx))
(define-public libpotassco
@@ -157,6 +159,7 @@ (define-public clingo
(snippet
#~(begin
(delete-file-recursively "clasp")
+ (delete-file-recursively "libgringo/gen")
(delete-file-recursively "third_party")))
(sha256
(base32
@@ -214,7 +217,8 @@ (define-public clingo
"propagator" "propgator-sequence-mining"
"symbol" "visitor"))))))))))
(inputs (list catch2-3 clasp libpotassco))
- (native-inputs (list mpark-variant
+ (native-inputs (list bison re2c
+ mpark-variant
pkg-config
tl-optional
tsl-hopscotch-map
--
2.41.0
L
L
Liliana Marie Prikler wrote on 24 Feb 08:56 +0100
[PATCH 08/13] gnu: python-clingo: Fix build.
(address . 69352@debbugs.gnu.org)
1eb47332f63b70c8c3242ce9e39029ef747af621.1708771294.git.liliana.prikler@gmail.com
* gnu/packages/potassco.scm (python-clingo)[#:configure-flags]: Add flag for
CMAKE_MODULE_PATH.
---
gnu/packages/potassco.scm | 3 +++
1 file changed, 3 insertions(+)

Toggle diff (16 lines)
diff --git a/gnu/packages/potassco.scm b/gnu/packages/potassco.scm
index 5a59eeffef..16cff245e7 100644
--- a/gnu/packages/potassco.scm
+++ b/gnu/packages/potassco.scm
@@ -364,6 +364,9 @@ (define-public python-clingo
(substitute-keyword-arguments (package-arguments clingo)
((#:configure-flags flags #~'())
#~(cons* "-DCLINGO_BUILD_WITH_PYTHON=pip"
+ (string-append "-DCMAKE_MODULE_PATH="
+ #$(this-package-native-input "python-scikit-build")
+ "/lib/cmake/modules")
"-DCLINGO_USE_LIB=yes"
#$flags))
((#:imported-modules _ '())
--
2.41.0
L
L
Liliana Marie Prikler wrote on 24 Feb 09:01 +0100
[PATCH 11/13] gnu: python-plingo: Update to 1.1.0.
(address . 69352@debbugs.gnu.org)
503610935c9012ba8d5cdb01046ed02479327f5c.1708771294.git.liliana.prikler@gmail.com
* gnu/packages/potassco.scm (python-plingo): Update to 1.1.0.
---
gnu/packages/potassco.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/potassco.scm b/gnu/packages/potassco.scm
index a9dc34f0d4..4eb0f4a2c7 100644
--- a/gnu/packages/potassco.scm
+++ b/gnu/packages/potassco.scm
@@ -482,7 +482,7 @@ (define-public python-clorm
(define-public python-plingo
(package
(name "python-plingo")
- (version "1.0.0")
+ (version "1.1.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -491,7 +491,7 @@ (define-public python-plingo
(file-name (git-file-name name version))
(sha256
(base32
- "1mp0pdjzwpl7bpba20iwszx9x49gsyl2rhrp7w7xpwjqdjrp23r8"))))
+ "0bdz755c6isp29layvzsw9c4kr12x7b5d8ip37ay3cl4dlq4bid3"))))
(build-system pyproject-build-system)
(arguments
(list #:phases
--
2.41.0
L
L
Liliana Marie Prikler wrote on 24 Feb 08:59 +0100
[PATCH 12/13] gnu: python-telingo: Update to 2.1.3.
(address . 69352@debbugs.gnu.org)
3fc6f4d5cbcdf2b2dbbf490e4a31caccdc23b330.1708771294.git.liliana.prikler@gmail.com
* gnu/packages/potassco.scm (python-telingo): Update to 2.1.3.
[source]: Drop obsolete patch.
* gnu/packages/patches/python-telingo-fix-comparison.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
---
gnu/local.mk | 1 -
.../python-telingo-fix-comparison.patch | 19 -------------------
gnu/packages/potassco.scm | 5 ++---
3 files changed, 2 insertions(+), 23 deletions(-)
delete mode 100644 gnu/packages/patches/python-telingo-fix-comparison.patch

Toggle diff (63 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index 25e2341a72..9eef46bf57 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1809,7 +1809,6 @@ dist_patch_DATA = \
%D%/packages/patches/python-sip-include-dirs.patch \
%D%/packages/patches/python-sgmllib3k-assertions.patch \
%D%/packages/patches/python-sphinx-prompt-docutils-0.19.patch \
- %D%/packages/patches/python-telingo-fix-comparison.patch \
%D%/packages/patches/python-typeguard-python3.10.patch \
%D%/packages/patches/python-uqbar-python3.10.patch \
%D%/packages/patches/python-wxwidgets-type-errors.patch \
diff --git a/gnu/packages/patches/python-telingo-fix-comparison.patch b/gnu/packages/patches/python-telingo-fix-comparison.patch
deleted file mode 100644
index 6d05048dcb..0000000000
--- a/gnu/packages/patches/python-telingo-fix-comparison.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-Index: source/telingo/transformers/head.py
-===================================================================
---- source.orig/telingo/transformers/head.py
-+++ source/telingo/transformers/head.py
-@@ -564,10 +564,12 @@ class HeadTransformer:
- cond = []
- diff = _ast.BinaryOperation(loc, _ast.BinaryOperator.Minus, param, shift)
- if lhs.ast_type != _ast.ASTType.SymbolicTerm or lhs.symbol.type != _clingo.SymbolType.Number or lhs.symbol.number > 0:
-- cond.append(_ast.Literal(loc, _ast.Sign.NoSign, _ast.Comparison(_ast.ComparisonOperator.LessEqual, lhs, diff)))
-+ cond.append(_ast.Literal(loc, _ast.Sign.NoSign,
-+ _ast.Comparison(lhs, [_ast.Guard(_ast.ComparisonOperator.LessEqual, diff)])))
-
- if rhs.ast_type != _ast.ASTType.SymbolicTerm or rhs.symbol.type != _clingo.SymbolType.Supremum:
-- cond.append(_ast.Literal(loc, _ast.Sign.NoSign, _ast.Comparison(_ast.ComparisonOperator.LessEqual, diff, rhs)))
-+ cond.append(_ast.Literal(loc, _ast.Sign.NoSign,
-+ _ast.Comparison(diff, [_ast.Guard(_ast.ComparisonOperator.LessEqual, rhs)])))
-
- elems.extend([_ast.ConditionalLiteral(loc, _ast.Literal(loc, _ast.Sign.NoSign, head), cond) for head in heads])
-
diff --git a/gnu/packages/potassco.scm b/gnu/packages/potassco.scm
index 4eb0f4a2c7..43d9ea6647 100644
--- a/gnu/packages/potassco.scm
+++ b/gnu/packages/potassco.scm
@@ -520,17 +520,16 @@ (define-public python-plingo
(define-public python-telingo
(package
(name "python-telingo")
- (version "2.1.1")
+ (version "2.1.3")
(source (origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/potassco/telingo")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
- (patches (search-patches "python-telingo-fix-comparison.patch"))
(sha256
(base32
- "0g3khxfdzc2hc7dkiyyqhb399h6h21m5wkp6wy8w71n0m32fiy53"))))
+ "1q6hlh4b5hsa4n5agvmfa9rhsxfd2g6kpl4b9kfccwbmf6dh51k6"))))
(build-system pyproject-build-system)
(propagated-inputs (list python-clingo))
(home-page "https://potassco.org/")
--
2.41.0
L
L
Liliana Marie Prikler wrote on 24 Feb 10:17 +0100
[PATCH OPTIONAL 13/13] gnu: python: python-scikit-build: Add more non-deterministic test failures.
(address . 69352@debbugs.gnu.org)
acb4b892c05cd8cb5951c214686997350de94e54.1708771294.git.liliana.prikler@gmail.com
* gnu/packages/python-xyz.scm (python-scikit-build)[#:phases]<check>: Also
exclude “test_cxx_compiler” and “test_fortran_compiler”.
---
This one might be a bit controversial, as I haven't reported this issue
upstream either, but I've noticed that some quite fundamental-seeming
tests fail locally. Shouldn't happen on CI, but you never know.

gnu/packages/python-xyz.scm | 5 ++++-
1 file changed, 4 insertions(+), 1 deletion(-)

Toggle diff (18 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 88dadb9f4a..dc99588ccb 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -31930,7 +31930,10 @@ (define-public python-scikit-build
;; nondeterministically (see:
;; https://github.com/scikit-build/scikit-build/issues/711).
"and not test_generator_cleanup "
- "and not test_generator_selection ")))))
+ "and not test_generator_selection "
+ ;; … and there's more of them
+ "and not test_cxx_compiler "
+ "and not test_fortran_compiler ")))))
(add-after 'install 'install-cmake
(lambda* (#:key outputs #:allow-other-keys)
(let ((lib (string-append (assoc-ref outputs "out")
--
2.41.0
L
L
Liliana Marie Prikler wrote on 24 Feb 08:57 +0100
[PATCH 09/13] gnu: python-clingo-dl: Fix build.
(address . 69352@debbugs.gnu.org)
674aae1064fe68d4715f5904e466778b46868b94.1708771294.git.liliana.prikler@gmail.com
* gnu/packages/potassco.scm (python-clingo-dl)[#:configure-flags]: Add flag for
CMAKE_MODULE_PATH.
[native-inputs]: Add python-scikit-build.
---
gnu/packages/potassco.scm | 8 +++++++-
1 file changed, 7 insertions(+), 1 deletion(-)

Toggle diff (28 lines)
diff --git a/gnu/packages/potassco.scm b/gnu/packages/potassco.scm
index 16cff245e7..e1dbaefa98 100644
--- a/gnu/packages/potassco.scm
+++ b/gnu/packages/potassco.scm
@@ -411,7 +411,11 @@ (define-public python-clingo-dl
(version (package-version clingo-dl))
(arguments
(list
- #:configure-flags #~'("-DPYCLINGODL_ENABLE=pip")
+ #:configure-flags
+ #~(list "-DPYCLINGODL_ENABLE=pip"
+ (string-append "-DCMAKE_MODULE_PATH="
+ #$(this-package-native-input "python-scikit-build")
+ "/lib/cmake/modules"))
#:tests? #f
#:imported-modules `(,@%cmake-build-system-modules
(guix build python-build-system))
@@ -433,6 +437,8 @@ (define-public python-clingo-dl
(inputs (modify-inputs (package-inputs clingo-dl)
(prepend python-wrapper)))
(propagated-inputs (list python-clingo python-cffi))
+ (native-inputs (modify-inputs (package-native-inputs clingo-dl)
+ (prepend python-scikit-build)))
(synopsis "Python bindings for clingo-dl")
(description "This package allows users to add the clingo-dl propagator
as a theory to clingo from Python code. It also supports running clingo-dl
--
2.41.0
L
L
Liliana Marie Prikler wrote on 24 Feb 08:55 +0100
[PATCH 07/13] gnu: clingo-dl: Update to 1.5.0.
(address . 69352@debbugs.gnu.org)
427405ac7778213cd77ed4c2e547b159c109518b.1708771294.git.liliana.prikler@gmail.com
* gnu/packages/potassco.scm (clingo-dl): Update to 1.5.0.
---
gnu/packages/potassco.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/potassco.scm b/gnu/packages/potassco.scm
index fd049e2e73..5a59eeffef 100644
--- a/gnu/packages/potassco.scm
+++ b/gnu/packages/potassco.scm
@@ -233,7 +233,7 @@ (define-public clingo
(define-public clingo-dl
(package
(name "clingo-dl")
- (version "1.4.0")
+ (version "1.5.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -241,7 +241,7 @@ (define-public clingo-dl
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0dncwj63vdm6958vb7355d5j9mdr7hm037j4z82yz6l77jg3sipw"))))
+ (base32 "0vf51pgwgiac801gr6w5pnxb6wa0kacz09ncrcn25w5siz17g4si"))))
(build-system cmake-build-system)
(arguments (list #:tests? #f ; no tests
#:configure-flags #~`("-DPYCLINGODL_ENABLE=off")))
--
2.41.0
L
L
Liliana Marie Prikler wrote on 24 Feb 08:58 +0100
[PATCH 10/13] gnu: python-clorm: Update to 1.5.0.
(address . 69352@debbugs.gnu.org)
ecdd852f43efb3ee15069d725eca0afcff3a1b07.1708771294.git.liliana.prikler@gmail.com
* gnu/packages/potassco.scm (python-clorm): Update to 1.5.0.
---
gnu/packages/potassco.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/potassco.scm b/gnu/packages/potassco.scm
index e1dbaefa98..a9dc34f0d4 100644
--- a/gnu/packages/potassco.scm
+++ b/gnu/packages/potassco.scm
@@ -447,7 +447,7 @@ (define-public python-clingo-dl
(define-public python-clorm
(package
(name "python-clorm")
- (version "1.4.1")
+ (version "1.5.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -456,7 +456,7 @@ (define-public python-clorm
(file-name (git-file-name name version))
(sha256
(base32
- "0jx99y71mrgdicn1da5dwz5nzgvvpabrikff783sg4shbv2cf0b5"))))
+ "1wbxniq60ph7bdaypcaahym7jxmlnm2zhrfmrgrk441i1iaida24"))))
(build-system pyproject-build-system)
(arguments
(list #:phases
--
2.41.0
E
E
Efraim Flashner wrote on 5 Mar 09:21 +0100
Re: [bug#69352] [PATCH 00/13] Update Clingo to 5.7.1, etc pp
(name . Liliana Marie Prikler)(address . liliana.prikler@gmail.com)(address . 69352-done@debbugs.gnu.org)
ZebV_UtLKT0FroaR@3900XT
These patches are applied to master. Closing!

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmXm1f0ACgkQQarn3Mo9
g1GJrw/9F6CwKeOu9R07hp1965wzRdLlGVHWmG3sAINuh8Y5/F5tzze9kww+DShq
kFIdvlkHaomao6Mf+Yk48uoegqkOiRj8p/cI6B044HwQPk+FxegIHRf6LDE+A0f0
TqbPd+wBnQ23Bf68V0uz4GTbGEO5KbIjgh3Asn4cTXFfVFtcpRnZ3mbgkRFrokS9
UwjeP1QuXJoGr5Pdw0u1ZglIO5yyzBJQBJauGBmxkoK1666ukXxXHIiCPQyV5Mhq
UXoz0dPfyhuTv2zk+tWEaiCXEtMNhQFY1MMDzNZ2S+ZtJ+0bv2RGqJZkKL3fuCh3
8Lrb775wJ8btbBaI4A1t13rx2IlRSXxdqNbthwZ/ToAM3G8M1bGFQ+gRvYekYL3l
9tcjt3ozdyHjn4yWrrpp8Me37sa+vw5MC3nLmOewnKGx/UwCNj9BWdiSxvX1UjNl
aoCuQLY6HRVYyYOYdj+cCh9yzaLZfXdOvc0o2M1dG2z3uv243pq0nNXPfwGww71m
5gFMLqKvHOWHQJ1yM3NCIpal2FhTVpHtyhX3qpaLFc5K6wKU3A8A6QswBfZktrey
jXtg7Rka8FhUMTgEg4IQ+alTQbGWeI1+5bdjQwnqVtm9luS1xT665o7tE5PL/wX8
qNsLsUmxWTUEvtAy7mQctbZVY1cF+P6Mpgvi6CAVBCNJKt1ypo0=
=fG0t
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 69352@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 69352
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch