[PATCH 0/2] gnu: sqls: Add missing inputs.

  • Done
  • quality assurance status badge
Details
2 participants
  • Sharlatan Hellseher
  • Troy Figiel
Owner
unassigned
Submitted by
Troy Figiel
Severity
normal
T
T
Troy Figiel wrote on 24 Feb 10:31 +0100
(address . guix-patches@gnu.org)
87h6hy9pia.fsf@troyfigiel.com
This patch series adds go-github-com-k0kubun-pp and adds two missing native inputs to sqls.

Troy Figiel (2):
gnu: Add go-github-com-k0kubun-pp.
gnu: sqls: Add missing inputs.

gnu/packages/databases.scm | 4 ++++
gnu/packages/golang-xyz.scm | 27 +++++++++++++++++++++++++++
2 files changed, 31 insertions(+)


base-commit: c0f88cd18649c31c75bcddf8247b14ef3e3a66a5
--
2.42.0
T
T
Troy Figiel wrote on 17 Feb 20:11 +0100
[PATCH 1/2] gnu: Add go-github-com-k0kubun-pp.
(address . 69348@debbugs.gnu.org)
87frxi9pb1.fsf@troyfigiel.com
* gnu/packages/golang-xyz.scm (go-github-com-k0kubun-pp): New variable.
---
gnu/packages/golang-xyz.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (50 lines)
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index e68948e495..c39670fcde 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -15,6 +15,7 @@
;;; Copyright © 2023 Timo Wilken <guix@twilken.net>
;;; Copyright © 2023, 2024 Sharlatan Hellseher <sharlatanus@gmail.com>
;;; Copyright © 2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>
+;;; Copyright © 2024 Troy Figiel <troy@troyfigiel.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -709,6 +710,33 @@ (define-public go-github-com-jinzhu-copier
struct to another.")
(license license:expat)))
+(define-public go-github-com-k0kubun-pp
+ (package
+ (name "go-github-com-k0kubun-pp")
+ (version "3.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/k0kubun/pp")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1vpp5n3kdazk4s1ljhwbrhz3kilzvdvx5hya922bg0q9vnjqqvvc"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/k0kubun/pp"))
+ (propagated-inputs (list go-github-com-mattn-go-colorable
+ go-golang-org-x-text))
+ (home-page "https://github.com/k0kubun/pp")
+ (synopsis "Colored pretty-printer for Go")
+ (description
+ "This package provides a pretty-printer for Go. The functions defined by
+@code{pp} follow an API similar to @code{fmt} and its configuration can be
+customized globally.")
+ (license license:expat)))
+
(define-public go-github-com-matryer-try
(package
(name "go-github-com-matryer-try")

base-commit: c0f88cd18649c31c75bcddf8247b14ef3e3a66a5
--
2.42.0
T
T
Troy Figiel wrote on 17 Feb 20:19 +0100
[PATCH 2/2] gnu: sqls: Add missing inputs.
(address . 69348@debbugs.gnu.org)
87edd29p8o.fsf@troyfigiel.com
* gnu/packages/databases (sqls): Add missing inputs.
[native-inputs]: Add go-github-com-google-go-cmp-cmp and
go-github-com-k0kubun-pp.

* gnu/packages/databases: Add (gnu packages golang-xyz) module.
---
gnu/packages/databases.scm | 4 ++++
1 file changed, 4 insertions(+)

Toggle diff (31 lines)
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 5169795404..d20ca0b298 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -62,6 +62,7 @@
;;; Copyright © 2023 Felix Gruber <felgru@posteo.ne
;;; Copyright © 2023 Munyoki Kilyungi <me@bonfacemunyoki.com>
;;; Copyright © 2023 Giacomo Leidi <goodoldpaul@autistici.org>
+;;; Copyright © 2024 Troy Figiel <troy@troyfigiel.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -110,6 +111,7 @@ (define-module (gnu packages databases)
#:use-module (gnu packages golang-build)
#:use-module (gnu packages golang-check)
#:use-module (gnu packages golang-web)
+ #:use-module (gnu packages golang-xyz)
#:use-module (gnu packages gperf)
#:use-module (gnu packages gtk)
#:use-module (gnu packages guile)
@@ -5252,6 +5254,8 @@ (define-public sqls
go-github-com-mattn-go-runewidth
go-golang-org-x-xerrors
go-gopkg-in-yaml-v2))
+ (native-inputs (list go-github-com-google-go-cmp-cmp
+ go-github-com-k0kubun-pp))
(synopsis "SQL language server written in Go")
(description
"This package implements the @acronym{LSP, Language Server Protocol} for SQL.")
--
2.42.0
S
S
Sharlatan Hellseher wrote on 7 Mar 01:01 +0100
[PATCH 0/2] gnu: sqls: Add missing inputs.
(address . 69348-done@debbugs.gnu.org)
87v85y52qs.fsf@gmail.com
Pushed as 15b96de852..48b8655667 to master.

--
Oleg
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmXpA9sACgkQdtcnv/Ys
0rV3GRAAgTYAr7Nbnk1cDDqUsIBF9AMnNPmmxEDamvvrZ570yeg0TrOLtou5DB5R
GBGGDdI+Ad+IYAHBrh8kwxuL8/u8fq+mw/nPXWf72NrvI/GjNrd5tVq6umip7Y6V
8jfoQqIEpCD94LuYs08oXwGocJRtjUDq8G09t7Nd2ApRImqdWRqM3BwPR9gIM5g5
vTqWqDA8I2tsUq6IZxWqJEFs4ZvkJDXZWlP+e0jjEHdxCEVAk6S/OiBENl+dHiPT
dbdOwBCGRQntOlo+DaKre82/UnQMcyDunaz+272zd7XFaG6ty/loP44U17uh9DcO
fAmrEeJRBAuyUPk22jXZMKilfnTKgVgY2Jpa9MSPZ2CPBKpxZUhUSc4DaqdO1Tls
WAmptjVg6v1JrMDltbX79z0vZX2DFXGM7D4IcSbimiDZIHibgiybMqnpIkQqv3DR
tR8I414wNLiXPUXbfzqt1pCB2qDIcq17WTPzw6jad2hwaN7GBo6BPxeJXSg/WUeC
yxUAw9OmsxI4Dgx/HL+DY/qLpaidZPTIrqtWrjZhdX1VflfMOk31YiNCR7MLe9Pq
4XfmHc2/KqXJcp8hrObYJ0qciKtZQV2jy/n+KTN8E0vQdKhJMxrvzV5TtYHamRzW
+UsjyBMD9TzSaVFOFPegM8KHGQDDg6d55e8pmSGb+4VHklZdrVI=
=oCta
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 69348@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 69348
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch