* gnu/packages/golang-xyz.scm (go-github-com-k0kubun-pp): New variable.
---
gnu/packages/golang-xyz.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)
Toggle diff (50 lines)
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index e68948e495..c39670fcde 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -15,6 +15,7 @@
;;; Copyright © 2023 Timo Wilken <guix@twilken.net>
;;; Copyright © 2023, 2024 Sharlatan Hellseher <sharlatanus@gmail.com>
;;; Copyright © 2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>
+;;; Copyright © 2024 Troy Figiel <troy@troyfigiel.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -709,6 +710,33 @@ (define-public go-github-com-jinzhu-copier
struct to another.")
(license license:expat)))
+(define-public go-github-com-k0kubun-pp
+ (package
+ (name "go-github-com-k0kubun-pp")
+ (version "3.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/k0kubun/pp")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1vpp5n3kdazk4s1ljhwbrhz3kilzvdvx5hya922bg0q9vnjqqvvc"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/k0kubun/pp"))
+ (propagated-inputs (list go-github-com-mattn-go-colorable
+ go-golang-org-x-text))
+ (home-page "https://github.com/k0kubun/pp")
+ (synopsis "Colored pretty-printer for Go")
+ (description
+ "This package provides a pretty-printer for Go. The functions defined by
+@code{pp} follow an API similar to @code{fmt} and its configuration can be
+customized globally.")
+ (license license:expat)))
+
(define-public go-github-com-matryer-try
(package
(name "go-github-com-matryer-try")
base-commit: c0f88cd18649c31c75bcddf8247b14ef3e3a66a5
--
2.42.0